Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

Cette page propose des informations sur l'implémentation de la norme MIDI par/dans ALSA.



Tests

Tester un périphérique MIDI

Avertissementattention
Ce paragraphe n'est plus d'actualité (au 31 juillet 2015) ! Si vous connaissez une méthode simple susceptible de la remplacer, allez-y !

Il existe une façon simple de tester qu'un périphérique MIDI fonctionne correctement en ligne de commande.
Branchez par exemple un clavier MIDI, puis entrez la commande suivante dans un terminal :
$ cat /dev/snd/midiC0D0

Jouer sur le clavier produira alors l'affichage de caractères "cabalistiques" dans le terminal.

Tester le support des périphériques MIDI

Un lsmod apportera encore quelques renseignements :
$ lsmod|grep 'midi'
snd_rawmidi        23328   2 snd_usb_lib,snd_mpu401_uart
snd_seq_device      8204   1 snd_rawmidi
snd                50276  14 snd_usb_audio,snd_hwdep,snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_seq_device,
                             snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer


Attention : la majorité des logiciels MIDI nécessitent le module snd-seq-midi, vérifiez qu'il est bien présent, surtout si en lançant un programme (ex : Rosegarden) dans un terminal vous avez un message d'erreur du type : "ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory". Pour le charger, utiliser en tant que super utilisateur la commande suivante :
# modprobe snd-seq-midi


Message d'erreur "open /dev/snd/seq failed: No such file or directory".

Utiliser en tant que super utilisateur la commande suivante :
# modprobe snd-seq-midi


Test 3 - Midi IN OUT

Utilisez Aconnectgui au besoin lors de ces tests pour connecter vos ports MIDI.

IN

Ce programme permet de monitorer les signaux MIDI entrant dans le PC: kMidiMon
Voir aussi : Tester un périphérique MIDI

OUT

pmidi -p 64:0 fichier.mid



À voir aussi






[+]

Collaborateur(s) de cette page : olinuxx , allany , romain_bar , pianolivier et utilisateur_anonyme .
Page dernièrement modifiée le Jeudi 14 septembre 2017 13:57:33 par olinuxx.
Le contenu de cette page est licencié sous les termes licence.

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 07:25, lun. 18 Jun 2018: @BrnVrn; réponse courte (mégaphone oblige) : oui et non. Ouvre un sujet dans le forum pour des réponses plus longues.
sub26nico, 22:42, dim. 17 Jun 2018: Salut et bienvenue à BrnVrn :-)
BrnVrn, 20:07, dim. 17 Jun 2018: LADSPA est-il obsolete ? On trouve du LADSPA parce qu'il y a beaucoup de legacy ou c'est utilisé sur de nouveau projets ?
sub26nico, 15:43, dim. 17 Jun 2018: Salut et bienvenue à ledufakademy :-)
olinuxx, 11:22, sam. 16 Jun 2018: Une nouvelle version du MOD Duo est apparue : [Lien]
sub26nico, 20:17, ven. 15 Jun 2018: Un éditeur audio original multiplateforme : [Lien]
sub26nico, 13:45, ven. 15 Jun 2018: Salut et bienvenue à Onerrach :-)
olinuxx, 19:23, mer. 13 Jun 2018: Bonjour et bienvenue à Zuardent :-)
sub26nico, 00:35, mer. 13 Jun 2018: Salut et bienvenue à milie :-)
sub26nico, 20:53, sam. 09 Jun 2018: @Nolwen, ça fonctionnait ici avec firefox
Nolwen, 18:46, sam. 09 Jun 2018: Bon, ce n'est pas que le son était de si mauvaise qualité, c'était surtout que FalkTX parlait tout bas (ou bien que son micro était trop loin de sa voix)...
Nolwen, 17:25, sam. 09 Jun 2018: Ah si, il faut un navigateur basé sur Chromium (Yandex en l'occurence). Firefox ESR ne fonctionne pas ! Youpi !