Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]




Sous Linux, l'installation de LinuxSampler et de QSampler est très simple si vous avez une distribution officiellement supportée (Debian, Gentoo, Suse) :

1 - Téléchargez les différents paquets présents dans le répertoire dédié à votre distribution sur le site officiel. Ces paquets sont linuxsampler (le serveur), qsampler (un client), et quelques modules indispensables au fonctionnement des deux premiers paquets : libgig, gigedit, liblscp, et jlscp (optionnel). Prenez soin de choisir la dernière version pour chacun d'entre eux. Les répertoires sont, il faut le dire, bordéliques. Courage ! Pour vous aider à vous repérer, sachez que les paquets sont les fichiers qui portent l'extension deb ou i586.rpm, suivant votre distribution.

2 - Allez dans le répertoire ou vous les avez enregistrés, et double-cliquez sur chaque paquet. Attention, vous devez attendre la fin de l'installation d'un paquet avant de passer à l'installation du suivant, et il y a un ordre à respecter : libgig, linuxsampler, gigedit, liblscp, qsampler. Tant qu'à faire, installez aussi le paquet jlscp. Il vous permettra d'utiliser de belles interfaces en Java telles que Fantasia.


Si votre distribution n'est pas officiellement supportée, vous pouvez probablement trouver ces paquets dans l'utilitaire installation/suppression de programmes de votre distribution. L'utilitaire généralement conseillé est Synaptic. Si vous ne l'avez pas, vous pouvez l'installer à partir de votre utilitaire habituel. Synaptic est conseillé car, sur certaines distributions, il arrive qu'il donne accès à beaucoup plus de paquets que l'utilitaire de base.

En dernier recours, si vous ne trouvez pas ces paquets dans votre utilitaire d'installation, vous devrez récupérer leurs sources sur le site, les compiler et les installer vous-même.

Installation


Sur LibraZiK-2 (debian Stretch)


(testé sur une installation "en dur" ainsi que sur clé USB persistante)

Ce qui suit est valable pour une architecture 64 bits (amd64).

1) Tout d'abord, vérifiez que GDebi est installé (avec Synaptic) pour permettre l'installation des fichiers .deb nécessaires.

2) Se rendre sur le site officiel de LinuxSampler et y télécharger les paquets .deb suivants : liblinuxsampler et linuxsampler (version des paquets : liblinuxsampler_2.0.0-1_amd64.deb et linuxsampler_2.0.0-1_amd64.deb au moment de l'écriture de ces lignes le 1er décembre 2017), ce sont les essentiels. Il est aussi intéressant d'y ajouter le paquet pour gigedit si l'on veut éditer des banques de sons au format Giga Studio. Inutile cependant de télécharger les paquets pour gigedit, QSampler , liblscp , et libgig7 : ils sont déjà présents par défaut dans LZK-2.
Lien : http://download.linuxsampler.org/packages/debian/?C=M;O=D Image
(Note du 17/12/2017): les paquets datés de 2017 proposés dans le lien ci-dessus ne semblent pas encore compatibles avec LZK-2/Debian 9. En attendant, préférer l'installation des versions de 2015.

3) Se rendre dans le dossier de téléchargement et installer dans l'ordre suivant : liblinuxsampler, puis linuxsampler. Le premier s'installent sans problème avec GDebi : clic droit sur le fichier .deb puis sélectionner "Ouvrir avec l'installateur de paquets GDebi". Le paquet de Linuxsampler en revanche présente un défaut en employant cette méthode :
"dpkg: erreur de traitement de l'archive /_chemin_du_dossier_de_téléchargement_/linuxsampler_2.0.0-1_amd64.deb (--install) :
tentative de remplacement de "/usr/bin/lscp", qui appartient aussi au paquet nilfs-tools 2.2.6-1+b1
dpkg-deb: erreur: le sous-processus collé a été tué par le signal (Relais brisé (pipe))"

Pour contourner ce petit bogue, ouvrir un terminal en super utilisateur et taper :
cd dossier_où_se_trouvent_les_paquets_téléchargés
dpkg -i --force-overwrite linuxsampler_2.0.0-1_amd64.deb

Ce forçage est sans danger et LinuxSampler est enfin installé. Vous pouvez maintenant supprimer les 2 fichiers .deb .

4) Pour aller plus loin, il est également intéressant d'installer les interfaces graphiques JSampler (Fantasia et JSClassic), bien que QSampler fasse déjà très bien le boulot ! Pour les obtenir, on peut suivre les instructions données ici : jsampler


Sur Ubuntu

1) Il existe un paquet .deb précompilé sur le site de linuxsampler (mentionné plus haut), mais seulement pour Ubuntu 8.04 Hardy Heron, uniquement en version 32 bits

2) Par ailleurs, on peut utliser le depot ppa de falkTX qui (si je ne me trompe) est le dépôt de la distribution multimédia KXStudio, basée sur Ubuntu. Ce dépôt ppa est pour Ubuntu 10.04 Lucid Lynx.

3) On peut compiler depuis les sources; c'est assez simple et rapide.Cette compilation marche sur mon système avec Ubuntu Studio et donc Jack déjà installé.

- installer les paquets g++ et libgig-dev via Synaptics; il faut aussi installer (toujours via Synaptics) libasound2-dev et libjack-jackd2-dev pour avoir les "headers" pour ALSA et JACK2 (pour JACK1, installer libjack-dev ?)
- télécharger les sources de linuxsampler à partir de leur site
- décompresser l'archive et aller dans le repertoire téléchargé, en tapant dans un terminal:
cd /home/victor/linuxsampler-1.0.0

si le répertoire téléchargé est décompressé dans /home/victor
- ensuite, toujours dans ce même terminal, taper successivement :
./configure

make

sudo make install

Et l'installation est terminée.

- ensuite on peut installer le paquet gigedit via Synaptics, mais après l'installation de linuxsampler;

À partir des sources


Commencez par installer les outils nécessaires pour compiler linuxsampler
Ouvrez un terminal

sudo apt-get install g++ debhelper pkg-config automake libtool fakeroot libsndfile1-dev doxygen uuid-dev


Installez les outils nécessaire pour compiler à partir des sources
sudo apt-get install subversion

Installez les dépendances nécessaire pour compiler linuxsampler
sudo apt-get install bison libjack-jackd2-dev

Laissez votre terminal ouvert puis (cd = allez à ...)
cd /home/$USER

Créez le répertoire de travail
mkdir lssvn

Allez dans le répertoire de travail
cd lssvn

Télécharger les source de la lib libgig
svn co https://svn.linuxsampler.org/svn/libgig/trunk libgig

Téléchager les sources de linuxsampler
svn co https://svn.linuxsampler.org/svn/linuxsampler/trunk linuxsampler

Allez dans le répertoire pour construire la libgig
cd libgig

construisez la libgig
dpkg-buildpackage -rfakeroot -b

Remontez au répertoire parent (cd .. = remonter vers le niveau supérieur dans la hiérarchie d'un répertoire)
cd ..

Vérifiez le contenu
ls


Fermer
Avertissement...
traitement en cours

... Installation de gigtools de la libgig et de la libgig_dev

Allez dans le répertoire pour compiler linuxsampler
cd linuxsampler

Construisez le paquet linuxsampler
dpkg-buildpackage -rfakeroot -b

Remontez au répertoire parent
cd ..

Vérifiez le contenu
ls



Fermer
Avertissement...
traitement en cours

...installation de la liblinuxsampler , liblinuxsampler_dev et linuxsampler .





[+]

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 08:18, mar. 19 Jun 2018: Salut et bienvenue à ThiuRii :-)
olinuxx, 07:25, lun. 18 Jun 2018: @BrnVrn; réponse courte (mégaphone oblige) : oui et non. Ouvre un sujet dans le forum pour des réponses plus longues.
sub26nico, 22:42, dim. 17 Jun 2018: Salut et bienvenue à BrnVrn :-)
BrnVrn, 20:07, dim. 17 Jun 2018: LADSPA est-il obsolete ? On trouve du LADSPA parce qu'il y a beaucoup de legacy ou c'est utilisé sur de nouveau projets ?
olinuxx, 11:22, sam. 16 Jun 2018: Une nouvelle version du MOD Duo est apparue : [Lien]
sub26nico, 20:17, ven. 15 Jun 2018: Un éditeur audio original multiplateforme : [Lien]
sub26nico, 13:45, ven. 15 Jun 2018: Salut et bienvenue à Onerrach :-)
olinuxx, 19:23, mer. 13 Jun 2018: Bonjour et bienvenue à Zuardent :-)
sub26nico, 00:35, mer. 13 Jun 2018: Salut et bienvenue à milie :-)
sub26nico, 20:53, sam. 09 Jun 2018: @Nolwen, ça fonctionnait ici avec firefox
Nolwen, 18:46, sam. 09 Jun 2018: Bon, ce n'est pas que le son était de si mauvaise qualité, c'était surtout que FalkTX parlait tout bas (ou bien que son micro était trop loin de sa voix)...
Nolwen, 17:25, sam. 09 Jun 2018: Ah si, il faut un navigateur basé sur Chromium (Yandex en l'occurence). Firefox ESR ne fonctionne pas ! Youpi !