Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > [½ RÉSOLU] Router le son du web vers Jackd
Dernier post

[½ RÉSOLU] Router le son du web vers Jackd

kokonotsurecords utilisateur non connecté
Bonjour,

Je souhaite mettre en oeuvre le tuto :" Un fichier de configuration pour toutes sortes d'utilisations avancées"
ALSA Asoundrc
afin de créer un périphérique virtuel jackplug.
Seulement voilà ^^
J'ai beau chercher, je ne trouve aucune trace des fichiers .asoundrc et /etc/asound.conf qui servent à configurer les drivers ALSA.
Que dois-je faire ?
Dois-je les créer ?
Sinon, mon Jackd fonctionne trés bien même avec ma carte-son firewire externe. J'en déduis que ces fichiers ne sont pas utiles pour le bon fonctionnement de l'application, peut-être la raison pour laquelle ils ne sont pas installés sur mon système par défaut.

Qu'en pensez-vous ?

Cordialement.

yza utilisateur non connecté France
Hello Patrick,

Bon... ce fichier doit théoriquement exister, quelle est ta distribution au final : une ubuntu customizée ? si oui comment ? ou autre chose ?
sur ma mint customizée studio via les super dépôts UFS d'elgeneralmidi (voir tuto de bluedid) j'ai bien un asounf.conf dans /etc.

A mon avis ils sont quelque part mais peut-être que je me trompe.

Pas trop le temps de creuser la question because atelier de ce soir MAO justement... d'ailleurs si tu veux venir ^^...ce sera très généraliste, sauf si je n'ai que des pros dans la salle.

gostaberling utilisateur non connecté
Salut koko ! (dana h. 's speaking)
J'avais essayé de router le son des applis web vers jackd (ce qui s'est avéré un échec) à l'époque où je travaillais sous ubuntu. Et je me souviens que j'avais du créer les fichiers .asound.conf et /etc/asound.conf
Dans les dernières versions d'alsa,, ces fichiers ne sont plus utiles et ne sont pas créés par défaut à ce que j'ai lu ici :
http://alsa.opensrc.org/.asoundrc
Je te cause de mémoire là, mais il me semblait qu'un des problèmes était du au fait que j'avais configuré ma carte son (Edirol FA 101) pour travailler en 48khz, et que plaisait pas aux applications que j'essayais de re-router..

youki utilisateur non connecté
Damned, pas le temps de tester ces jours ci, mais si certains le font et que ca vaut le coup, un petit tuto serait le bien venu ;)

kokonotsurecords utilisateur non connecté
Salut Dana :-)

Bonjour tout le monde. Merci pour vos pistes que je vais étudier. Mais je vois que tout le monde cherche la solution et ne semble pas l'avoir trouvé. Personne n'a tenter de suivre le tuto sur Linux MAO que je mets en lien ?
Parce que si ça ne fonctionne pas, il faudrait peut-être faire remonter l'info ou bien la compléter.

Cordialement.

youki utilisateur non connecté
Desole, je n'avais pas lu ton premier post en fait. Pour le fichier ~/.asoundrc vu que c'est un fichier de configuration user, tu ne risques rien a essayer de le creer et a l'enlever si ca ne fonctionne pas a mon avis.

youki utilisateur non connecté
Je viens d'essayer en creant ce ficher .asoundrc dans mon home comme indique dans le tuto :

pcm.jackplug {
    type plug
    slave { pcm "jack" }
}

pcm.jack {
    type jack
    playback_ports {
       0 alsa_pcm:playback_1
       1 alsa_pcm:playback_2
   }
    capture_ports {
       0 alsa_pcm:capture_1
       1 alsa_pcm:capture_2
    }
}

pcm.!default {
    type plug
    slave { pcm "jack" }
}


Ca marche avec une video de youtube sous jack, ce qui n'etait pas le cas avant. J'ai pas pousse plus les essais pour l'instant, mais y'a pas de raisons... Comme quoi on ne fouille pas assez ce formidable site. :-) Du coup, merci kokonotsurecords de m'avoir permis de decouvrir cette astuce. Et merci a l'auteur de la page en question.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 11:35, lun. 27 Sep 2021: Bonjour et bienvenue à Vincentb63fr et à pub69250@tutanota.com cool
olinuxx, 12:30, ven. 24 Sep 2021: Bonjour à et bienvenue à kitty32, beldic2, et à Carlos54 cool
olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /