Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post

[Résolu!!]Fedora/Jack/Pulse/CCRMA

Benbo utilisateur non connecté
Suite du problème de ce sujet (qui commençait en effet à un peu trop s'allonger) : Problème Jack "Cannot connect to server socket err = No such file or directory"


[+]
Alors pour les cartes proposées avec F6 dans alsamixer :
- (default)
0 HD-Audio Generic
1 HDA ATI SB
enter device name...

Sinon, oui j'ai bien mon / et /home séparé (enfin je crois, c'est ce que j'ai fait lors de l'install)...

Enlever seulement Pulseaudio via le logiciel ajout/supression de programme me ferait aussi enlever énormément de programmes...

J'ai essayé via yum (c'est le apt-get de fedora si je ne m'abuse) et il me ferait enlever quelques trucs quand même :

[+]Qu'est-ce que t'en pense ? Ca m'enleverais le gnome shell par exemple ??? Je ne comprends pas trop

allany utilisateur non connecté
Oui, en effet.
Par contre, je ne vois pas de méta-paquets qui seraient giclés. Déjà ça !

Pas 36 solutions, sinon :
  • soit réinstaller le "/" en conservant ton "/home" (données et variables d'environnement), mmmmmh, bof...
  • soit passer par yum (je me souviens, c'est ça), supprimer tout ce qui contient "pulseaudio" en notant les trucs à réinstaller comme le gnome-shell, le bluez, le gnome-bluetooth, par exemple, et surtout alsa (tools, lib, etc...). Perso, je risquerais d'abord cette option.
  • tu ne m'as pas dit si yum proposait une fonction "réinstaller" ?

C'est un peu longuet tout ça, mais tu cumules les manques de bol : Pulseaudio qui n'est pas "adapté" pour un usage MAO, le HDMI qui fiche le bazar, une carte-son qui semble très, très particulière (source Google) et Alsa tronqué par les manip's sur Pulse.
Rien de bien nouveau mais le tout additionné, c'est un peu chiant, surtout pour toi...

Modéro : merci pour le nouveau topic !

A+

Benbo utilisateur non connecté
Ok

ouai en fait il faut faire yum install pour installer et yum remove pour désinstaller. Donc je pense que ton idée de bien noter le nom des paquets qui seront enlevés et de les réinstaller avec yum install devrait fonctionner.
J'installe tout avec ça depuis mes débuts sur fedora.
Je me lance alors.

Mais par rapport à l'idée d'acheter une petite carte son (behringer 202 si je me souviens) tu penses pas que ça vaut le coup, en attendant d'acheter une vraie carte ? Ou une carte simple avec quand même une prise in jack ?

à+

allany utilisateur non connecté
Ouaip !
Je ne t'avais pas répondu à propos de la carte car, pour l'avoir expérimenté, il y a des investissements, en la matière, qui peuvent s'avèrer vite décevants.

Ceci dit, j'ai récemment dépanné un camarade qui avait une Behringer UCG102 qui convenait bien pour sa façon de bosser.

Tout dépend de ce que tu veux faire (connectique "line in" RCA, qualité convertisseurs, préamp's absents,...), d'une part et, d'autre part, ça ne serait pas pire que ta config' actuelle et te permettrait de produire, au moins, un peu de musique au lieu de galérer avec les paramètres de Jack et autres bilevesées informatiques.
Peut-être combinée avec une mixette ?

Bon, Alsa ne la répertorie pas dans les cartes supportées mais comme sous Win et OSX elle ne nécessite pas de drivers, elle doit être "class compliant" donc fonctionner en 16 bits/44100 hz avec le driver snd-usb-audio d'Alsa, en plug&play.

Enfin, malgré tous les préjugés qui circulent, j'ai pas mal de hardware de la marque depuis des années et je n'ai jamais eu de soucis de fiabilité.
Bon, pour une trentaine de dollars, tu ne risques pas grand chose, à mon avis.

Tu peux aussi regarder sur les sites d'occase si, au même tarif, tu ne pourrais pas trouver une USB un peu plus riche en entrées et préamp's...

Ta machine, c'est un desktop ou un laptop ?
En PCI ou USB, les compatibilités sont  .

A+

Benbo utilisateur non connecté
C'est un laptop. J'ai pas de firewire, donc usb mais pci je ne sais pas si j'ai une entrée le permettant ? (image )
Ouai une entrée jack ou rca ce serait pas mal, mais j'ai besoin de quelquechose de pas trop gros, autoalimenté.

Sinon c'est pas top pour la désinstallation parceque j'arrive pas à réinstaller avec yum le gnome-shell sans qu'il m'installe pulseaudio...

Donc je sais pas trop quoi faire !

à+

Benbo utilisateur non connecté
En fait j'ai l'impression que pulseaudio est intégré à fedora...
jackctl ne marche pas plus pour l'instant en tout cas.

allany utilisateur non connecté
Dans le précédent sujet, je t'avais suggéré de "tuer" Pulseaudio avant chaque démarrage de Jack.
La commande adéquate étant, je crois :
pulseaudio -k

Si ça fonctionnait, plus besoin de le virer.
Le gnome shell (?) semble être indispensable donc...
A ce moment, une installation propre de Pulse et d'Alsa devrait suffire à remettre ton système au carré.

Pour ce qui est de ta carte actuelle, la doc pêchée chez Realtek, jointe à leurs drivers Linux, dit ceci .
Tu vois que ton modèle précis (VB) n'est pas répertorié...
Donc la plus petite interface audio en USB sera de toute façon préférable, pour peu qu'elle soit supportée par Alsa.
Si on s'en réfère à ce sujet , ça semble être le cas.

Les cartes PCI sont celles qui s'insèrent dans les slots des desktops donc on oublie...

A+

Benbo utilisateur non connecté
Bon alors finallement j'ai trouvé une solution !
J'ai toujours pas acheté de carte son, pas de sous...

Après une dernière réinstallation de fedora, le problème était toujours le même.

Mais ça marche finallement.

Je me suis d'abord ajouté dans le groupe audio avec
usermod -a -G audio benbo


Et j'ai fait ces réglages trouvés sur ce thread :


[+]

Cependant quand j'ouvre mon Jackctl, il me met ça dans les messages :

[+]

Et ensuite en cliquant sur play (et ça marche!) :

[+]

C'est normal ? Que je puisse cloturer le problème (ouf!)

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 21:29, mer. 22 Sep 2021: Bonjour et bienvenue à tezere cool
funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool
Samuel, 02:44, dim. 12 Sep 2021: [Lien] C'est la video de présentation du futur de VCV RACK, un synthé modulaire