Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > [CONTOURNÉ] ERREUR _ DBUS : impossible de démarrer le serveur JACK.
Dernier post

[CONTOURNÉ] ERREUR _ DBUS : impossible de démarrer le serveur JACK.

kimilie utilisateur non connecté
Bonjour,
Quelqu'un peut-il m'aider sur ce genre d'erreur ? merci

Je suis sur ubuntu 11.10 et lorsque j'ouvre JACK, une erreur survient :
DBUS : impossible de démarrer le serveur JACK.


puis je clique sur annuler (il n'y a que ce choix) une autre fenêtre s'ouvre :
Impossible de connecter le serveur JACK comme client
l'opération a échoué
Incapable de se connecter au serveur
Veuillez consulter la fenêtre des messages pour plus d'informations


Et voici la fenêtre des messages :

[+]

allany utilisateur non connecté
Hello !

Peux-tu nous poster un :
aplay -l

afin que nous y voyions quelles cartes-son sont présentes ?

Joins-y un :
lsmod | grep snd

pour voir les drivers chargés.

A+

kimilie utilisateur non connecté
Bonsoir !

Merci de bien vouloir me donner un coup de main.
Voici les résultats des commandes :
kimilie@kimilie-desktop:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: ICH5 [Intel ICH5], périphérique 0: Intel ICH [Intel ICH5]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: ICH5 [Intel ICH5], périphérique 4: Intel ICH - IEC958 [Intel ICH5 - IEC958]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0

kimilie@kimilie-desktop:~$ lsmod | grep snd
snd_intel8x0           33318  2 
snd_ac97_codec        106082  1 snd_intel8x0
ac97_bus               12642  1 snd_ac97_codec
snd_pcm                80435  2 snd_intel8x0,snd_ac97_codec
snd_seq_midi           13132  0 
snd_rawmidi            25241  1 snd_seq_midi
snd_seq_midi_event     14475  1 snd_seq_midi
snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
snd_timer              28932  2 snd_pcm,snd_seq
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    55902  11 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              12600  1 snd
snd_page_alloc         14115  2 snd_intel8x0,snd_pcm
kimilie@kimilie-desktop:~$


Normalement, j'ai installé il y a peu une PHASE22 de TERRATEC. Elle est annoncée sans problèmes sur ubuntu. Je l'ai donc installée mais depuis je n'arrive plus à faire fonctionner mon son.

Bonne soirée,

pierrotlo utilisateur non connecté Suisse
Bonjour,
Est ce que ton utilisateur fait partie du groupe audio ?

olinuxx utilisateur non connecté France
Salut,

selon ton log de jack, tu essaies de démarrer Jack sur une interface se nommant " hw:1 " mais selon ton " aplay -l ", tu ne possèdes qu'une interface se nommant " hw:0 ".

Si tu sélectionnes cette interface " hw:0 " dans les options de qjackctl, ceci fera démarrer jack sur ta puce-son intégrée.

À priori, selon les résultats des commandes que tu nous as fourni, ta Terratec n'est pas reconnue sur ton système. Ceci dit, les quelques informations dont on dispose sur le site pour la Phase 22 semblent dire qu'il est possible de la faire fonctionner sous linux.

La terratec phase 22 se connectant sur le bus PCI, donne nous le résultat d'un " lspci " aussi.

Olivier

kimilie utilisateur non connecté
Bonjour,

Merci à tous pour vos messages d'entraide !

Tout d'abord, en ce qui concerne le groupe, j'ai trouvé sur le net cette commande : groups. Elle me retourne que je suis admin en audio (mais j'ai fait la commande à la fin des manips racontées ci-dessous).

kimilie@kimilie-desktop:~$ groups
kimilie adm dialout cdrom audio plugdev lpadmin admin sambashare

Ensuite, voici ce que j'ai trafiqué ce soir.
Olinuxx m'ayant expliqué que JACK ne démarrais pas sur le bon "hw:x" et que la TERRATEC n'était pas reconnue, je me suis lancé dans des manips hardware (au passage je pense avoir compris que les "hw:x" signifient "hardware : x", isn't it Olinuxx ?). voici les manips que j'ai faites :

1- j'ai "disablé" la carte son de ma carte mère, puis j'ai changé la TERRATEC de slot PCI.
2-redémarrage du PC puis commandes aplay -l, lsmod | grep snd et enfin lspci
3- Ces dernières commandes m'ont dit que carte carte (sur son nouveau slot) n'était pas reconnue.
4-Tête de mule que je suis et ne voulant pas entendre parler de carte défectueuse .... j'éteins le PC et je rechange de slot (non mais des fois, quand le PC veut jouer au con .... il est servi).
5-redémarrage du PC, je tape les commandes aplay -l, lsmod | grep snd et enfin lspci et je vois que la carte est enfin reconnue !!!! voici les résultats des dernières commandes :
kimilie@kimilie-desktop:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: T22 [Terratec PHASE 22], périphérique 0: ICE1724 [ICE1724]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: T22 [Terratec PHASE 22], périphérique 1: ICE1724 IEC958 [ICE1724 IEC958]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


[+]


[+]

Maintenant, ne me reste plus qu'à ouvrir JACK et .... la suite au prochain épisode.

kimilie utilisateur non connecté
Re bonsoir !

Arghhhhh ! JACK m'a redonné le même message d'erreur !
  • -22:38:56.181 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
    Cannot connect to server socket err = Aucun fichier ou dossier de ce type
    Cannot connect to server socket
    jack server is not running or cannot be started
    22:39:12.795 Script de démarrage...
    22:39:12.796 artsshell -q terminate
    Cannot connect to server socket err = Aucun fichier ou dossier de ce type
    Cannot connect to server socket
    jack server is not running or cannot be started
    sh: artsshell: not found
    22:39:13.209 Script de démarrage terminé avec statut de sortie=32512.
    22:39:13.582 DBUS : impossible de démarrer le serveur JACK. Désolé
    ....
    Wed Oct 17 22:39:13 2012: Starting jack server...
    Wed Oct 17 22:39:13 2012: JACK server starting in realtime mode with priority 70
    Wed Oct 17 22:39:13 2012: control device hw:1
    Wed Oct 17 22:39:13 2012: ERROR: control open "hw:1" (No such file or directory)
    Wed Oct 17 22:39:13 2012: control device hw:1
    Wed Oct 17 22:39:13 2012: ERROR: control open "hw:1" (No such file or directory)
    Wed Oct 17 22:39:13 2012: ERROR: Failed to acquire device name : Audio-1 error : Input/output error
    Wed Oct 17 22:39:13 2012: ERROR: Audio device hw:1 cannot be acquired, trying to open it anyway...
    Wed Oct 17 22:39:13 2012: creating alsa driver ... hw:1|hw:1|512|3|44100|0|0|nomon|swmeter|-|32bit
    Wed Oct 17 22:39:13 2012: control device hw:1
    Wed Oct 17 22:39:13 2012: ERROR: control open "hw:1" (No such file or directory)
    Wed Oct 17 22:39:13 2012: ERROR: ALSA: Cannot open PCM device alsa_pcm for playback. Falling back to capture-only mode
    Wed Oct 17 22:39:13 2012: ERROR: Cannot initialize driver
    Wed Oct 17 22:39:13 2012: ERROR: JackServer::Open() failed with -1
    Wed Oct 17 22:39:13 2012: ERROR: Failed to open server
    22:39:19.695 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
    Cannot connect to server socket err = Aucun fichier ou dossier de ce type
    Cannot connect to server socket
    jack server is not running or cannot be started
Bon, mais en reprenant les aides précedentes, je retombe sur la même erreur !
Ce bon vieux JACK veut ouvrir hw:1 alors que ma carte son est en hw:0 ...

Donc je suis allé dans "réglages" de JACK et j'ai paramétré les entrées et sorties par hw:0 !
Résultat, encore la même musique à part que là il trouve la carte :

[+]

Je suis dégoûté mais je continue les essais ... à bientôt et merci !

kimilie utilisateur non connecté
Bonsoir,

En relisant les erreurs colportées par JACK, je m'intéresse à ces lignes qui sont présentes dans le message posté précédemment :

Wed Oct 17 22:43:55 2012: ERROR: JackProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Wed Oct 17 22:43:55 2012: ERROR: Driver is not running
Wed Oct 17 22:43:55 2012: ERROR: Cannot open client name = dbusapi
Wed Oct 17 22:43:55 2012: ERROR: failed to create dbusapi jack client


Je vois le mot ERROR (ca sent pas bon ça ...) et donc je me dis que il y a un problème sur ces lignes !

JACK me dit :
Driver is not running : le driver ne tourne pas !

Cela voudrait-il dire qu'ubuntu n'a pas de driver par défaut pour la PHASE22 ????

puius je vois aussi "failed to create dbusapi jack client" : je ne sais pas ce qu'est dbusapi ... eek

je continue de chercher .... merci !

allany utilisateur non connecté
Si je récapitule : tu as désactivé ta carte-son interne via ton setup de BIOS et trouvé un slot reconnu.
Bonne idée mais, du coup, le aplay n'affiche plus que la Terratec.
Elle devient donc la carte hw:0 (soit de premier rang, puisqu'unique) et non hw:1 comme dans ton dernier log de Jack.

Donc, dans tes réglages de jack, tu devrais essayer, dans l'ordre "interface/P. entrée/P. sortie" les valeurs suivantes :
  • hw:0
  • défaut
  • défaut
ou
  • défaut
  • hw:0,1
  • hw:0,0

Pour ces histoires de groupe audio, lis ce qui concerne le PAM.

A ta question sur les hw:xy, la réponse est :
x représente le N° d'interface audio. En général, la carte interne est de rang 0 et les cartes-son additionnelles sont incrémentées de 1.
y représente le périphérique concerné. On a souvent 1 pour entrée (capture) et 0 pour sortie (playback).

Voili, voilou...
A+

olinuxx utilisateur non connecté France
JACK me dit :
Driver is not running : le driver ne tourne pas !

Cela voudrait-il dire qu'ubuntu n'a pas de driver par défaut pour la PHASE22 ????



Non, ton ubuntu reconnait bien ta carte à partir du moment ou le aplay -l te la liste et/ou que le lsmod te liste bien le module snd_ice1724 comme chargé. Pour t'en convaincre et t'en assurer, tu peux écouter de la zik ou mater une vidéo (sans passer par Jack) et écouter le son sortant de la terratec venir te frétiller les oreilles.

Le "driver" dont jack te parle est certainement un "driver" interne à Jack.





puius je vois aussi "failed to create dbusapi jack client" : je ne sais pas ce qu'est dbusapi ... eek



arrow Dbus est un "bus logiciel" : http://fr.wikipedia.org/wiki/Dbus .
arrow une API est une interface de programmation api


Question : tu es sur ubuntu 11.10 qui est une version bêta. Pourquoi ne pas passez à la version 12.04 qui est une stable appelée également "LTS" = Long Time Support ?

A+ !
Olivier

kimilie utilisateur non connecté
Bonsoir,

Oui, j'ai désactivé la carte son interne via le setup de BIOS. Je me suis dit qu'il y avait peut-être un conflit de cartes ...
Et oui, j'ai changé la TERRATEC de slots 3 fois avant d'arriver à la faire reconnaître par ubuntu.

Donc les drivers de cette carte sont donc bien reconnus.wink
Je ne vais pas faire d'essais ce soir car fatigué...redface
Oh ! donc le driver serait interne à JACK arrow piste à explorer

Donc, dans tes réglages de jack, tu devrais essayer, dans l'ordre "interface/P. entrée/P. sortie" les valeurs suivantes :

* hw:0
* défaut
* défaut

ou

* défaut
* hw:0,1
* hw:0,0
arrow je vais essayer ca la prochaine fois (surement samedi ...)

lis ce qui concerne le PAM.arrowj'ai lu ! c'est excellent je ne savais pas qu'il existait des versions linux spéciales pour la MAO ... je me demande si je ne devrais pas essayer par là plutôt ???
Ce qui répondrait en partie à Olinuxx :Pourquoi ne pas passez à la version 12.04 arrowpourquoi ne pas passer à UBUNTU studio ou l'autre dont les développeurs sont proches de LINUX MAO et qui sont frenchies ?

Pianolivier :

pourquoi jackdbus ? utilises-tu ladish ?
DBUS est arrivé dans ma vie sans que je l'y invite. Donc je ne sais pas pourquoi JACKDBUS.
Je ne connaissait pas LADISH ! Je vais me renseigner aussitôt que possible !

eek AU DODO maintenant !

allany utilisateur non connecté
Pour les distrib's orientées MAO, tu peux aussi regarder KXStudio ou AVLinux ...

Je suis en train de les tester et elles présentent chacune certains atouts mais je pense que je resterai sous AVLinux malgré une ergonomie d'installation plus improbable et une francisation assez limitée.

ATTENTION : c'est, pour l'instant, un avis très subjectif car je suis encore très loin d'avoir exploré toutes les possibilités "audio" des deux packs...

A+

kimilie utilisateur non connecté
Bonjour,

Je viens d'installer TANGO STUDIO.
Dès le départ, JACK fonctionne N I C K E L santa

pierrotlo utilisateur non connecté Suisse
salut,

juste une remarque concernant les slots PCI. Pour la carte son il ne faut jamais utiliser le slot PCI contigu à la carte video surtout s'il y'a du Nvidia ou du ATI. Et si la carte video est intégrée à la carte mère, il faut éviter le slot PCI 0. En général le premier.
Cela m'a personnellement toujours posé pas mal de problèmes.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 11:06, dim. 24 Oct 2021: @lootre : contacte moi via IRC si tu vois ce message
olinuxx, 10:48, dim. 24 Oct 2021: Bonjour et bienvenue à JSNGZN, B_Beun, salamrouba, et Iwanael cool
Shangri-l, 17:39, sam. 23 Oct 2021: Bienvenue à white-wolf ! J'ai cotoyé un temps sur d'autres lieux des réseaux un White Wolf, si tu es lui, tu te souviendras de moi. Si tu n'es pas lui, tu pars avec un bon point positif pour avoir ma sympathie, vu que tu me le rappelles :-)
sri_raoul, 13:11, jeu. 21 Oct 2021: Un avant-goût de ce que sera Ardour 7: [Lien]
olinuxx, 17:20, lun. 18 Oct 2021: Bonjour et bienvenue à white-wolf cool
olinuxx, 16:23, sam. 16 Oct 2021: Bonjour et bienvenue à didremi, TiFred et à Cecile43 cool
bluedid29, 12:40, dim. 10 Oct 2021: A titre d'info, test interface audio Audient Di14 en cours sur Debian, Ubuntu... ...pour l'instant, que du bon ;-) Je tiens au courant pour plus de précisions dès que que possible...
bluedid29, 12:38, dim. 10 Oct 2021: Merci pour l'édito et bon dimanche sous le soleil :-)
sub26nico, 22:05, mer. 06 Oct 2021: Bien joué les potos, qu'il est bien, qu'il est beau l'édito !
r1, 15:33, mer. 06 Oct 2021: Les rhinos comme les chameaux, tous sont accros à l'édito !
allany, 09:06, mer. 06 Oct 2021: Pas besoin d'otorhino, c'est juste l'édito ! [Lien]
olinuxx, 20:38, mar. 05 Oct 2021: Bonjour et bienvenue à Turtlebass6 et à FalCT60 cool