Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [RÉSOLU] M-audio Fast track MKII + Rakarrack + QJackCtl
Dernier post

[RÉSOLU] M-audio Fast track MKII + Rakarrack + QJackCtl

Tchoalien utilisateur non connecté
Bonsoir !

Je suis nouveau sur Ubuntu depuis aujourd'hui, tous c'est bien passer à l'installation de l'OS mais maintenant que je veux installer mon matériel de MAO sa commence a se compliqué. Je m'explique :

J'ai une carte son externe M-audio Fast Track MKII, en la branchant pour la première fois, elle a été reconnu, je peux switcher entre la carte interne et externe. J'ai ensuite installé Rakarrack et j'ai vite découvert qu'il me fallait Jackd, j'ai donc installer QJackCtl et je l'es configuré en faisant en sorte que le son joué sur la carte son externe soit retransmis au logiciel qui lui retransmet au périphérique de sortie audio.

Voila un screen de ma config jackd : http://image.noelshack.com/fichiers/2013/19/1368379888-capture-1.png

Le problème c'est que quand j'arrive sur Rakarrack, j'ai uniquement le son de mon micro interne ( j’entends les bruit de mon entourage )

Voila un screen de ma config Rakarrack : http://image.noelshack.com/fichiers/2013/19/1368380222-capture-2.png

Je me permet également de vous faire un screen de la commande alsamixer : http://image.noelshack.com/fichiers/2013/19/1368380431-capture-3.png

EDIT : Dans Alsamixer, j'ai également remarquer ceci : http://image.noelshack.com/fichiers/2013/19/1368392049-capture-4.png

Voila, j'ai essayé d'être le plus clair possible, si vous voulez plus de détails n'hésitez pas, je m'excuse pour les éventuelles fautes d’orthographes.
J’espère que vous pourrez m'aider à réglé ce problème, j'ai passé la journée sur les forum pour essayer de trouver une solution mais j'ai rien trouver, ce qui me laisse
pensé que sa doit être quelque chose de bête.

allany utilisateur non connecté
Hello !

Je t'ai rapidement répondu sur Ubuntu.fr mais on va détailler un peu plus, ici.

Pour ton dernier écran d'alsamixer, c'est normal. L'USB n'est pas pris en charge par le mixer logiciel.

Les hw:1,x que je t'avais suggérés ne valent que si la carte USB est bien la seconde reconnue par ton système.
Après lecture de ta réponse postée sur Ubuntu.fr, je me dis qu'il se peut qu'un module HDMI vienne perturber cet ordre, comme souvent sur les chipsets récents.

Pour vérifier, peux-tu poster les résultats de :
aplay -l
cat /proc/asound/cards
lsmod | grep usb

ainsi que les différents choix que Jack te propose (flèches) pour :
  • interface
  • périph' d'entrée
  • périph' de sortie

A+

PS modéro : un p'tit passage par les "présentations" ? Cool... cool

Tchoalien utilisateur non connecté
Bonjour, merci beaucoups pour t'es reponses allany !

Alors j'ai remarqué que j'avais bien un soucie au niveau du nombres de cartes, en effet voici un screen des commande que tu ma donné.

http://image.noelshack.com/fichiers/2013/20/1368462397-capture-5.png

Et quand je vais dans jack, il me propose :

Interface : hw:0 HDA intel PCH
hw:0,0 ALC269VB Analog
hw:1 Fast Track
hw: 1,0 USB Audio
Par Default

Pérophérique entrée : Interface : hw:0 HDA intel PCH
hw:0,0 ALC269VB Analog
hw:1 Fast Track
hw: 1,0 USB Audio
Par Default
Pérophérique sortie : Interface : hw:0 HDA intel PCH
hw:0,0 ALC269VB Analog
hw: 0,3 HDMI 0
Par Default

Ps : J'y vais de suite chef ! mrgreen

allany utilisateur non connecté
Mmmmh, bizarre... pas de périphérique USB en sortie... en entrée oui... du HDMI mal placé...
Par contre le module du pilote USB est bien chargé.

A ce niveau, le plus simple serait d'essayer de désactiver la carte-son interne (le HDMI, surtout) via le setup de ton BIOS.
Pas possible avec tous les BIOS mais si ça marchait, ta carte USB serait peut-être reconnue comme carte par défaut et, sinon, il faudrait nous poster les mêmes 3 commandes avec ce nouveau contexte.

A+

Tchoalien utilisateur non connecté
Je peux pas desactiver ma carte son depuis le BIOS =/

allany utilisateur non connecté
Peux-tu envoyer les logs (messages) de Jack en le lançant avec les périph's à défaut et :
  • interface=hw:1 d'abord
  • interface=hw:1,0 ensuite
A+

Tchoalien utilisateur non connecté
EDIT : Pour les trois périphérique il m'affiche
20:23:59.368 Client activé.
Cannot lock down 82246176 byte memory area (Ne peut allouer de la mémoire)
20:24:39.578 Client désactivé.


Ps : Merci pour le tuyau Flo !

Flo utilisateur non connecté
Pour les résultats de commandes, fais plutôt un copier coller (pour copier depuis le terminal, il faut faire Ctrl + Shift + c), puis met dans une balise de code
comme ceci

(c'est le bouton avec une feuille blanche et < > dessus).

Flo

pour citer l'image en question flo: Imagewink
{img src="img/icons/page_white_code.png"}


allany utilisateur non connecté
As-tu bien configuré le PAM ?
Essaie de poster le log de Jack en entier. Ca permet de voir tes réglages aussi...
En suivant les bons conseils de mise en page de nos camarades. cool
A+

Tchoalien utilisateur non connecté
Bonsoir, merci pour vos réponses !

Je n'avais pas configuré PAM et je viens de passer quelques heures à le faire, ce qui ma permis de supprimer ce fameux message :

Cannot lock down 82246176 byte memory area (Ne peut allouer de la mémoire)


Mais a par ca, rien a changé =/ Voici le code complet de Jack quand je le lance

23:08:15.205 Baie de brassage désactivée.
23:08:15.206 Réinitialisation des statistiques.
23:08:15.224 Changement des connexions ALSA.
23:08:15.275 DBUS : le service est disponible (org.jackaudio.service soit jackdbus).
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server socket
jack server is not running or cannot be started
23:08:15.284 Changement du graphique des connexions ALSA.
23:08:18.359 Changement du graphique des connexions ALSA.
23:08:18.483 Changement des connexions ALSA.
23:08:28.182 Changement des connexions JACK.
23:08:28.203 Client activé.
23:08:56.486 Client désactivé.
23:09:00.093 Changement des connexions JACK.
23:09:00.117 Client activé.
23:09:29.531 Client désactivé.
23:09:39.082 Changement des connexions JACK.
23:09:39.091 Client activé.
23:10:02.795 Changement des connexions JACK.
23:10:04.615 Changement des connexions JACK.


allany utilisateur non connecté
Euuuuh, il en manque un bon morceau, de ce log...

Tchoalien utilisateur non connecté
Hello !

Bon bein ca y est tous fonctionne ! Ca devais être le relgage PAM que j'ai fais hier.
Contrairement à d'habitude, aujourd'hui j'ai lancer jack tous seul et sa marche ! Alors que d'habitude je lancais Rakarrack et ensuite jack. Si je démarré le serveur jack tous seul celui si m'afficher une erreur et ne démarré pas.

Je vais pouvoir reprendre mes compo !
Merci a tous ceux qui on répondu et un grand merci à allany =) !

A bientôt sur le forum !

allany utilisateur non connecté
Cool !
Merci pour le "résolu".
Du coup, je verrouille avec joie le sujet.
Bonne zique, à+

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]


sub26nico

Mégaphone [Afficher / Cacher]

funroad34, 15:50, lun. 20 Sep 2021: c est surtout lors de la connection que ça rame sinon c 'est correct niveau timming a l'ouverture des pages..
funroad34, 15:43, lun. 20 Sep 2021: slt Oui patience et perseverence...
Houston4444, 11:17, lun. 20 Sep 2021: Ici on apprend la patience, bientôt la cafetière aura terminé sa mission avant que la page soit chargée...
sub26nico, 17:50, dim. 19 Sep 2021: pas de souci ici
funroad34, 14:14, dim. 19 Sep 2021: Bonjour idem chez moi
Geis007, 18:03, sam. 18 Sep 2021: binjch, c'est très lent, en effet !
binjch, 22:51, ven. 17 Sep 2021: Salut c'est hyper lent chez tout le monde là? Ou c'est moi qui ai un problème?
olinuxx, 18:46, jeu. 16 Sep 2021: Bonjour et bienvenue à pierre2 cool
zicstef, 22:40, mer. 15 Sep 2021: Hello, il y a bien longtemps que je n'ai pas eu la joie de passer. Découvert au détour d'un surf: /
olinuxx, 18:30, lun. 13 Sep 2021: [INFO] nouveau compte Diaspora pour linuxmao : [Lien] Venez nous y rejoindre cool
Samuel, 02:44, dim. 12 Sep 2021: [Lien] C'est la video de présentation du futur de VCV RACK, un synthé modulaire
olinuxx, 18:55, jeu. 09 Sep 2021: @dugalandco : utilises le forum pour mener des discussions. Le mégaphone n'est pas utilisé pour des discussions, mais pour informer de façon rapide.