Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

2 - Les distributions et les noyaux

> Forums de discussion > 2 - Les distributions et les noyaux > Problème impression sur Debian Jessie Librazik [RESOLU]
Dernier post

Problème impression sur Debian Jessie Librazik [RESOLU]

bluedid29 utilisateur non connecté France
Bonjour,cool

Je suis confronté à un problème d'impression sur distribution Librazik 64 bits (version de juillet 2016)

Le serveur d'impression est bien installé > Système -> Centre de contrôle -> Services -> (mot de passe root) -> "cups" et "cups-browsed" sont présents.

Le paquet "task-print-server" est bien installé.

Il n'y a pas de service d'impression accessible dans le menu, du coup j'ai installé HPLIP Toolbox.

Mon imprimante HP Office Pro 8600 est bien reconnue (USB)

Ensuite quand je clique sur Add Printer, il y a une fenêtre me demandant mon Login et mot de passe mais cela ne fonctionne pas avec la réponse : Printer queue setup failed Error successful-ok-ignored-or-substituted-attributes

A noter qu'il y a aussi problème (bogues (!) avec d'autres distributions basées sur Debian jessie 64 bits, en utilisant l'interface "normale" (impression) apparaissant dans le menu

Pour imprimer, je switche sur Ubuntu Studio 16.04 64 bits, cela fonctionne (avec même ordinateur i7), c'est vrai que pour l'impression de partitions, c'est mieux quand cela fonctionne ! mrgreen lol

Voilà, merci pour vos réponses / suggestions / aide wink

à bientôt

BlueDid cool

sub26nico utilisateur non connecté France
Je rencontre le même problème sur LibraZiK 32bits sur mon fixe,
"cups" et "cups-browsed" sont également présents et le paquet task-print-server est installé.
Imprimante Canon MG3550, le driver maison est installé (correctement?, effectif?).
Quand je veux imprimer, seule l'option imprimer dans un fichier est possible.

Sur mon laptop, LibraZiK 64bits, avec les mêmes fichiers, paquets et driver cela fonctionne
très bien, je peux imprimer 'normalement', mon imprimante apparait dans les fenetres d'impression
de chaque logiciel.

Je précise que j'ai installé le driver 32 bits sur le fixe, donc ça devrait fonctionner aussi, mais non...

bluedid29 utilisateur non connecté France
Idem, chez moi seule l'option imprimer dans un fichier est possible mais un peu normal aussi puisqu'il y a impossibilité de faire reconnaître l'imprimante... mrgreen

Est ce que par hasard il ne vous manquerait pas des paquets non libre ?
Jetez un oiel du coté du sources.list c'est possible qu'il manque la partie non-free et contrib ...

deb http://debian.proxad.net/debian/ jessie non-free contrib main 
# deb-src http://debian.proxad.net/debian/ jessie non-free contrib main 

deb http://security.debian.org/ jessie/updates main contrib non-free 
# deb-src http://security.debian.org/ jessie/updates non-free contrib main 

# jessie-updates, previously known as 'volatile'
deb http://debian.proxad.net/debian/ jessie-updates main contrib non-free 
# deb-src http://debian.proxad.net/debian/ jessie-updates non-free contrib main 

# jessie-backports
deb http://debian.proxad.net/debian/ jessie-backports main contrib non-free 
# deb-src http://debian.proxad.net/debian/ jessie-backports non-free contrib main


Prudence quand même avec les backports ne l'activez qu'au besoin ...

sub26nico utilisateur non connecté France
Je vais essayer de réinstaller le driver pour voir si ça vient de là chez moi.

Dans ton premier message tu dis que l'imprimante est reconnue, donc d'où vient le schmilblik?

sub26nico utilisateur non connecté France
bien vu utilisateur_anonyme, c'est possible, j'ai du installé des paquets non-libre pour mon laptop (apple),
et pas fait sur le fixe car...pas eu besoin. Mais sur le laptop, c'était pour le wifi,
j'ai du installé tout un tas de truc sans savoir à quoi ça correspondait.
J'ai pourtant fait le ménage depuis et viré tout ce qui ne servait pas.
Je creuserai cette piste dans la soirée.

bluedid29 utilisateur non connecté France
Curieux tout de même qu'il fasse installer des paquets non libre pour faire reconnaître une imprimante mais bon, dans le monde informatique, plus rien ne me surprend... mrgreen

J'vais essayer, merci du tuyau utilisateur_anonyme wink

olinuxx utilisateur non connecté France
Salut ici,

c'est bien possible qu'il faille installer des paquets spécifiques non-libres pour des pilotes de certaines imprimantes. Ça doit dépendre des imprimantes.

J'en profite pour placer ici que les dépôts de backports sont déjà en place sur LibraZiK, et qu'ils sont accessibles par menu Synaptic -> Configuration -> dépôts. Pas besoin d'aller trifouiller en ligne de commande pour cela wink. Attention, les backports sont en place, mais ne sont pas activés par défaut. Les dépôts backport ne sont pas assez testés pour que ce soit le cas. Ceci dit, je ne pense pas que les backports soient utiles ici.

Je viens de faire une recherche dans Synaptic avec "print driver". Je t'encourage Didier à faire de même. Si ton imprimante est une bluetooth, alors peut être que le paquet "bluez-cups" pourrait t'être utile.

Sinon, tu peux également installer le paquet "printer-driver-all-enforce" qui pourra peut être forcer l'installation de quelque chose qui te manquerait.

J'ai également regardé en ajoutant le "non-free" au dépôt de debian Jessie, mais il ne semble pas y avoir d'avantage de paquets de pilotes d'imprimantes. Donc, la piste du "non-free" tombe à l'eau. Ceci dit Didier et sub26nico, jetez-y un œil, j'ai regardé ça en bossant sur l'intégration de paulstretch sur LZK, du coup, peut être qu'un truc m'est passé à côté des yeux sans que je ne le remarque.

Ça m'intéresse bien de savoir ce qui se passe ici, donc si vous trouvez une solution, tenez moi au jus.

Et aussi, avant de retourner à PaulStretch, c'est une question générale "debian" ça, donc peut être aller voir chez debian-facile (ou autre) pourra vous aiguiller.

Bon courage !

bluedid29 utilisateur non connecté France
Merci pour les infos,

Mon imprimante HP Office 8600 est branchée en USB et reconnue par l'utilitaire HP (voir 1er post).

Quand je fais lpinfo -v, j'ai le résultat suivant :

direct hp:/usb/Officejet_Pro_8600?serial=CN38HEXHFV05KC
direct usb://HP/Officejet%20Pro%208600?serial=CN38HEXHFV05KC&interface=1
direct usb://HP/Officejet%20Pro%208600%20FAX?serial=CN38HEXHFV05KC&interface=3
direct hpfax:/usb/Officejet_Pro_8600?serial=CN38HEXHFV05KC


Donc, elle est bien reconnue !

Il manque en fait cela dans le menu : Système > Administration > Impression

Pourtant, j'ai tout installé ce qui concerne MATE

Sinon, il reste à le faire en ligne de commande...

Je vais y arriver... wink

bluedid29 utilisateur non connecté France
J'ai trouvé !!!! biggrin

J'ai rajouté le menu impression par apt-get install system-config-printer en mode administrateur

Puis ensuite, j'ai lancé la recherche d'imprimante, et voilà wink

Bonne journée, cela commence bien en tout cas !

BlueDid cool

PS : Je mettrai [RESOLU] quand le problème de sub26nico sera.... ....ben résolu en fait ! mrgreen

sub26nico utilisateur non connecté France
T'es le meilleur BlueDidexclaim

J'ai réinstallé les drivers, puis dans un terminal administrateur

lpinfo -v


qui m'indiquait que l'imprimante était reconnue, puis, toujours en administrateur,

apt-get install system-config-printer


Ensuite 'Système','Administration', 'Configuration de l'impression', je lance la recherche...marche pas !
puis j'ai relancé la recherche après avoir coché un truc dans les options, genre 'permettre les impressions en réseau',
désolé, je n'ai pas noté sur le moment le terme exact, puis la recherche m'a trouvé l'imprimante, 'appliquer' puis 'valider'
et en voiture Simone !

Par contre, la qualité des couleurs est pas top mais pas du à LibraZiK, j'ai le même soucis sur Ubuntu,
je creuserai plus tard car sur système proprio, aucun soucis, et le driver est pourtant fournis par Canon.

En tout cas, c'est résolu de mon coté également!
Grand merci à toi BlueDid biggrin

PS: petite colle pour olinuxx, je n'ai pas eu besoin de ces manips sur mon laptop, juste l'instal' des drivers et ça roulait.
Je n'ai pas de menu d'impression donc mais elle est reconnue par les softs....Peut être les drivers(non free) que j'avais installé
comme un bourrin pour résoudre le problème du wifi, mais j'ai fait le ménage depuis,
j'en ai peut être laissé quelques uns, ignorants leurs rôles.

bluedid29 utilisateur non connecté France
Super !!! smile Faut surtout dire grand merci aux forums spécialisés Debian ou je me suis baladé ce matin wink

sub26nico utilisateur non connecté France
HS : il est vraiment super et très complet ce menu d'impression, on peut vraiment régler aux petits oignons l'impression,
dommage que j'y connaisse riensad

bluedid29 utilisateur non connecté France
Fais comme moi, clique partout !!! mrgreen biggrin wink

olinuxx utilisateur non connecté France
Ouhaou, bien joué Didier !

@sub26nico et Didier : donc, en résumé, il manquait simplement le paquet "system-config-printer" pour que ça fonctionne ? Merci de me le confirmer. Si c'est bien ça, je l'ajouterai à LibraZiK.

sub26nico écrit :
PS: petite colle pour olinuxx, je n'ai pas eu besoin de ces manips sur mon laptop, juste l'instal' des drivers et ça roulait.
Je n'ai pas de menu d'impression donc mais elle est reconnue par les softs....Peut être les drivers(non free) que j'avais installé
comme un bourrin pour résoudre le problème du wifi, mais j'ai fait le ménage depuis,
j'en ai peut être laissé quelques uns, ignorants leurs rôles.


Comme ça, de but en blanc ... ... ... aucune idée.
Si tu trouves une réponse à ça, dit la moi, ça m'intéresse.

bluedid29 utilisateur non connecté France
Oui Olivier, tu peux rajouter ce paquet, si les pilotes sont installés, tout devrait rouler ensuite...

Bien sur, il est possible d'installer en ligne de commande mais bon, cette distribution s'adresse aussi aux débutants qui peuvent avoir besoin d’imprimer rapidement des partitions avec MuseScore par exemple ! wink

A noter donc qu'un (possible) bogue en impression a été éliminé, il existait depuis un moment chez moi dis donc, impossible d'installer une imprimante sur Debian Jessie jusqu'à aujourd'hui ! j'avais essayé Debian MX en 32 et 64 bits, Librazic 32 et 64 bits et d'autres... ...pour le même résultat mrgreen

Cette résolution de problème d'impression est donc une très bonne nouvelle biggrin

sub26nico utilisateur non connecté France
olinuxx écrit :
@sub26nico et Didier : donc, en résumé, il manquait simplement le paquet "system-config-printer" pour que ça fonctionne ? Merci de me le confirmer. Si c'est bien ça, je l'ajouterai à LibraZiK.


Après vérification, "system-config-printer" est bien installé sur mon laptop,
je suis pourtant sur de ne pas l'avoir fait, confirmé par
Synaptic qui ne trouve pas ce paquet dans son historique des modifications.

J'en tire l'hypothèse suivante, à confirmer, que le paquet est venu avec Debian-net-install,
car j'ai installé LZK par ce biais là car pas de live 64bits à l'époque.

Il serait intéressant de le trouver dans LZK, voir dans le live
si ça peut aider à vérifier la compatibilité de l'imprimante avant installation 'en dur'.

olinuxx utilisateur non connecté France
OK, merci pour le retour les gars.

bluedid29 écrit :
Bien sur, il est possible d'installer en ligne de commande mais bon, cette distribution s'adresse aussi aux débutants qui peuvent avoir besoin d’imprimer rapidement des partitions avec MuseScore par exemple !


Complètement d'accord avec ça.

J'ai donc refait le méta-paquet librazik-base-systeme en version 1.06 pour qu'il entraîne l'installation automatique de system-config-printer. J'en ai profité pour y ajouter bluez-cups (paquet pour la gestion des imprimantes en Bluetooth par le serveur d'impression CUPS). Normalement, une simple mise à jour de votre système LZK, et hop, c'est tout bon. Il sera donc intégré dans le prochain Live de LibraZiK version 1.4 qui sortira ... quant ça sera prêt :-)

À noter que ceci ajoute un lien dans menu LZK -> Système -> Administration -> Configuration de l'impression

Merci !

PS : ce bogue a été rapporté sur le logiciel de suivi des tâches de LZK. Bogue 190.

olinuxx utilisateur non connecté France
PS 2 : si il y en a d'entre vous qui ont le temps d'essayer une installation fraîche de LibraZiK pour voir si ça fonctionne bien, c'est bienvenu. N'oubliez pas de mettre à jour avec Synaptic après l'installation car le live n'a pas été refait, mais la mise à jour apportera (normalement si j'ai bien fait mon boulot) les paquets nécessaires cités plus haut.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Mégaphone [Afficher / Cacher]

olinuxx, 13:44, ven. 22 Jan 2021: Nouveautés LibraZiK : [Lien]
sub26nico, 13:28, jeu. 21 Jan 2021: Salut et bienvenue à Yo du Milieu :-)
olinuxx, 18:17, mer. 20 Jan 2021: Bonjour et bienvenue à jaylcee cool
olinuxx, 19:11, mar. 19 Jan 2021: Bonjour et bienvenue à BPM_CONTEST cool
calixtus06, 15:29, lun. 18 Jan 2021: Bienvenue à Bruno29 ! :-)
olinuxx, 18:22, sam. 16 Jan 2021: Bonjour et bienvenue à witold et à Toctoc cool
olinuxx, 21:11, ven. 15 Jan 2021: Pas de soucis.
louiesauvage, 19:44, ven. 15 Jan 2021: ok désolé olinuxx
olinuxx, 19:40, ven. 15 Jan 2021: Pareil pour toi @louisauvage, si tu as une question, utilise le forum.
olinuxx, 19:40, ven. 15 Jan 2021: Bonjour et bienvenue @Polo cool. Utilise les forums pour les questions (lien dans le menu en haut du site).
louiesauvage, 19:39, ven. 15 Jan 2021: bonjour quelqu'un à essayé les cartes son antelope audio?
Polo, 16:24, ven. 15 Jan 2021: Bonjour, Je voudrais connecter un clavier M-audio keysattion mini 32 MK3 sur un ordinateur avec Ubuntu 20.04 et Ubuntu Studio- Installer. J'ai installé le module audio mais cela ne marche pas. Quelqu'un peut m'aider ? En fait je n'ai plus de son ..