Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

Dernier post

Konnekt8 - firewire et alsa

BenjBoy utilisateur non connecté
Bonjour à tous,

voilà 3 jours que je planche sur le truc.

Prologue :
Je suis un gros gamer, j'étais donc jusqu'à il y a peu, sur windows10. Puis utilisant Ubuntu au taf, j'ai fini par ne plus comprendre pourquoi on utilisait un OS aussi mal pensé, pour être poli. J'ai pris connaissance de Lutris (plateforme de compatibilisation gaming Windows -> Linux, en gros) et j'ai donc installé Ubuntu 19.10 sur un nouveau SSD pour faire un test.

Déroulé des évènements :
L'installation de U19.10 se passe très bien, je lance l'OS, et là ouah, j'ai du son, directement sans rien faire. Bon je remarque que ça craquouille un peu, je me dis que je devrais pouvoir les enlever facilement.
J'ai commencé à regarder, j'ai découvert jackd, ffado, cadence, l'ajout dans groups "audio", le déverouillage des limites de ressources, le blacklistage de snd-dice, etc... J'ai vraiment essayé beaucoup de chose.

Tout ces essais ont au mieux, eut exactement la même qualité de son qu'au départ (good mais légers craquements) au pire coupé complètement le son et même éteint la carte (il y a une LED bleue qui s'allume lorsqu'elle est connectée) lorsque je blacklistait snd_dice comme me le demandais jackd.

Ayant vu le topic à ce propos, je suis passé sur Alsa, et ça marche pas trop mal, le serveur jackd se lance mais n'apporte rien, en fait.

En lisant à droite à gauche, ça ressemble à des problèmes de xrun mais je n'en ai pas vu un seul dans les logs et même lorsque je coupe le process jackd (lancé en ligne de commande) c'est marqué "aucun overrun".

Mais d'ou donc ça peut bien venir ces craquements ?

J'ai pensé à un problème de matériel mais la carte PCI, comme la konnekt8, est parfaitement reconnue par windows.

Je suis à bout d'idée. Je fouille le web un peu partout.

a+

BenjBoy utilisateur non connecté
Précision sur "qu'est-ce qu'il fait le son".

Le son passe correctement mais on entend des petits "tics" à une fréquence de répétition d'environ 2 à 3 fois par seconde, et toute les 30 secondes environ, un freeze total du son qui se coupe, moins d'une seconde.

je sais pas si le symptôme est reconnu, mais à toute fin utile.

a+

BenjBoy utilisateur non connecté
Hello,

non pas essayé une autro distro. Tu penses que ça ferait une différence ? A priori a peu près toute les distro devrait pouvoir accueillir tel ou tel paramétrage (un peu poussé avec toutes les subtilités que je citais en exemple plus haut) ? Noyau linux quoi, enfin de ce que j'en sais à mon niveau.

C'est frustant parce que j'ai lu sur la page de la K8 qu'un gars semble y être parvenu ("thanks to all developpers ... and after a little troubleshooting it worked").

Et donc oui il s'agit bien de la Konnekt8 de TC.

Là pour l'instant j'utilise (pour jouer sur lutris) ma carte son intégrée qui marche parfaitement. J'avais quand même fini par mettre en doute mon casque ... Mais non.

Pour info j'ai retrouvé mon ancienne M-Audio firewire solo, qui n'est pas reconnue du tout (avec le snd_dice blacklisté ou pas). Sur la page dédiée elle est inscrite en statut "experimental". Je n'ai pas plus poussé que ça.

[edit : ah mais la M-Audio c'est une "firewire solo", pas "audiophile", j'ai rien dis.]

a+

olinuxx utilisateur non connecté France
Des nouvelles ici @BenjBoy ?
Oui, ça peut fonctionner mieux ou moins bien suivant la distribution utilisée (le noyau, les réglages,...). Donc ça vaut le coup d'essayer ça.

Si pas de nouvelles d'ici à mon prochain passage de maintenance, je fermerai avec un [ABANDONNÉ].

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

allany, 19:11, ven. 27 mai 2022: @anonyme304 : tu n'obtiendras pas de réponse ici à une question aussi technique. Le mieux : ouvre un sujet dans le forum approprié. Bonne chance !
anonyme304, 17:57, ven. 27 mai 2022: Bonjour, j'ai ubuntu 20.04. Je n'y connais pas grand chose. je suis sur LMMS j'ai réussi a connecter mon clavier maître dessus mais je n'arrive pas a faire sortir le son par les hauts parleur de mon ordinateur le son dort que par le haut parleur de mo
olinuxx, 12:00, jeu. 26 mai 2022: Bonjour et bienvenue à gurneyalex cool
olinuxx, 16:01, dim. 22 mai 2022: Bonjour et bienvenue à bap23 et gorphex cool
minimoineau, 20:15, jeu. 19 mai 2022: Petite pensée pour la magnifique œuvre de Vangelis qui nous a quitté... cry
olinuxx, 09:44, lun. 16 mai 2022: Bonjour et bienvenue à Fan cool
olinuxx, 09:43, dim. 15 mai 2022: Bonjour et bienvenue à nik0 cool
olinuxx, 12:25, ven. 13 mai 2022: Bonjour et bienvenue à Michael83 et MiniGnome cool
olinuxx, 20:06, jeu. 12 mai 2022: Bonjour et bienvenue à Valnax cool
olinuxx, 17:35, lun. 09 mai 2022: [ANNONCE] La nouvelle version LibraZiK-4 est sortie ! [Lien]
olinuxx, 08:27, dim. 08 mai 2022: Une nouvelle concernant le futur des greffons LV2 : [Lien]
olinuxx, 10:58, sam. 07 mai 2022: Bonjour et bienvenue à Fabrice et à BertoX cool