Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié à Ardour

> Forums de discussion > 3 - Forum dédié à Ardour > pb de compilation ardour-vst
Dernier post

pb de compilation ardour-vst

Jazzboubs utilisateur non connecté
Bonjour, tout le monde.
J'essaie désespérément de compiler Ardour avec les VST.
j'ai essayé avec les versions 2.4 et 2.5, et j'obtiens toujours la même erreur:
Citation :
/usr/include/slv2/world.h:61: erreur: «librdf_world» was not declared in this scope


voici ma démarche:

je décompresse :
Citation :
tar xjvf ardour-2.5.tar.bz2

je copie le support sdk :
Citation :
cp vst_sdk2_3.zip ardour-2.5/libs/fst

dans le dossier, un petit scons
Citation :
scons VST=1

et là, c'est le drame :
Citation :
.......
Dans le fichier inclus à partir de /usr/include/slv2/slv2.h:40,
à partir de libs/ardour/ardour/lv2_plugin.h:34,
à partir de libs/ardour/ardour/plugin_manager.h:31,
à partir de libs/ardour/globals.cc:58:
/usr/include/slv2/world.h:28:20: erreur: librdf.h : Aucun fichier ou dossier de ce type
In file included from /usr/include/slv2/slv2.h:40,
from libs/ardour/ardour/lv2_plugin.h:34,
from libs/ardour/ardour/plugin_manager.h:31,
from libs/ardour/globals.cc:58:
/usr/include/slv2/world.h:61: erreur: «librdf_world» was not declared in this scope
/usr/include/slv2/world.h:61: erreur: «world» was not declared in this scope
scons: *** libs/ardour/globals.os Error 1
scons: building terminated because of errors.


Je ne comprends pas...eek
quelqu'un peut-il m'aider, please ?


elpioupiou utilisateur non connecté
bah en gros il dit que ton fichier world.h fait référence au fichier librdf.h, mais il ne le trouve pas dans le répertoire des fichiers à inclure (probablement /usr/include/slv2/)
solution aller chercher le fichier librdf.h sur internet ici où alors faire une recherche sur les dépots de ta distribution

bon courage

Jazzboubs utilisateur non connecté
Merci elpioupiou pour cet aiguillage.
j'avais déja librdf0 installé, mais visiblement, il m'en manquait une. Du coup, ne sachant quelle librdf prendre, j'ai installé les 3 que j'ai trouvé via synaptic. Aprés, plus de problème, la compilation se termine et l'installation se fait sans soucis. tout a l'air de fonctionner.biggrin

merci


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

minimoineau, 20:15, jeu. 19 mai 2022: Petite pensée pour la magnifique œuvre de Vangelis qui nous a quitté... cry
olinuxx, 09:44, lun. 16 mai 2022: Bonjour et bienvenue à Fan cool
olinuxx, 09:43, dim. 15 mai 2022: Bonjour et bienvenue à nik0 cool
olinuxx, 12:25, ven. 13 mai 2022: Bonjour et bienvenue à Michael83 et MiniGnome cool
olinuxx, 20:06, jeu. 12 mai 2022: Bonjour et bienvenue à Valnax cool
olinuxx, 17:35, lun. 09 mai 2022: [ANNONCE] La nouvelle version LibraZiK-4 est sortie ! [Lien]
olinuxx, 08:27, dim. 08 mai 2022: Une nouvelle concernant le futur des greffons LV2 : [Lien]
olinuxx, 10:58, sam. 07 mai 2022: Bonjour et bienvenue à Fabrice et à BertoX cool
olinuxx, 10:51, sam. 07 mai 2022: Une petite fringale ? Alors un bout de pain et de maroilles et hop ! Lecture de l'éditorial !
allany, 19:40, ven. 06 mai 2022: Universal r1 !!!
r1, 21:35, jeu. 05 mai 2022: Dans le Cantal, à Cancale ou à la Capitale, tous kiffent l'éditorial !
allany, 21:11, jeu. 05 mai 2022: C'est du métal, c'est phénoménal, idéal, l'éditorial ! [Lien]