Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

Dernier post

Wifi et Xruns

Patate sympa utilisateur non connecté
Bonjour, utilisateur de Bitwig depuis quelques années sur ma machine principale je ne rencontre aucun soucis. Tout est stable, tout va bien. Cependant sur mon pc portable j'ai des xruns qui apparaissent uniquement lorsque le wifi est allumé (craquements, le visualiseur DSP de Bitwig qui s'excite). Mais si je coupe le wifi, tout est parfait. Si je me mets en partage de connexion avec mon téléphone, je n'ai aucun soucis non plus. Même en navigant un peu à côté pour tester je n'ai pas de craquements ou coupures.

J'ai optimisé au maximum ma machine avec toutes les optimisations que j'ai pu trouver sur le sujet et vérifié avec realtimeconfigquickscan.
Je suis sous Fedora 35 (les deux machines) et utilise à chaque fois ma Motu M4. Le carte wifi est une BCM4360.

piratebab utilisateur non connecté
Bonjour,
peux tu clarifier un point de ton message STP.
Tu écris que lorsque le wifi de la l'ordi est allumé, tu as des craquements (cela suppose que tu as un interrupteur logiciel ou matériel). Mais ensuite tu nous dis que tu fais un partage de connexion avec ton téléphone. Est ce par câble USB ?

Je vois 2 causes possibles à ton problème:
- matérielle (les ondes wde la carte wifi perturbent la carte son). Pour le vérifier, utilise une autre carte son externe, utilise un câble USB plus performant, déplace ta carte son ....
- problème logiciel: vérifie déja la charge CPU et l'utilisation mémoire lorsque les craquements se produisent.

Patate sympa utilisateur non connecté
Oui, bien sur je vais ajouter quelques précisions:
Si j'ouvre un projet Bitwig type avec un simulateur d'ampli et une batterie par exemple et que je lance la piste, je vais avoir des xruns irréguliers (minis décrochages audio et en même temps que je peux visualiser via le graphe DSP de Bitwig) uniquement lorsque le wifi est allumé (via les paramètres de Gnome).
-Si je mets le wifi sur off (toujours via les paramètres de Gnome), je ne vais avoir aucun décrochages audio ni "pics" visuels sur le graphe de Bitwig. Tout est impeccable.
-Si je crée un partage de connexion en Bluetooth ou en USB, je n'ai aucun soucis également.
-En partage de connexion Wifi avec mon téléphone, le problème reviens.
-Ni la mémoire où le CPU n'est surchargé lors de mes tests.
-J'ai essayé avec la carte son interne et ma carte externe (Motu M4) et j'ai le même résultat.

Je fais une petite vidéo pour illuster. On peut visualiser le décrochage lorsque je wifi est allumé. Il n'y a pas de son car c'était sur ma carte externe au casque mais à chaque "pic" il y a un décrochage audio. Dans la vidéo il y'a une piste de batterie VST en boucle et la piste avec le simu d'ampli.
https://streamable.com/7kex1j

J’espère avoir été assez clair. Merci.

dlb utilisateur non connecté
Bonjour,

rtirq est peut-être une solution s'il n'est pas déjà installé ...

rtirq

Patate sympa utilisateur non connecté
Bonjour, en effet je ne l'avais pas fait. Je m'étais penché dessus au début de ma transition vers Linux et je n'avais pas tout saisi. J'en avais gardé un souvenir un peu abstrait.
Et effectivement en m'y repenchant, je pense avoir mieux compris et le maintenant tout fonctionne nickel! Merci pour la suggestion.
Si quelqu'un veut mieux bien me confirmer si j'ai bien tout saisi. Les paramètres que j'ai rentré sont:

RTIRQ_NAME_LIST="rtc xhci_hcd" (xhci_hcd correspond si j'ai bien compris au contrôleur USB et rtc à l'horloge interne. Je ne sais pas si il faut que je rajoute autre chose)

Highest priority.
RTIRQ_PRIO_HIGH=99

Priority decrease step.
RTIRQ_PRIO_DECR=2

Lowest priority.
RTIRQ_PRIO_LOW=65

Priority for udev rules
RTIRQ_PRIO_UDEV=70

Default priority for irq processes
RTIRQ_PRIO_DEFAULT=53 (il s'agit de l'IRQ correspondant à l'xhci_hcd et que j'utilise une carte son USB)

Tant que l'on y est, concernant le fichier de configuration de PAM pourquoi on peut voir sur différents site des valeurs conseillées différentes (en gros entre 90 et 99 pour le RTprio)? Est-ce que cela fait une différence?

Merci encore pour votre aide.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 07:18, lun. 30 Jan 2023: Bonjour et bienvenue à blug et X836461 :-)
olinuxx, 21:07, dim. 29 Jan 2023: Nouveautés à propos de LibraZiK : [Lien]
olinuxx, 09:11, dim. 29 Jan 2023: @louiesauvage, utilise plutôt les forums pour poser des questions.
louiesauvage, 12:11, mar. 24 Jan 2023: Qui utilise Ardour avec antelopes audio
olinuxx, 18:56, lun. 23 Jan 2023: Bonjour et bienvenue à zigaboo, gotouch, et Yrbua cool
olinuxx, 21:35, lun. 16 Jan 2023: Bonjour et bienvenue à KABORE Alain et à minimalist cool
calixtus06, 07:04, ven. 13 Jan 2023: Bonjour et bienvenue à bullrai :-)
calixtus06, 07:23, lun. 09 Jan 2023: Bonjour et bienvenue à editgo :-)
allany, 18:30, jeu. 05 Jan 2023: Les années passent, reste l'éditorial ! [Lien]
olinuxx, 16:24, mar. 03 Jan 2023: Bonjour et bienvenue à runny cool
djkarlito, 22:49, lun. 02 Jan 2023: AKAI AMX skin pour MIXXX;Bonne année a tous
olinuxx, 13:26, lun. 02 Jan 2023: Bonjour et bienvenue à zobi8225 cool