Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[résolu] jack 2 est il stable?

ben280 utilisateur non connecté France
bonjour,
ayant un ordinateur plutot puissant je me suis dit et pourquoi ne pas installé jack2... je voulais avant avoir quelques impression au sujet de celui-ci... me conseiller vous d'attendre un peu (je cherche la stabilité...) ou de foncé?
merci
ben

pianolivier utilisateur non connecté France
oui ! sans hésiter !
un des travaux sur la nouvelle version de jack est justement sa stabilité !
après ca dépend surtout de ton système...

oliv'

ben280 utilisateur non connecté France
je suis sur linuxmint 8.04 64 bit (quadcore 2.6ghz, 8go de ram...) ca le ferai alors? je vais essayé je vous tiens au ju...

pianolivier utilisateur non connecté France
eheh avec ca, ca devrait rocker !
d'ailleur je pense même que ton pc est trop puissant...
...tu veux pas en donner des petits bouts ?? biggrinbiggrin

ben280 utilisateur non connecté France
bon apperemment ya un pb... jé bien suivi le tuto http://www.linuxmao.org/tikiwiki/tiki-index.php?page=jack_installation
quand je tape
./waf configure --prefix=/usr no problem

ms quand je tape
./waf
voila ce que jé en fin de commande:


[+]
je ne comprend pas pourriez vous m'éclairer?

merci

ben
Je précise certaine choses... quand je tape ./waf configure --prefix=/usr jé ca

[+]

Je travaille avec une rme hammerfall hdsp 96/52 (carte pci)

ben280 utilisateur non connecté France
bon par curiosité jé continuer l'installation ca donne ca:

[+]

et ca à l'air de marché... des idées?

pianolivier utilisateur non connecté France
re !
pour commencer, dans tes posts, ca serait bien d'essayer d'agrémenter la lecture en mettant des balises de code du genre :
{CODE()}les résultats de la ligne de commande {CODE}
ce qui donne
les résultats de la ligne de commande

c'est plus joli non ?biggrin
la barre du haut "Raccourcis" permet de faire tout un tas de trucs comme ca
ensuite pour des logs longs de 10 km, et pour éviter aux lecteurs d'avoir a descendre avec la molette de la souris tout en bas de la page tu peut utiliser le sigle
*-
ce qui donne

[+]
voila pour la mise en page (essaye de ré-éditer ton message de cette facon)

pour en revenir a ton problème, je dirai que alsa-lib n'est pas installé correctement
peux-tu regarder de ce coté la ?

je connait pas tres bien linuxmint, mais n'es tu pas senser utiliser des paquets .deb plutot que de compiler a la main ? (je me trompe peut etre...)
et puis question subsidiaire : as tu un noyau réglé en temps réel ? (important pour profiter pleinement de jack)

oliv'

jy_moustache utilisateur non connecté
salut

merci pianolivier pour ce petit rappel sympathique concernant la mise en page biggrin

en fait quand tu fais
./waf configure
waf te dit ce qu'il te manque pour compiler correctement jack2.

donc il faut que tu installes une version de celt récente... fais une recherche dans les paquets et installe celt ainsi que ses headers (pour pouvoir compiler avec). En général les headers sont du type nom_de_paquet-dev ou nom_de_paquet-devel ou nom_de_paquet-dev0.

les headers alsa ont l'air d'etre installé donc pas besoin de regarder de ce côté là.

L'installation se termine par
OSError: [Errno 2]
donc non ça n'a pas marché ou alors c'est une bande de petits rigolos les codeurs de jack2 qui font dire error quand en fait c'est success wink

ATTENTION : puisque tu as poursuivi l'installation, il va falloir que tu fasses le ménage avant de réinstaller. Voir ici

Tiens nous au courant !

jy

ben280 utilisateur non connecté France
yes merci,
bon j'essai de m'améliorer pour la mise en page mais c pas tout à fait ca encore...

alors d'après ce que tu me dit "jy moustache" il faudrai que j'installe celt mais je ne vois pas pourquoi puisque apperemment ca ne sert que pour le réseau or je n'en ai pas l'utilité...

Je comfirme que je suis bien sur un noyau rt (pour répondre à pianolivier) et pour ce qui est de la version de jack 2 je ne l'ai pas trouvé en .deb donc obliger de compiler...

De plus, lorsque je lance jack, il fonctionne pour l'instand sans probleme... J'ai travailler sur ardour, rezound et il ne m'a pas fait de plantage ou quoi que ce soit...

ben280 utilisateur non connecté France
OUAI!!! biggrinbiggrinbiggrin génial

[+]
cool

[+]

jy_moustache utilisateur non connecté
ha ha ha ha ha !!!!
très bon la mise en page biggrin

Citation :
il faudrai que j'installe celt mais je ne vois pas pourquoi puisque apperemment ca ne sert que pour le réseau or je n'en ai pas l'utilité...

peut-etre mais visiblement c'est nécessaire pour que jack2 compile

pour info, jack2 n'existe pas en paquet. Seules les sources sont disponibles...

jy

olinuxx utilisateur non connecté France
Coucou wink

essaie quand même après avoir installé un paquet CELT (ou libcelt, ou quelque chose comme ça) et les dev qui vont avec. Chez moi sous Ubuntu 9.10, j'ai la version 0.6 et je n'ai pas cette erreur.

Ceci dit, c'est étrange car le message d'erreur fait plutôt penser à un manque de bilbiothèque de développement d'Alsa ( libasound2 + libasound2-dev). Les as-tu bien installées ?

++
Olivier

ben280 utilisateur non connecté France
salut olinuxx

jé bien installé libsound, pour ce qui est de celt je l'ai installé par gestionnaire de paquet mais c la version 0.5.2... et jé les meme erreur lors de la réinstall....

olinuxx utilisateur non connecté France
alors autant prendre les informations à la source .
wink

Pravoslavac utilisateur non connecté
Hello,

P'tite question : JACK2 est compatible avec Qjackctl ? Et JACK2 en dehors des autres modifications, c'est un serveur qui exploite les systèmes multicores je ne me trompe pas ?

pianolivier utilisateur non connecté France
Citation :
P'tite question : JACK2 est compatible avec Qjackctl ? Et JACK2 en dehors des autres modifications, c'est un serveur qui exploite les systèmes multicores je ne me trompe pas ?

oui et re-oui Pravoslavac
c'est un programme mutli-thread (avec des sous-programmes)
de tete il supporte 2 procs, mais c'est a verifier...

jy_moustache utilisateur non connecté
Citation :
de tete il supporte 2 procs, mais c'est a verifier...

oui, exact !
j'avais trouvé l'info un jour mais impossible de remettre la main dessus.
peut-etre sur le blog de jack....

jy

pianolivier utilisateur non connecté France
Citation :
de tete il supporte 2 procs, mais c'est a verifier...

verification faite, nous nous sommes fourvoyé (peut etre du au fait qu'il existe des rapports de tests de comparaison sur des machines 1 et 2 processeurs)
en fait, jack prend en compte le nombre de processeur existant, le principe de la technologie multi-thread etant de lancer un sous-programme sur le proc 1, un deuxieme sur le proc 2 etc...
evidemment, s'il n'y a que 2 sous-programmes (threads) et 4 processeurs, seul la moitiié d'entre eux sera utilisé
sources
Citation :
for uniprocessor and multiprocessor machines

Citation :
several available CPU at the same time

Citation :
On a 4 cores Intel Mac Pro running jack...


olinuxx utilisateur non connecté France
Coucou, wink

peut être à remonter plus clairement ici : jackdmp ?
Vous-en pensez quoi ?

++
Olivier

klem utilisateur non connecté France
Salut,

jack2 a été développé pour le support multirpocessor (et quelques autres refactoring), qui correspond à la fonctionnalité smp (symetric multi processor) du kernel. C'est la même chose pour les multicores qui se comportent presque pareil.
En fait si tu tapes uname -a tu devrais voir les infos de ton kernel dont les options PREEMPT (por le temps réel) et SMP.

Perso, je suis passé à jack2 car sur ma debian 64bits avec un dual core comme proc, j'avais des craquements du à des buffers overrun avec jack1. Je suis passé à jack2 et tout est nickel: le son, la stabilité, etc

Pour ton problème de compile, tu as pris la derniere release de source existante ou les sources CVS de jack? Apparement tout est ok niveau conf. Est-ce qu'il aurait oublié de remettre à jour la version d'alsa dépendante.

Le problème semble que la fonction existe bien dans les headers alsa (*.h) mais pas dans la lib alsa au moment du linkage (*.so).
Est-ce que tu as la même version entre les paquages alsa et alsa-dev ?

Sinon essaye avec une autre version, c'est peut-être une mauvaise release.

ben280 utilisateur non connecté France
@olinuxx je pense que effectivement c sa bonne place

@klem je suis actuellement sur linuxmint 8.04 64 bit (jé un quadcore 2.6 ghz...) et je viens d'installé jack2 et jé effectivement l'impression que sur ardour (sachant que jé des gros projets) c beaucoup plus stable...

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

allany, 19:56, dim. 05 Apr 2020: :-D
r1, 19:56, dim. 05 Apr 2020: @allany : ouais !!! c'est noël ! Quelle équipe hallucinante ! :-D
allany, 19:28, dim. 05 Apr 2020: L'édito, c'est le bon topo, les cocos ! [Lien]
olinuxx, 21:36, mer. 01 Apr 2020: Bonjour et bienvenue à simon_martineau, martineau_simon, et à Roland57 cool
olinuxx, 20:13, mar. 31 mars 2020: Bonjour et bienvenue à sethi1cool
Nolwen, 22:46, lun. 30 mars 2020: Sortie d'Hydrogen 1.0.0-beta 2 ce 30 mars 2020. [Lien]
olinuxx, 17:39, lun. 30 mars 2020: Bonjour et bienvenue à JulienRadio cool
sub26nico, 23:48, dim. 29 mars 2020: Salut et bienvenue à Chihiro49130, Gigi, Ptilou, yudas, FF63, mimifloch, mvvl et tophque :-)
malt, 15:55, dim. 29 mars 2020: @Sahaathyva. Je n'avais pas vu ton post!
malt, 15:51, dim. 29 mars 2020: Ardour 6.0-pre1: [Lien]
sub26nico, 20:50, ven. 27 mars 2020: Salut et bienvenue à Topyweb, Serge Samson, ChtiJeff, Zeplead et Zonzon :-)
r1, 20:27, ven. 27 mars 2020: La joute 15 est sur les rails ! [Lien] Viendez jouer avec nous !!!