Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [ABANDONNÉ] Problème Jack + divers programmes sur Ubuntu Studio 10.04
Dernier post

[ABANDONNÉ] Problème Jack + divers programmes sur Ubuntu Studio 10.04

chtfn utilisateur non connecté
Au secours !

Je ne veux pas avoir l'air pitoyable, mais je suis vraiment sur le point de craquer !

En fait, à chaque fois qu'une nouvelle version d'Ubuntu Studio apparaît, je l'installe en espérant que les problèmes que j'avais avec la précédente disparaitraient. Mais en fait, avec la nouvelle 10.04, après m'être battu avec Network Manager pour enfin avoir une connexion wifi, je me retrouve avec les même problèmes qui me bloquent dès le début en ce qui concerne la production musicale.

Donc me revoilà ici, pour demander de l'aide sur les choses auxquelles je n'ai pas trouvé de réponse autre part.

1. Jack Control : le serveur se lance vraiment quand il veut. Mais en général, ça ne marche pas et ça me donne ça :


[+]

Pourtant, j'ai suivi beaucoup de conseils, essayé pas mal de configurations, mais c'est toujours la même chose. Et pour info, j'ai le noyau temps réel 2.6.31-10-rt, que j'ai installé moi-même grâce au StartUp Manager que j'ai installé moi-même par la Logithèque Ubuntu que j'ai installée moi-même par Synaptic. Et j'ai toutes les autorisations audio, je suis dans le groupe audio et limits.conf est modifié en conséquence (d'abord à la main, puis via Ubuntu Studio Controls). Mais rien n'y fait.

Ah oui : et quand la fenêtre de Jack Control est ouverte, il est impossible d'ouvrir Firefox, ou même un fichier texte (!).

2. Hydrogen marche bien quand Jack veut bien se lancer, mais le problème que j'ai toujours eu est toujours là : impossible de charger mes propres couches .wav pour créer mon kit personnalisé. Le programme se plante et se ferme dès que je clique sur un son de ma banque, dans le navigateur d'Hydrogen. Pourtant, je n'ai aucun problème à lire un .wav avec n'importe-quel autre programme.

3. FreeWheeling : dans les version précédentes d'Ubuntu Studio, j'arrivais tout de même à relier Hydrogen et FreeWheeling par Jack, et dès que ça ne plantait pas, je pouvais m'amuser un peu. Mais maintenant, en cliquant sur l'îcone de FreeWheeling, il ne se passe absolument rien : je n'en vois pas le bout de son nez. Que ce soit avec ou sans Jack.

4. Sooper Looper : comme toujours, si je le lance avec Jack qui fonctionne, 10 secondes après l'avoir lancé, il m'annonce :
Lost connection to SooperLooper engine.
See the Preferences->Connections tab to start a new one.

Mais si je le lance sans Jack, il plante et me ferme toutes les fenêtres en cours. Si j'ouvre à nouveau d'autres fenêtres, elles sont dépourvues de cadre...

Voilà.

Je n'ai pas encore essayé ZynAddSubFX ou PureData, mais ça promet...

Merci pour un quelconque conseil. J'ai toujours été ravi de m'intéresser au libre, de le découvrir et d'en parler autour de moi, mais là je me sens de moins en moins « libre » face à mon portable, justement...

Cordialement.

Samuel utilisateur non connecté Allemagne
Tu pourrais détaille ta config ?
As-tu deux cartes son ? Parce que là, jack est réglé avec hw:1, ce qui est la deuxième carte son. Si tu ne veux pas utiliser ta deuxième carte son, ou si tu n'en as pas, essaie avec hw:0 dans les paramètres de qjackctl. Passer le nombre de période/tampon à 3 permet des fois de stabiliser jack.

Pour le reste là à froid je ne sais pas trop.

gregolak utilisateur non connecté
Il faudrait aussi le contenu de la fenêtre "messages" de qjackctl après le plantage.

chtfn utilisateur non connecté
Bonjour Samuel et Gregolak ! Merci pour vos réponses. Désolé pour le ton pas très agréable de mon message, j'étais un peu au bout du rouleau après quelques heures d'essais divers qui n'ont fait qu'empirer les choses.

Alors, ma config :
J'ai un Toshiba Satellite A100, deux cartes son : une intégrée, une USB dans mes baffles (Alesis M1 Active 320 USB). Les deux marchent parfaitement, elles sont bien reconnues par Ubuntu, je peux les sélectionner dans le Contrôle du volume Pulse Audio. Donc la hw:1 c'est ma carte USB, qui est bel et bien utilisée quand Jack est lancé.
Quelle est la commande pour avoir toutes les spécifications des cartes son ?

Je vais essayer de changer la valeur de période/tampon.

Pour ce qui est du message, c'est en fait la dernière ligne du texte que j'ai copié.

piep utilisateur non connecté France
Citation :
15:15:44.863 /usr/bin/jackd -v -P75 -dalsa -dhw:1 -r48000 -p512 -n2
<br />
<br />Memory locking is unlimited - this is dangerous. You should probably alter the line:
<br />     @audio   -  memlock    unlimited
<br />in your /etc/limits.conf to read:
<br />     @audio   -  memlock    763188
<br />
<br />getting driver descriptor from /usr/lib/jack/jack_dummy.so
<br />getting driver descriptor from /usr/lib/jack/jack_firewire.so
<br />no message buffer overruns
<br />getting driver descriptor from /usr/lib/jack/jack_oss.so
<br />getting driver descriptor from /usr/lib/jack/jack_net.so
<br />getting driver descriptor from /usr/lib/jack/jack_alsa.so
<br />JACK compiled with System V SHM support.


salut

n'intitule pas ton message : "à l'aide..." personne ne les lit...

Memory locking is unlimited - this is dangerous. You should probably alter the line:
     @audio   -  memlock    unlimited
in your /etc/limits.conf to read:
     @audio   -  memlock    763188


modifie /etc/security/limits.conf et positionne limite le memlock genre 512000 si tu as 2Go de RAM.

ensuite refait tes test avec le noyau d'origine 2.6.32 de la 10.04...
ça ne me surprendrait pas qu'il y des problèmes avec le 2.6.31-RT vu que les logiciels ne sont pas compilés pour lui....

librement,
Piep

chtfn utilisateur non connecté
Donc c'est préférable de régler le memlock sur une valeur de l'ordre de 25 % de la mémoire dispo ? Je vais essayer ça via Ubuntu Studio Controls (j'ai 1 giga).

Pour ce qui est du titre, il était lourd de sens au moment où je l'ai écrit... Désolé pour ça.

Mes deux cartes son sont :
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)

Bus 004 Device 002: ID 08bb:2900 Texas Instruments Japan PCM2900 Audio Codec


Je vais essayer de régler le memlock et la période/tampon. Si ça ne donne rien, je remets le noyau générique au démarrage.

Merci pour vos idées !

jy_moustache utilisateur non connecté
salut

Ubuntu Studio Controls ne marche pas sur la version 10.04. fais le a la main.

jy

pianolivier utilisateur non connecté France
Citation :
Memory locking is unlimited - this is dangerous. You should probably alter the line:
@audio - memlock unlimited
in your /etc/limits.conf to read:
@audio - memlock 763188

modifie /etc/security/limits.conf et positionne limite le memlock genre 512000 si tu as 2Go de RAM.

Citation :
Donc c'est préférable de régler le memlock sur une valeur de l'ordre de 25 % de la mémoire dispo ? Je vais essayer ça via Ubuntu Studio Controls (j'ai 1 giga).

la page concernant l'acces temps réel est définitevement a refaire, c'est prévu
d'apres ce que j'ai plus glané comme info, la valeur "memlock" se choisi comme suit :
pas trop grande, mais pas trop petite confused
en gros :
  • au dela de 4Go de RAM : unlimited car aucune application n'a besoin d'autant de mémoire de toute facon (sauf une application avec des bugs vraiments méchants, dans ce cas vous ne devriez pas l'utiliser)
  • en dessous, la valeur est à choisir entre 25 et 99 %. Il faut une petite marge (75 à 1%) en cas de crash, pour que root puisse prendre la main sur la machine quand meme et dipose d'un peu de mémoire. Il faut que la valeur memlock soit aussi assez grande pour que le programme qui utilise le plus de mémoire vive (jack, ou sooperlooper par exemple) soit à l'aise.

je conseille en général 50%, a toi de voir....
cependant le message "You should probably alter the line memlock" n'est pas critique.
ce n'est donc pas ces réglages qui te posent probleme ici.

apparement tu rencontre plusieurs problemes en meme temps, essaye de les décrire un à un le plus précisement possible

chtfn utilisateur non connecté
Merci Olivier.

Pour répondre à Jy_moustache, Ubuntu Studio Controls semble marcher : j'ai réglé le memlock à 25 %, et depuis mon limits.conf contient la ligne « @audio - memlock 256217 », ce qui correspond tout à fait à ma config...

J'ai essayé avec period/buffer à 3 et le nouveau memlock, ça me donne dans Jack control :


[+]

L'avertissement « memlock unlimited » est toujours là, alors que mon limits.conf le fixe à un quart !

Est-ce que les valeurs « rtprio » et « nice » importent ici ? Je les ai respectivement à 89 et -19.

pianolivier utilisateur non connecté France
refait nous un
grep audio /etc/security/limits.conf

et mes le dans une balise de code pour ere sur cette fois

apres modification de ce fichier, il faut se déconnecter ou redémarrer pour que les changements prennent effet

pour rtprio, il s'agit de la valeur MAX de prio assignée a une application
généralement, rtprio = la valeur de priorité de jack
certains problemes se posetn avec alsa pour un rtprio trop grand, essaye danc de modifier ca en 70, dans limits.conf ainsi que les regmages de jack

ldu utilisateur non connecté
Bonjour,

Je ne sais pas si mes infos te seront utiles.

J'ai lu que tu as pusle audio et que tu vois bien tes cartes son dedans.

J'avais deux carte son (une interne et une usb).
J'ai viré pulse audio car avec Jack ne fonctionnait pas correctement.
Et aussi dans Jack si je veux utiliser une carte son en sortie et une carte en entrée ça ne fonctionne pas et ça fait tout planter. Donc j'utilise l'USB en entrée sortie.

EN tout cas pour moi enlever Pulse Audio fut salutaire!

Salutations

jdlv utilisateur non connecté
As-tu essayé avec une fréquence d'échantillonnage de 44.1KHz?

Édition admin Olinuxx - 27 août 2013 : sujet fermé car [ABANDONNÉ].

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 19:45, mer. 25 Nov 2020: Bonjour et bienvenue à endymion93 cool
calixtus06, 07:13, mar. 24 Nov 2020: Bonjour et bienvenue à Noxanera ! :-)
sub26nico, 10:40, lun. 23 Nov 2020: Ardour 6.5 est disponible, le bogue d'export a été corrigé
Houston4444, 20:35, dim. 22 Nov 2020: Ardour 6.4 a de serieux soucis selon robin gareus lui-même. Attendez la 6.5 !
sub26nico, 18:00, dim. 22 Nov 2020: Ardour 6.4 est disponible :[Lien]
olinuxx, 14:48, dim. 22 Nov 2020: Bonjour et bienvenue à ykrons cool
olinuxx, 14:47, dim. 22 Nov 2020: @diigitae : [Lien]
diigitae, 02:54, dim. 22 Nov 2020: comment faire pour cloturer mon compte de linuxmao diigitae
olinuxx, 11:40, sam. 21 Nov 2020: LibraZiK-3 dispose à présent d'un live ! [Lien]
Sahaathyva, 20:42, jeu. 19 Nov 2020: Hey!
niquoi, 14:39, jeu. 19 Nov 2020: Merci :-)
olinuxx, 12:31, jeu. 19 Nov 2020: Bonjour et bienvenue à niquoi cool