Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > [résolu] [ArchLinux+KDE4] Galères avec Jack
Dernier post

[résolu] [ArchLinux+KDE4] Galères avec Jack

Packman utilisateur non connecté
Bonjour,

Quatrième tentative d'installation de Jack, et là je craque vraiment.

Je suis sous Arch Linux avec KDE4 (4.4.5-1) (donc Phonon qui traine), et impossible de faire fonctionner Jack (0.118.0-3), même avec phonon-xine (après potassage du wiki Arch Linux, de ce site et du forum).

Voici le détail de mes cartes :
$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe220000 irq 33
29 [ThinkPadEC     ]: ThinkPad EC - ThinkPad Console Audio Control
                      ThinkPad Console Audio Control at EC reg 0x30, fw 7KHT24WW-1.08


Et ce que me racconte qjackctl :
11:31:44.217 Baie de brassage désactivée.
11:31:44.245 Réinitialisation des statistiques.
11:31:44.273 Changement du graphique des connexions ALSA.
11:31:44.740 Changement des connexions ALSA.
11:32:12.766 JACK démarre...
11:32:12.767 /usr/bin/jackd -P89 -p128 -dalsa -dhw:0 -r48000 -p256 -n3 -i2 -o2
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:0|hw:0|256|3|48000|2|2|nomon|swmeter|-|32bit
control device hw:0
the playback device "hw:0" is already in use. Please stop the application using it and run JACK again
cannot load driver module alsa
11:32:12.810 JACK a été démarrer avec le PID=12333.
11:32:12.828 JACK a été arrêté avec succès.
11:32:12.832 Script post-extinction...
11:32:12.833 killall jackd
jackd: aucun processus trouvé
11:32:13.252 Script post-extinction terminé avec statut de sortie=256.
11:32:13.898 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
11:32:18.261 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
11:32:24.362 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
11:32:27.233 JACK démarre...
11:32:27.234 /usr/bin/jackd -P89 -p128 -dalsa -dhw:0 -r48000 -p256 -n3 -i2 -o2
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
11:32:27.272 JACK a été démarrer avec le PID=12352.
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:0|hw:0|256|3|48000|2|2|nomon|swmeter|-|32bit
control device hw:0
the playback device "hw:0" is already in use. Please stop the application using it and run JACK again
cannot load driver module alsa
11:32:27.394 JACK a été arrêté avec succès.
11:32:27.395 Script post-extinction...
11:32:27.396 killall jackd
jackd: aucun processus trouvé
11:32:27.814 Script post-extinction terminé avec statut de sortie=256.
11:32:28.464 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.


Au passage, j'adore le "cannot load driver module alsa" sachant que c'est bien ALSA que j'utilise comme controleur.

Si quelqu'un a une solution, j'accepterais volontiers parce que là j'ai vraiment besoin de Jack pour appliquer du filtrage à la volée (pas sur un fichier à posteriori quoi).

Merci !

jy_moustache utilisateur non connecté
salut

the playback device "hw:0" is already in use. Please stop the application using it and run JACK again

cette ligne indique que ta carte son est déjà occupée (sous ubuntu c'est pulseaudio qui pose ces problèmes). après je connais pas archlinux, mais le problème est vraisemblablement de ce côté là.

ce problème a déjà été traité plusieurs fois sur ce forum, essaye de faire une recherche et de mon côté, j'essaie de regarder ce que je trouve...

jy

PS : un priorité de 89 pour jack est probablement trop élevée, je te suggère de baisser à 79 (car la priorité d'alsa est de 80, il vaut mieux que jack aie une priorité inférieure à alsa).

Packman utilisateur non connecté
Citation :
cette ligne indique que ta carte son est déjà occupée (sous ubuntu c'est pulseaudio qui pose ces problèmes). après je connais pas archlinux, mais le problème est vraisemblablement de ce côté là.

Sous KDE4, Phonon prend la main (je l'ai lu par ici), mais j'ai pas réussi à passer outre. Je continue à potasser.
Citation :
PS : un priorité de 89 pour jack est probablement trop élevée, je te suggère de baisser à 79 (car la priorité d'alsa est de 80, il vaut mieux que jack aie une priorité inférieure à alsa).

C'est noté !

Merci pour la réponse !

jy_moustache utilisateur non connecté
j'ai trouvé ça
essaie de lancer
sudo /sbin/alsa force-reload
puis de lancer jack...

jy

Packman utilisateur non connecté
sudo /sbin/alsa force-reload

J'ai pas de tel programme sous Arch, désolé (les plus approchants étant /usr/sbin/alsaconf et /usr/sbin/alsactl... et aucun n'a d'option force-reload).

Bon, s'pas gagné... je continue à interroger mon ami (ou pas (!) Google.

Je reste ouvert aux idées. Merci des efforts, jy ! (Pas à dire, pour ça, j'adore les forums FLOSS, il y a toujours quelqu'un qui est là)

Lonigan utilisateur non connecté
Salut

Je suis également sous Arch et KDE.
Mes questions vont peut-être paraître imbécile mais j'ai besoin de savoir si tu as vraiment tout configuré.

Dans Configuration du système -> Multimédia -> Moteur : xine est t-il sélectionné ?
Puis dans Configuration du système -> Multimédia -> Préférence du périphérique : as-tu Jack Audio Connection Kit placé au premier niveau de la sortie audio ?
Enfin, as tu pensé à rebooter ton système ?

Packman utilisateur non connecté
Citation :
Mes questions vont peut-être paraître imbécile mais j'ai besoin de savoir si tu as vraiment tout configuré.

On est là pour débugger, imbécile n'est pas français.

Citation :
Dans Configuration du système - Multimédia - Moteur : xine est t-il sélectionné ?

Oui (mais n'offre pas d'onglet Jack)

Citation :
Puis dans Configuration du système - Multimédia - Préférence du périphérique : as-tu Jack Audio Connection Kit placé au premier niveau de la sortie audio ?

Ça non, je corrige.

Citation :
Enfin, as tu pensé à rebooter ton système ?

J'avais fait, mais je recommence avec la modif précédente.

Conclusion : ça semble fonctionner impec ! Merci à vous deux.

Lonigan utilisateur non connecté
Ce fût un plaisir Packman (mais le yaourt, c'est meilleurmrgreen)

Packman utilisateur non connecté
Citation :
le yaourt, c'est meilleurmrgreen

J'avoue que c'est carrément plus mieux ! Et en plus c'est français.

Jack testé avec Ardour (en replay) et Jamin. Programme pour aujourd'hui : me débrouiller avec mon micro... Au besoin je referais un sujet neuf.

Merchiiii

jy_moustache utilisateur non connecté
Édition (admin jy_moustache) : sujet fermé car résolu. Merci de remonter les informations pertinentes dans les pages Wiki adéquates.
Si besoin de réouvrir le sujet, vous pouvez vous adresser à un des admins wink
Pour des conseils sur le fonctionnement général du forum, vous pouvez voir cette page.


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


bda

Mégaphone [Afficher / Cacher]

olinuxx, 21:36, mer. 01 Apr 2020: Bonjour et bienvenue à simon_martineau, martineau_simon, et à Roland57 cool
olinuxx, 20:13, mar. 31 mars 2020: Bonjour et bienvenue à sethi1cool
Nolwen, 22:46, lun. 30 mars 2020: Sortie d'Hydrogen 1.0.0-beta 2 ce 30 mars 2020. [Lien]
olinuxx, 17:39, lun. 30 mars 2020: Bonjour et bienvenue à JulienRadio cool
sub26nico, 23:48, dim. 29 mars 2020: Salut et bienvenue à Chihiro49130, Gigi, Ptilou, yudas, FF63, mimifloch, mvvl et tophque :-)
malt, 15:55, dim. 29 mars 2020: @Sahaathyva. Je n'avais pas vu ton post!
malt, 15:51, dim. 29 mars 2020: Ardour 6.0-pre1: [Lien]
sub26nico, 20:50, ven. 27 mars 2020: Salut et bienvenue à Topyweb, Serge Samson, ChtiJeff, Zeplead et Zonzon :-)
r1, 20:27, ven. 27 mars 2020: La joute 15 est sur les rails ! [Lien] Viendez jouer avec nous !!!
bluedid29, 17:13, ven. 27 mars 2020: Bon week-end, à fond encore sur Musescore et LibraZik-2... ...bientôt utilisation régulière sur LibraZik-3...
sub26nico, 14:11, ven. 27 mars 2020: @tolliac, ouvres un fil spécifique dans les forums.
tolliac, 11:41, ven. 27 mars 2020: Bonjour, je ne me suis intéressé jusqu'ici qu'à l'écriture de partitions via lilypond et Frescobaldi et pour résoudre des problèmes de lecture de fichiers MIDI je me retrouve dans l'univers de la MAO chaleureusement accueilli mais complètement perdu. quel