Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

Dernier post

dssi-vst erreur :(

MrBark Articles : 54 utilisateur non connecté France
Salut ;)
alors voila, j'ai tout installé correctement:

wine 0.9.19 (avec fontforge 20060822) ; fftw 2.1.5 et 3.1.2
ladspa sdk 1.12 et cmt 3.4.6 ; swh plugins 0.4.15
libsndfile 1.0.16 ; libsamplerate 0.1.2 ; liblo 0.23
jack 0.101.1 ; qkackctl 0.2.20

Je tourne sous zenwalk 2.8 avec le dernier gcc (4.1.1) et évidement un kernel realtime soigneusement compilé: 2.6.17-rt8.
Ma carte son est reconnue (Echo Layla24) et fonctionne.

A chacune des installs, le configure trouvait bien ce dont il avait besoin: "yes"

Mes exports sont bien sur parfaits, grace à un .profile dans /root.
A noter que mon pkg config a 2 locations: /usr/local/lib/pkgconfig et /usr/lib/pkgconfig j'ai donc fait exporté les 2 avec $PATH:LE1er:LE2eme

Alors voila,
mon install de dssi (0.9.1) a bien fonctionée. puis ldconfig.
mais dssi-vst (0.4) ca va pas du tout ! :-(
j'ai bien mis le repertoire "vstsdk2.4" de steinberg mais toujours la meme erreur :

Citation :
rootdssi-vst-0.4# make
g++ -I./vstsdk2.4/pluginterfaces/vst2.x -Wall remotepluginclient.cpp -c
g++ -I./vstsdk2.4/pluginterfaces/vst2.x -Wall remotepluginserver.cpp -c
g++ -I./vstsdk2.4/pluginterfaces/vst2.x -Wall -c -o rdwrops.o rdwrops.cpp
g++ -I./vstsdk2.4/pluginterfaces/vst2.x -Wall -c -o paths.o paths.cpp
ar r libremoteplugin.a remotepluginclient.o remotepluginserver.o rdwrops.o paths.o
ar: création de libremoteplugin.a
wineg++ -I./vstsdk2.4/pluginterfaces/vst2.x -Wall dssi-vst-server.cpp -o dssi-vst-server -L. -lremoteplugin
dssi-vst-server.cpp: In member function 'virtual void RemoteVSTServer
hideGUI()':
dssi-vst-server.cpp:566: attention : unused variable 'fd'
dssi-vst-server-tPUtLg.o(.text+0x2d1e): In function `RemoteVSTServer
process(float**, float**)':
: undefined reference to `pthread_mutex_trylock'
collect2: ld a retourné 1 code d'état d'exécution
winegcc: g++ failed.
make: *** dssi-vst-server.exe.so Erreur 2


Voila, si quelqu'un a une idée... je suis désemparé, voila environ 1 mois que je suis 24/24 sur mon install musicale linux pour tout faire ultra proprement et paf... frown

Thanks @++

MrBark Articles : 54 utilisateur non connecté France
XXXXXXXXXXX BON, PROBLEME RESOLU !!! XXXXXXXXXXX

je ne vous l'avais pas dit mais pour compiler ladspa, j'ai du prendre gcc 3 (3.4.6)
car il faisait des erreurs avec le 4,
j'ai donc fait un clone de mon systeme pour etre sur d'avoir exactement la meme chose, puis j'ai installé gcc 3 dessus, et ait fait le make de sdk. puis copié le repertoire, puis fait le make install de sdk, puis le make de cmt.
je suis ensuite retourné sous mon systeme original, ai fait le make install de sdk (a partir du repertoire sauvegarde) et make install cmt ausi.
je vais donc faire la meme chose avec dssi-vst. (en repartant de la derniere image disque sauvée puisque je veux que tout soit PARFAIT :-p)

Voila ++ et thanks ;)

Articles : 606
Citation :
XXXXXXXXXXX BON, PROBLEME RESOLU !!! XXXXXXXXXXX

je ne vous l'avais pas dit mais pour compiler ladspa, j'ai du prendre gcc 3 (3.4.6)
car il faisait des erreurs avec le 4,
j'ai donc fait un clone de mon systeme pour etre sur d'avoir exactement la meme chose, puis j'ai installé gcc 3 dessus, et ait fait le make de sdk. puis copié le repertoire, puis fait le make install de sdk, puis le make de cmt.
je suis ensuite retourné sous mon systeme original, ai fait le make install de sdk (a partir du repertoire sauvegarde) et make install cmt ausi.
je vais donc faire la meme chose avec dssi-vst. (en repartant de la derniere image disque sauvée puisque je veux que tout soit PARFAIT :-p)

Voila ++ et thanks ;)


Salut,

Si mes souvenirs sont exacts, tu utilises une distrib' plutôt basée sur les sources, non ?
Le changement de version de gcc n'est jamais chose simple ... surtout pour une distrib basée sur les sources ... par exemple, entre les versions 3.3 et 3.4, l'ABI C++ a changé ...

Même pour une distrib qui automatise pas mal de choses au niveau compilations comme Gentoo, l'expérience doit être réalisée avec soin : http://www.gentoo.org/doc/fr/gcc-upgrading.xml
De plus, il est souvent préférable de ne pas chercher systématiquement la version la plus récente de gcc, le temps de laisser la découverte et la résolution de bugs inévitables dans gcc dont les conséquences sont d'autant plus problématiques sur un système entièrement compilé ...

T.

MrBark Articles : 54 utilisateur non connecté France
oui oui, c'est justement parce que c'est crade de mettre un gcc sur l'autre, que j'ai fait un systeme clone sur une partition voisine, puis ait installé gcc 3.4.6 sur celui ci, uniquement pour faire le make.
Je suis donc ensuite retourné sous l'autre systeme pour faire l'install.


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 07:48, jeu. 06 Oct 2022: Bonjour et bienvenue à CapuDZ :-)
malt, 20:02, dim. 02 Oct 2022: [Lien]
malt, 20:02, dim. 02 Oct 2022: livestream avec le créateur de Ardour en direct maintenant
Samuel, 23:03, sam. 01 Oct 2022: zrythm beta 3.5.1 est sorti. Il commence à être sacrément bon...
calixtus06, 10:26, ven. 30 Sep 2022: Bonjour et bienvenue à pampete :-)
calixtus06, 21:38, dim. 25 Sep 2022: Bonjour et bienvenue à Dom44 :-)
calixtus06, 10:14, ven. 23 Sep 2022: Bienvenue à Chantegrave et à Michael Alex :-)
calixtus06, 08:11, mer. 21 Sep 2022: Bonjour et bienvenue à BernArd ! :-)
dlb, 11:49, sam. 17 Sep 2022: Mes messages remarchent ... Youpi !
calixtus06, 10:22, jeu. 15 Sep 2022: Bonjour et bienvenu à bobphils et à Hugopierrel :-)
calixtus06, 09:24, mer. 14 Sep 2022: Bonjour et bienvenue à tis :-)
tis, 22:51, mar. 13 Sep 2022: qui est-ce qui zone a st'heuuure ?