Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post

[Résolu] Jack bloqué à 48 kHz

Kuba utilisateur non connecté
Bonjour,

Petit souci avec Jack donc, sur mon portable. En démarrant Qjackctl hier, je me rend compte qu'il est bloqué à 48kHz. Je vérifie dans les processus lancés et Jack est bien lancé, MAIS à 44,1kHz.

00:00:00 /usr/bin/jackd -r -t1000 -dalsa -dhw:0,0 -r44100 -p1024 -n3 -P -Xseq


Et quand je lance Ardour ou Qtractor, les 2 me disent que le moteur audio tourne à 48kHz eek

Mais que se passe-t-il ?!

J'utilise la carte son interne du portable. Avant j'utilisais une UA-25EX, possible qu'en 48k mais je ne m'en souviens pas vraiment.

J'ai réinstallé une version antérieure de Qjack au cas où ce serait la dernière en date qui planterai (0.37 en svn), mais non. Avec la 0.36 pareil. Et Jack tourne bien et toujours en 44100Hz, mais les logiciels captent que le 48k de Qjackctl

Faut-il faire un exorcisme avec la UA-25EX que je n'ai pas sous la main et je devrais alors attendre ? Là c'est professionnel, donc j'aimerai ne pas attendre. S'il faut réinstaller TangoStudio, se serait envisageable, mais y'a-t-il autre chose à faire ?

Merci de votre attention ;)
Kuba

jy_moustache utilisateur non connecté
salut

a mon avis QJackCtl n'a rien à voir la-dedans. en fait ce qu'il faudrait pouvoir vérifier c'est si jack tourne à 48 ou 44,1 kHz parce que vu ce que tu dis, on ne sait pas si c'est jack qui tourne à 48 ou si c'est les autres logiciels qui se gourent...

Plusieurs pistes
  • à quoi correspond la device hw:0,0 ? peux-tu nous mettre le retour de
    cart /proc/asound/cards
    ? es-tu sur que ca correspond bien à ta carte UA-25EX ?
  • Lance jack en mode verbose. tu peux le faire depuis QJackCtl (paramètres -> messages bavards).
et rapporte nous le log complet ici.

merci

jy

Kuba utilisateur non connecté
Salut,

Si tu lis bien mon post mrgreen

Jack tourne à 44.1khz.

Citation :
00:00:00 /usr/bin/jackd -r -t1000 -dalsa -dhw:0,0 -r44100 -p1024 -n3 -P -Xseq


J'utilise la carte interne de mon portable et la UA-25EX n'est pas branchée, car je ne l'ai pas.

Citation :
J'utilise la carte son interne du portable. Avant j'utilisais une UA-25EX, possible qu'en 48k mais je ne m'en souviens pas vraiment.


cat proc/asound/cards : je ne peux pas le mettre j'ai du basculer sous windows sur le portable mais c'est la carte interne intel ICH6

Log de Jack : pareillement je ne peux pas l'afficher, je suis sur l'autre ordi là. Mais c'est la même ligne de code que tout en haut (finissant par Xseq).
Je suis à 44.1khz, 512 frames et 3 periods et dans la fenêtre de Qjackctl il est écris 48000Hz et les soft détectent que le moteur audio est en 48000Hz. Magie magie ? smile

Merci en tout cas,
Kub

olinuxx utilisateur non connecté France
Chelou ton truc ...
pour qTractor et Ardour, ce sont des nouvelles sessions ?

Kuba utilisateur non connecté
Oui fraîchement créés.

Je viens de lancer jack en ligne de commande au cas où, même chose. les 2 détectent du 48K.

olinuxx utilisateur non connecté France
oué, chelou, mais je suis curieux de voir ce que tu vas trouver !

jy_moustache utilisateur non connecté
désolé
je ne sais pas comment ca marche sous windows et je n'ai aucune idée concernant comment essayer de comprendre ce qui se passe...
désolé
jy

pianolivier utilisateur non connecté France
Citation :
Jack tourne à 44.1khz.
00:00:00 /usr/bin/jackd -r -t1000 -dalsa -dhw:0,0 -r44100 -p1024 -n3 -P -Xseq

c'est tentant de croire la ligne de commande, mais ce qui est plus probant c'est la ligne qui ressemble à "creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit"
et peut être d'autres indications que tu aurai loupé dans le reste du log, c'est pour ca qu'il vaudrait mieux le recopier en entier wink

jy_moustache utilisateur non connecté
c'est ce que je voulais dire par vérifier si jack est bien à 44,1 kHz. Ce n'est pas parce que c'est écrit sur la ligne de commande que c'est forcément vrai.
dans ce cas, ca s'appelle un bug wink

jy

Kuba utilisateur non connecté
Oki, autant pour moi.
Je ne peux toujours pas afficher le log ici (pas de clé usb sous la main), mais je l'ai regardé attentivement et les infos de la ligne de commande ainsi que du log Message de Qjackctl sont identiques. A savoir en 44100Hz, samples à 1024 frames et tampon à 3 periods. La carte son hw:0 est bien sélectionnée, et elle marche bien.
J'ai bien du son, mais j'aimerai bien ne pas avoir à convertir tout mes fichiers en 48k.

Je vais faire une tour sur le forum de Ardour, on verra bien. D'autre part comme ça urge, et que j'avais fait une expérimentation en ReiserFs et que ça traine tout compte fait. possible que je refasse une install neuve, au moins je sais qu'elle tourne nickel en ext3-4.
On aime les prises de risques ds la vie..razz

J'vous tiens au jus.

Kuba utilisateur non connecté
Voilà le log de la partie voulue :

no message buffer overruns
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:0|-|1024|3|44100|0|2|nomon|swmeter|-|32bit
control device hw:0
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 3 periods
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 3 periods for playback


a+
Kub

Kuba utilisateur non connecté
Alors, dès que je remet la main sur la page que j'ai trouvé je mets le lien, mais en gros, avec certaines cartes sons intégrée (AC'97, ICH...), la fréquence d'échantillonnage est fixée par défaut et est immuable. Inhérent à la carte quoi, rien à faire. confused

Je n'avais pas visiblement pas remarqué jusqu'à ce jour car cela ne m'avait pas empêché de faire de la musique, là avec des samples multiples c'était la cata.

Donc problème résolu en quelque sorte. Je complète le post dès que remis la main sur le lien.

bonne soirée folks! cool

Kuba

jy_moustache utilisateur non connecté
Édition (admin jy_moustache) : sujet fermé car résolu. Merci de remonter les informations pertinentes dans les pages Wiki adéquates.
Si besoin de réouvrir le sujet, vous pouvez vous adresser à un des admins wink
Pour des conseils sur le fonctionnement général du forum, vous pouvez voir cette page.


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 22:39, lun. 14 Oct 2019: Salut et bienvenue à samaudio :-)
sub26nico, 11:04, dim. 13 Oct 2019: Salut et bienvenue à benoitf :-)
sub26nico, 17:56, ven. 11 Oct 2019: Des greffons proprios portés sous GNU/Linux : [Lien]
sri_raoul, 16:50, ven. 11 Oct 2019: The sonaremin: un projet synthé modulaire porté pour arm [Lien]
sub26nico, 22:37, jeu. 10 Oct 2019: Salut et bienvenue à nickythomas :-)
sub26nico, 10:34, jeu. 10 Oct 2019: Salut et bienvenue à Kiara, shadows, flofloy100 et Do_done :-)
r1, 17:24, mer. 09 Oct 2019: Moi aussi j'ai revu olinuxx avec grand plaisir !
allany, 08:37, mer. 09 Oct 2019: Merci, bluedid29, pour toute l'équipe de l'édito !
sub26nico, 08:46, mar. 08 Oct 2019: Bonjour et bienvenue à Notabene78, MOA, Gaz Korbier, setkaabwoy, gegeours et Siryu :-)
bluedid29, 16:08, lun. 07 Oct 2019: Et j'ai revu avec grand plaisir Olinuxx ! :-)
bluedid29, 14:00, lun. 07 Oct 2019: Hello :-) Génial l'édito ;-)
zebassprophet, 13:21, lun. 07 Oct 2019: hello les libristes