Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

Dernier post

Problème de xruns sur Mixxx

Chtfn Articles : 29 utilisateur non connecté
Bonjour à tous !

J'utilise Mixxx 1.8.2 sur mon Dell Studio Hybrid avec Ubuntu Studio 10.10, mais je n'arrive pas à faire baisser convenablement les xruns que j'obtiens.
J'ai augmenté la latence dans qjackctl jusqu'à 256 ms (!) mais il me reste encore quelques sauts/glitchs, et en plus la waveform n'est pas utilisable (trop saccadée).
J'ai essayé d'enlever quelques applications qui tournaient en même temps, ça n'a rien donné.
Mes deux cartes son donnent le même problème.

Ubuntu Studio 10.10 n'inclut pas de noyau temps réel. De plus, sur les release notes, on peut lire :
/etc/security/limits.conf (cont.) :

Beginning with the Ubuntu package jack-audio-connection-kit-0.118+svn3796-1ubuntu2 editing of /etc/security/limits.conf should not be required. JACK will write the following during post-installation to /etc/security/limits.d/audio.conf

# generated by jackd's postinst.
# Do not edit this file by hand, use
# dpkg-reconfigure -p high jack
# instead
@audio - rtprio 99
@audio - memlock unlimited
#@audio - nice -19

Please note that creating or modifying /etc/security/limits.conf may cause conflicts with the JACK written /etc/security/limits.d/audio.conf settings.

Email from Linux Audio Users mailing list: http://linuxaudio.org/mailarchive/lau/2010/3/5/166428 Debian Bug #507248: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507248

Also note that the user should NOT be in the @audio group.



Donc je ne compte pas toucher limits.conf...

Quelqu'un a une idée ? J'aimerai vraiment pouvoir travailler avec Mixxx...

Samuel Articles : 1855 utilisateur non connecté Allemagne
Salut,

quelles cartes sons ?
T'es sur qu'il n'y a pas de noyau preempt, ce qui est quand même mieux que rien ?
As-tu fait la manip indiquée dans le fichier :
dpkg-reconfigure -p high jack

jy_moustache Articles : 1512 utilisateur non connecté
hello,

il faut effectivement configurer /etc/security/limits.d/audio.conf au lieu de /etc/security/limits.conf.

par ailleurs, la valeur que tu mets à rtprio est un peu élevée. tu devrais la baisser. autour de 70/80 ça devrait aller.

fais quelques essais et dis nous....

jy

Chtfn Articles : 29 utilisateur non connecté
Voilà mes deux cartes son :

chtfn@ubuntu:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)
chtfn@ubuntu:~$ lsusb | grep -i audio
Bus 005 Device 002: ID 08bb:2900 Texas Instruments Japan PCM2900 Audio Codec

Pour ce qui est du noyau :

Le moniteur me dit que j'utilise le 2.6.35-25-generic, mais les release notes disent que le preempt est aussi inclus. Mai au démarrage, je n'ai aucune invite à choisir le noyau que je veux (d'ailleurs, dans synaptic, je ne trouve aucun paquet « rt » ou « preempt »....).

Voilà ce que me retourne la commande conseillée :

chtfn@ubuntu:~$ sudo dpkg-reconfigure -p high jack
[sudo] password for chtfn:
Le paquet « jack » n'est pas installé et aucune information n'est disponible.
Utilisez dpkg --info (= dpkg-deb --info) pour examiner les fichiers
archives, et dpkg --contents (= dpkg-deb --contents) pour afficher leur contenu.
/usr/sbin/dpkg-reconfigure: jack n'est pas installé

Chtfn Articles : 29 utilisateur non connecté
Ah, et pour info, ils ont probablement fait une faute dans les release notes, il manquait le « d » à la fin de la commande.
Voilà ce que contient le fichier /etc/security/limits.d/audio.conf :

# Provided by the jackd package.
#
# Changes to this file will be preserved.
#
# If you want to enable/disable realtime permissions, run
#
#    dpkg-reconfigure -p high jackd

@audio   -  rtprio     95
@audio   -  memlock    unlimited
#@audio   -  nice      -19


J'ai lancé la commande, mais rien ne s'est passé... Est-ce que c'est juste un « switch » qui ne donne même pas de retour ?

Chtfn Articles : 29 utilisateur non connecté
En fait je pense avoir résolu le problème : je me suis retiré du groupe Audio, comme c'était indiqué dans les release notes plus haut. Je n'ai plus de de xruns pendant le playback !

La commande
dpkg-reconfigure -p high jackd
ne semble pas avoir changé quoi que ce soit... Si cette commande opère un changement, où est-ce que ça se trouverait ? J'aimerai quand-même vérifier.

Je confirme tout ça et je rajouterai [résolu] au sujet.
Merci pour votre aide les Maoïstes !

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


gegeweb

Mégaphone [Afficher / Cacher]

olinuxx, 15:14, mar. 01 Dec 2020: Bonjour et bienvenue à Soso et gegeweb cool
calixtus06, 11:21, lun. 30 Nov 2020: Bonjour et bienvenue à n0n3m ! :-)
calixtus06, 07:29, dim. 29 Nov 2020: Bonjour et bienvenue à Iluvatar ! :-)
olinuxx, 12:35, sam. 28 Nov 2020: Nouvelles du mois de novembre pour LibraZiK : [Lien]
olinuxx, 12:34, sam. 28 Nov 2020: Bonjour et bienvenue à diogene et à klopkloc cool
olinuxx, 19:45, mer. 25 Nov 2020: Bonjour et bienvenue à endymion93 cool
calixtus06, 07:13, mar. 24 Nov 2020: Bonjour et bienvenue à Noxanera ! :-)
sub26nico, 10:40, lun. 23 Nov 2020: Ardour 6.5 est disponible, le bogue d'export a été corrigé
Houston4444, 20:35, dim. 22 Nov 2020: Ardour 6.4 a de serieux soucis selon robin gareus lui-même. Attendez la 6.5 !
sub26nico, 18:00, dim. 22 Nov 2020: Ardour 6.4 est disponible :[Lien]
olinuxx, 14:48, dim. 22 Nov 2020: Bonjour et bienvenue à ykrons cool
olinuxx, 14:47, dim. 22 Nov 2020: @diigitae : [Lien]