Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : JACK, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : JACK, PulseAudio et autres... > pas de prise en charge par jack et rosegarden
Dernier post
Page : 1/4   -   Aller directement à la page : 1  2  3  4 

pas de prise en charge par jack et rosegarden

ikarios utilisateur non connecté
Bonjour à tous!!! je suis un gros débutant dans la mao et dès lors je dois faire des erreurs à qui mieux mieux.....
j'ai installé qjack et il démare mais je n'ai pas ma carte son dans les possibilités de connexions par contre j'ai bien rosegardene et le clavier casio ctk7000 (usb)
quand je passe par rosegarden je n'ai aucune possibilités d'ajouter des effets par les greffons de synthés et de plus je ne peux écouter ce que j'ai enregistré car la carte son n'est pas reconnue (du moins c'est ce que je pense)
sinon pour écouter de la musique tout est nickel et là la carte son est bien reconnue (une soundblaster live 5.1 pro)
si quelqu'un peut m'aider dans ce fouilli de possibilités je lui serais très reconnaissant oui car que faire je ne sais pas quoi faire et ca fait une semaine que je ne peux que passer par lmms pour jouer mes sons (mais il plante souvent)
merci d'avance pour toute aide et je vous souhaite d'excellentes créations sous mao!
merci
ikarios

allany utilisateur non connecté
Bon, il faudrait quelques précisions...

Tu confirmes que ta carte, c'est du PCI ?
Quelle est ta distribution ?
Envoie aussi les résultats des commandes :
aplay -l
cat /proc/asound/cards

Si tu ne l'as pas déjà fait lis ce petit tuto, à propos de Jack.
Jack étant le coeur de la MAO/Linux, son fonctionnement doit être optimum.

A+

ikarios utilisateur non connecté
la carte est connectée sur le port usb de la machine et ma version est ubuntu 12.04 mais j'ai dwl ubuntu studio pour voir
cat /proc/asound/cards
*** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC887-VD Analog [ALC887-VD Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 1: ALC887-VD Digital [ALC887-VD Digital]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: Pro [SB X-Fi Surround 5.1 Pro], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: Pro [SB X-Fi Surround 5.1 Pro], périphérique 1: USB Audio [USB Audio #1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 4: NVidia [HDA NVidia], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 4: NVidia [HDA NVidia], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 4: NVidia [HDA NVidia], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


je ne sais pas si cela te parle mais moi cela ne me dis pas grand chose de précis lol
mais merci pour ton aide
et je vais lire le tuto que tu m'as conseillé merci encore et je te fais savoir si il y a du changement
merci et à +
ikarios

ikarios utilisateur non connecté
zut je me suis rendu compte un peu tard que j'avais mis la même chose deux fois
cat /proc/asound/cards
0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7210000 irq 46
 1 [Pro            ]: USB-Audio - SB X-Fi Surround 5.1 Pro
                      Creative Technology Ltd SB X-Fi Surround 5.1 Pro at usb-0000:00:14.0-1, full sp
 2 [USBMIDI        ]: USB-Audio - CASIO USB-MIDI
                      CASIO CASIO USB-MIDI at usb-0000:00:1a.0-1.3, full speed
 3 [CinemaTM       ]: USB-Audio - Microsoft® LifeCam Cinema(TM)
                      Microsoft Microsoft® LifeCam Cinema(TM) at usb-0000:00:1d.0-1.5, high speed
 4 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17



voilà j'espère que c'est bon maintenant

Bonjour ikarios

Pas de problème tu peux éditer ton post non ?

Je te l'ai édité ton post mais logiquement tu dois avoir cet icon : Image ça te donne le droit pour éditer tes réponses et sujet wink

ikarios utilisateur non connecté
merci de l'astuce mais tu as fait tout le travail pour moi je ne vois pas ce que je pourrais dire ou écrire d'autre ????
j'ai lu le sujet sur qjack et sa configuration je pense que je suis bon de ce coté (tout en étant pas sur à 100%)
bonne zique à vous tous
ikarios

Heu oui excuse moi je tappait des modifes sur le site

donc apriori tu as 3 carete son et le clavier midi

Alors il faut que tu configure jack en lui assignant le prériférique par défaut
ensuite voir quel panneau de controle agit sur le volume ...

ikarios utilisateur non connecté
merci pour ton post mais je ne vois pas très bien à quoi se réfère le panneau de contrôle du volume si tu pouvais m'en dire un peu plus je pourrais répondre de manière plus précise mais je voulais ajouter qu'en modifiant la sortie usb et en passant sur une usb 3.0 je n'ai plus de crépitements en lancant lmms donc c'est déjà ca de gagné.....
merci et bonne création à toi et à +
ikarios

Tu dois avoir un menu dans lequel tu auras plusieur panneau de controle tels que
  • Contrôleur de volume
  • Envy24
  • HDSPmixer

et d'autre qui fonctionnent ou pas selon ta carte son

(ceci est un test d'allany)

ikarios utilisateur non connecté
merci mais excuse moi mais je ne vois pas du tout où tu trouves ces panneaux de contrôles dans jackqctl? dans alsamixer? où?
en attendant ta réponse je cherche sans grandes convictions car je n'ai jamais entendu parler de ces panneaux ....
mais merci de ton aide je crois que c'est la bonne piste a suivre .....
et toujours en entendant que tu me dises où trouver ces panneaux je fais mumuse avec lmms et avec mon clavier MIDI
mais j'aimerais pouvoir utiliser rosegarden et pour le moment c'est le vide intégral (pas de sons pas de greffons utilisables) l'absence par le vide si tu as une idée ou plusieurs je suis preneur car j'aimerais utiliser avec mon clavier MIDI rosegarden
merci d'avance pour ton aide et bonne zique à toi
ikarios

allany utilisateur non connecté
Bon.
Tu devrais donc, normalement, utiliser le driver audio pour l'USB.
Peux-tu le confirmer en postant le résultat de :
lsmod | grep usb

Dans les réglages de Jack, que te propose-t-il dans :
  • interface
  • périph' entrée
  • périph' sortie
lorsque tu actionnes les touches >V ?
Et qu'y as-tu, toi, renseigné (défaut, hw:x,y,...) ?

A+

ikarios utilisateur non connecté
lsmod | grep usb
lsmod | grep usb
snd_usb_audio         130468  3 
snd_usbmidi_lib        24939  1 snd_usb_audio
snd_hwdep              17699  2 snd_usb_audio,snd_hda_codec
snd_pcm                96668  4 snd_hda_codec_hdmi,snd_usb_audio,snd_hda_intel,snd_hda_codec
snd_rawmidi            30513  2 snd_usbmidi_lib,snd_seq_midi
snd                    74825  25 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_usb_audio,snd_usbmidi_lib,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_rawmidi,snd_timer,snd_seq_device
btusb                  22475  0 
bluetooth             209306  23 rfcomm,bnep,ath3k,btusb
usb_storage            48834  0 
usbhid                 46987  1 hid_logitech_dj
hid                   100411  3 hid_logitech_dj,hid_generic,usbhid


Pour les réglages de JACK
interface : par defaut
périph d'entrée: hw:4 (correspond au clavier midi)
périph de sortie: hw:1 (correspond à la carte son sb 5.1 pro en usb)
nota: je ne comprend pas ce que tu veux dire par "actionner la touche >V"
sinon je pense que les réglages sont bon puisque sous lmms ca fonctionne nickel
que voulais tu savoir d'autres car je n'arrive pas a faire tourner fluidsynth et rosegarden c'est le vide absolu!
merci pour ton aide à +
ikarios

allany utilisateur non connecté
Je ne pense pas, au vu des aplay et des réglages pour périphériques dans Jack, que tu t'adresses aux bonnes cartes-son.

C'est pourquoi il faudrait la liste des périph's et interface que Jack te propose, que tu visualises en appuyant sur les boutons avec les symboles "V" et ">".
Il devrait t'afficher une liste de "défaut", "plughw" et autres "hw:x,y".

Fais également attention au fait que d'un démarrage à l'autre du PC, l'ordre des cartes-son peut varier.
Celle qui était en hw:4 peut se retrouver en hw:3 ou hw:2, 1 ou 0.

A+

ikarios utilisateur non connecté
merci de ton soutien mais par chance l'appelaation des cartes sons ne changent pas au redémarrage de la machine mais je ne vois toujours pas ce que tu veux dire par "v" et ">" c'est à quel moment que ces touches sont disponibles?
excuse du baba de mes questions mais j'aimerais en savoir un peu plus vu que tu sembles avoir détezcté un mauvais branchement dans mes cartes sons
merci à toi et amuse toi bien en composant
ika rios

allany utilisateur non connecté
Hello,

Pour les options de interface/périphériques de Jack, tu cliques sur la case "réglages" (ou "setup") et tu obtiens l'écran ci-dessous.
La mini-liste des différents périphériques s'affiche en cliquant sur le bouton "flèche bas" aux cases :
  • interface
  • périphérique d'entrée
  • périphérique de sortie
visibles en orangé sur cet écran :
Image
A+

ikarios utilisateur non connecté
ah oui effecctivement que je suis bête c'était là!!!!!!
donc en preiph d"entrée j'ai mon clavier midi en usb sur hw:4
et en périph de sortie j'ai ma carte sonh toujours en usb sur hw:1
voilà j'espère avoir été assez complet pour pouvoir pousuivre l'installation de qjack et rosegarden

merci à toi et bonne composition
ikarios

allany utilisateur non connecté
OK mais peux-tu m'indiquer la globalité des listes que Jack te propose pour ces périph's et interface ?
Joins-y, pour rappel, un autre "aplay -l".
A+

ikarios utilisateur non connecté
ok a votre service monsieur biggrin
aplay -l
aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC887-VD Analog [ALC887-VD Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 1: ALC887-VD Digital [ALC887-VD Digital]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: Pro [SB X-Fi Surround 5.1 Pro], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0
carte 1: Pro [SB X-Fi Surround 5.1 Pro], périphérique 1: USB Audio [USB Audio #1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 3: NVidia [HDA NVidia], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 3: NVidia [HDA NVidia], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 3: NVidia [HDA NVidia], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0



pour l'interface de jack je n'ai que celle par défaut
sinon la liste est longue pour les périph d'entrée et de sortie
comme je ne sais pas comment mettre une image de mon écran je te copie les solutions posssibles
hw:0 HDA intel PCH
hw:0.0 ALC 887 VD ANALOG
hw0.2 ALC 887 VD ANALOG
hw:1 SB XFI surround 5.1 PRO
hw:1.0 USB AUDIO
hw:2 lifecam microsoft tm (WEBCAM)
hw:2.0 USB AUDIO
hw:3 HDa NVIDIA
hw:4 CASIO MIDI USB
par defaut
voilà j'espère quue c'est plus clair pour toit maintenant
merci encore pour ton aide et amuse toi bien en créant de la bonne zique
ikarios

allany utilisateur non connecté
OK !

Est-ce que ça marche avec P. entrée = hw:1,1 et P. sortie = hw:1,0, interface = "defaut" ?

A+

ikarios utilisateur non connecté
merci pour la tentative de soluttion c'était bien essayé mais ca ne foncrtionne pas mieux a part que rosegarden joue (mais je ne peux l'entendre) ce que je pianote sur le clavier midi donc c'est déjà mieux!!!!!!
je n'ai aucune idée de ce qui foire dans mes branchements mais c'est agacant de ne pouvoir utiliser rosegarden donc j'attend avec impatience
la bonne configuration sur ce je vous souhaite un bon délire musical
a +
ikarios

Page : 1/4  [Suivant]
1  2  3  4 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Faire un don
[Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

calixtus06, 10:26, ven. 30 Sep 2022: Bonjour et bienvenue à pampete :-)
calixtus06, 21:38, dim. 25 Sep 2022: Bonjour et bienvenue à Dom44 :-)
calixtus06, 10:14, ven. 23 Sep 2022: Bienvenue à Chantegrave et à Michael Alex :-)
calixtus06, 08:11, mer. 21 Sep 2022: Bonjour et bienvenue à BernArd ! :-)
dlb, 11:49, sam. 17 Sep 2022: Mes messages remarchent ... Youpi !
calixtus06, 10:22, jeu. 15 Sep 2022: Bonjour et bienvenu à bobphils et à Hugopierrel :-)
calixtus06, 09:24, mer. 14 Sep 2022: Bonjour et bienvenue à tis :-)
tis, 22:51, mar. 13 Sep 2022: qui est-ce qui zone a st'heuuure ?
tis, 22:50, mar. 13 Sep 2022: BOnsoir les bras cassé
dlb, 10:46, mar. 13 Sep 2022: La "publication" des messages ne fonctionne plus chez moi Désolé Calixtus06 !
dlb, 10:43, mar. 13 Sep 2022: Je ne peux plus éditer de message ...
olinuxx, 23:31, jeu. 08 Sep 2022: Bonjour et bienvenue à do, culbuto, et à pchevalier cool