Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

7 - Développer/Traduire/Documenter/Annoncer une application

Dernier post

gestion de composition

ardoisebleue utilisateur non connecté France
Je compose sous ubuntu 12.04 avec différents logiciels séquenceurs et synthétiseurs, suivant ce que je veux produire. De plus, je ne reste pas sur le même morceau, parfois je le met de coté pour en commencer ou reprendre un autre. Si bien qu'à chaque fois je dois sauvegarder, protéger copier ; Bref des choses dont je me passerais bien.
Il y a un an j'ai créé une série de scripts bash pour faciliter tout ça, mais quand j'ai voulu améliorer le principe, je me suis vite retrouvé coincé par les limites du langage bash (c'est logique il n'est pas prévu pour ce genre de travail).
J'ai donc tout repris en créant un logiciel sous QT4, dans le but de gérer les logiciels et les fichiers destinés à composer une musique. Il démarre automatiquement la configuration de logiciels que j'ai mis en place pour faire ma composition et je n'ai donc plus à me soucier de savoir ce que j'utilisais, ni dans quelles conditions.
Je le mets à votre disposition au cas où quelques-uns d'entre vous lui trouveraient un intérêt.
La version que je mets en place est une version ultra-bêta. Vous pouvez aussi le tester juste pour voir, pour "nettoyer", il suffit de supprimer un répertoire dans votre home.
Si vous l'utiliser définitivement ça ne posera pas de problème, mais dans un premier temps, n'oubliez pas de sauvegarder vos données par prudence.
Pour la description et l'installation c'est ici
Pour télécharger le zip contenant le bin c'est ici
Ce logiciel ne fonctionne que sur linux.
Ne pas oubliez de changer les propriétés du "bin" pour le rendre exécutable.

Si vous avez des commentaires n'hésitez surtout pas.

Salut ardoisebleue
Interrsant ton gestionnaire de session mais :

demarreMAO: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory


Pourtant libQtGui est bien présent sur le système (debian wheezy 7.4) Un paquet ou une commande à me recommander?

ardoisebleue utilisateur non connecté France
Bonjour utilisateur_anonyme et merci de tester.

Comme je suis sur ubuntu 32 bits, je suppose que tu es en 64 bits et de ce fait tu n'as peut-être pas la version i386:32 de la bibliothèque QT.
Je viens de compilé en mode release (j'avais mis dans le tar.gz la version debug (!), tu peux donc télécharger à nouveau et faire un essai ; QT devrait aller chercher la bonne bibliothèque.
Si le message revient, il faudrait installer le paquet i386 de libQtGui.so.4.8 dans le dossier /usr/lib/i386-linux-gnu et aussi créer un lien "libQtGui.so.4.8.1" sur cette librairie (ou la copier et renommer). Mais là ça devient fastidieux et peut-être hasardeux.
Je vais donc me pencher sur la création de paquet avec dpkg qui fera une installation simple et j'espère efficace

A+

Salut

Je veux bien mais pouyr ça faudrait que le paquet de libQtGui soit en ALL.deb et c'est pas le cas Néanmoins je vais tester sur une 32 voir ce que ça dit car même ceci:

x86_64-linux-gnu # ln -s libQtGui.so.4.8.2  libQtGui.so.4.8.1
ne fonctionne pas

Hmmm sur la 32 ça fonctionne mais y'a petit soucis avec l'affichage de l'interface :-)

En fait sur un laptop de 17" il est impossible d'afficher complètement l'interface du coup les boutons du bas sont inaccessibles bien que j'ai activé la fonction de masquage automatique de mes panels et réduit au maxi l'interface de demarreMAO.

romain_bar utilisateur non connecté France
Bonjour Daniel,

ça fait plaisir de voir du neuf dans la gestion des sessions.
J'ai pu le lancer sans problème sur ma Linux Mint 16.

J'ai vu que la version date du 25 septembre 2013, tu nous as caché ça depuis 6 mois !?!

Faut que je me plonge dans la doc et essaie de voir ce que je peux en faire.
T'as prévu un nom, une license et peut-être un partage du code ? Ou alors c'est vraiment un tout début de chantier ?

Romain

ardoisebleue utilisateur non connecté France
@utilisateur_anonyme : je consulte les dépendances dans le dpkg et apt-get. pour le 64 bits
Pour la taille de l'interface au départ, il dépend de la taille des boutons, je vais réduire cette valeur. Comme elle est configurable, il suffira de changer dans la config, après installation.

@romain_bar : merci aussi de tester. Avant de le mettre sur le site j'ai testé, et aussi modifié sans trop m'occuper de la date de version. Quand le code sera "propre" (avec des commentaires) et que la base sera saine (sans bugs planteur) il sera partagé. Normalement c'est GNU, mais pour l'instant, comme dans les licences de musique, il faut que je comprenne ce que ça veut dire. Mais comme il utilise les bibliothèque libre de QT4 ce devrait être GNU GPL2.

Je me suis même aperçu qu'il pouvait démarré n'importe quel logiciel, il suffit que j’implémente un bouton ajouter un logiciel dans la configuration.

Citation :
Je me suis même aperçu qu'il pouvait démarré n'importe quel logiciel, il suffit que j’implémente un bouton ajouter un logiciel dans la configuration.


Merveilleux je n'ai pas osé formuler la demande mais c'est la première chose qui m'est venue à l'esprit :-D

ardoisebleue utilisateur non connecté France
@utilisateur_anonyme : J'ai rectifié pour la taille des boutons le tar.gz du nuage est à jour.
Pour le démarrage d'autres logiciels, j'ai tenté ce weekend, mais il y a des problèmes de priviléges root.
Exemple : pour développer pour le web : je dois, stopper les serveurs mysql, postgres, puis démarrer un serveur spécifique, puis firefox, puis le Xchat-gnome, puis l'éditeur pour python et un editeur pour html. J'ai fais un shell. Mais si j'arrête pour démarrer un autre développement plus lèger qui ne demande que 3 logiciels, c'est casse-pied. Donc Si je n'avais qu'à démarrer avec une config différente pour chaque environnement de travail ce serait le nirvana.
Bien sûr si c'est pour démarrer firefox sur le site linuxmao directement, un raccourci est préférable (d'ailleurs c'est ce que j'ai fait).

Heu ... ???

Image Le truc c'est que sur mon laptop par exemple (mon panel inférieur se masque automatiquement vu la taille de l'écran ça ok.)
J'ai remplacé le binaire mais l'affichage ne change pas.
D'ailleurs quand je clique sur la croix en haut à droite il devrait s'afficher sur toute la place disponible hors il ne le fait pas.

Donc pour Info:
TangoStudio 2.1
environnement de bureau "mate" (fork de gnome 3)

[EDIT] sur la capture la vue du bureau est complète et comme tu vois la partie basse est inaccessible.

ardoisebleue utilisateur non connecté France
@utilisateur_anonyme : tu as deux solutions :
soit utiliser le bouton en bas à droite (configuration) et tu changes les valeurs des dimensions d'icônes. Tu sors (avec la croix puisque le bouton n'est pas visible) le fichier cfg déjà a été modifié. et redémarres.
soit dans ~/demarremao tu supprimes le fichier "cfgdemarreMAO.gla" ; Au redémarrage il sera recréé avec les valeurs par défaut que j'ai réinitialisée.

Ha oui ! Impeccable là il s'affiche bien en prenant tout l'espace disponible à l'écran !

L'aspect est assez sympa . Bon y'a plus qu'à tester ça .

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 18:33, jeu. 16 Nov 2017: Salut et bienvenue à BlackVelvet :-)
sub26nico, 13:47, jeu. 16 Nov 2017: Salut et bienvenue à RnoxMadTan :-)
sub26nico, 23:32, mer. 15 Nov 2017: Salut et bienvenue à niconico :-)
sub26nico, 23:53, mar. 14 Nov 2017: Salut et bienvenue à jpcima :-)
olinuxx, 17:25, dim. 12 Nov 2017: Bonjour et bienvenue à loik56 :-)
sub26nico, 14:52, dim. 12 Nov 2017: Salut et bienvenue à NahMecl :-)
sub26nico, 01:23, dim. 12 Nov 2017: Salut et bienvenue à pitoufo3 :-)
olinuxx, 18:47, sam. 11 Nov 2017: bonjour et bienvenue à jmtrivial et à pacorabano :-)
sub26nico, 09:20, sam. 11 Nov 2017: Salut et bienvenue à sincosta et SamanTortega :-)
bluedid29, 00:04, sam. 11 Nov 2017: Merci m2v2 ;)
m2v2, 10:53, ven. 10 Nov 2017: @bluedid29 : j'ai ajouté s/pdif ok dans m-audio 2496
sub26nico, 09:26, ven. 10 Nov 2017: Salut et bienvenue à blacksam :-)