Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

9 - Synthèse sonore et Banques de sons

> Forums de discussion > 9 - Synthèse sonore et Banques de sons > [Résolu] LMMS grésille et coupe les autres sons
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[Résolu] LMMS grésille et coupe les autres sons

Nio utilisateur non connecté
Bonjour,

J'ai installé LMMS 1.0.3 sur ubuntu 14.04 LTS. Lorsqu'il est en route, je perds le son sur le reste du système et ce même si je l'éteins.
De plus le son grésille.

Que puis-je faire pour résoudre ces problèmes.

Merci d'avance pour votre aide.

malt utilisateur non connecté
Sous Linux c'est pulseaudio qui gère le son quand tu ne fait pas de MAO et jack qui "prend" le son quand tu fais de la MAO (quand il est bien configuré ça permet d'avoir une latence très faible).QJackCtl est une interface graphique pour piloter jack. Ce qui est bizarre c'est que LMMS est sensé pouvoir utiliser le son via jack et via pulseaudio...

Je pense que quand tu lance lmms, jack se met en route et quand tu ferme lmms jack ne se ferme pas, du coup il ne rend pas le son à ton système (donc à pulseaudio).

Après avoir fermé LMMS si tu n'a pas de son, essaye d'ouvrir le moniteur système d'ubuntu, de sélectionner jackd de cliquer sur terminer le processus pour voir si le son revient.

Au fait utilise tu une carte son externe ou une table de mixage?

Nio utilisateur non connecté
Merci Malt pour ta réponse.

Rectification il s'agit de LMMS 1.0.0 au lieu de 1.0.3.

"Après avoir fermé LMMS si tu n'a pas de son, essaye d'ouvrir le moniteur système d'ubuntu, de sélectionner jackd de cliquer sur terminer le processus pour voir si le son revient."

"En terminant un processus, vous pouvez détruire vos données, endommager votre session de travail ou bien introduire une faille de sécurité. Seuls les processus ne répondant plus devraient être terminés." Malgré ce petit message du moniteur j'ai terminé le processus et super ça fonctionne, je retrouve le son.

Par contre pulseaudio est en propriété très basse. si ça peut être utile.

Comment faire fonctionner pulseaudio et jack en même temps?

De plus sur LMMS j'ai le son qui grésille ou sature genre criiiichhh dès que je joue un accord. Une idée?


"Au fait utilise tu une carte son externe ou une table de mixage?"
Et bien ni l'un ni l'autre, j'utilise ma carte son interne.

Soit tu as un problème avec PAM ce qui fait que t'as pas la priorité Temps Réel.

Aussi LMMS préfère fonctionner avec alsa plutot qu'avec jack d'autant que si tu tourne sur la carte son intégrée tu gagne au change en utilisant alsa...

malt utilisateur non connecté
Oui pardon LMMS se serre de ALSA, pour compléter la réponse de utilisateur_anonyme je dirai qu'il faut que tu ouvre LMMS, et dans l'onglet Éditer du choisi Configuration puis tu vas dans Configuration audio (le haut parleur) et dans Interface audio tu choisi ALSA(Advanced Linux Sound Architecture).

Ensuite tu ferme LMMS et tu fait terminer jackd dans le moniteur système (comme tu l'a déjà si bien fait).

La prochaine fois que tu ouvre LMMS ça devrait le faire cool

Nio utilisateur non connecté
Avec Alsa ça se complique, LMMS semble ne pas en vouloir, puisqu'il reste bloqué sur interface audio: Dummy (no sound ouput) pas faux j'ai plus de son sur LMMS mais j'ai toujours le son de mon système (test avec une radio : je l'entends).

Si j'ai bien compris PAM fonctionne avec jack?

Nio utilisateur non connecté
localiser PAM avec /etc/security/limits.d/audio.conf
Réponse= /etc/security/limits.d/audio.conf.disabled

Alors j'ai fais un tour dans la logithèque pas de PAM...

PAM est juste une procédure à suivre.
Commance par t'ajouter au groupe audio
sudo gpasswd -a ton-nom-d'utilisateur audio


Ensuite ton fichier te donne une piste:
cat  /etc/security/limits.d/audio.conf.disabled

Donc voici comment procéder :
sudo dpkg-reconfigure -p high jackd

Aussitot tu fait :
sudo mv /etc/security/limits.d/audio.conf.disabled /etc/security/limits.d/audio.conf

puis
sudo reboot


À la prochaine ouverture tu lance jack et tu lui donne la priorité RT sur 89...

Nio utilisateur non connecté
Merci pour ces commandes explicites.
Terminal ok
reboot ok
RT 89 ok

résultat = aucun changement = perte de son et grésillement sur LMMS

Dans les prefs de LMMS t'as pensé à réglé la taille du buffer?
Par defaut il est à 256 il vaudrait mieux le passer sur sur 512 (par exemple).
Dans jack pareil il faut que la taille "échantillons par période" soit à 512 aussi (rapport à ton usage de la carte son du pc)

D'ailleur fait voir ce que dit :
cat ~/.config/rncbc.org/QjackCtl.conf

Ce qui m'interresse est la partie [Settings]

Nio utilisateur non connecté
512 fait pas de changement.

[Settings]
Server=/usr/bin/jackd
ServerName=
Realtime=true
SoftMode=false
Monitor=false
Shorts=false
NoMemLock=false
UnlockMem=false
HWMon=false
HWMeter=false
IgnoreHW=false
Priority=89
Frames=512
SampleRate=44100
Periods=2
WordLength=16
Wait=21333
Chan=0
Driver=alsa
Interface=
Audio=0
Dither=0
Timeout=500
InDevice=
OutDevice=
InChannels=0
OutChannels=0
InLatency=0
OutLatency=0
StartDelay=2
Verbose=false
PortMax=256
MidiDriver=aucun
ServerSuffix=


Nio utilisateur non connecté
1024 ok

bon l'idéal dans mon cas serait pulseaudio vers jack. j'ai fait le tuto mais jack sink n’apparaît nul part.

Nio utilisateur non connecté
Dans les configurations de LMMS j'ai choisi pulseaudio (bad lantency) au moins ça fonctionne. je peux garder mon son sur LMMS et mon système.
Par contre dès que je joue un accord criiiich.

POur ton affaire de pulse audio dans jack il te faut pulseaudio-module-jack

sudo apt-get install pulseaudio-module-jack


Nio utilisateur non connecté
pulseaudio-module-jack était demandé dans les prérequis du tuto pulseaudio vers jack, comme je n'avais pas la ligne de commande j'ai pu l'installer depuis la logithèque.
j'ai donc installé pulseaudio-module-jack et pulseaudio-module-jack-dbg.

Ensuite j'ai créé le script jack_startup et l'ai exécuté comme programme. Puis dans QJackCtl, options, Exécuter un script après le démarrage = jack_startup.
Voilà de là je devrais le voir apparaître dans l'audio de QJackCtl et dans les paramètres sons, maiiiis NON.

Selon ce que j'ai pu lire vis à vis du script jack_startup.
sudo nano /usr/local/bin/jack_startup

Tu lui colle le contenu dedans puis tu sauve et tu ferme. (noano peut être remplacé par gedit ou autre editeur ...
Ensuite tu rouvre ton terminal et :
chmod +x /usr/local/bin/jack_startup


La commande jack_startup sera donc valide et pourra fonctionner depuis qjackctl selon le tuto....
ET aussi toujours rédémarrer jack après avoir fait un changement.

Mais tu peux aussi plutot que de le faire avc jack procéder différemment (à des fins de tests)
Tu lance jack et une fois qu'il est lancé tu ouvre ses connexions puis tu ouvre un terminal et tu lance la commande de la sorte
/usr/local/bin/jack_startup

ou tout simplement
jack_startup

ça devrait marcher aussi.

Nio utilisateur non connecté
Alors l'option 3
jack_startup
m'a donné
bash: /usr/local/bin/jack_startup: Permission non accordée

Option 2
/usr/local/bin/jack_startup

bash: /usr/local/bin/jack_startup: Permission non accordée

Option 1
sudo gedit /usr/local/bin/jack_startup

Il m'ouvre l'éditeur gedit nommé jack_startup (/usr/local/bin) - gedit
dans lequel j'ai collé
#load pulseaudio jack modules
#!/bin/bash

pactl load-module module-jack-sink 
pactl load-module module-jack-source

echo "set-default-sink jack_out" | pacmd
echo "set-default-source jack_in" | pacmd

enregistrer et fermer

Ensuite
chmod +x /usr/local/bin/jack_startup

chmod: modification des permissions de «/usr/local/bin/jack_startup»: Opération non permise

Avec sudo ça ira mieux :-)
sudo chmod +x /usr/local/bin/jack_startup


Nio utilisateur non connecté
Marche pas
Lorsque je démarre Qjackctrl j'ai droit à un message d'erreur.


15:05:22.953 DBUS : le service est disponible (org.jackaudio.service soit jackdbus).
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
15:05:23.013 Changement du graphique des connexions ALSA.
15:05:33.276 Script de démarrage...
15:05:33.277 QjackCtrl sh action=clean
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
sh: 1: QjackCtrl: not found
15:05:33.683 Script de démarrage terminé avec statut de sortie=32512.
15:05:34.021 DBUS : impossible de démarrer le serveur JACK. Désolé
Fri Feb  6 15:05:33 2015: Starting jack server...
Fri Feb  6 15:05:33 2015: JACK server starting in realtime mode with priority 89
Fri Feb  6 15:05:33 2015: ERROR: cannot register object path "/org/freedesktop/ReserveDevice1/Audio0": A handler is already registered for /org/freedesktop/ReserveDevice1/Audio0
Fri Feb  6 15:05:33 2015: ERROR: Failed to acquire device name : Audio0 error : A handler is already registered for /org/freedesktop/ReserveDevice1/Audio0
Fri Feb  6 15:05:33 2015: ERROR: Audio device hw:0 cannot be acquired...
Fri Feb  6 15:05:33 2015: ERROR: Cannot initialize driver
Fri Feb  6 15:05:33 2015: ERROR: JackServer::Open failed with -1
Fri Feb  6 15:05:34 2015: ERROR: Failed to open server
Fri Feb  6 15:05:35 2015: Saving settings to "/home/celi/.config/jack/conf.xml" ...
15:05:38.688 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Incapable de se connecter au serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started


Lorsque je tape
jack_startup


il me répond
jack_startup
Échec : Échec lors de l'initialisation du module
28
Welcome to PulseAudio! Use "help" for usage information.
>>> Sink jack_out does not exist.
>>> Welcome to PulseAudio! Use "help" for usage information.


olinuxx utilisateur non connecté France
Nio écrit :
sh: 1: QjackCtrl: not found


QjackCtrl -> qjackctl

(sans majuscules et sans le "r")

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 20:50, ven. 27 mars 2020: Salut et bienvenue à Topyweb, Serge Samson, ChtiJeff, Zeplead et Zonzon :-)
r1, 20:27, ven. 27 mars 2020: La joute 15 est sur les rails ! [Lien] Viendez jouer avec nous !!!
bluedid29, 17:13, ven. 27 mars 2020: Bon week-end, à fond encore sur Musescore et LibraZik-2... ...bientôt utilisation régulière sur LibraZik-3...
sub26nico, 14:11, ven. 27 mars 2020: @tolliac, ouvres un fil spécifique dans les forums.
tolliac, 11:41, ven. 27 mars 2020: Bonjour, je ne me suis intéressé jusqu'ici qu'à l'écriture de partitions via lilypond et Frescobaldi et pour résoudre des problèmes de lecture de fichiers MIDI je me retrouve dans l'univers de la MAO chaleureusement accueilli mais complètement perdu. quel
Sahaathyva, 09:08, ven. 27 mars 2020: 1 billet de mr Paul : [Lien]
Sahaathyva, 09:07, ven. 27 mars 2020: Salut a tous!
GuillaumeD, 10:58, jeu. 26 mars 2020: @sub26nico, merci pour le message et ravi de vous rejoindre. Le meilleur reste à venir... ;)
sub26nico, 10:27, jeu. 26 mars 2020: Salut et bienvenue à prederour, GuillaumeD et pennsoner :-)
Samuel, 11:55, mer. 25 mars 2020: @zigmhount, tu penses à quoi exactement ? Je pense qu'ouvrir un nouveau fil est plus adapté
zigmhount, 14:41, mar. 24 mars 2020: Bonjour à tous! Y a-t-il une section sur ce site pour des liens vers des cours en ligne (gratuits ou non) qui pourraient intéresser d'autres utilisateurs? Je viens d'en finir un pas mal!
olinuxx, 15:28, dim. 22 mars 2020: Bonjour et bienvenue à Mito77, à MikeRodd et à MenoiaJin cool