Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Techniques et manipulations du son

> Forums de discussion > 4 - Techniques et manipulations du son > [audacity] enregistrement transposé et ralenti + précision visualisation
Dernier post

[audacity] enregistrement transposé et ralenti + précision visualisation

farvardin utilisateur non connecté
bonjour,

j'ai le même problème qu'ici : http://ubuntuforums.org/showthread.php?t=2174391 (c'est marqué résolu mais ça ne semble pas l'être)
Je souhaite enregistrer des musiques issues d'applications (enregistrement logiciel), mais les enregistrements dans audacity sont ralentis et transposés (désaccordés). J'ai essayé d'utiliser sox à la place. L'enregistrement fonctionne avec sox, mais ça fait pareil, c'est transposé d'environ 1 ton plus bas que dans la réalité. Si j'enregistre depuis une source extérieure, la vitesse et la hauteur sont correctes.

Ma distribution est linux mint (+ dépôts de kxstudio), et utilise donc alsa + pulseaudio.

Ma carte son est une carte externe presonus usb, donc c'est normalement une bonne qualité.

Accessoirement, j'aimerai savoir pourquoi quand je lis des sons dans audacity, il y a une latence assez importante entre ce que j'entends, et l'emplacement du curseur visuel qui est décalé d'environ 1 ou 2 secondes.

m2v2 utilisateur non connecté France
Bonsoir,
Une piste, peut-être : les taux d’échantillonnage sont-ils les mêmes ? Je veux dire que si tu enregistres un fichier échantillonné à 48 khz et qu'Audacity est réglé sur 44,1 khz (la case "projet à" en bas à gauche) ça peut poser problème; A vérifier...

farvardin utilisateur non connecté
oui, j'avais pensé à ça, c'était sur 48 khz et j'ai testé à 44 mais c'est pareil :-(
Je pense plus à un problème avec la carte son et / ou pulseaudio, vu que ça fait la même chose avec sox.

Citation :
Ma distribution est linux mint (+ dépôts de kxstudio), et utilise donc alsa + pulseaudio.


Bin tu ouvre cadence et choisi la configue alsa=>jack (plugin)
Ce que tu peux aussi faire c'est désactiver le démarrage auto de pulseaudio (applications au démarrage)

farvardin utilisateur non connecté
je ne connaissais pas cadence, ça semble intéressant, merci ça va bien me servir pour essayer de me débarrasser de cette $*@# de pulseaudio. Pour le moment je viens de voir qu'avec paman (pour "pulse audio manager" je présume), je peux stopper pulseaudio tout en continuant à avoir du son, et effectivement ça venait bien de ça, maintenant avec sox je peux enregistrer et c'est à la bonne vitesse et hauteur. Par contre j'ai toujours la petite latence visuelle avec audacity lorsque je joue la musique...

Merci pour votre aide, c'était donc bien à cause de pulseaudio (comme à chaque fois qu'il y a un problème de son). Quelle cochonnerie ce truc...

Salut



Sinon tu peux aussi reduire la taille du buffer depuis cadence ou jack à 512 voir même 256 si ta carte son le permet.

Sans les prefs d'audacity Enregistrement => latence tu peux reduire la taille du buffer d'audacity.

Débarrasse toi de pulseaudio de façon définitive :
apt-get remove --purge pulseaudio


Il va te retirer tout ce qui est lié à pulseaudio mais après tu devrais installer par exemple pour vlc le vlc-plugin-jack ect ...

Voilà !

@plus!

farvardin utilisateur non connecté
merci, je vais essayer cela. Je pensais que beaucoup trop de paquets dépendaient complètement de pulseaudio, mais savoir que d'autres ici peuvent faire de la musique sans ça, cela me rassure.

Pulseaudio en MAO moins on le voit et mieux on se porte mais dans certains cas de figure il est possible après quelque réglages de le faire cohabiter dans la mesure du raisonnable... Mais dans un temps tu le vire et si t'en as vraiment besoin alors repasse par le forum...

farvardin utilisateur non connecté
Donc j'ai purgé Pulseaudio du système. Ça fonctionne pas trop mal, mais j'ai quand même quelques trucs bizarres :

- Dans firefox, je n'ai plus de son html5 (mp3, ogg etc). Flash sur youtube ça fonctionnait bien, jusqu'à ce que je mette à jour vers la version 40 de FF, et là ça pousse le lecteur html5 par défaut, impossible d'avoir quoi que ce soit. Pour les autres lecteurs flash, ça fonctionne. Par contre quand je coupe le son qui est joué en flash (quitte la page par exemple), ça fait un effet de disque rayé pendant 2 secondes :-(

- Dans chrome, j'ai toujours les sons html5.

Dans les autres logiciels, le pont alsa => jack semble fonctionner correctement.

Je vais continuer mes recherches parce que je n'ai pas envie de remettre pulseaudio.

Sinon on dirait que le coup de la latence dans audacity ça venait bien du buffer, avec 512 ou 256 ça ne le fait plus. Par contre après ce paramétrage j'ai mis mon ordi en veille, et à la sortie de veille jack ne fonctionnait plus (plus de son), mais était toujours activé. Je l'ai arreté, impossible de le redémarrer (problème dbus dans les log). Je n'ai pu le redémarrer qu'en remettant le buffer à 1024 (coincidence ?)

La mise en veille et jack ne font pas bon ménage (question de priorité) ...
D'ailleurs selon moi le mode mise en veille (disque dur) devrait être systématiquement désactivé sur une machine dédiée à la mao ...

Pour lecteur flash vois pour trouver le paquet mozilla-flashplayer (ne pas confondre avec le flasplugin-nonfree).

Astuce:
Si tu installe la suite cadence de KXStudio tu auras une application nommée Carlaelle permet entre autre chose de changer la taille du buffer en directe sans avoir à relancer jack...

farvardin utilisateur non connecté
malheureusement j'ai dû faire un retour en arrière et revenir à cette pourriture de pulseaudio et ses latences, bugs et autres dégénérescences sonores :-( (désolé, je n'ai pas d'autre mot, vu comment ça s'est propagé sur tous les logiciels et est devenu "obligatoire"), je n'ai pas réussi à savoir si cela venait de chez moi ou si firefox était obligé de fonctionner avec pulseaudio (parce que ce n'est compilé qu'avec ça), mais malgré de nombreuses tentatives, le html5 restait toujours silencieux, et comme j'en ai besoin et que ça me gavait d'ouvrir tous les liens avec du son (soundcloud etc) dans chrome, je suis revenu à ma configuration d'avant :-(

Salut

Ça dépend de quels logiciels parle tu?
Tu peux très bien avoir par exemple mplayer et mozilla-flashplayer sans pulse audio installé. T'installe juste la libpulse et c'est marre.

Pour contourner le problème de pulseaudio voici ce que je fait:
Je règle cadence sur ALSA -> Loop -> JACK ok?
Tous les softs qui d'ordinaire seraient routés sur PA ou bien qui restent silencieux dans jack je les envois sur Jack ou bien sur aloop .

Voici un petit tuto Alternative à PulseAudio

farvardin utilisateur non connecté
salut,

juste un petit message pour dire que si j'ai toujours envie de me débarrasser de pulseaudio, j'avais un peu abandonné pour ce problème, je me suis rendu compte qu'il devait y avoir un problème dans mon installation, car sur 2 autres ordinateurs en retirant pulseaudio je n'ai pas ces symptômes avec firefox... Je pense donc réinstaller tout mon système lors de la prochaine mise à jour LTS de linuxmint.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 23:13, lun. 11 Dec 2017: Salut et bienvenue à DA :-)
sub26nico, 23:59, dim. 10 Dec 2017: Salut et bienvenue à yop08 et Flunkenstein :-)
bluedid29, 21:16, dim. 10 Dec 2017: Bonne soirée ;)
bluedid29, 21:16, dim. 10 Dec 2017: Projet pour la joute musicale nr 13 envoyé ! :-) [Lien]
sub26nico, 13:41, dim. 10 Dec 2017: Salut et bienvenue à Hachesse :-)
MrKebab, 12:01, dim. 10 Dec 2017: io GNU/Linux 2017.03 64 bits dispo.. bon dimanche [Lien]
sub26nico, 09:05, jeu. 07 Dec 2017: theobuntu, j'ai bien eu ton message, on s'en occupe.
theobuntu, 01:57, jeu. 07 Dec 2017: quelqu'un ?
bluedid29, 00:51, jeu. 07 Dec 2017: Installé aussi sur d'autres ordinateurs, bientôt un p'tit topo, le temps de rassembler les données ;) Bon jeudi :-)
bluedid29, 00:48, jeu. 07 Dec 2017: Librazik 2 installé avec succès sur Asus Rog i7 (64bits)... ...et sur Compaq Mini Atom (32 bits), tout va bien :-)
jujudusud, 11:46, mar. 05 Dec 2017: Merci Sub26nico, je vais lire ça de suite :-)
sub26nico, 11:03, mar. 05 Dec 2017: L'édito de décembre est en ligne : [Lien]