Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

6 - Le MIDI

> Forums de discussion > 6 - Le MIDI > Bulk Dump de Yamaha..
Dernier post

Bulk Dump de Yamaha..

jpmtrax utilisateur non connecté
Bonjour ou Bonsoir,

voilà je vous fait part d'un problème assez particulier. Mon vieux lecteur de disquette Midi Yamaha MDF2 m'a lâché, temporairement du moins. Beaucoup de mal à retrouver une courroie vraiment adaptée au lecteur, mais passons.

J'ai réussi à recopier quelques disquettes écrites avec ce lecteur sur mon PC (sous Xubuntu 14.04). J'ai réussi aussi à renvoyer ces mêmes fichiers dans une de mes machines (un vieux Yamaha QR-10) grâce à la commande aplaymidi, mon pc étant relié à une interface midi usb de M-AUDIO.
Donc ça c'est nickel, je redécouvre même des vieux trucs composés y'a des années. biggrin

Par contre je n'arrive pas à faire l'inverse, c'est à dire renvoyer un bulk de mon qr-10 vers mon pc. J'utilise arecordmidi, mais quand je renvoie le fichier sur mon séquenceur Yamaha, j'ai un joli message d'erreur.

Comment résoudre ce problème ?

J'utilise ces deux commandes aplaymidi et arecordmidi car les Yamaha produisent des fichiers midi standard (et donc la commande amidi ne fonctionne pas).

PS je n'ai pas utilisé Jack pour ces procédures, je n'en vois pas l'intérêt.

jpmtrax utilisateur non connecté
J'en profite pour vous partager ma solution pour le Yamaha SU-10, où là figurez-vous que arecordmidi et aplaymidi fonctionnent nickel.

http://fr.audiofanzine.com/sampleur/yamaha/SU10/forums/track.,t.496320,bulk-dump-et-midiox,post.8538279.html

Y'a donc certainement un souci d'intervalle ou de message avec le qr-10, mais là je sèche. De fait, le QR-10 m'indique deux erreurs (err07 et err05), qui correspondent je pense à un problème de vitesse de transmission. En fait le QR-10 sait qu'il reçoit un bulk, mais ne sait pas l'interpréter, et le buffer du qr-10 est plein (cf Manuel du QR-10).

Par contre je ne vois pas d'option dans aplaymidi pour réduire la vitesse de transmission ?

olinuxx utilisateur non connecté France
Chouette pour le partage de la solution.

jpmtrax utilisateur non connecté
Bon, je viens de réussir !! biggrin

Mais je ne m'enthousiasme pas trop vite non plus. Pour l'instant ce que j'ai fait, c'est installer le firmware de mon interface midi M-audio USB Uno. A vrai dire je ne sais pas si c'est ça qui a joué, parce que mon interface était quand même reconnue sans ce firmware..

sudo apt-get install midisport-firmware


Une fois l'installation du firmware faite, il faut redémarrer le PC.

Ensuite j'ai refait la commande aplaymidi, mais j'ai ajouté l'option -d 10. Visiblement ça introduit un délai de 10 secondes au début du bulk. J'ai fait un essai sans cette option, ça ne fonctionne pas.

Ce qui donne donc en clair

aplaymidi -p <numero_de_port_de_l_interface> monfichier.mid -d 10


et là ça a marché, sur une sauvegarde que j'avais faite auparavant avec arecordmidi.

Donc c'est cool, je vais pouvoir bosser, mais mais mais, on n'est jamais trop prudent, je vous confirme tout ça après !

olinuxx utilisateur non connecté France
Super pour le retour. J'ai mis un lien vers ici dans la page M-audio Uno. J'imagine bien que ce n'est pas le meilleur endroit, mais bon ... à défaut de mieux, au moins il est dans la doc. Si tu as une idée d'où parler de ça dans la documentation, n'hésite pas à en parler ici.
a+

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 21:11, ven. 15 Jan 2021: Pas de soucis.
louiesauvage, 19:44, ven. 15 Jan 2021: ok désolé olinuxx
olinuxx, 19:40, ven. 15 Jan 2021: Pareil pour toi @louisauvage, si tu as une question, utilise le forum.
olinuxx, 19:40, ven. 15 Jan 2021: Bonjour et bienvenue @Polo cool. Utilise les forums pour les questions (lien dans le menu en haut du site).
louiesauvage, 19:39, ven. 15 Jan 2021: bonjour quelqu'un à essayé les cartes son antelope audio?
Polo, 16:24, ven. 15 Jan 2021: Bonjour, Je voudrais connecter un clavier M-audio keysattion mini 32 MK3 sur un ordinateur avec Ubuntu 20.04 et Ubuntu Studio- Installer. J'ai installé le module audio mais cela ne marche pas. Quelqu'un peut m'aider ? En fait je n'ai plus de son ..
olinuxx, 14:49, jeu. 14 Jan 2021: Bonjour et bienvenue à SERGIO SOLIBEL cool
olinuxx, 13:35, mer. 13 Jan 2021: Bonjour et bienvenue à alfa cool
olinuxx, 13:25, mar. 12 Jan 2021: Bonjour et bienvenue à Robotophe cool
olinuxx, 12:52, lun. 11 Jan 2021: merci Bluedid cool
olinuxx, 12:51, lun. 11 Jan 2021: Bonjour et bienvenue à hugodoko et neijlu cool
bluedid29, 13:59, dim. 10 Jan 2021: Merci pour l'édito, super ! :-)