Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

7 - Développer/Traduire/Documenter/Annoncer une application

Dernier post

petri-foo mod1

jphaenlin utilisateur non connecté France
Bonjour,
J'ai apporté quelques améliorations à Petri-Foo (le sampleur).
--> https://github.com/jphaenlin/Petri-Foo
J'ai fait ça pour mon propre usage, car je trouvais que, en l'état, il n'était guère utilisable (que faire avec des temps de decay d'enveloppe de 1 s maxi ?).
Je m'en sert maintenant depuis quelques mois et c'est très stable.
Si ça vous intéresse...

jp

olinuxx utilisateur non connecté France
Salut jphaenlin,

je viens de le tester en faisant un paquet pour debian stable. Lors du processus de construction du paquet, j'ai eu une erreur qui disait "je ne peux pas installer le fichier petri-foo.xml car il n'existe pas". J'ai simplement mis une rustine dans mon paquet qui commente la ligne :
install (FILES petri-foo.xml DESTINATION ${MIME_DIR}/packages)
du fichier CMakeLists.txt .

Ensuite, le processus de construction est très bien passé et du coup, j'ai pu sortir un son pour le tester rapidement il y a 2 minutes.

Un peu trop les yeux qui se ferment pour moi du coup, je le testerai un peu plus en profondeur demain je pense.

Je voulais simplement te remonter l'expérience ici et te demander aussi si tu comptais pousser tes modifications sur le projet amont.

À demain,
Olivier

jphaenlin utilisateur non connecté France
Merci, j'ai oublié de mettre ce fichier sur Github, je vais le rajouter.
Projet amont ? Certes, c'est des choses qui se font... on verra.

jp

olinuxx utilisateur non connecté France
De rien pour le retour.

Si je te pose la question par rapport au projet amont, c'est parce que j'ai vu que depuis que tu as forké petri-foo sur ton propre dépôt, le petri-foo d'origine à eu 2 nouveaux commits. Comme je travaille sur une distribution MAO basée sur Debian Jessie et que le paquet de ton logiciel est prêt à être intégré (je vais attendre que tu places le XML pour refaire un paquet propre), je me dis que c'est dommage d'avoir les 2 branches qui partent chacune de leur côté. À moins bien sûr qu'il y ait de bonnes raisons à cela. De plusse, en tant qu'empaqueteur (mon petit point de vue égo-centré :-) ), c'est beaucoup de travail si je souhaite conserver les 2 versions dans la distribution car il faudrait que j'aille tripoter les makefile et autre de ton paquet pour lui donner un autre nom que petri-foo.

Bref, merci pour le partage de ton travail !
a+
Olivier

jphaenlin utilisateur non connecté France
Salut,

Mon avis est que c'est trop tôt pour faire une distrib, vu que je n'en ai pas parlé au concepteur de PF, ce serait un peu cavalier. Donc, je vais faire un pull request sur Github, puisque tu me forces un peu la main (d'abord il faut que je voie comment ça marche...). Il faut voir ma version comme une expérimentation, pas comme un concurent de la version principale.
Je n'ai pas pour l'instant l'intention de faire plus de développement, à part s'il y a des bugs. Ce que j'ai fait n'était pas très compliqué vu qu'il y avait déjà toutes les fondations dans PF, faire un plugin LV2 est une autre paire de manches. On verra, dans 6 mois, 1 an.

jp

olinuxx utilisateur non connecté France
OK, merci pour les précisions. Je vais donc garder ce paquet en tant qu'expérimental et attendre de voir ton pull request être accepté en amont.

J'espère ne pas avoir été trop brutal en te "forçant la main" car ce n'était pas l'intention :-)

olinuxx utilisateur non connecté France
Pour info, j'ai mis une paire de [feature request] sur le github de petri-foo. Et j'ai eu une réponse du développeur principal sur l'une d'elle (ici : https://github.com/jwm-art-net/Petri-Foo/issues/14#issuecomment-161447417 ) qui dit :

James Morris écrit :
I'm not deeply enough involved in code anymore to work on this or any other aspect of Petri-Foo.


Bref, il dit qu'il n'est plus très actif dans le code. J'ai l'impression que ça sent un peu le sapin pour petri-foo. Je viens de m'inscrire à la liste de diffusion et j'y enverrai un message pour savoir ce qu'il en est quand ma souscription sera validée.

Édition : ça a été vite et mon message est là : http://sourceforge.net/p/petri-foo/mailman/petri-foo-devel/?viewmonth=201512 , on verra bien ce que ça dit dans les jours qui viennent.


jphaenlin utilisateur non connecté France
Bah, c'est open source, libre et tout, donc il y aura tjrs qqun pour reprendre le flambeau, moi par ex. Comme je disais, ma version marche, elle a quelques fonctionnalités en plus qui me semblaient indispensables et si ces fonctionnalités semblent utiles à d'autres, eh bien ils n'ont qu'à compiler la version et l'utiliser. Donc tout va bien, non ?
Pour l'instant, je n'ai pas l'intention d'y retoucher, mais il est certain que je ferai encore d'autres modifications, car ce soft est bien écrit, facile à comprendre, donc ce n'est pas du temps perdu que de s'y intéresser.

jp

olinuxx utilisateur non connecté France
Il est évident que c'est l'une des choses intéressantes avec le libre, le code peut être repris. Ceci dit, ça n'est pas parce que ça "peut" que ça le "sera", j'ai en tête l'exemple de rezound, bien dommage qu'il ait disparu celui-ci.

Ceci dit, pour petri-foo, vu que tu sembles actif dessus, c'est chouette. Je vais prendre un peu de temps pour tester tout ça plus en profondeur. Tiens, je t'ai envoyé une amélioration sur ton fork.

C'est bon de savoir que le code est propre. Il y a eu du boulot de la part du dernier mainteneur (James Morris) de ce côté-là de ce que j'en ai lu dans les archives des listes de discussion.

a+

jphaenlin utilisateur non connecté France
Mais... Rezound n'est pas mort --> http://sourceforge.net/projects/rezound/files/ReZound/
Il y a eu une modif en 2013. Evidemment, il faut le compiler, et aussi compiler la bonne version de fox, ce n'est pas ultra simple, mais ça marche, c'est le meilleur éditeur sous Linux.

jp

olinuxx utilisateur non connecté France
Ba il est pas très vivace non plus hein :-) Il n'y a guère que gentoo qui le propose encore dans ses dépôts. Je suis d'accord avec toi, c'est certainement le meilleur éditeur audio sous linux (de ce que je m'en souviens, ça doit faire 3 ou 4 ans que je n'ai pas joué avec). Quand j'aurais 2 heures devant moi, j'essaierai de le compiler et si ça passe, je verrai pour faire une demande à Debian.

olinuxx utilisateur non connecté France
Je remonte ce sujet.

Debian est en train de faire le ménage dans les dépôts pour la prochaine stable. Une partie de ce ménage et de ne pas fournir les anciennes bibliothèques de Gnome (GTK2 dans ce cas si je ne m'abuse).

Ce fil de discussion dans le BTS de Debian Image en parle, et je résumé ici en français :

  • petri-foo devra être porté vers les bibliothèques de GTK3 ou disparaîtra des dépôts de la future stable de Debian
  • un message a été envoyé à James Morris (le développeur de petri-foo) pour lui demander quels sont ses plans pour le futur
  • James Morris a répondu qu'il ne développera plus petri-foo

Du coup, petri-foo a tout l'air d'être en l'état d'abandon.

@jphaenlin : aurais-tu le temps, les compétences, l'énergie, et l'envie pour effectuer ce portage ?

Est-ce que quelqu'un d'autre se sentirai de le faire ?

jphaenlin utilisateur non connecté France
Salut,

J'avais fait des ajouts à Petri-Foo parce que j'en avais besoin. Mais maintenant je ne m'en sert plus, donc je n'ai pas la motivation de m'y mettre, je l'avoue. D'un autre côté, annoncer l'abandon de GTK2 me semble exagéré, je demande à voir.
Maintenant je travaille avec Reaper Linux et des VST Linux et Windows, et j'en suis très content.


A plus,

JP

olinuxx utilisateur non connecté France
Merci d'avoir répondu. Du coup, si un autre mainteneur potentiel lit ceci, qu'il n'hésite pas.

Concernant la suppression d'un maximum de trucs GTK2 dans la future Debian (buster), il y a beaucoup de boulot ces temps-ci autour de la suppression de GTK2 pour la future stable de Debian (qui arrivera peut être en 2019). On peut lire par exemple ceci https://qa.debian.org/debcheck.php?dist=unstable&package=petri-foo Image et https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=885781 Image en ce qui concerne petri-foo dans Debian. Le message général en ce qui concerne ceci est https://lists.debian.org/debian-devel/2017/10/msg00299.html Image .

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Mégaphone [Afficher / Cacher]

sub26nico, 22:13, jeu. 22 Feb 2018: Salut et bienvenue à minou :-)
minou, 19:07, jeu. 22 Feb 2018: Slt, je souhaiterai contacter les usagers de la carte son Behringer FCA1616, il semble que la mienne ne soit pas reconnu ni par Alsa/PulseAudio/Jack, je travail en usb
r1, 17:22, jeu. 22 Feb 2018: Une interview de Paul Davis (Ardour) [Lien]
sub26nico, 16:27, jeu. 22 Feb 2018: Salut et bienvenue à Maharmouzet :-)
sub26nico, 16:58, mer. 21 Feb 2018: Salut et bienvenue à Widmir et MatM :-)
olinuxx, 15:00, mer. 21 Feb 2018: Bonjour et bienvenue à ssachot :-)
sub26nico, 23:24, mar. 20 Feb 2018: Salut et bienvenue à Psychogay et anais :-)
sub26nico, 18:26, mar. 20 Feb 2018: salut et bienvenue à jlcord :-)
sub26nico, 13:23, dim. 18 Feb 2018: Salut et bienvenue à Abdelaid :-)
sub26nico, 01:59, dim. 18 Feb 2018: Salut et bienvenue à omalley :-)
sub26nico, 18:07, ven. 16 Feb 2018: Et des promos aussi sur certains plugins Harrison : [Lien]
pierrotlo, 18:00, ven. 16 Feb 2018: SAlut tous, je viens de recevoir un Behringer Model D. pas de soucis en mode USB avec Linux (MIDI)