Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

2 - Les distributions et les noyaux

> Forums de discussion > 2 - Les distributions et les noyaux > LibraZiK : version 32 (normal et PAE) et 64 bits, avec noyaux 4.4.6 (basique, basse-latence et temps réel)
Dernier post
Page : 2/4   -   Aller directement à la page : 1  2  3  4 

LibraZiK : version 32 (normal et PAE) et 64 bits, avec noyaux 4.4.6 (basique, basse-latence et temps réel)

olinuxx utilisateur non connecté France
Pour les impatients, LibraZiK est installable en version 64 bits ou 32 bits (normal et PAE) avec les nouveaux noyaux 4.4.6 (versions disponibles : basique, basse-latence et temps réel).

Pour ce faire, vous suivrez la "méthode n°2" d'installation ici : http://librazik.tuxfamily.org/doc/installation .

Note : vous pouvez également utiliser la "méthode n°3" si vous comprenez précisément ce que vous faites (car elle n'est pas destinée à des débutants).

Je vais à présent travailler sur la fabrication de nouvelles ISO.

Amusez vous bien et bonne zik !
Olivier

Arkanium utilisateur non connecté
Es possible de l'installer sur debian stretch ?? car j'ai des problèmes de drivers nvidia sur Jessie

Arkanium utilisateur non connecté
Es possible de l'installer sur une debian Stretch sans trop de problèmes ? car décidément je ne peu pas faire avec Jessie ma carte 3d n'es pas supporter

olinuxx utilisateur non connecté France
Citation :
Es possible de l'installer sur debian stretch


Je ne le conseille pas. LibraZiK est conçue pour fonctionner sur Jessie.

Si tu as besoin de Stretch, alors io.gnu.linux devrait te convenir.

olinuxx utilisateur non connecté France
@sub26nico : tiens moi au jus, ça m'intéresse d'avoir une page qui explique comment installer LibraZiK sur un MacBook. Et bon courage à toi ! :-)

stamkorg utilisateur non connecté
Bon,
Premières impressions de Librazik64, très positives.
Installation selon la méthode 2, nickel.
Installation du noyau RT, sans problème.
Configuration jack et carton son, ok.

Résultat :
Pianoteq 5.5.1 tourne sur un i5-460m double coeur et 8Gb de RAM à 64 samples, 2 périodes et 48000Hz, pour une latence indicative jack de 2,67ms, sans aucun xrun après 1h de jeu. Avec ce réglage je ne perçois pas la latence, la connexion entre le clavier et le son est parfaite.
A tester donc de manière plus approfondie.

Pour info, ni ubuntustudio, ni kxstudio, ni avlinux ne m'ont permis de tenir ce réglage sur la même machine sans xruns. Seul tango studio m'a permis cela.

Juste un soucis avec screensaver que j'ai désinstallé.

Par contre, un peu plus gênant : mon wifi ne marche plus (micro code manquant ou quelque chose du genre) alors que ça marchait avec librazik32...
Toute aide serait la bienvenue,
Merci pour ce bon travail.

olinuxx utilisateur non connecté France
Super retour stamkorg, ravi que ça se passe bien pour toi :-)

Pour l'économiseur d'écran, je mettrai certainement, bientôt, une optimisation pour le virer de base.

Pour le wifi, c'est logique si tu as installé librazik32 avec le live car les firmwares wifi étaient embarqués. Là, avec l'installation netinst, ils ne le sont pas. Du coup, ce qu'il te faut, c'est activer le composant non free de la ligne "deb" de la distribution "jessie", puis recharger synaptic, puis installer le paquet non-libre du firmware nécessaire à ton wifi.

Si tu as compris ce que je viens d'écrire, nickel, sinon, le mieux c'est que tu passes sur mon canal IRC pour que je te "pilote" en direct.

À la réflexion, j'ajouterai un paragraphe pour le wifi dans la documentation de configuration car j'imagine que ça va être souvent demandé.

a+
Olivier

sub26nico utilisateur non connecté France
olinuxx écrit :
tiens moi au jus, ça m'intéresse d'avoir une page qui explique comment installer LibraZiK sur un MacBook. Et bon courage à toi ! :-)

Merci, mais ça risque d'être long, j'ai fait une connerie en enlevant KX Studio et si, pas de problème
pour démarrer et utiliser OSX, j'ai peur qu'après l'install' de Debian je puisse pas avoir le choix
de système au boot. Si cela se confirme, il faudra que je fasse une clean install d'OSX, avec
tout le bonheur de réinstal des softs avec licence, autorisation, etc comme savent le faire
les systèmes proprios. Je te tiens au jus et si cela t'intéresse, je peux lister ma démarche pour
te faciliter la tache si tu veux une page d'install pour Mac.
Je verrai ça en début de semaine prochaine.

PS : préparerais tu un live 64bits?

stamkorg utilisateur non connecté
Merci Olivier,
Je testerai ce soir.
Pour activer le dépôt non free, ça va aller, mais comment savoir le nom du paquet à installer ensuite?
Cdt,
SK

olinuxx utilisateur non connecté France
sub26nico écrit :
si cela t'intéresse, je peux lister ma démarche pour te faciliter la tache si tu veux une page d'install pour Mac

Oui, ça m'intéresse. Ouvre un autre fil de discussion genre "Installer LibraZiK sur un MacBook Pro" pour y coller tes trouvailles.

sub26nico écrit :
PS : préparerais tu un live 64bits?


Oui.


stamkorg écrit :
Pour activer le dépôt non free, ça va aller, mais comment savoir le nom du paquet à installer ensuite?


Les paquets se nomme "firmware-quelquechose" dans ton Synaptic. Le nom des paquets est visible ici . Pour savoir lequel, tu peux par exemple :
  1. relever quel est le firmware manquant et faire une recherche avec son nom dans synaptic,
  2. rechercher dans un moteur de recherche
  3. passer en mode bourrin et installer tous ces paquets en te disant que le tiens est parmi eux

Je conseille 1) ou 2)

stamkorg utilisateur non connecté
ok, merci,
Ca marche en mode bourin

sub26nico utilisateur non connecté France
Je ne trouve pas le noyau 4.4.6 low latency,
j'ai au choix :
-Linux 4.4.0-1-lzk-amd64
-Linux 4.4.0-1-lzk-bl-amd64
-Linux 4.4 for 64-bit PCs, PREEMPT_RT

Librazik 64bits, méthode d'installation n°2...

sub26nico utilisateur non connecté France
je crois que j'ai trouvé, bl comme basse latence, pas l'habitude du françaislol

sub26nico utilisateur non connecté France
Instal' faite sur mon laptop, quelques difficultés mais rien d'insurmontable...jusqu'à l'installation
du noyau basse latence, qui s'il fonctionne nickel, ne me permet plus depuis qu'il est installé
de me connecté en wifi. Je vais essayer de réinstallé le driver proprio.
Autre problème au démarrage j'ai ce message d'erreur
Image
Le trackpad qui était fonctionnel ne me permet plus le défilement depuis sa configuration,
mais je pense qu'en tweakant un peu, je trouverai la solution

Willty utilisateur non connecté France
version 64bits installée sur 2 portables et un fixe, ça pète du tonnerre ! Merci à toute l'équipe de LibraZIK !

sub26nico utilisateur non connecté France
Problèmes résolus :

- Affichage de l'erreur au démarrage : disposition du clavier: passé de MacBook/MacBookPro à Macintosh,
plus de message d'erreur au démarrage.
-TrackPad: en fait certaines fonctions étaient désactivés(sûrement après l'édition du fichier etc/default/keyboard),
j'ai remis le défilement à 2 doigts et le clic par touche, et c'est reparti.

Problème non résolu:
le driver wifi ne fonctionne toujours pas, j'ai installé pourtant plusieurs paquets nonlibre mais toujours rien..
à suivre.

olinuxx utilisateur non connecté France
Merci pour les retours sub26nico, willty et stamkorg. C'est super, ça me permet d'évaluer si LibraZiK fonctionne ou pas :-)

@sub26nico : as-tu suivi les recommandations de mon message (7 messages ci-dessus) ?

sub26nico utilisateur non connecté France
olinuxx écrit :
@sub26nico : as-tu suivi les recommandations de mon message (7 messages ci-dessus) ?

méthode 1 et 2 oui, puisque j'ai réussi, avant l'intal du noyau bl à installer le driver proprio.
Méthode 3 partiellement, jevais peut être rcommencer de manière moins nuancée.
J'ai installé le noyau rt au cas où, pas d'amélioration coté wifi,
mais au moins j'ai pu essayer avec ce noyau et c'est très stable (Ardour, une 10 pistes
midi et audio, hydrogen en même temps, Musescore, etc...)
Je m'y remet et te tiens au courant.
PS: j'ai préparé un tuto d'instal pour Mac, mais en le faisant, j'ai repéré plusieurs
'conneries' que j'ai faite, je risque donc à nouveau de tout devoir refaire, mais ça attendra,
vu qu'à part le wifi, tout fonctionne coté LibraZik, et coté OSX, à part les mises à jour système,
tout fonctionne également.

sub26nico utilisateur non connecté France
Bon, ça y est, dernier soucis résolu,
Après avoir installer tout ce qui se trouver dans Synaptic avec la méthode 3, dit bourrine,
pas de meilleurs résultats.
Puis, après un reboot,
j'ai relancé les commandes suivantes:

sudo apt-get install linux-firmware-nonfree
sudo modprobe b43
dmesg | grep -e b43 -e bcma


Et là, ça remarche.

sub26nico utilisateur non connecté France
Par contre, au redémarrage, cela ne fonctionne plus,
obligé de refaire les 2 dernières commandes dans le terminal administrateur (donc sans sudo),
et ça remarche, faut il faire quelquechose pour fixer la chose? je n'avais pas eu à le faire
avant l'installation du noyau bl ou rt

olinuxx utilisateur non connecté France
Pour faire charger automatiquement un module noyau au démarrage, tu peux l'ajouter dans le fichier /etc/modules-load.d/modules.conf .

Chouette et bravo à toi d'être parvenu à configurer aux petits oignons ton installation sur un ordi mac ! Concernant le tuto d'install sur Mac, même s'il n'est pas (encore) parfait, ça serait chouette que tu nous fasses part de tes notes dans un fil de discussion. J'imagine que tu préférerais proposer un truc fini et c'est tout à ton honneur. En attendant que tu aies du temps à y consacrer, ça sera utile que d'éventuels utilisateurs sur Mac puisse lire ton expérience, non ? En plusse, il se peut que des lecteurs corrigent et/ou améliorent la méthode d'installation que tu as défriché, te permettant de gagner en compétence, en performance et en temps lors de ta prochaine installation.

Page : 2/4  [Suivant]
1  2  3  4 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


rico211
calixtus06

Mégaphone [Afficher / Cacher]

calixtus06, 10:46, mar. 20 Oct 2020: Bienvenue à toi fran_studio :-)
minimoineau, 15:20, lun. 19 Oct 2020: Salut à tous, on aurait besoin d'aide pour faire tourner une Saffire pro 26 dans le forum [Lien] svp!
calixtus06, 20:40, sam. 17 Oct 2020: Bienvenu à Dan.p :-)
olinuxx, 19:34, sam. 17 Oct 2020: Bonjour et bienvenue à Dan.p cool
calixtus06, 23:00, ven. 16 Oct 2020: Bienvenue à MorganeH :-)
calixtus06, 09:56, jeu. 15 Oct 2020: Bienvenue à Michelk ! :-)
olinuxx, 14:44, mar. 13 Oct 2020: Merci @Sahaathyva, ça fait plaisir. @tous : n'hésitez pas à commenter l'édito, ça fait plaisir de voir que le travail est apprécié !
Sahaathyva, 10:49, mar. 13 Oct 2020: Encore 1 super edito, merci a vous !!!
calixtus06, 10:12, lun. 12 Oct 2020: Bienvenue à pat01111967 :-)
olinuxx, 11:50, sam. 10 Oct 2020: Bonjour et bienvenue à Ched, Lalain, courage, reno, et Nellou cool
piep, 15:15, mer. 07 Oct 2020: bienvenue à l'ami Reno. va sur "Mon LinuxMAO" et positionne toi sur la carte. merci
allany, 15:53, mar. 06 Oct 2020: @r1 : ouaip, quelle équipe !