Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié Ardour

> Forums de discussion > 3 - Forum dédié Ardour > [A4] Bug/Crash avec Ardour4 et Calf LV2
Dernier post

[A4] Bug/Crash avec Ardour4 et Calf LV2

yruama utilisateur non connecté
J'ai depuis quelques jours un bug très gênant qui rend les plugins Calf LV2 inutilisable dans Ardour4 : soit ardour crash à l'insertion du plugin, soit il est impossible d'ouvrir l’interface du plugin. J'aimerais savoir :
- est que ce problème arrive chez d'autre personne ?
- avez des pistes pour identifier et corriger le problème ?

Détails configuration:

version d'ardour (dépot debian strech)
Ardour 4.7.0
"Cluster and Eno"
(built from revision 1:4.7~dfsg-1)
Intel 64-bit

version calf ( dépot jessie backport )
calf-plugins 0.0.60-1~bpo8+1

ma distrib : j'utilise lxde-debian

Example à reproduire :

Pour que ca crash : inserer Calf Deesser, ca crash avec le message d'erreur suivant dans le terminal :

ardour-4.7.0: lv2gui.cpp :313 : void* gui_instantiate(const _LV2UI_Descriptor*, const char*, const char*, LV2UI_Write_Function, LV2UI_Controller, void**, const LV2_Feature* const*): l'assertion « xml » a échoué.
Abandon


Impossible d'ouvrir l'interface : inserer Calf Crusher , le message d'erreur suivant apparait dans le termainal à chaque fois que je tente d'ouvrir l'interface :
suil error: Failed to instantiate UI <http://calf.sourceforge.net/plugins/gui/gtk2-gui> [^] in /usr/lib/lv2/calf.lv2/calflv2gui.so


Ce que j'ai déjà tenté

j'ai essayé de compiler ardour 4.4 qui est la plus proche d'une version que je savais fonctionnel avec calf : j'ai plus de crash, mais l'interface du plugin reste impossible à ouvrir.

J'ai aussi essayé la version de calf dans le dépôt stable ainsi que la dernière version git : aucun changement.

Supposition

ça viendrais pas d'une lib des fois ?

La libxml++2.6-2 ?

Je suis plutôt sous debian stable mais avec les dépôts de kxstudio et j'utilise la version cal-plugins-git.
J'ai la même révision que toi et ça marche pareil avec ardour 5 compilé depuis le git RAS

oto utilisateur non connecté
Bonjour,
ça marche bien sur mon système, Debian stable/testing-Ardour 4.7.
Au revoir
oto

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

bluedid29, 04:28, sam. 18 Nov 2017: Bon samedi musical ! :-) Je sens qu'aujourd'hui il va faire beau ;)
sub26nico, 20:38, ven. 17 Nov 2017: Salut et bienvenue à caline10mao :-)
sub26nico, 18:33, jeu. 16 Nov 2017: Salut et bienvenue à BlackVelvet :-)
sub26nico, 13:47, jeu. 16 Nov 2017: Salut et bienvenue à RnoxMadTan :-)
sub26nico, 23:32, mer. 15 Nov 2017: Salut et bienvenue à niconico :-)
sub26nico, 23:53, mar. 14 Nov 2017: Salut et bienvenue à jpcima :-)
olinuxx, 17:25, dim. 12 Nov 2017: Bonjour et bienvenue à loik56 :-)
sub26nico, 14:52, dim. 12 Nov 2017: Salut et bienvenue à NahMecl :-)
sub26nico, 01:23, dim. 12 Nov 2017: Salut et bienvenue à pitoufo3 :-)
olinuxx, 18:47, sam. 11 Nov 2017: bonjour et bienvenue à jmtrivial et à pacorabano :-)
sub26nico, 09:20, sam. 11 Nov 2017: Salut et bienvenue à sincosta et SamanTortega :-)
bluedid29, 00:04, sam. 11 Nov 2017: Merci m2v2 ;)