Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié Ardour

> Forums de discussion > 3 - Forum dédié Ardour > impossible de compiler ardour 4
Dernier post

impossible de compiler ardour 4

zebassprophet utilisateur non connecté
hello je dois avoir une depedance qui deconne
si vous pouvez m'eclairer c'est cook

bye
Checking for 'jack' >= 0.121.0                       : not found 
The configuration failed
(complete log in /home/zebassprophet/ardour4/build/config.log)
zebassprophet@MusicMachine:~/ardour4$ ^C


ycollet utilisateur non connecté France
Question stupide: jack-devel est installé ?

zebassprophet utilisateur non connecté
comment je peux verifier ca?

ycollet utilisateur non connecté France
Quelle distribution tu utilises ? Debian ? Fedora ?

olinuxx utilisateur non connecté France
libjack-dev ou libjack-jackd2-dev sous debian et dérivées.

Questions de curiosité zebassprophet :

1) pourquoi vouloir compiler un Ardour toi même ?
2) et pourquoi une version 4 alors qu'on en est à la 5.3 ?

Aide : Ardour 4 Compilation.

zebassprophet utilisateur non connecté
compiler moi meme : parce qu'il y'a un tuto sur ce site et qu'a un moment pour avoir un ardour correct la seule solution etait la compilation
(ou le paiement mais je fais deja mes dons ;))
5.3 : euh bah j'en savais rien :-/ j'ai pas touché linux depuis 3 mois et je me suis pas tenu au courant
je voulais juste un truc qui marche pour la gamejam

ardour 4 compilation jke l'ai suivit a la lettre mais j'ai eu une couille en chemin

Citation :
Ce tutoriel est basé sur la branche master du git de ardour.org


Je ne l'ai pas écrit assez gros sans doute .

La branche master signifie qu'actuellement ardour est 5.3.

La commande ./waf configure doit te dire ce qu'il y a ou qu'il n'y a pas.-- Donc retourne ici le contenu de ton terminal ...-- et voir la nouvelle version Ardour 5 compilation

EDIT verifie comme te disait ycollet que la libjack-dev est bien en place. Toute les librairies de développement ne sont pas forcément installées. Et le tuto étant basé sur debian je n'utilise plus ubuntu depuis ... un bon moment verifie donc les lib et n'hésite pas à mettre à jour le tuto pour ubuntu ....

olinuxx utilisateur non connecté France
@utilisateur_anonyme, le tuto en question dit :
git clone git://git.ardour.org/ardour/ardour.git ardour4

Ceci peut laisser à croire que d'une manière ou une autre, cela va installer ardour4. Je propose :
1) de remplacer ce "ardour 4"
2) de mettre une grosse note en haut de la page qui dit que ce tuto est obsolète et qui redirige grâce à un lien vers la page de compilation d'Ardour 5


zebassprophet écrit :
compiler moi meme : parce qu'il y'a un tuto sur ce site et qu'a un moment pour avoir un ardour correct la seule solution etait la compilation
(ou le paiement mais je fais deja mes dons ;))
5.3 : euh bah j'en savais rien :-/ j'ai pas touché linux depuis 3 mois et je me suis pas tenu au courant
je voulais juste un truc qui marche pour la gamejam


Mmmm, c'est un peu casse gueule ça mais pourquoi pas. À ta place, j'installerai un Ardour 5.3 déjà empaqueté. Ça doit bien se trouver pour ubuntu j'imagine.


zebassprophet écrit :
ardour 4 compilation jke l'ai suivit a la lettre mais j'ai eu une couille en chemin

Tu as dû oublié la bibliothèque de développement de JACK : libjack-dev ou libjack-jackd2-dev.

Note qu'à ce stade, je te conseille également de suivre la page de compilation d'ardour 5 si tu veux absolument le compiler toi même.

les deux tutos sont rectifiés.

Citation :
Mmmm, c'est un peu casse gueule ça mais pourquoi pas. À ta place, j'installerai un Ardour 5.3 déjà empaqueté. Ça doit bien se trouver pour ubuntu j'imagine.


Aucune raison que ce soit plus casse gueule qu'autre chose sauf si les libs ne sont pas en place. Pour ubuntu ça m'étonnerai qu'elle y soit déja sauf au dépôt de kxstudio mais l'absence des sources laisse à désiré d'autant qu'il me semble que le dépot est du genre non-free.

Mais il a une version en 5.1 dedans

olinuxx utilisateur non connecté France
Super pour les 2 tutos de compilation.

La compilation de logiciel pour un utilisateur c'est casse-gueule car, bien que ce soit un truc intéressant et qui puisse être fonctionnel si on prend des tas de précautions, ça ne permet pas de maintenir un système propre sur la longueur.

Bref, zebassprophet je te conseille de te trouver un paquet tout fait. À moins que tu n'aies envie de te geeker la compilation, mais là, si tu as envie, c'est autre chose :-)

zebassprophet utilisateur non connecté
hello vous battez opas j'ai finit par prendre un paquet ;)

mais entre le site qui plante et internet qui deconne la ou je suis, c'est l'enfer :-D

je mettrais en 5.3 a mon retour ;)

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 11:11, ven. 20 Oct 2017: bonjour et bienvenue à Burnus_1er et Upal :-)
sub26nico, 21:08, jeu. 19 Oct 2017: salut et bienvenue à rosjjim :-)
olinuxx, 15:28, mer. 18 Oct 2017: bonjour et bienvenue à Gopherlechien :-)
olinuxx, 08:46, mer. 18 Oct 2017: @Respire : contacte moi à l'adresse info HATTE linuxmao POINGT org
sub26nico, 23:46, mar. 17 Oct 2017: Salut et bienvenue à Fonky62 :-)
Pascal, 21:03, mar. 17 Oct 2017: Je crois qu'on peut y aller àdonf maintenant ;)
Pascal, 21:02, mar. 17 Oct 2017: avec un coreI5 on peut faire ca sans soucis :-) crash test ben pas de crash ! renoise + ardour + reaper + bitwig + fusion + lightworks + resolve. j'ai pas réussi a planter le PC !!!!
Pascal, 21:02, mar. 17 Oct 2017: Merci sans doute à Apple qui tourne en rond...
Pascal, 21:01, mar. 17 Oct 2017: Pendant des années Linux en MAO vidéo c'était un peu la galère... et puis...
olinuxx, 18:36, mar. 17 Oct 2017: bonjour et bienvenue à Respire :-)
bluedid29, 14:28, mar. 17 Oct 2017: Perso je suis passé (au moins en MAO) sur l'excellente distribution Debian Librazik réalisé par le talentueux olinuxx ! :-)
bluedid29, 23:06, lun. 16 Oct 2017: Voilà, je ne fais que relayer l'info... ;) Inscription ici : /