Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Le home-studio, les instruments et le DIY

> Forums de discussion > 3 - Le home-studio, les instruments et le DIY > [Résolu] Audacity, enregistrement, latence et.. craquements
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[Résolu] Audacity, enregistrement, latence et.. craquements

Roto utilisateur non connecté France
Salut,

J'ai des soucis d'enregistrement avec Audacity.

Je m'explique : Le but est pour moi de m'enregistrer (guitare) sur un backingtrack mp3, d'y ajouter des effets ou pas, et d'exporter le tout en mp3.

Audacity correspond bien à cette demande.

j'ai Jack qui est démarré, le logiciel de simulation d'ampli "Guitarix" fonctionnel, Audacity également et ma guitare branchée sur ma carte son USB.

Mon problème vient des bruits de craquements qui se mêlent à mon enregistrement.

Ces craquements surviennent lorsque j'essaie de corriger la latence dans le menu préférence/enregistrement. Je met une latence négative (-53 dans mon cas) et c'est à partir de là que mes problèmes de craquements surviennent, enfin je crois frown.

En tout cas, quand je met zéro comme latence, je n'ai plus de craquements (mais j'ai un décalage ! evil)

Voilà, si vous avez une idée ?

Je suis en train d'essayer Ardour 5.3.5 mais je suis pas familiarisé avec.sad Déjà, j'ai passé du temps juste pour m’apercevoir qu'il n'acceptait pas le mp3 et qu'il fallait convertir en wav mon backingtrack lol

Roto

Le plus simple si ton but est juste d'enregistrer c'est d'utiliser quelque chose comme jack_capture ou qjackrcd et seulement si t'as besoin d'éditer ton fichiers tu utilisera audacity . Ces logiciels sont conçus pour capturer ce qui sort dans tes enceintes via jack.

olinuxx utilisateur non connecté France
Quelle distribution @Roto ?

Roto utilisateur non connecté France
Voilà ma config :

Ordinateur de bureau
° LinuxMint 18 Cinnamon 64 bits, noyau : 4.4.0-36-generic
° Asus P5K, Intel core 2 Duo E6750 2.66GHz, Mém vive 4 Go, Nvidia GeForce GTS 450
° Multimédia : SB XFI extreme audio (PCI) - Focusrite 2i2 (USB) - Clavier midi AKay LPK 25 (USB) - Caméra USB Logitech (USB)L

Les dépôts de KXstudio ont été ajoutés
Pulseaudio est configuré sur ma SB XFI et Jack sur la Focusrite 2i2

En fait ce n'est pas que "un enregistrement" mais un mixage du backingtrack (accompagnement) et de mon enregistrement (solo).
Eventuellement je rajoute des effets (amplification, reverb, chorus etc) si je ne me sert pas de guitarix.

sub26nico utilisateur connecté France
Roto écrit :
4.4.0-36-generic


Est ce que les problèmes de craquements et de latence ne viendraient pas de ça,
un noyau basse latence devrait résoudre les problèmes.

Roto utilisateur non connecté France
Sub26nic écrit :
Est ce que les problèmes de craquements et de latence ne viendraient pas de ça,
un noyau basse latence devrait résoudre les problèmes.


C'est possible mais comment changer de noyau ? Evidemment je pourrais changer de distri et prendre une distri orienté MAO mais je perdrais alors les avantages et conforts de ma LinuxMint. frown

sub26nico utilisateur connecté France
2 solutions pour ça, à confirmer par des utilisateurs plus expérimentés et expérimentateurs que moi :

- il est peut être possible d'installer via synaptic un noyau basse latence si il existe pour cette distro,
si c'est le cas, ça devrait être assez simple. Tapes linux-image et/ou linux-headers dans Synaptic, et vois si il te propose
quelquechose comme linux-image-x.x.x-x(les x remplace des chiffres en fonction de la version du noyau) avec une anotation
low latency (ll) ou basse latence (bl ) si il y a une traduction françouze.

- soit tu le compiles toi même, c'est plus technique, mais certains le font. Des tutos existent sur cette manip',
certains membres pourront également te filer un coup de main.

Roto utilisateur non connecté France
Oui, apparemment en faisant une recherche sur latency dans synaptic, j'ai le choix. mais lequel prendre ?

Image

sub26nico utilisateur connecté France
là, je vais laissé la main, ne connaissant pas Mint, mais après une recherche sur les forums de Mint, ici

https://forums.linuxmint.com/viewtopic.php?f=90&t=224197&p=1181569&hilit=kernel+low+latency#p1181567

on peut lire ça

Citation :
For a 3.19 low latency kernel series install package linux-lowlatency-lts-vivid
For a 4.2 low latency kernel series install package linux-lowlatency-lts-wily
For a 4.4 low latency kernel series install package linux-lowlatency-lts-xenial

Le truc, c'est que cette réponse s'appliquait à un utilisateur de linuxmint17..et que ton synaptic indique un noyau 4.4
pour les 3 (vivid, wily et xenial).

Attends peut être d'autres réponses ici, on ne sait jamais..

Citation :
Les dépôts de KXstudio ont été ajoutés


Commence par désactiver les dépôts de kxstudio et vois ce qu'il reste après avoir recharger la liste.

Roto utilisateur non connecté France
utilisateur_anonyme écrit :
Commence par désactiver les dépôts de kxstudio et vois ce qu'il reste après avoir recharger la liste.


Bon et bien j'ai plus que des noyaux "Généric" sad

Et si j'installe un noyau low latency de KXstudio ? cà va foutre le bordel sur mon PC ? c'est quoi le risque ?

Roto utilisateur non connecté France
Bon finalement j'ai installé 4.4.0-36-lowlatency du dépôt KXstudio à la place de 4.4.0-36-Généric

Apparemment linux Mint digère bien ce nouveau noyau...A suivre mrgreen

J'ai pu passer du coup, dans les paramètres de QJackctl, de la valeur d’échantillonnage de 48000 à 96000 sans notification de XRUNS supplémentaires biggrin
Mon temps de latence est tombé de 53 ms à 23 ms biggrin

Par contre, Audacity fait toujours des craquements... c'est un peu aléatoire cette histoire, je modifie les paramètres (qualité d'enregistrement, latence, etc) les craquements n'y sont plus mais réapparaissent une session plus tard evil sur un nouvel enregistrement

En tout cas merci Sub26nico, pour ton idée de passage à un noyau lowlatency.

Roto

sub26nico utilisateur connecté France
De rien!
Penses à refaire tes réglages dans Audacity, remets les paramètres comme ils étaient avant,
et dans Qjackctl, tu peux faire les réglages suivants pour tester : fréquences d'échantillonnage 44100kHz ou 48000kHz,
et dans Echantillons/période tu mets à 512, ou 256 voir moins si processeur tient le choc.
Ta latence devrait devenir plus confortable.
Penses à mettre un résolu dans le titre en éditant ton premier message, si tout est résolu pour toi.

sub26nico utilisateur connecté France
@Roto:
C'est fonctionnel? on peut fermer le fil si c'est bon pour toi?

Roto utilisateur non connecté France
Salut Sub26nico,

Le problème n'est pas vraiment résolu, mais comme il n'y a pas de nouvelles pistes sur le sujet tu peux clore le fil, pas de soucis.

Les paramètres (fréquence d'échantillonage, qualité d'enregistrement etc) ont de l'influence sur ces petits craquements, mais c'est assez aléatoire. Je m'explique : les craquements peuvent réapparaître sur une session alors que lors de celle précédente, avec les mêmes paramètres, ils n'y étaient pas evil.

Il me semble qu'il y a du mieux depuis que j'ai mis un noyau lowlatency.

Voilà,

Roto

sub26nico utilisateur connecté France
Si ce n'est pas encore résolu, on peut attendre un peu, on trouvera peut être des solutions.

sub26nico utilisateur connecté France
Est ce que le problème se reproduit avec un autre logiciel (Ardour, Qtractor ou autres)?

allany utilisateur non connecté
Peux-tu poster le résultat de :
lsmod | grep snd
Une idée. A voir...
Pas trop normal, avec un lowlatency (et ta Scarlett, je suppose), de pas descendre sous 23 ms.
A+

Roto utilisateur non connecté France
Salut,

Sub26nico écrit :
Est ce que le problème se reproduit avec un autre logiciel (Ardour, Qtractor ou autres)?


Apparemment non, je n'ai le problème qu'avec audacity.

Voilà la fenêtre de cadence une fois lancé :

Image Image Image

Allany écrit :
Peux-tu poster le résultat de :

lsmod | grep snd

Une idée. A voir...
Pas trop normal, avec un lowlatency (et ta Scarlett, je suppose), de pas descendre sous 23 ms.
A+


Et voilà

lsmod | grep snd
snd_hda_codec_hdmi     53248  4
snd_usb_audio         176128  5
snd_usbmidi_lib        36864  1 snd_usb_audio
snd_ca0106             45056  2
snd_hda_intel          40960  1
snd_hda_codec         135168  2 snd_hda_codec_hdmi,snd_hda_intel
snd_ac97_codec        131072  1 snd_ca0106
snd_hda_core           69632  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
ac97_bus               16384  1 snd_ac97_codec
snd_pcm               106496  9 snd_usb_audio,snd_ac97_codec,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_ca0106,snd_hda_core
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  3 snd_usbmidi_lib,snd_ca0106,snd_seq_midi
snd_seq                69632  2 snd_seq_midi_event,snd_seq_midi
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_pcm,snd_seq
snd                    81920  27 snd_usb_audio,snd_ac97_codec,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_ca0106
soundcore              16384  1 snd


A @

sub26nico utilisateur connecté France
Juste comme ça, essayes dans Cadence, avec 'hardware Aliases' décocher pour voir ce que ça donne(dans l'onglet driver).
Après à 96Khz comme réglage, tu tires sur le processeur, mais dans ce cas là ça devrait aussi
le faire sur les autres logiciels.
Tu ne nous a pas renseigné quelle version d'Audacity?

allany utilisateur non connecté
Je vois donc que ton système a chargé, pour piloter l'audio, le module snd-usb-audio.
La carte ne dispose donc pas d'un driver spécifique.

J'ai un peu de mal à réunir mes sources mais je lis ici , par exemple :
"Most stereo devices will work out of the box (unlike multichannel devices), but often not with settings above 48kHz/16bits."
Dans mes souvenirs, c'était même 44,1khz/16 bits, rien de plus, pour le générique snd-usb-audio.

Je me disais donc que les réglages d'échantillonnage, dans jackd, devraient peut-être se conformer à ces limitations ?
Ceci dit, le fait que ça fonctionne sans à-coups avec d'autres softs qu'audacity ne plaide pas en faveur de mon hypothèse...

Néanmoins, en phase de tests, il est préférable de ne pousser les réglages de jackd qu'une fois que son fonctionnement à échantillonnage mini (16/44.1) sera acquis.

Désolé pour le détour cool, à+

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]

sub26nico

Mégaphone [Afficher / Cacher]

olinuxx, 15:28, mer. 18 Oct 2017: bonjour et bienvenue à Gopherlechien :-)
olinuxx, 08:46, mer. 18 Oct 2017: @Respire : contacte moi à l'adresse info HATTE linuxmao POINGT org
sub26nico, 23:46, mar. 17 Oct 2017: Salut et bienvenue à Fonky62 :-)
Pascal, 21:03, mar. 17 Oct 2017: Je crois qu'on peut y aller àdonf maintenant ;)
Pascal, 21:02, mar. 17 Oct 2017: avec un coreI5 on peut faire ca sans soucis :-) crash test ben pas de crash ! renoise + ardour + reaper + bitwig + fusion + lightworks + resolve. j'ai pas réussi a planter le PC !!!!
Pascal, 21:02, mar. 17 Oct 2017: Merci sans doute à Apple qui tourne en rond...
Pascal, 21:01, mar. 17 Oct 2017: Pendant des années Linux en MAO vidéo c'était un peu la galère... et puis...
olinuxx, 18:36, mar. 17 Oct 2017: bonjour et bienvenue à Respire :-)
bluedid29, 14:28, mar. 17 Oct 2017: Perso je suis passé (au moins en MAO) sur l'excellente distribution Debian Librazik réalisé par le talentueux olinuxx ! :-)
bluedid29, 23:06, lun. 16 Oct 2017: Voilà, je ne fais que relayer l'info... ;) Inscription ici : /
bluedid29, 23:05, lun. 16 Oct 2017: Hello ! Ubuntu-fr organise une ubuntu party et recherche à Paris à la cité des sciences et de l'industrie (25 et 26 nov.) des personnes qui pourraient y proposer une conférence, un atelier
sub26nico, 22:43, lun. 16 Oct 2017: Salut et bienvenue à leclar