Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > Carte son disparue du menu 'son'[Résolu]
Dernier post

Carte son disparue du menu 'son'[Résolu]

sub26nico utilisateur non connecté France
Salut à vous,
J'ai un petit problème que je n'arrive pas à résoudre
malgré plusieurs manips' vues ici et là sur les forums d'Ubuntu.
Hier, en trifouillant dans le menu 'son' d'une Ubuntu 14.04,
j'ai mis comme périphérique de sortie ma carte son interne,
du même coup, ma carte usb a disparu du menu (en sortie uniquement).
Elle est toujours activé comme périphérique d'entrée, mais n'apparait
plus dans les sorties possibles, elle est par contre
bien détectée par le système, mais pas moyen de sortir du son,
puisque le menu ne la propose plus.

Une idée?
Je penche pour un problème de l'application car le système la reconnait,
et que j'ai du son en sortie par la carte intégrée.

Jack n'est pas installé car je me sers de cette distro
uniquement en multimédia/taches quotidiennes.

jams utilisateur non connecté
Citation :
Hier, en trifouillant dans le menu 'son' d'une Ubuntu 14.04,

Je pense que le menu en question serait pavucontrol ? Si tu la choisi alors elle devient celle utilisée par le système.
Essaie de revenir sur la carte son intégrée pour voir si elle réaparait.

sub26nico utilisateur non connecté France
salut Jams,
merci pour la réponse.
Je regarde ça ce soir car je ne suis pas chez moi.
J'ai simplement cliquer sur l'icone dans la barre du haut sur Ubuntu.
Je suis déjà sur la carte son intégrée, je n'ai plus le choix qu'entre la sortie spdif ou
ligne, ma jamlab n'apparait plus.

sub26nico utilisateur non connecté France
Pavu control n'est pas installé. Ma carte son usb (jamlab) n'a pas de fenetre de réglage,
alsamixer ne peut donc pas m'aider non plus.

sub26nico utilisateur non connecté France
J'ai installé pavucontrol, même constat, il ne propose pas ma jamlab comme périphérique de sortie.
J'ai switché sur LibraZik sur le même pc, la carte fonctionne, donc le problème ne viendait pas de la carte.
Comment faire en sorte que les applis de gestion du son me propose à nouveau ma carte USB?
Problème Alsa?PulseAudio?

allany utilisateur non connecté
Hello !

Est-ce que :
aplay -l
liste bien les E/S de ta jamlab ?
Et est-ce que le "menu" dont tu parles c'est l'applet standard de volume (clic droit/préférences) ?
As-tu essayé toutes les façons de booter, par rapport à la carte (allumée, éteinte, connectée à chaud, à froid, ...) ?

A+

sub26nico utilisateur non connecté France
Salut allany,
oui j'ai essayé de démarrer avec la carte non branché,
débrancher/rebrancher la carte à chaud, aucun changements.

Voici le retour de commande

**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: SB [HDA ATI SB], périphérique 0: ALC887-VD Analog [ALC887-VD Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: SB [HDA ATI SB], périphérique 1: ALC887-VD Digital [ALC887-VD Digital]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: JamLab [JamLab], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


allany utilisateur non connecté
... ouaip, normal !
Ce menu, alors, tu y accèdes comment ?
Tu es bien sous unity ?
A+

sub26nico utilisateur non connecté France
allany écrit :
Ce menu, alors, tu y accèdes comment ?


Je clique droit sur l'icône son du bureau.Sinon 'Paramètres systèmes','Son',

Citation :
Tu es bien sous unity ?


oui je suis sur Unity (ubuntu 14.04 de base,
j'ai pas installé d'autres environnements)

Image

Comme tu peux le constater, la JamLab n'apparait pas dans la colonne de gauche de
l'onglet 'sortie'. Alors qu'elle y figurait.

Image

Par contre elle est bien là en entrée.

Dans la colonne de droite on peut observer une option 'mode', qui ouvre un menu déroulant.
Ce même menu figurait dans l'onglet sortie, ma JamLab sélectionnée.
C'est en modifiant ce 'menu déroulant' que la carte usb a disparu du menu sortie.

Y aurait il un moyen de réinitialiser/purger le fichier qui enregistre les préférences de cette appli?

allany utilisateur non connecté
En effet. Curieux... eek

Je te demandais ça, pour unity, car sur une Ustudio 14, j'ai aussi un comportement zarbi de l'applet son du bureau... Mais ça n'a rien à voir, je suppose.

Si pavucontrol te propose les mêmes uniques E/S, ça signifierait que le blème serait plutôt au niveau d'alsa ?

As-tu essayé une réinstallation, via synaptic, de tout ce que tu as d'installé comportant la chaîne "alsa" (si ça ne casse pas d'autres choses...) ?
Ce serait peut-être intéressant, dans ce cas, de sauvegarder dans un coin l'état actuel de tes fichiers de config' alsa, puis de comparer avec le contenu de ceux fraîchement installés...

A+

sub26nico utilisateur non connecté France
Non pas encore, mais du coup j'essayerai ce soir ou en fin de semaine, selon mes dispos.
Merci pour l'aide, on se sent moins seul dans ces moments troubles biggrin

allany utilisateur non connecté
T'en prie...
J'y vais aussi un peu à l'aveugle. Sans garantie, donc.
Je crois que c'est inédit d'avoir une carte en "in" et l'autre en "out".
Y'a pas très longtemps, on s'est donné du mal pour un des membres qui, lui cherchait à obtenir ce résultat... cool
Bon courage, à+

olinuxx utilisateur non connecté France
allany écrit :
Je crois que c'est inédit d'avoir une carte en "in" et l'autre en "out".


Pas tant que ça :

C'est un des trucs que permet (facilement) pulseaudio par rapport à ALSA,... et une des nombreuses raisons (manque au niveau ALSA) de l'apparition de pulseaudio.

À noter que la même chose est réalisable avec JACK et les "alsa_in" et "alsa_out" aussi. Voir : jack_alsa_io.

sub26nico utilisateur non connecté France
Ouf, c'est résolu!
Grace à pavucontrol (merci jams pour l'idée),
j'ai pu rétablir la situation.
En fait quand j'ai changé l'option dans le menu sortie, j'ai bloqué la jamlab
à seulement être un périphérique d'entrée, donc elle n'apparaissait plus dans les sorties,
mais il n'y a pas d'options dans l'appli pour changer.
Dans pavucontrol, dans l'onglet 'configuration', ma jamlab est listée mais configurée
comme 'stereo analogique entrée' dans son menu déroulant, parmi lequel figure
'duplex stereo analogique' qui une fois sélectionné, redonne à la carte son son role
en entrée comme en sortie.
Yipikaé !
PS: j'avais au préalable réinstallé tout ce qui touché à ALSA (biblio, fichier de config)
dans Synaptic, ce qui n'avait absolument rien changé.
Si l'appli son du bureau Ubuntu n'est pas très clair ni très complète,
elle n'avait rien à voir dans l'histoire.
Le problème, comme souvent, se situait entre la chaise et le clavier wink.

Merci pour le soutien

allany utilisateur non connecté
Cool !
Tu peux essayer d'installer Qasmixer en applet de tableau de bord.
La mixette est très complète et pas vilaine.
Content que ça marche. Sacré pulseaudio !
Bonne zic, à+

olinuxx utilisateur non connecté France
Note modo-forum : fil de discussion déplacé depuis "1 - Le matériel et les pilotes ALSA, FFADO, ...".


Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

zebassprophet, 10:14, lun. 23 Jan 2017: retour de gamejam, ;) compte rendu sur le site
onirom, 00:25, lun. 23 Jan 2017: hello à tous! merci :-)
olinuxx, 23:53, dim. 22 Jan 2017: bonjour et bienvenue à onirom :-)
Long Sam Silver, 15:19, dim. 22 Jan 2017: @ zebassprophet [Lien]
olinuxx, 12:52, dim. 22 Jan 2017: bonjour et bienvenue à thecakeisaspy, à Dubrasseix, et à AMoMusic :-)
zebassprophet, 16:25, sam. 21 Jan 2017: yo je cherche nu taiko en sf2 quequ'un a ca?
tenryu, 11:40, sam. 21 Jan 2017: @zebassprophet: ça va être une tuerie ;-)
zebassprophet, 03:06, sam. 21 Jan 2017: yo tenryu, j'ai finit ta ligne de basse j'etait prti sur nu truc a moi puis j'ai vu ta part je t'envoi la piste demain (3 herue du mat a la gamejam, ca c'est du devouement. je go dodo à a demain ;)
xaccrocheur, 01:14, sam. 21 Jan 2017: Hiya! Présentation d'un nouveau plugin de batterie: [Lien]
zebassprophet, 21:52, ven. 20 Jan 2017: je vais essayer de voir ça.
olinuxx, 21:43, ven. 20 Jan 2017: T'as un lien zebassprophet ?
zebassprophet, 20:45, ven. 20 Jan 2017: live from the gamejam les enfants ;)