Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié Ardour

> Forums de discussion > 3 - Forum dédié Ardour > [Résolu] _ Ardour 5 _ Erreur de Compilation
Dernier post

[Résolu] _ Ardour 5 _ Erreur de Compilation

romrom78 utilisateur non connecté France
Bonjour,

Je pense qu'il y a une erreur ou une lacune sur cette page-ci.
Je suis scrupuleusement les étapes indiquées et voici ce que j'obtiens.

romainhelo@romainhelo-All-Series:~$ sudo apt-get install git-core
[sudo] Mot de passe de romainhelo : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
git-core is already the newest version (1:2.7.4-0ubuntu1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.4.0-34 linux-headers-4.4.0-34-generic
  linux-image-4.4.0-34-generic linux-image-extra-4.4.0-34-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 4 non mis à jour.
romainhelo@romainhelo-All-Series:~$ sudo -i
root@romainhelo-All-Series:~# apt-get install autotools-dev cdbs dh-buildinfo devscripts libaubio-dev libboost-dev libcppunit-dev libcurl3 libcurl4-gnutls-dev libfftw3-dev libglibmm-2.4-dev  libjack-jackd2-dev liblilv-dev liblo-dev liblrdf0-dev libraptor1-dev librubberband-dev libsamplerate0-dev libsratom-dev libserd-dev libsndfile1-dev libsord-dev libsuil-dev libtag1-dev libcwiid-dev libxml2-dev itstool vamp-plugin-sdk
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
autotools-dev is already the newest version (20150820.1).
cdbs is already the newest version (0.4.130ubuntu2).
devscripts is already the newest version (2.16.2ubuntu3).
libboost-dev is already the newest version (1.58.0.1ubuntu1).
libfftw3-dev is already the newest version (3.3.4-2ubuntu1).
libglibmm-2.4-dev is already the newest version (2.46.3-1).
libjack-jackd2-dev is already the newest version (1.9.10+20150825git1ed50c92~dfsg-1ubuntu1).
libsamplerate0-dev is already the newest version (0.1.8-8).
libsndfile1-dev is already the newest version (1.0.25-10).
libtag1-dev is already the newest version (1.9.1-2.4ubuntu1).
dh-buildinfo is already the newest version (0.11).
libaubio-dev is already the newest version (0.4.1-2build4).
libcppunit-dev is already the newest version (1.13.2-2.1).
libcwiid-dev is already the newest version (0.6.00+svn201-3.2).
liblilv-dev is already the newest version (0.22.0~dfsg0-1).
liblo-dev is already the newest version (0.28-5).
liblrdf0-dev is already the newest version (0.4.0-7).
libraptor1-dev is already the newest version (1.4.21-11).
librubberband-dev is already the newest version (1.8.1-6ubuntu2).
libserd-dev is already the newest version (0.22.0~dfsg0-2).
libserd-dev passé en « installé manuellement ».
libsord-dev is already the newest version (0.14.0~dfsg0-1).
libsord-dev passé en « installé manuellement ».
libsratom-dev is already the newest version (0.4.6~dfsg0-1).
libsratom-dev passé en « installé manuellement ».
libsuil-dev is already the newest version (0.8.2~dfsg0-1).
vamp-plugin-sdk is already the newest version (2.6~repack0-2).
libcurl3 is already the newest version (7.47.0-1ubuntu2.1).
libcurl4-gnutls-dev is already the newest version (7.47.0-1ubuntu2.1).
libxml2-dev is already the newest version (2.9.3+dfsg1-1ubuntu0.1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.4.0-34 linux-headers-4.4.0-34-generic
  linux-image-4.4.0-34-generic linux-image-extra-4.4.0-34-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les NOUVEAUX paquets suivants seront installés :
  itstool
0 mis à jour, 1 nouvellement installés, 0 à enlever et 4 non mis à jour.
Il est nécessaire de prendre 19,9 ko dans les archives.
Après cette opération, 116 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Réception de:1 http://fr.archive.ubuntu.com/ubuntu xenial/universe amd64 itstool all 2.0.2-3 [19,9 kB]
19,9 ko réceptionnés en 0s (927 ko/s)
Sélection du paquet itstool précédemment désélectionné.
(Lecture de la base de données... 1017675 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../itstool_2.0.2-3_all.deb ...
Dépaquetage de itstool (2.0.2-3) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Paramétrage de itstool (2.0.2-3) ...
root@romainhelo-All-Series:~# git clone git://git.ardour.org/ardour/ardour.git
Clonage dans 'ardour'...
remote: Counting objects: 220071, done.
remote: Compressing objects: 100% (38325/38325), done.
remote: Total 220071 (delta 182348), reused 218394 (delta 180944)
Réception d'objets: 100% (220071/220071), 157.20 MiB | 10.60 MiB/s, fait.
Résolution des deltas: 100% (182348/182348), fait.
Vérification de la connectivité... fait.
root@romainhelo-All-Series:~# cd ~/ardour
root@romainhelo-All-Series:~/ardour# ./waf configure --freedesktop --lxvst  --lv2 --prefix=/usr/ --no-phone-home --optimize --with-backend=alsa,jack,dummy
Setting top to                           : /root/ardour 
Setting out to                           : /root/ardour/build 
Checking for 'gcc' (c compiler)          : /usr/bin/gcc 
Checking for 'g++' (c++ compiler)        : /usr/bin/g++ 

Global Configuration 
 * Install prefix                                    : /usr 
 * Debuggable build                                  : False 
 * Build documentation                               : False 

Ardour Configuration 
 * Will build against private GTK dependency stack   : no 
 * Will rely on libintl built into libc              : yes 
 * Will build against private Ardour dependency stack : no 
Checking for function dlopen                         : yes 
Checking for boost library >= 1.39                   : ok 
Checking for program pkg-config                      : /usr/bin/pkg-config 
Checking for 'alsa'                                  : yes 
Checking for 'glib-2.0' >= 2.28                      : yes 
Checking for 'gthread-2.0' >= 2.2                    : yes 
Checking for 'glibmm-2.4' >= 2.32.0                  : yes 
Checking for 'sndfile' >= 1.0.18                     : yes 
Checking for 'giomm-2.4' >= 2.2                      : yes 
Checking for 'libcurl' >= 7.0.0                      : yes 
Checking for 'libarchive' >= 3.0.0                   : not found 
The configuration failed
(complete log in /root/ardour/build/config.log)
root@romainhelo-All-Series:~/ardour#


Quelqu'un a t-il une idée sur ce qui cloche ?

Merci

romrom78 utilisateur non connecté France
Problème résolu, il suffisait en fait d'installer comme indiqué dans le terminal le paquet "libarchive".
Depuis, j'obtiens pour la commande ./waf configure le résultat
'configure' finished successfully (2.968s)


Du coup, je poursuis mon installation ...

olinuxx utilisateur non connecté France
Bien joué pour l'auto dépannage et merci pour le [résolu] !

Si tu veux, tu peux également contribuer en ajoutant le fait qu'il faille le paquet libarchive dans la page ardour 5 compilation.

romrom78 utilisateur non connecté France
Salut olinuxx,

voilà un long moment que je ne suis pas passé par ici !
Cool de te retrouver ;-)

Je viens donc d'apporter ma petite contribution en l'ajoutant dans la rubrique Commentaires.
J'espère que c'est là où il faut mettre ...

À bientôt !

olinuxx utilisateur non connecté France
Super, elle a déjà été intégrée à la page, ça a été vite !
Du coup, je supprime ton commentaire si ça ne t'embête pas.
a+

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 20:37, mar. 25 Apr 2017: bonjour et bienvenue à mojokeeoper :-)
tenryu, 16:22, mar. 25 Apr 2017: @zebassprophet: un Big up pour toi !
zebassprophet, 15:07, mar. 25 Apr 2017: nan, cremaillere en France, le luxo c'est trop cher :-D
Nolwen, 14:42, mar. 25 Apr 2017: @zebassprophet : Félicitations !!! Crémaillère au Luxembourg de prévu, du coup !
sub26nico, 13:35, mar. 25 Apr 2017: Merci et félicitations ZBP!
zebassprophet, 13:28, mar. 25 Apr 2017: et qui c'est qui a eu le poste de prof de gratte au luxembourg??? FUCK YEAH !!! Moi :-D
zebassprophet, 13:27, mar. 25 Apr 2017: @sub26nico, profite bien ;)
sub26nico, 12:39, mar. 25 Apr 2017: Salut à tous des plages de Stes Marie de la mer :-)
sub26nico, 08:11, mar. 25 Apr 2017: Nouvelle version de Rosegarden, [Lien]
sub26nico, 21:12, lun. 24 Apr 2017: @Nolwen! Y'a besoin de s'inscrire si on veut assister aux conférences ? Je croyais que c'était pour y participer..
Nolwen, 20:43, lun. 24 Apr 2017: @sub26nico : Et oui, "La participation à LAC2017 est gratuite (mais nécessite une inscription)." dixit leur site !! Un peu comme les RMLL, il me semble.
olinuxx, 19:54, lun. 24 Apr 2017: bonjour et bienvenue à MOSY :-)