Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

Dernier post

[RESOLU]installation de impro-visor

calixtus06 Articles : 532 utilisateur non connecté
Salut à tous,

J'ai téléchargé sur le site officiel la dernière version de impro-visor, puis java 8 puis le fichier sh rendu exécutable.

J'ouvre ensuite le dossier impro-visor , tombe sur un fichier jar qu'on me propose d'ouvrir avec java 8 run time.

Réponse : Warning: Error: could not generate preferences files

j'appuie sur ok

warning: failure genereting default preference file 'My.prefs'

j'appuie sur ok

warning: Preference melody-channel does not exist

j'appie sur ok et ...plus de fenêtre

Que faire ??

Merci d'avance !!

Nico

allany Articles : 5500 utilisateur non connecté
Salut, Calixtus06 !

Le retour ? cool
Perso, je ne connais pas impro-visor mais je vois qu'olinuxx a rédigé ceci (en 2009...) :
Citation :
Impro-visor nécessite la présence d'un environnement java.
J'ai (olinuxx) le 11 décembre 2009 pour la version 4.09 :
installé par Synaptic (UbuntuStudio 9.10) sun-java6-jre.
installer le script (fichier .sh) d'installation sur le site officiel.
clic droit sur le fichier .sh, Propriétés, Permissions,
cocher : "Autoriser l'exécution du fichier comme un programme"
double-cliquer sur le fichier .sh,
se laisser guider
Je vois que les deux premières opérations ont bien été effectuées (pour du java 8) mais as-tu assuré la gestion des permissions d'exécution ?
Il semble qu'il manque des variables d'environnement mais est-ce java qui les demande ou impro-visor ? A quel moment du lancement ?

A+

olinuxx Articles : 14938 utilisateur non connecté France
Quelle distribution calixtus ?

calixtus06 Articles : 532 utilisateur non connecté
Olinuxx écrit :
Quelle distribution calixtus ?


Bah sur ta librazik !

Allany écrit :
Il semble qu'il manque des variables d'environnement mais est-ce java qui les demande ou impro-visor ? A quel moment du lancement ?


Je ne comprends pas ce que tu appelles "variables d'environnement"

J'ai rendu java 8 executable

Merci à vous deux

olinuxx Articles : 14938 utilisateur non connecté France
calixtus06 écrit :
Bah sur ta librazik !


Je ne pouvais pas le deviner ! Il est toujours utile de rappeler quelle distribution tu utilises lorsque tu fais une demande d'aide.

J'essaierai de suivre ce fil de discussion, mais pour l'instant, j'ai (beaucoup) de pain sur la planche concernant linuxmao pour les prochains jours qui viennent, je ne dispose donc pas de temps pour LibraZiK pour cette période (courte je l'espère).

Bonnes recherches !

calixtus06 Articles : 532 utilisateur non connecté
hello je repassais par là. j'en profite pour faire remonter le fil

olinuxx Articles : 14938 utilisateur non connecté France
T'as refais des essais calixtus06 ?

calixtus06 Articles : 532 utilisateur non connecté
Salut à toi !

Image

Image

Si tu peux m'éclairer

Merci d'avance !!

Nico

olinuxx Articles : 14938 utilisateur non connecté France
Citation :
Si tu peux m'éclairer


J'aimerai bien mais je ne peux point. J'ai essayé aujourd'hui de l'installer, mais j'ai également des erreurs java. Pas les mêmes que les tiennes ceci-dit. On se tient au jus si l'un d'entre nous trouve une solution ?

calixtus06 Articles : 532 utilisateur non connecté
ça roule !

olof Articles : 716 utilisateur non connecté
Je viens d'essayer sur ma ubuntu-studio-yakkety/kxstudio, et à part un gel complet de ma cession gnome à la fin de l'installation, aucun souci, j'ai pu ensuite le lancer sans probleme

à quel moment avez vous ces messages ? à l'installation ou au lancement ?

si c'est à l'installation, quelle version de java utilisez vous ? (moi c'est openjdk-8-jre 8u111-b14-2ubuntu0.16.10.2)

calixtus06 Articles : 532 utilisateur non connecté
Salut Olof !

Pour ma part c'est au lancement que ça pose soucis .

Ma version de java ?

Image

Image

Du coup tu m'as mis le doute

olof Articles : 716 utilisateur non connecté
visiblement pas la 8 ...

calixtus06 Articles : 532 utilisateur non connecté
Salut Olof, je suis retourné chez synaptic, coché les openjdk8. J'imagine qu'il faut que je vire la version 7 ?

Et que je retrouve le mode d'emploi du fichier .sh à rendre exécutable ?

Ok. J'ai suivi le "protocole" de téléchargement et me suis retrouvé chez source forge, impro-visor puis files pour trouver mon .sh. Je le télécharge à nouveau puis vais dans les permissions et le rend exécutable ainsi que ses sous dossiers. Je relance impro-visor et me retrouve avec encore ce genre de message :

Image

Y a t il des permissions à bouger ?

Image

Merci pour ton aide

olof Articles : 716 utilisateur non connecté
Alors voici la suite d'opérations que j'ai réalisées pour ma part :
  • ai d'abord telecharge le fichier zip complet chez sourceforge, l'ai mis dans un repertoire (improvisor) que j'avais créé pour ça, et l'y ai decompacté
  • ai cherché vainement le .sh dans tout ça
  • suis donc retourne sur surceforge explorer l'arborescence, et ai trouve ce .sh que j'ai aussi mis dans le meme repertoire
  • ai rendu ce .sh executabe, puis l'ai lance dans un terminal

cela m'a donné non pas le programme impro-visor, mais son installateur, qui s'est execute sans probleme, mais au la fin à tout bonnement gele mon interface graphique

apres relance, suis parti a la recherche de l'intallation, il avait bien créé un sous repertoire (Impro-Visor8.11) dans mon repertoire dans lequel je trouve entre autre un fichier impro-viso que je peux lancer

as tu aussi telecharge les sources ? (je ne sais pas du tout si c'est necessaire, mais vu que je les avais, pour ma part ...)

as tu vu le programme d'installation s'executer ?

il semble que oui et donc que ce soit le programme impro-visor lui meme que tu n'arrives pas a lancer, puisque tu as les repertoire Impro-Visor8.11 et Impro-Visor8.11files qui sont créés par l'installateur.

mais apparement, tu rends executables des repertoires rolleyes, et comment lances tu impro-visor ?

le lancement se fait en allant dans le repertoire Impro-Visor8.11 et en y lançant le Impro-Visor... celui ci etant déjà par nature un executable.
Je ne comprends donc pas pourquoi tu cherches a rendre quelque chose executabe a ce stade.

le message d'erreur est a considerer de plus pres : il te parle d'unknown source, ne serais tu pas en train de tenter de lancer par java quelque chose qui n'est pas une application java ?

en faisant quelques recherches sur ce message d'erreur, suis tombé sur des personnes qui n'arrivaient plus a lancer certains programmes java apres une mise a jour de java. ils avaient du reinstaller completment leur programme pour que ça fonctionne. ce peut donc etre une autre piste : maintenant que tu as le bon java, effacer tout ce qui concerne improvisor et recommencer toute l'install comme je l'ai faite...

calixtus06 Articles : 532 utilisateur non connecté
Hello, bon j'ai tout repris à zéro et ça fonctionne ou presque. J'ai rentré une grille mais il me lit une grille "autre" ou un accord sur deux. J'ai jeté un coup d'oeil du côté du piano et de son volume: bof j'ai pas obtenu grande différence même en baissant la casserole qui sert de batteur. Le son est bizarre: dans les préférences midi, j'ai mis gervill ( c'est tout ce qui m'était proposé)

Image

En tout cas, merci !!

olof Articles : 716 utilisateur non connecté
moi aussi j'avoue que le son est pas terrible frown il me propose des trucs tres fantaisistes en plus de gervill, du style melange entre carte son interne et clavier midi usb, un gros n'importe quoi, et impossible d'utiliser autre chose que gervill, bon tout ça est à explorer, je pense que je vais surtout regarder du coté d'une exportation de ses resultats vers d'autres programmes capables de gerer les banques de sons correctement ...

mais au moins, l'installation a pu marcher, ravi d'avoir pu etre utile, et merci pour ce programme que je ne connaissais pas :-)

calixtus06 Articles : 532 utilisateur non connecté
TRop TRop TRop bien !! et un grand merci !!

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 21:45, ven. 21 Jun 2019: Bonjour et bienvenue à papis jazz et à Lemania cool
zebassprophet, 11:05, jeu. 20 Jun 2019: yo les enfants je vais envoyer un mp a program lyrique tiens ;)
olinuxx, 02:21, lun. 17 Jun 2019: Bonjour et bienvenue également à madguitar cool
olinuxx, 15:54, dim. 16 Jun 2019: Bonjour et bienvenue à lafissure cool
sub26nico, 23:59, sam. 15 Jun 2019: Salut et bienvenue à ikerino59 :-)
sub26nico, 22:24, jeu. 13 Jun 2019: Salut et bienvenue à rankxerom :-)
Sasaki, 14:49, mer. 12 Jun 2019: Inspirations sportives [Lien]
Nolwen, 17:36, dim. 09 Jun 2019: Sortie de LMMS 1.2.0 ! [Lien]
sub26nico, 11:41, sam. 08 Jun 2019: Salut et bienvenue à dewiweb :-)
sub26nico, 20:26, ven. 07 Jun 2019: Yo Zebassprophet :-)
zebassprophet, 16:21, ven. 07 Jun 2019: yoooooooooooooooo les amis
sub26nico, 21:38, jeu. 06 Jun 2019: Salut et bienvenue à Texas Barbudos :-)