Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post

Tascam US224 / Jack / Ardour4

pierred utilisateur non connecté
Bonjour,

J'ai ressorti du placard ma bonne vieille Tascam.
Je suis sous Ubuntu 16.04.
J'ai pas mal avancé en suivant les différents sujets de ce forum, c'est à dire qu'après pas mal de manip :
-le voyant USB de ma carte s'allume
-c'est confirmé par un "LSUSB", et de surcroît le firmware est chargé.
-us428control la reconnaît
-JackD également, j'ai le même écran que sur les forums

En revanche, quand je lance Ardour, que je choisis les ressources de JACK, impossible d'ouvrir la session et d'aller plus loin...

Pour autant, en faisant d'autres tests, j'arrive bien à démarrer Jack depuis Ardour, mais la sentance est la même.

Je précise que si j'arrête le serveur jack, j'ai un bon gros plantage qui me rappelle windaube, mais sans l'écran bleu (crash bête et méchant, rien ne répond, retour à la case "appuyer sur le bouton reset"...)

J'ai bien cherché à droite à gauche des réponses, sans les trouver sauf un tuto qui explique carrément comment flasher le FPGA mais j'avoue que ça m'a fait un peu peur.

Peut être suis-je passé à coté d'une réponse évidente ? Peut être pas...

Je termine en précisant que mon passage au libre est notamment idéologique, et je suis particulièrement motivé pour la faire marcher sous GNU/Linux, car après avoir mis en doute son intégrité physique, et avoir rebooté un windaube pour vérifier qu'elle fonctionne encore, je me suis aperçu que dans le monde privateur, les réponses de tascam c'est tout simplement : pas supporté sur votre OS, merci de la jeter à la poubelle et d'en racheter une neuve. Merci pour la croissance, désolé pour la planète. Quel scandale...
Au moins sous GNU/Linux, j'ai réussi à allumer le voyant USB. Bon, il y a encore un peu de chemin pour l'utiliser pleinement ;-)

Merci

olinuxx utilisateur non connecté France
Essaies d'utiliser ta carte avec un autre logiciel que Ardour. Ça permettra de voir si le problème vient de ta carte et de sa configuration au niveau du système, ou bien d'Ardour et de sa configuration.

dlb utilisateur non connecté
Bonsoir,

Je viens d'essayer chez moi, à priori ça fonctionne bien. Ma configuration n'est pas tout à fait identique cependant :
- us224 montée sur distribution Debian Jessie "basique"
- ardour version 3.5, paquet debian
- je lance jackd d'abord, via qjackctl, puis ensuite seulement Ardour ; les réglages jackd ressemblent à ça :
Image

...

Avant de lancer ardour, vérifie que jackd est bien lancé avec la us224 ( avec qjackctl, une interface graphique de jackd) puis effectivement essaie avec un "petit" logiciel ; audacious par exemple ( avec jackd coché dans les prefs serveur audio )

pierred utilisateur non connecté
Bonsoir,
merci pour vos retours qui annoncent 2017 sous le signe de la MAO !
Après avoir effectué ma petite procédure de démarrage, j'ai lancé Audacity qui fonctionne en sortie ET en entrée !
C'est déjà un grand pas car impossible à franchir sous windows faute de drivers, et ca me permet de bosser quelques morceaux c'est ce que je voulais. Reste à voir ce que je peux faire pour améliorer la latence.
Cependant, je ne parviens toujours pas à lancer Ardour4...
Merci

olof utilisateur non connecté
lorsque tu dis qu us428control la reconnait, je me pose une question :
as tu avant lancé usx2yloader, ou directement us428control ?
en effet ce dernier ne sert pas à faire reconnaitre la carte son, mais à declarer la carte en tant que controleur midi.

j'ai une tascam us428 pour ma part, et je peux tres bien faire fonctionner jack avec sans lancer us428control.

par contre, je n'ai pas non plus pu faire fonctionner la carte en full duplex avec ardour. la solution que j'ai mise en oeuvre a été d'utiliser celle ci en entree, et la carte son interne en sortie. (apres je suis passé a une autre carte pour l'audio, ne gardant la tascam que pour le midi et en controleur, car sa latence est trop importante pour une utilisation confortable)

comment sont parametrees tes entrees sortie dans qjackctl ?

olinuxx utilisateur non connecté France
Pour info, j'ai ajouté un lien vers ici dans la page Tascam US-224.

pierred utilisateur non connecté
En effet, ça fonctionne (audacity) sans lancer US428control.
Sur la configuration : en entrée j'ai mis hw:USX2Y,0 et en sortie, ma carte son interne sur laquelle sont branchées mes enceintes.
Entre temps je me suis amusé avec Guitarix, ça fonctionne très bien (assez rigolo d'ailleurs, je sens que ça va me causer quelques insomnies...)
J'ai également tenté le tuto pour réduire la latence, sans résultats... 46.4ms...
Cependant, après plusieurs bidouilles et le serveur démarré, pour une raison que j'ignore je suis parvenu à démarrer ardour !!!
Ca fonctionne !
Par contre, pas moyen d'utiliser les controles (play/rec/la molette) de ma tascam. Quelqu'un aurait-il une idée ?
merci

dlb utilisateur non connecté
Pour la latence, j'ai suivi ces explications là :
http://alsa.opensrc.org/Tascam_US-224 , paragraphe "Minimizing latency in JACK".
J'ai créé (en root) le fichier /etc/modprobe.d/modules.conf et placé la ligne magique
options snd-usb-usx2y nrpacks=1

( le fichier modules.conf doit être placé dans /etc/modprobe.d/ sur une Debian Jessie, mais c'est peut-être pas sa place sur une Ubuntu ... à essayer, de toute façon ça ne risque rien )
Puis j'ai redémarré la machine. Dans qjackctl, apparaissent deux nouveaux périphériques, l'un en entrée et l'autre en sortie, "US-X2Y hwdep ..." qui sont censés être super rapides, mais qui ne fonctionnent pas. Pas grave, les périphériques d'entrée et de sortie "ordinaires" de la us224 fonctionnent très bien, et cette fois avec une latence plus acceptable de 5,33 ms.
Image

pierred utilisateur non connecté
Merci.
J'ai fini par trouver la boulette, dans Ubuntu il faut impérativement pour que le fichier soit en ".conf" pour être pris en compte.
Cependant, après avoir rebooté, qjackctl fait bien apparaître un nouveau device "US-X2Y hwdep..." mais lorsque je sélectionne celui ci, impossible de démarrer le serveur jack...

Par ailleurs, j'ai aussi fait le tuto pour essayer de récupérer mes controles (bien pratique quand on épluche un solo de guitare...la guitare à la main) et je ne vois pas apparaître Ardour dans la fenetre de connexions de jack, dans l'onglet "Alsa"...

sub26nico utilisateur non connecté France
Dans Qjackctl, il faut peu être indiqué le nombre d'entrées/sorties, ça permettra de lancer jackd
sans erreur.

Pour Ardour, il est normal qu'il n'apparaisse pas dans le menu 'Alsa',
l'audio d'Ardour se trouve dans le menu 'Audio' et le midi d'Ardour est présent dans l'onglet 'Midi'.

olof utilisateur non connecté
pour pouvoir utiliser les controleurs, là il faut lancer us428control

il faut aussi router les sorties de usControl vers l'entree control et l'entree MMC d'ardour, et inversement, la sortie controleur d'ardour vers l'entree controleur de la tascam
pour cela j'utilise a2jmidid dans un terminal :

a2jmidid -e &


qui me donne acces à ces entrees/sorties midi dans qjackctl (ou claudia pour ma part)

par contre dans ardour il va falloir apprendre à ardour quels sont les messages envoyés par la tascam pour ce qui est des potentiometres de tranches.

bon tout ça ça reste à verifier que c'est pareil pour la us224 que pour ma us428, mais il me semble avoir lu quelque part que oui

dlb utilisateur non connecté
Si les devices "US-X2Y hwdep..." apparaissent, c'est que l'option nrpacks est bien prise en compte, c'est tout bon.
MAIS ces nouveaux devices "US-X2Y hwdep..." ne fonctionnent pas. Il NE FAUT PAS les sélectionner. Tu choisis les devices d'entrées/sorties habituels de la us224, qui eux permettent maintenant une latence de 5,...ms.

pierred utilisateur non connecté
Bonjour,
Merci pour tous vos retours !

Alors, bilan des courses après pas mal de manips : assez mitigé...
-avec l'option kernel qui va bien (snd-usb-usx2y nrpacks=1), j'ai toujours la fameuse carte "US-X2Y hwdep..." qui apparaît. Je ne la sélectionne pas, et j'essaye soit "hw:USX2Y,0", soit "hw:USX2Y" et je parviens à lancer le serveur !
-je connecte les entrées et les sorties, en ayant testé la sortie de ma tascam ET la sortie de ma carte interne
Et j'ai toujours le même résultat : latence de 46.4ms...

A un moment, j'ai mis en doute le chiffre annoncé par qjacktcl mais en jouant j'entends bien que c'est "audible" (par définition...) et donc assez élevé...

Existe-t-il d'autres moyens pour mesurer la latence ?

Je n'ai pas encore testé le midi, à chaque jour suffit sa peine !

Merci !

dlb utilisateur non connecté
La latence se règle en jouant sur les trois paramètres de qjackctl :
- Echantillons/Période
- Fréquence d'échantillonnage
- Périodes/Tampon
Pour obtenir une latence correcte avec ma carte, j'utilise respectivement ces valeurs : 64 - 48000 - 4, cf image jointe dans un message précédent. C'est à l'utilisateur de rentrer ces valeurs, les valeurs par défaut sont volontairement élevés pour permettrent un fonctionnement à coup sûr, mais au détriment d'une latence élevée et gênante. Tu n'as probablement pas encore réglé ces paramètres, tout devrait aller bien mieux après !

pierred utilisateur non connecté
Encore merci !
Donc, il semblerait que "mon" optimum soit 256 / 44100 / 2, en deçà c'est inaudible.
Ceci me permet de descendre à 11.6ms. Je n'ai pas de référence en tête, je ne sais pas si c'est une belle perf pour une carte son qui a presque 10 ans, simplement ça ne s'entend presque pas, c'est suffisant pour mon niveau.
Je n'ai pas avancé sur le midi (mais j'avoue avoir hâte de jouer avec guitarix et ardour !!).
Cependant, la capture d'écran de ce (excellent) tuto Tascam US-224 , dans la rubrique "faire fonctionner le midi avec Ardour" montre bien des connexions possible MIDI/Ardour sur Alsa. Bref, j'ai encore beaucoup à apprendre mais je suis TRES content de pouvoir ré-utiliser cette carte son, ce qui était visiblement impossible dans le monde du logiciel privateur.
GNU/Linux : +1 / Micrappeul 0 !

olof utilisateur non connecté
Pour l'utilisation d'ardour et de guitarix en meme temps, tu vas devoir sans doute trouver un compromis :
l'utilisation d'ardour réclame généralement une taille de buffer assez elevée (512 est une bonne base) et 3 voir 4 buffers, tandis que guitarix reclame une taille de buffer plutot petite (64
à 128) pour un bon confort de jeu en temps réel. Il faut donc généralement jongler entre les sceances d'enregistrement de la guitare avec des parametres de faible latence et peu de monde dans ardour en meme temps, et les sceances de travail sur ardour avec des parametres de buffer eleves pour pouvoir inserer tous les pluggins voulus sans generer d'xruns.
Si tu veux utiliser le tout en live, ça devient dejà bien plus compliqué ...

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 10:48, jeu. 27 Apr 2017: bonjour et bienvenue à arcencia2a :-)
olinuxx, 20:37, mar. 25 Apr 2017: bonjour et bienvenue à mojokeeoper :-)
tenryu, 16:22, mar. 25 Apr 2017: @zebassprophet: un Big up pour toi !
zebassprophet, 15:07, mar. 25 Apr 2017: nan, cremaillere en France, le luxo c'est trop cher :-D
Nolwen, 14:42, mar. 25 Apr 2017: @zebassprophet : Félicitations !!! Crémaillère au Luxembourg de prévu, du coup !
sub26nico, 13:35, mar. 25 Apr 2017: Merci et félicitations ZBP!
zebassprophet, 13:28, mar. 25 Apr 2017: et qui c'est qui a eu le poste de prof de gratte au luxembourg??? FUCK YEAH !!! Moi :-D
zebassprophet, 13:27, mar. 25 Apr 2017: @sub26nico, profite bien ;)
sub26nico, 12:39, mar. 25 Apr 2017: Salut à tous des plages de Stes Marie de la mer :-)
sub26nico, 08:11, mar. 25 Apr 2017: Nouvelle version de Rosegarden, [Lien]
sub26nico, 21:12, lun. 24 Apr 2017: @Nolwen! Y'a besoin de s'inscrire si on veut assister aux conférences ? Je croyais que c'était pour y participer..
Nolwen, 20:43, lun. 24 Apr 2017: @sub26nico : Et oui, "La participation à LAC2017 est gratuite (mais nécessite une inscription)." dixit leur site !! Un peu comme les RMLL, il me semble.