Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié Ardour

> Forums de discussion > 3 - Forum dédié Ardour > [résolu] Installation de Ardour problématique. Paquets cassés !
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[résolu] Installation de Ardour problématique. Paquets cassés !

darkpassenger utilisateur non connecté
Salut à tous,

Je fais suite à ce post qui est un partie dans tous les sens :-). Du coup, je recentre le débat :-).
J'ai fais ma BA, j'ai acheté (oui, monsieur (!) Ardour 5.5. Par contre, à l'installation, j'ai des erreurs :
fabrice@:~/Téléchargements$ ./Ardour_64bit-5.5.0.run 
Verifying archive integrity... All good.
Uncompressing Ardour  100%  

Welcome to the Ardour installer

Ardour will be installed for user fabrice in /opt

[sudo] Mot de passe de fabrice : 
dimanche 22 janvier 2017, 18:06:08 (UTC+0100)
Architecture is x86_64
Checking for required disk space
Bundle is on ext4 filesystem
Unpacking bundle for x86_64-gcc5
Bundle unpacked

Checking system libs to see if they are compatible with Ardour.


Installing Ardour 5.5.0 in /opt

Adding Ardour to the applications menu

Creating a desktop link for Ardour in /home/fabrice/Bureau

Copying uninstall script to /opt


Creating link Ardour5 in /usr/local/bin


Checking to see if Jack is installed


The program Jack is missing from this system.

Jack is a very useful utility to allow you to interconnect Ardour and other audio/MIDI applications.
You can use Ardour without it, but you may find it useful to have around.

Install jack using system software repository? [y/n]: y
Attempting to install Jack
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 jackd : Dépend: jackd2 mais ne sera pas installé ou
                  jackd1 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

!!! ERROR !!! apt-get install failed for an unknown reason.
Please install package jackd after this installer completes.


Press ENTER to continue:

The program QjackCtl is missing from this system.
QjackCtl is an extremely useful tool for any system that runs JACK applications like Ardour.
We recommend that you install it.

Install QjackCtl using system software repository? [y/n]: ^CSignal caught, cleaning up


fabrice@:~/Téléchargements$ sudo apt-get install jackd2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 jackd2 : Dépend: libjack-jackd2-0 (= 1.9.10+20150825git1ed50c92~dfsg-1ubuntu1) mais ne sera pas installé
          Recommande: qjackctl mais ne sera pas installé
          Recommande: jackd2-firewire mais ne sera pas installé
 libcheese8 : Dépend: gstreamer1.0-plugins-good (>= 0.11.0) mais ne sera pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.

Une idée ?, car avant j'ai bien réparé et nettoyé tous mes paquets :
sudo apt-get autoclean && sudo apt-get clean && sudo apt-get autoremove --purge && sudo apt-get update && sudo apt-get upgrade && sudo apt-get install -f


Merci
Fabrice

mk1967 utilisateur non connecté Allemagne
Salut Fabrice,

malheureusement je ne connais pas assez Qsynth et LinuxSampler - mais concernant Ardour 5: il marche sans JACK aussi, seulement avec ALSA. J'ai lu qu'au moins Qsynth marche aussi avec ALSA...

Bonne chance
Michael

olinuxx utilisateur non connecté France
Les logs que tu mets dans ton message indique que tu as un problème avec JACK. Réinstalle jackd et qjackctl, et réessaie d'installer Ardour.

darkpassenger utilisateur non connecté
Salut,

J'ai mis dans les logs le retour d'apt-get, pour installer jackd et qjackctl... sans succès :
fabrice@:~/Téléchargements$ sudo apt-get install jackd2  jackd qjackctl libjack-jackd2-0
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libjack-jackd2-0 is already the newest version (2:1.9.11~20161209-1~kxstudio5).
libjack-jackd2-0 passé en « installé manuellement ».
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 jackd2 : Dépend: libjack-jackd2-0 (= 1.9.10+20150825git1ed50c92~dfsg-1ubuntu1) mais 2:1.9.11~20161209-1~kxstudio5 devra être installé
          Recommande: jackd2-firewire mais ne sera pas installé
 libjack-jackd2-0 : Est en conflit avec: jackd2 (< 2:1.9.11~20161209-1~kxstudio5) mais 1.9.10+20150825git1ed50c92~dfsg-1ubuntu1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».


olof utilisateur non connecté
tu as visiblement un probleme au niveau de libjack-jackd2 qui est en version 1.9.10 dans ubuntu et en version 2.1.9 dans kxstudio
c'est un probleme que j'ai rencontré à un moment, mais comme je te l'ai deja dit, c'est avec synaptic que j'ai trouvé comment resoudre ce type de probleme. tu gagnerais à te pencher sur la question, il y a dans synaptic une fonction qui te permet d'imposer aux installations de se baser sur une version plutot qu'une autre lorsque deux versions differentes sont en conflit dans deux repositories differents.

connais tu synaptic ?

tu trouveras l'historique de mes démélés avec ce probleme dans ce post

darkpassenger utilisateur non connecté
Merci pour ces infos. J'utilise apt-get, que je connais, pas à fond, mais je connais :-)

Autre chose, j'ai décoché le dépot "kxstudio" dans le gestionnaire de logiciels. Comment cela se fait qu'Ubuntu me propose des fichiers de ce dépot alors ??!

olof utilisateur non connecté
ubuntu ne te les propose plus, mais ce sont ceux qui sont actuellement installés chez toi : une version plus avancée que celle qu'ubuntu propose, et qui est utilisée pour des pluggins que tu n'utilises sans doute pas, ce qui crée des dependances existantes obligatoires qui empechent de mettre ce dont ardour a besoin parcequ'il s'agit d'une version anterieure de jack. c'est ton installation du .deb de kxstudio qui a fait tout ça.
sur le fil de discussion que je t'ai mis plus haut tu verras exactement les paquets et la methode pour enlever ce qui ne te sert pas et empeche de mettre ce que tu veux.
j'utilise aussi apt-get parfois, et il est probable que la manip soit possible avec, mais je ne sais pas comment faire ça en ligne de commande alors que tout est expliqué sur comment le faire avec synaptic.

darkpassenger utilisateur non connecté
ok.

Je suis dans synaptic, et effectivement, je vois bien que libjack*-* est sous le dépot de KxStudio (voir images) :

Image

Mais si je veux supprimer les 2, il veut me virer aussi tout un tas de softs !!, et pas, "pas glop, pas glop" :-( :

Image

olinuxx utilisateur non connecté France
Tu peux effacer le paquet en -dev sans problème normalement.

Ensuite, tu cliques sur la ligne pour l'autre paquet dans synaptic, puis : "menu -> paquet -> forcer la version". En tout cas, ça marche comme ça pour debian.

darkpassenger utilisateur non connecté
oui, j'avais compris, mais je n'ai pas la version "ubuntu" de "libjack-jackd2".

Si je la supprime, il me vire plein de softs; et je ne peux pas l'installer :-(. On tourne en rond :-(
fabrice@:~/Téléchargements$ sudo apt-get install libjack-jackd2-0
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libjack-jackd2-0 is already the newest version (2:1.9.11~20161209-1~kxstudio5).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.


olof utilisateur non connecté
as tu lu le post dont je t'ai parlé plus haut ? j'y ai expliqué exactement comment faire ça sans tout desinstaller.
olof écrit :
il faut revenir à la version 1.9.10 de jackd2.

pour cela, plutot que tout desinstaller et reinstaller (pas loin de 50 paquets dependant de jackd2), il y a une solution plus propre :

dans synapic, sélectionner le paquet jackd2, puis dans le menu paquets choisir "forcer la version" (ou ctrl E)

là on peut choisir de revenir à une version plus ancienne, lorsque 2 versions sont disponibles dans les depots selectionnés.

celà enleve seulement les paquets qui ne trouveraient pas leur dependance avec l'ancienne version. (en l'occurence cela m'a juste enlevé des pluggins additionnels pour alsa que je n'utilisais pas, et des librairies wine-devel, qui faisaient double emploi avec les librairies wine-developpement.

ensuite appliquer les modifs, et le tour est joué.


ps
depuis j'ai la version 1.9.11 qui a ete installee en mise à jour normale de ubuntu, parceque je suis en ubuntu yaketty, maintenant, et toutes les applications peuvent etre installees sans aucun souci

olinuxx utilisateur non connecté France
@darkpassenger : j'en rajoute une couche à ce que te dit olof ci-dessus puisqu'on te dit tous les deux la même chose mais que tu ne semble pas avoir saisi ou que tu as lu trop vite :

olinuxx écrit :
"menu - paquet - forcer la version"


Note qu'on te dit d'utiliser synaptic, pas apt-get (que tu ne sembles pas maîtriser assez pour faire la même opération avec lui). Il n'y a aucun problème à utiliser synaptic puisque synaptic est une interface graphique pour apt-get et il n'y a donc pas de conflit entre l'un et l'autre.

darkpassenger utilisateur non connecté
Oui, vous avez raison de m'engueuler redface lol. En fait, j'ai lu peut etre lu un peu trop vite, mais surtout, dans synaptic, "Forcer la version" m'a fait penser à "Forcer la version que je viens de t'afficher" : c'est à dire celle de kxstudio. Certes, cela n'a pas vraiment de sens, en fait :-)

Donc, l'installation se passe bien jusqu'a ce qu'Ardour 5.5 comprenne que je n'utilise pas le noyau "low latency", c'est çà ? :
Paramétrage de qjackctl (0.4.2-0ubuntu2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu5) ...
no message buffer overruns
no message buffer overruns
no message buffer overruns

Jack Version Check OK (jackdmp version 1.9.11 tmpdir /dev/shm protocol 8)


System failed the quick sanity check... Looking for the cause

!!! WARNING !!! - Your system seems to use frequency scaling.
This can have a serious impact on audio latency.
For best results turn it off, e.g. by choosing the 'performance' governor.

Press ENTER to continue:^CSignal caught, cleaning up


Mais est-ce vraiment utile en fait (d'apres ce que j'ai lu) ?

J'ai lu çà et çà .


Merci
Fabrice.

olinuxx utilisateur non connecté France
Navré, si on t'a donné l'impression de t'"engueuler", ça n'était pas le but pour ce qui me concerne. L'objectif était de mettre l'emphase sur ton erreur pour que tu puisses la comprendre et progresser, et ça semble avoir fonctionné. :-)

darkpassenger écrit :
Donc, l'installation se passe bien jusqu'a ce qu'Ardour 5.5 comprenne que je n'utilise pas le noyau "low latency", c'est çà ? :


Non, il te dit simplement que ton système n'est pas optimisé et que c'est possible que tu aies des problèmes de performances en utilisant Ardour.

Je vois que tu as Ctrl+C l'installation, mais tu peux la poursuivre.

darkpassenger utilisateur non connecté
Ok Merci
Je plaisantais :-)

Donc, les articles que j'ai lu sur le "frequency scaling" ne sont pas à prendre aux serieux ?

Fabrice

olinuxx utilisateur non connecté France
darkpassenger écrit :
Donc, les articles que j'ai lu sur le "frequency scaling" ne sont pas à prendre aux serieux ?


Si, mais il ne s'agit pas là de quelque chose ayant rapport avec un noyau basse-latence à proprement parler.

darkpassenger utilisateur non connecté
Ok. Merci

Donc, je peux installer ce qu'il faut, mais c'est pas obligé. Si je vois un problème de latence ou autre, j'installe :-)

Fabrice

olinuxx utilisateur non connecté France
Pas compris ce que tu veux dire.

darkpassenger utilisateur non connecté
J'ai installé Ardour 5.5, qui a l'air de fonctionner correctement (le peu que j'ai fait).

Je n'ai donc pas besoin de faire les modifs évoqué dans les 2 liens que j'ai donné :-). Sauf si je rnecontre un soucis de "frequency scaling"

olinuxx utilisateur non connecté France
Ok, je comprends mieux, merci. Et merci pour le [résolu] dans le titre, c'est un très bon réflexe !

Bonne musique à toi.

alexandre2612 utilisateur non connecté
Bonsoir le même souci que notre ami? avant de me lancer dans des bidouilles je vous montre il semble que c'est alsa le probleme et j'aimerai aussi me passer de jack qui me pose des problemes.
alex@alex-HP-Pavilion-17-Notebook-PC ~/Ardour-5.5.0 $ sudo apt-get install autotools-dev cdbs dh-buildinfo devscripts libarchive-dev libaubio-dev 
[sudo] Mot de passe de alex : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
cdbs is already the newest version (0.4.130+deb8u1).
dh-buildinfo is already the newest version (0.11).
autotools-dev is already the newest version (20150820.1).
devscripts is already the newest version (2.16.2ubuntu3).
libarchive-dev is already the newest version (3.2.1-2~ubuntu16.04.1).
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libaubio-dev : Dépend: libaubio4 (= 0.4.1-2+b2) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
alex@alex-HP-Pavilion-17-Notebook-PC ~/Ardour-5.5.0 $ ./waf configure
Setting top to                           : /home/alex/Ardour-5.5.0 
Setting out to                           : /home/alex/Ardour-5.5.0/build 
Checking for 'gcc' (c compiler)          : /usr/bin/gcc 
Checking for 'g++' (c++ compiler)        : /usr/bin/g++ 

Global Configuration 
 * Install prefix                                    : /usr/local 
 * Debuggable build                                  : True 
 * Build documentation                               : False 

Ardour Configuration 
 * Will build against private GTK dependency stack   : no 
 * Will rely on libintl built into libc              : yes 
 * Will build against private Ardour dependency stack : no 
Checking for function dlopen                         : yes 
Checking for boost library >= 1.39                   : ok 
Checking for program pkg-config                      : /usr/bin/pkg-config 
Checking for 'alsa'                                  : not found 
The configuration failed
(complete log in /home/alex/Ardour-5.5.0/build/config.log)
alex@alex-HP-Pavilion-17-Notebook-PC ~/Ardour-5.5.0 $


Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 13:19, mer. 24 mai 2017: bonjour et bienvenue à laffcoop :-)
olinuxx, 17:01, mar. 23 mai 2017: bonjour et bienvenue à av69, à martin_wr, et à quands :-)
sub26nico, 15:45, mar. 23 mai 2017: Salut et bienvenue à Gredin :-)
sub26nico, 22:08, lun. 22 mai 2017: Salut et bienvenue à Maxicore :-)
jams, 08:40, lun. 22 mai 2017: [Lien]
sub26nico, 21:46, dim. 21 mai 2017: A voté également !
tenryu, 21:12, dim. 21 mai 2017: A voté !
theRealPok, 01:59, dim. 21 mai 2017: Merci. Pas répondu a ton PV parce que je trouve plus où c'est mais je me suis présenté dans le forum adéquat
sub26nico, 00:17, dim. 21 mai 2017: Salut et bienvenue à theRealPok :-)
eazymaogeek, 23:10, sam. 20 mai 2017: J'ai voté pour la joute aussi. Hier je crois :-)
sri_raoul, 14:28, sam. 20 mai 2017: 2h23m40s bien évidemment...
sri_raoul, 14:26, sam. 20 mai 2017: La conf de Paul Davis est ici: [Lien] et commence à 2h2340s... environ.