Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié Ardour

> Forums de discussion > 3 - Forum dédié Ardour > problemes de dependances pour l'installation de Ardour 5
Dernier post

problemes de dependances pour l'installation de Ardour 5

alexandre2612 utilisateur non connecté
avant de me lancer dans des bidouilles je vous montre il semble que c'est alsa le souci et j'aimerai aussi me passer de jack qui me pose des problemes.

alex@alex-HP-Pavilion-17-Notebook-PC ~/Ardour-5.5.0 $ sudo apt-get install autotools-dev cdbs dh-buildinfo devscripts libarchive-dev libaubio-dev 
[sudo] Mot de passe de alex : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
cdbs is already the newest version (0.4.130+deb8u1).
dh-buildinfo is already the newest version (0.11).
autotools-dev is already the newest version (20150820.1).
devscripts is already the newest version (2.16.2ubuntu3).
libarchive-dev is already the newest version (3.2.1-2~ubuntu16.04.1).
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 libaubio-dev : Dépend: libaubio4 (= 0.4.1-2+b2) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
alex@alex-HP-Pavilion-17-Notebook-PC ~/Ardour-5.5.0 $ ./waf configure
Setting top to                           : /home/alex/Ardour-5.5.0 
Setting out to                           : /home/alex/Ardour-5.5.0/build 
Checking for 'gcc' (c compiler)          : /usr/bin/gcc 
Checking for 'g++' (c++ compiler)        : /usr/bin/g++ 

Global Configuration 
 * Install prefix                                    : /usr/local 
 * Debuggable build                                  : True 
 * Build documentation                               : False 

Ardour Configuration 
 * Will build against private GTK dependency stack   : no 
 * Will rely on libintl built into libc              : yes 
 * Will build against private Ardour dependency stack : no 
Checking for function dlopen                         : yes 
Checking for boost library >= 1.39                   : ok 
Checking for program pkg-config                      : /usr/bin/pkg-config 
Checking for 'alsa'                                  : not found 
The configuration failed
(complete log in /home/alex/Ardour-5.5.0/build/config.log)
alex@alex-HP-Pavilion-17-Notebook-PC ~/Ardour-5.5.0

Mon travail sur ardour étant le mixage et surtout le mastering. 4 pistes mono ou 2 steréo a traiter. Peut etre un peu de midi et de banque de sons.La bécane est un hp le proc AMD A4-5000 APU 4 cœurs 8oo mhz 2018 khz de cache, 4 go mémoire avec Radeon(TM) HD Graphics carte son interne hd géneric intel et externe Ur 44 steinberg.
merci d"avance pour les conseils.

olinuxx utilisateur non connecté France
Checking for 'alsa'                                  : not found


Il te dit qu'il te manque les bibliothèques de développement d'ALSA dont il a besoin pour construire le support d'ALSA pour Ardour. Si tu es sur une debian ou dérivée (c'est toujours une bonne idée de préciser la distribution utilisée dans tes messages), alors il te faut installer le paquet "libasound2-dev".

Ceci dit, tu es en train de compiler le paquet Ardour qui est loin d'être le logiciel le plus simple à installer par compilation. Pourquoi ne pas installer un paquet tout fait ?

Si tu tiens vraiment à compiler Ardour 5, alors la page Ardour 5 Compilation devrait pas mal t'aider.

alexandre2612 utilisateur non connecté
je n'ai pas trouvé la version 5 en paquet d-ou la compil . a chaque fois que j'installe un paquet j'ai un message de dependance insatisfaite . les depots ubuntu viennent foutre la pagaille chez mint je suppose .

olinuxx utilisateur non connecté France
Doit y en avoir une chez KXstudio j'imagine. Sinon, tu as aussi la possibilité de prendre un binaire chez Ardour.

alexandre2612 utilisateur non connecté
Je n'ai pas résolu le probleme mais contourné. J'ai reinstalé une version mint betsy ensuite les paquets par synaptic et non par console. j'ai compilé ardour 5.4 . pendant 1 heure le portable a fumé ronflé mais ca fonctionne. Les pilote alsa pris en charge, jack of courses.Je teste l'interface externe demain. prise de son par ardour et comparatif audacity que je maitrise mieux.

sub26nico utilisateur non connecté France
@alexandre2612: du nouveau ici?
Si ton problème a trouvé sa solution, merci
de rajouter dans le titre un [RESOLU] ou un
[CONTOURNE] en éditant ton premier message.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]

brigitte
ardoisebleue


Mégaphone [Afficher / Cacher]

sub26nico, 10:38, sam. 19 Aug 2017: L'éditorial du mois d'Août 2017 est publié !
sub26nico, 10:26, sam. 19 Aug 2017: Salut et bienvenue à Scorpi4 et be1 :-)
sub26nico, 10:17, sam. 19 Aug 2017: @be1, n'hésites pas à créer une page pour ton greffon, ça lui donnera plus de visibilité et tu peux ouvrir un fil de forum pour ta demande
be1, 01:55, sam. 19 Aug 2017: hello, j'ai fait un plugin LV2 de spacialisation stéréo d'une source (bi-)mono. Si ça intéresse des testeurs, me faire un message perso...
sub26nico, 18:45, jeu. 17 Aug 2017: Salut et bienvenue à sebos et Schmorgluck :-)
sub26nico, 20:31, mer. 16 Aug 2017: Ardour 5.11 est disponible [Lien]
sub26nico, 16:58, mer. 16 Aug 2017: Salut et bienvenue à Seb56Os :-)
zebassprophet, 15:17, mer. 16 Aug 2017: yep et j'en suis désolé sri_raoul. Des bouchons en Bretagne alors que anne de Bretagne a tant fait pour les autoroutes gratuites, un comble bref je m'organiserais mieux l'an prochain ;)
sub26nico, 14:08, mar. 15 Aug 2017: Salut et bienvenue à RoYmasta et Zulaan :-)
brigitte, 10:35, dim. 13 Aug 2017: Salut à tout le monde. Je débute en mao mais je joue du clavier depuis longtemps. J'ai installé Librazik studio. Je suis un peu perdu mais je plonge . Merci pour ce site sans lequel je ne pourrai pas imaginer avoir accès à tout ce savoir
sub26nico, 01:34, dim. 13 Aug 2017: Salut et bienvenue à charlhenri :-)
sub26nico, 13:51, sam. 12 Aug 2017: il me semble que seuls les admins-wiki peuvent le faire