Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post

[RESOLU]Jack ne veut plus démarrer ?

calixtus06 utilisateur non connecté
Hello , j'ai ouvert un fichier musescore et là pas de son. Je vais dans édition/préférences/E/S et vérifie que j'ai coché jack. Je redémarre et voilà que le bouton lecture est encore grisé mais pas en surbrillance signe que la lecture ne peut démarrer.
Je rallume l'ordi re vérifie et toujours rien (???)

A quoi est ce dû ?

22:53:50.908 Journalisation démarrée --- ven. mars 10 22:53:50 2017 ---
22:53:51.113 Réinitialisation des statistiques.
22:53:51.147 Changement des connexions ALSA.
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
22:53:51.171 Changement du graphique des connexions ALSA.
22:54:22.277 Script de démarrage...
22:54:22.278 pulseaudio -k
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
E: [pulseaudio] main.c: Impossible de tuer le démon : Aucun processus de ce type
22:54:22.822 Script de démarrage terminé avec statut de sortie=256.
22:54:22.822 JACK démarre...
22:54:22.822 /usr/bin/jackd -dalsa -dhw:PODStudioUX2 -r44100 -p256 -n2
22:54:22.882 JACK a été démarré avec le PID=2842.
no message buffer overruns
no message buffer overruns
no message buffer overruns
jackdmp 1.9.11
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2014 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
audio_reservation_init
Acquire audio card Audio1
creating alsa driver ... hw:PODStudioUX2|hw:PODStudioUX2|256|2|44100|0|0|nomon|swmeter|-|32bit
configuring for 44100Hz, period = 256 frames (5.8 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 2 periods for playback
22:54:30.039 Impossible de connecter le serveur JACK comme client. - L'opération a échoué. - Erreur de communication serveur. Veuillez consulter la fenêtre des messages pour plus d'informations.
22:54:30.103 Script d'extinction...
22:54:30.104 killall a2jmidid
JackPosixProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Driver is not running
Cannot create new client
Cannot read socket fd = 23 err = Succès
CheckRes error
JackSocketClientChannel read fail
Cannot open qjackctl client
JackShmReadWritePtr1::~JackShmReadWritePtr1 - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for 4294967295, skipping unlock
a2jmidid: aucun processus trouvé
22:54:30.591 Script d'extinction terminé avec statut de sortie=256.
22:54:30.593 JACK s'arrête...
Jack main caught signal 15
ALSA: poll time out, polled for 8706022 usecs
JackAudioDriver::ProcessAsync: read error, stopping...
Released audio card Audio1
audio_reservation_finish
22:54:32.231 JACK a été arrêté
22:54:32.243 Script post-extinction...
22:54:32.247 pulseaudio --start
22:54:33.244 Script post-extinction terminé avec succès


merci d'avance !!

Nico

tenryu utilisateur non connecté France
Bonjour,
Essaye le truc proposé dans la section dépannage, section "Jack ne démarre plus"

calixtus06 utilisateur non connecté
hello Tenryu

J'ai fait les commandes. La carte UX2 apparait pour les deux premières mais pas pour lspci (??)

nicolas@nicolasMAO:~$ su 
Mot de passe : 
root@nicolasMAO:/home/nicolas# cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7f78000 irq 23
 1 [PODStudioUX2   ]: Line6-TonePort - POD Studio UX2
                      Line 6 POD Studio UX2 at USB 3-3:1.0



root@nicolasMAO:/home/nicolas# aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
XDG_RUNTIME_DIR (/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e g happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
carte 0: NVidia [HDA NVidia], périphérique 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0
carte 0: NVidia [HDA NVidia], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: PODStudioUX2 [POD Studio UX2], périphérique 0: POD Studio UX2 [POD Studio UX2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0


root@nicolasMAO:/home/nicolas# lspci
00:00.0 Host bridge: NVIDIA Corporation MCP79 Host Bridge (rev b1)
00:00.1 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.0 ISA bridge: NVIDIA Corporation MCP79 LPC Bridge (rev b2)
00:03.1 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.2 SMBus: NVIDIA Corporation MCP79 SMBus (rev b1)
00:03.3 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.5 Co-processor: NVIDIA Corporation MCP79 Co-processor (rev b1)
00:04.0 USB controller: NVIDIA Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:04.1 USB controller: NVIDIA Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:06.0 USB controller: NVIDIA Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:06.1 USB controller: NVIDIA Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:08.0 Audio device: NVIDIA Corporation MCP79 High Definition Audio (rev b1)
00:09.0 PCI bridge: NVIDIA Corporation MCP79 PCI Bridge (rev b1)
00:0b.0 SATA controller: NVIDIA Corporation MCP79 AHCI Controller (rev b1)
00:0c.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:15.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:16.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
02:00.0 VGA compatible controller: NVIDIA Corporation G96M [GeForce GT 120M] (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 01)
04:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
root@nicolasMAO:/home/nicolas#


Qu'est ce que je dois comprendre ??

merci d'avance !

allany utilisateur non connecté
Pour lspci, c'est normal puisque la carte externe est en USB et non en PCI.
Est-ce que cette config' fonctionne avec d'autres softs interfacés avec jackd ?
A+

calixtus06 utilisateur non connecté
je m'en vais voir ça..

En tout cas j'ai trois messages d'erreur en ouvrant mon pc concernant cette carte son externe..(?)

Où est ce qu'on voit ces log ( il me semble qu'on appelle ça comme ça) dans /var/log ? un truc du genre ?

Merci je vous tiens au courant pour vos deux questions

tenryu utilisateur non connecté France
Tapes

dmesg | less

dans un terminal.

Dmesg, c'est le log de démarrage de ton ordinateur , | est un "pipe" qui détourne la sortie vers un autre programme, qui est en l'occurence less, une commande linux qui te permet de naviguer dans le flux de sortie plus facilement.

calixtus06 utilisateur non connecté
hello entre deux ménages maison:

[    0.000000] microcode: microcode updated early to revision 0xa0b, date = 2010-09-28
[    0.000000] Linux version 4.9.0-0.bpo.1-amd64 (debian-kernel@lists.debian.org) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 SMP Debian 4.9.2-2~bpo8+1 (2017-01-26)
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-0.bpo.1-amd64 root=UUID=aaecb9e5-2cb6-4e7d-9611-3d68b3774e65 ro threadirqs quiet
[    0.000000] x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers'
[    0.000000] x86/fpu: Enabled xstate features 0x3, context size is 576 bytes, using 'standard' format.
[    0.000000] x86/fpu: Using 'eager' FPU context switches.
[    0.000000] e820: BIOS-provided physical RAM map:
[    0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009e7ff] usable
[    0.000000] BIOS-e820: [mem 0x000000000009e800-0x000000000009ffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000000100000-0x00000000dffa7fff] usable
[    0.000000] BIOS-e820: [mem 0x00000000dffa8000-0x00000000dffaffff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000dffb0000-0x00000000dffbfeff] ACPI data
[    0.000000] BIOS-e820: [mem 0x00000000dffbff00-0x00000000dffeffff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000dfff0000-0x00000000dfffffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000ff700000-0x00000000ffffffff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000100000000-0x000000011fffffff] usable
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] SMBIOS 2.5 present.
[    0.000000] DMI: ASUSTeK Computer Inc.  K70IO               /K70IO     , BIOS 208     06/22/2009
[    0.000000] e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
[    0.000000] e820: remove [mem 0x000a0000-0x000fffff] usable
[    0.000000] e820: last_pfn = 0x120000 max_arch_pfn = 0x400000000
[    0.000000] MTRR default type: uncachable
[    0.000000] MTRR fixed ranges enabled:
[    0.000000]   00000-9FFFF write-back
[    0.000000]   A0000-BFFFF uncachable
[    0.000000]   C0000-CFFFF write-protect
[    0.000000]   D0000-DFFFF uncachable
[    0.000000]   E0000-EFFFF write-through
[    0.000000]   F0000-FFFFF write-protect
[    0.000000] MTRR variable ranges enabled:
[    0.000000]   0 base 0E0000000 mask FE0000000 uncachable
[    0.000000]   1 base 000000000 mask F00000000 write-back
[    0.000000]   2 base 100000000 mask FE0000000 write-back
[    0.000000]   3 disabled
[    0.000000]   4 disabled
[    0.000000]   5 disabled
[    0.000000]   6 disabled
[    0.000000]   7 disabled
[    0.000000] x86/PAT: Configuration [0-7]: WB  WC  UC- UC  WB  WC  UC- WT  
[    0.000000] e820: update [mem 0xe0000000-0xffffffff] usable ==> reserved
[    0.000000] e820: last_pfn = 0xdffa8 max_arch_pfn = 0x400000000
[    0.000000] found SMP MP-table at [mem 0x000ff780-0x000ff78f] mapped at [ffff8e0c400ff780]
[    0.000000] Base memory trampoline at [ffff8e0c40098000] 98000 size 24576
[    0.000000] BRK [0x1c961000, 0x1c961fff] PGTABLE
[    0.000000] BRK [0x1c962000, 0x1c962fff] PGTABLE
[    0.000000] BRK [0x1c963000, 0x1c963fff] PGTABLE
[    0.000000] BRK [0x1c964000, 0x1c964fff] PGTABLE
:


je ne vois pas par contre les 3 lignes de "failed" concernant l'ux2 toneport à l'allumage de l'ordi.

Je m'occupe des autres questions

calixtus06 utilisateur non connecté
bon j'ai essayé de lancé guitarix : erreur inconnue

calixtus06 utilisateur non connecté
renommer le fichier conf ?

root@nicolasMAO:/home/nicolas/.config/rncbc.org# ls
QjackCtl.conf  Qtractor.conf
root@nicolasMAO:/home/nicolas/.config/rncbc.org#


Précisément c'est lequel que je dois renommer : QjackCtl.conf ?

root@nicolasMAO:/home/nicolas/.config/rncbc.org# rm QjackCtl.conf QjackCtl1.conf
rm: impossible de supprimer « QjackCtl1.conf »: Aucun fichier ou dossier de ce type
root@nicolasMAO:/home/nicolas/.config/rncbc.org#


J'ai dû faire une mauvaise manip car ça ne marche pas

Merci

tenryu utilisateur non connecté France
Si tu renommes le fichier QjackCtl.conf, le système sera obligé de refaire un fichier tout neuf. Quelquefois, ça règle le problème.

allany utilisateur non connecté
Essaie plutôt :
cp QjackCtl.conf QjackCtl.conf.old
rm QjackCtl.conf
Tu n'avais pas répondu à ma question : est-ce que cette config' fonctionnait avec d'autres softs que musescore ?
A+

calixtus06 utilisateur non connecté
le soucis c'est que je ne remets pas la main sur QjackCtl.conf avec la commande locate et avec find je ne maîtrise pas bien la syntaxe. Mon fichier musescore a redémarré en tout cas sur ma carte son externe.

root@nicolasMAO:/# find -name "QjackCtl"
root@nicolasMAO:/#


calixtus06 utilisateur non connecté
J'avais essayé d'ouvrir guitarix mais j'avais eu aussi un message m'indiquant que Jack ne pouvait pas démarrer.

tenryu utilisateur non connecté France
Tu veux dire que malgré le fait d'avoir renommé Qjackctl.conf, ça ne démarre toujours pas? Si c'est le cas, tu dois nous transmettre les messages de JACK, et voir avec cette page.

calixtus06 utilisateur non connecté
Aujourd'hui le fichier est de nouveau là mais sous son nom d'origine

root@nicolasMAO:/home/nicolas/.config# cd rncbc.org/
root@nicolasMAO:/home/nicolas/.config/rncbc.org# ls
QjackCtl.conf  Qtractor.conf
root@nicolasMAO:/home/nicolas/.config/rncbc.org#


J'ai fait un enregistrement avec ardour et guitarix et me suis retrouvé avec plein de xrun.

Un coup d’œil aux paramètres de jack: et là je découvre que ma latence est quasi à zéro et mes réglages complètement changé. Je remets 48000 hz en fréquence d’échantillonnage et 256 en échantillon période. Pourquoi n'ai je pas accès à période/tampon ? Il me semblait qu'il fallait le régler sur 3 pour les cartes sons externes

Merci à tous !

calixtus06 utilisateur non connecté
ce soir le problème s'est reproduit. hier j'étais en cours chez des personnes et j'ai dû rebasculer sur un autre serveur que jack. Je n'ai pas cocher alsa ni ( je crois) pulseaudio.

J'ai dû donc renommer QjackCtl, effacer l'ancien...Les paramètres par défaut étaient différents de lundi ( temps réels était coché cette fois )

Est ce qu'il y a moyen de maintenir les paramètres de jack malgré des changements de serveurs ( j'ai un portable) ??

merci à vous

tenryu utilisateur non connecté France
Quand tu parles de serveur, tu parles de quoi ?

calixtus06 utilisateur non connecté
Désolé du retard

Quand je parle de serveur je pense aux serveurs sons (jack, pulse audio, alsa, portaudio..) qui sont proposés dans musescore .

Quand j'emporte mon ordi portable chez les gens je coche, musescore, autre chose que jack pour que le son sorte sur les enceintes de mon pc et non pas comme à la maison où le son sort par les enceintes branchées sur la carte externe qui elle même est indiquée comme périphérique de sortie dans les réglages de jack.

En écrivant ça je me rend compte qu'il faudrait peut-être indiquer à jack d'utiliser un autre périphérique de sortie quand je n'utilise pas ma carte externe.

Un script bash ne me simplifierait pas la vie ? Mais là, si c'est le cas, faut que j'apprenne à en écrire un

Qu'en dites vous ?

allany utilisateur non connecté
Pas nécessaire.
Si tu enregistres dans jackd un réglage pour la carte interne et un autre pour l'externe, il suffit de les sauvegarder, toujours dans jackd, sous deux noms différents et appeler celui que tu veux au moment du lancement.
Image
Chaque réglage sera sauvegardé ici :
Image
Attention à l'ergonomie de la touche enregistrer qu'il faut parfois actionner plusieurs fois avant de pouvoir saisir le nom entier du réglage...

A+

calixtus06 utilisateur non connecté
ok du coup je n'aurais plus à décocher jack pour portaudio . Je vais essayer ..merci

A toute

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 14:57, lun. 19 Aug 2019: Un thérémine numérique open-source : [Lien]
sub26nico, 20:14, sam. 17 Aug 2019: Salut et bienvenue à Samuel BARBIER :-)
sub26nico, 13:26, mer. 14 Aug 2019: Salut et bienvenue à Byond :-)
olinuxx, 14:48, mar. 13 Aug 2019: Bonjour et bienvenue à echevresm cool
olinuxx, 18:02, lun. 12 Aug 2019: Bonjour et bienvenue à barnabulle1700 cool
olinuxx, 15:15, dim. 11 Aug 2019: Bonjour et bienvenue à aldudes cool
sub26nico, 20:13, sam. 10 Aug 2019: Salut et bienvenue à pannanico1 :-)
dawamss, 13:09, ven. 09 Aug 2019: salut à toi olinuxx
olinuxx, 12:45, ven. 09 Aug 2019: Bonjour et bienvenue à dawamss cool
sub26nico, 15:11, mar. 06 Aug 2019: Salut et bienvenue à kiwi007 :-)
olinuxx, 14:07, mar. 06 Aug 2019: Bonjour et bienvenue à zigmhount cool
allany, 19:30, lun. 05 Aug 2019: Du tonnerre, l'édito d'août !!! [Lien]