Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > Jack/pulseaudio (encore) = probleme routage
Dernier post

Jack/pulseaudio (encore) = probleme routage

raskolnik utilisateur non connecté
bonjour à tous

je tourne sous ubuntu 16.04
et avec carte son alpha lexicon
et jack

hier encore (ou enfin...) tout roulait parfaitement
m'était venue l'idée de faire une sauvegarde, puis j'ai oublié
mal m'en a pris :
aujourd'hui, je m'arrache les cheveux
1.icone son disparue de la barre des tâches
mais surtout
2.pulseaudio n'est plus routé vers jack
plus de module jack sink, quime servait tant dans mes installations

et plus de sortie jack dans le pavucontrol

donc plus moyen de faire fonctionner ma carte externe lexicon,
pourtant bien reconnue du systeme

cat /proc/asound/cards 
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfbaf4000 irq 16
 1 [Alpha          ]: USB-Audio - Lexicon Alpha
                      Lexicon Lexicon Alpha at usb-0000:00:12.0-2, full speed


Qui plus est,pulseaudio semble tourner
pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: Échec de pa_pid_file_create().


Qjack se lance normalement aussi

il y a une sorte de faux-contact qqpart, mais où (bordel)!

je viens de me manger une bonne heure et demi de recherches
j'ai aussi refait des installs pulseaudio et alsa
nada, niet, je rebute sur le même os
déprime, car je suis précisément en train d'enregistrer ces temps-ci

big help

merci d'avance
meilleurs voeux en passant

sub26nico utilisateur non connecté France
est ce qu'un simple
pulseaudio -k

puis
pulseaudio --start

arrangerait la solution ?

raskolnik utilisateur non connecté
entre-temps j'ai réinstallé un pulse-module-jack
qui m'a remis les connections manquantes pulseaudio jack sink

mais au démarrage
il faut que je me fende d'un sudo alsa force-reload
+ effectivement pulseaudio -D
et ça semble fonctionner

ça fait quand même bien bricolage tout ça


mais maintenant reste le probleme de l'icone son
je ne parle pas de pavu
mais de l'autre, la normale, qui me permet de cliquer sur la bonne sortie
(+ le fait que n'étant pas présente, cela sous-entend un problème à régler)

des idées pour fixer tout ça dans le bon ordre ?

allany utilisateur non connecté
Je ne demande qu'à être contredit mais il me semble avoir déjà vu passer quelques posts concernant le même genre de soucis (alsa-jackd-pulse) rencontré par d'autres utilisateurs d'ubuntu 16.04...

Ca vaudrait peut-être le coup d'essayer une autre distrib' en live-DVD/USB et dédiée à la MAO. LibraZik, io-GNU-Linux ou KXStudio, par exemple ?
Voir si le phénomène se reproduit à l'identique.

raskolnik utilisateur non connecté
j'y songe sérieusement, bien sûr, ces sessions de tripatouillages tournent au débile
un problème en chassant un autre

une question, en passant :
tu ne cites pas ubuntu studio, il y a une raison ?

(car c'est plutôt ça que je voudrais tester)

(quant à kxstudio, no way, j'y ai mis les pieds et la seule interface m'a effrayé, même après une simulation de bureau ubuntu classique.On se croirait connecté à l'eglise de scientologie.+ une merde incompréhensible avec le mot de passe, qui me poussa à le virer fissa)

olof utilisateur non connecté
j'ai comme toi préféré ubuntu a toute autre distrib au depart et suis passé en effet par les memes delires entre jack et pulseaudio avec des fois de trucs qui fonctionnaient des fois, non, chaque mise a jour faisant retomber le couperet, et je suis passé par 5 versions successives d'ubuntu et en plus les depots kxstudio, sans que ça se stabilise.
là j'ai decidé de tester librazik 2 , sans pour autant enlever mon ubuntu, mais depuis que j'ai bien mis en place ma librazik, je n'ai plus mis les pieds sur ubuntu, que ce soit les performances ou la stabilité, c'est sans appel pour la mao

(ah oui, j'ai aussi mis ubuntu studio, mais ça ne differe pas vraiment d'ubuntu normal en fait)

par contre si tu veux rester sous ubuntu, oublie l'utilisation de pavucontrol pour la musique (oublie pulseaudio tout simplement) et utilise juste jack, tu vas te simplifier les noeuds des neurones, je t'assure (pourquoi en fait veux tu les deux ?)

raskolnik utilisateur non connecté
oui, Librazik, j'y songe aussi bien sûr
je m'en vais du moins y jeter un oeil via usb

pour ce qui est de pulseaudio, oui, j'ai lu ça moultes fois, virer le bousin et voilà tout
c'est que je suis encore un peu couard, et j'ai peur qu'il me manque des trucs essentiels, que d'autres casse-têtes inédits apparaissent
les fonctions paramètres disparaissent, non, par exemple ?
c'est aussi une rasion bien à moi, que je ne l'ai pas éjecté :
dans Bitwig, je peux router les sons d'internet sur une piste via pulseaudio,
et sur une autre les sons systeme
c'est pour mon radioshow
je ne suis pas un cador du routage, et quand j'ai trouvé ce truc, j'en étais fier - c'est con , n'est-ce pas

bon,
donc tu vires pulseaudio, toi.Cela ne t'a posé aucun problème par la suite ?

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 09:47, jeu. 19 Sep 2019: Salut et bienvenue à Luigi83 :-)
olinuxx, 14:33, mer. 18 Sep 2019: Bonjour et bienvenu à Knard cool
olinuxx, 13:17, dim. 15 Sep 2019: Bonjour et bienvenue à wwp et à Kraod cool
sub26nico, 22:18, sam. 14 Sep 2019: Salut et bienvenue à Gretsh56 :-)
olinuxx, 13:44, sam. 14 Sep 2019: Bonjour et bienvenue à T-Yo cool
PenZyh, 16:09, mar. 10 Sep 2019: Merci ^^
olinuxx, 16:08, mar. 10 Sep 2019: Bienvenue e bonjour également à PenZyh cool
olinuxx, 14:47, mar. 10 Sep 2019: Bonjour et bienvenue à SKUNKLOAD cool
sub26nico, 10:29, lun. 09 Sep 2019: Salut et bienvenue à aldepr :-)
olinuxx, 09:01, dim. 08 Sep 2019: Bonjour et bienvenue à nuka cool
sub26nico, 20:21, jeu. 05 Sep 2019: Salut et bienvenue à smo :-)
olinuxx, 10:31, jeu. 05 Sep 2019: Il est tout beau, il est tout chaud, c'est l'édito de linuxmao ! [Lien]