Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > PROBLEME AVEC QJACKCTL SOUS XUBUNTU 17.10 [RESOLU]
Dernier post

PROBLEME AVEC QJACKCTL SOUS XUBUNTU 17.10 [RESOLU]

jpmtrax utilisateur non connecté
Bonjour,

j'ai un gros souci que je n'arrive pas à résoudre. Je suis sur un PC récent équipé d'un Amd Ryzen 5 1400, avec 8Go de ram . La carte mère est une Asrock A320M Pro 4.

Le pc était auparavant sous Xubuntu 17.04 et de ce côté là tout fonctionnait bien. Je pouvais utiliser Audacity ou Audacious avec Jack lancé sans problèmes.

Mais depuis que j'ai fait la mise à jour vers la 17.10, ça ne fonctionne plus.

En fait, je parviens à démarrer sans problèmes Qjackctl, il ne plante pas.
Mais Audacity ne trouve pas Jack, Audacious non plus : j'ai ce message d'erreur :

Échec lors de la connexion au serveur JACK ; est-il en cours d'exécution ?


Pourtant quand je tape la commande groups j'ai bien :

permanents@STUDIO2-PRODUCTION:~$ groups
permanents adm cdrom sudo audio dip plugdev lpadmin sambashare


Je suis aussi sur la bonne carte son et pas sur la sortie son HDMI. Les applications fonctionnent avec Alsa. Quelque chose m'échappe...

j'ai essayé de désinstaller qjackctl avec la commande apt-get autoremove --purge qjackctl, et de réinstaller, rien à faire... visiblement ça n'est pas suffisant pour pallier aux éventuels problèmes de configuration de départ..

une idée ?

Loki Harfagr utilisateur non connecté
à tout hasard le classique :
killall pulseaudio
 killall -9 pulseaudio


et si ça persiste, histoire d'avoir une piste :
lsof | grep snd | awk '{print $1}' | sort -u


jpmtrax utilisateur non connecté
Bonjour et merci déjà de t'intéresser au problème.

Les commandes killall n'ont aucun effet.

Voici le résultat de la seconde commande, mais pas certain que cela puisse t'aider (ça m'a l'air incomplet)

AudioThre
BatterySt
BrowserWa
CacheThre
Chrome_Hi
Chrome_IO
chromium-
Composito
CrShutdow
D-Bus\x20
dconf\x20
disk_cach
extension
gdbus
gmain
gpu-proce
indicator
inotify_r
jackdbus
LevelDBEn
NetworkCh
null-sink
pulseaudi
QDBusConn
qjackctl
QThread
QXcbEvent
renderer_
sandbox_i
TaskSched
threaded-
utility_c
xfce4-vol


Loki Harfagr utilisateur non connecté
Ah ben oui, très curieux effectivement !

apparemment les killall n'ont pas "nettoyé" pulseaudio puisque je le vois listé dans le résultat que tu donnes du "lsof" :

pulseaudi

Je ne pratique pas le Xubuntu 17.10 mais il incorpore peut-être des nouveaux renforts de catégorie 'polkit' ou 'SE-Linux' ou autre atrocité de même famille ?!
Du coup il faudrait que tu voies comment désactiver, au moins temporairement 'pulseaudio' et inhiber son "réveil automatique" éventuel sauf sur demande expresse de la part de l'utilisateur.

Note: pulseaudio est pour l'instant la piste la plus probable de conflit avec alsa/jack mais dans le "lsof" que tu cites
je vois également avec étonnement "jackdbus", donc essaie quand même aussi de "killer" jackdbus ainsi que pulseaudio, ne serait-ce que pour tester un lancement de jack dans des conditions théoriquement "propres" :-)

avant et après le lancement de Qjackctl teste aussi:

ps -ef | grep -i pulse
ps -ef | grep -i jack


(et les 'kill', tant qu'à y être fais-les en tant que superutilisateur)

jpmtrax utilisateur non connecté
Salut, alors voilà ce que j'ai fait :

permanents@STUDIO2-PRODUCTION:~$ sudo killall pulseaudio
permanents@STUDIO2-PRODUCTION:~$ sudo killall -9 pulseaudio
permanents@STUDIO2-PRODUCTION:~$ ps -ef | grep -i pulse
permane+  4038   941  0 13:46 ?        00:00:00 /usr/bin/pulseaudio --start --log-target=syslog
permane+  4161  4003  0 13:47 pts/0    00:00:00 grep --color=auto -i pulse


Aucun changement, Jack démarre, Audacity et Audacious ne trouvent pas Jack.

Résultat de la seconde commande :

permanents@STUDIO2-PRODUCTION:~$ ps -ef | grep -i jack
permane+  4041  1128  0 13:46 ?        00:00:00 /usr/bin/qjackctl
permane+  4050   941  0 13:46 ?        00:00:00 /usr/bin/jackdbus auto
permane+  4226  4003  0 13:51 pts/0    00:00:00 grep --color=auto -i jack
permanents@STUDIO2-PRODUCTION:~$


eekj'avoue ne pas trop comprendre..

DrFunk utilisateur non connecté
Bonjour

Pulse va se relancer automatiquement.

Sauf à mettre l'option "autospawn = no" dans /etc/pulse/client.conf

pulseaudio --kill ensuite

lsof +D /dev/snd pour vérifier qui utilise

jpmtrax utilisateur non connecté
Bonjour,

Désolé je n'ai guère pu m'en charger avant. ça ne change absolument rien. Jack n'appararaît toujours pas dans audacity. Voici le retour de lsof +d /dev/snd

lsof +D /dev/snd
COMMAND   PID       USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
qjackctl 2727 permanents   24u   CHR  116,1      0t0  442 /dev/snd/seq
jackdbus 2734 permanents  mem    CHR  116,3           468 /dev/snd/pcmC1D0p
jackdbus 2734 permanents  mem    CHR  116,4           469 /dev/snd/pcmC1D0c
jackdbus 2734 permanents    6u   CHR  116,2      0t0  467 /dev/snd/controlC1
jackdbus 2734 permanents    8u   CHR  116,3      0t0  468 /dev/snd/pcmC1D0p
jackdbus 2734 permanents    9u   CHR  116,4      0t0  469 /dev/snd/pcmC1D0c
audacity 2750 permanents    7u   CHR  116,1      0t0  442 /dev/snd/seq
audacity 2750 permanents    8u   CHR  116,7      0t0  489 /dev/snd/controlC0
audacity 2750 permanents   11u   CHR  116,7      0t0  489 /dev/snd/controlC0


olof utilisateur non connecté
moi je commencerais par regarder à quel niveau est le probleme : coté jack ou coté audacity ?
- pour ça essayer de produire un son via jack est une premiere etape, et ce SANS audacity
- ensuite regarder comment audacity est paramétré et essayer de produire un son avec audacity SANS jack

jpmtrax utilisateur non connecté
Déjà tenté.. rien ne se connecte à Jack.. j'ai testé hydrogen tout à l'heure, rien à faire.. je crois que je vais repartir sur la 16.04 et installer le noyau adapté aux Ryzen.. parce qu'en fait j'ai eu besoin de la dernière version de soundkonverter (et pas soundconverter qui est beaucoup moins bien)et elle n'est que dans le dépôt de la 18.04, que j'ai rajouté.. ça a dû mettre le foutoir..

mk1967 utilisateur non connecté Allemagne
A propos d'hydrogen que tu as testé - je l'aime et je l'utilise beaucoup mais des fois j'ai vu des problèmes audio avec ca. Peut-être qu'on pourrait essayer connecter Audacious à jack ? (Sur mes systèmes Audacious audio est un peu plus fiable qu'hydrogen audio... wink )

jpmtrax utilisateur non connecté
je déterre ce vieux post en cherchant d'autres solutions, mais j'avais omis de le mentionner : Problème résolu après réinstallation de la 16.04. Ce qui d'ailleurs m'a convaincu de ne plus me précipiter pour migrer vers les nouvelles versions.

Pour info, j'ai branché sur ce PC une Behringer UCA 222 en USB qui fonctionne nickel. Pas de souffle, pas de xruns, très bonne fidélité de restitution. Juste parfois un souffle qui apparaît, et qui m'oblige à relancer qjackctl mais c'est rare.

Par contre c'est pareil, je me suis un peu précipité sur l'AMD Ryzen à sa sortie, là aussi, je ne ferai plus la même erreur (j'ai dû faire changer par les fournisseurs Et le proc Et la carte mère tous deux défectueux !! et encore... parfois ça continue de planter sans aucune raison, au bout de 12h ou de 5 minutes ou une fois par semaine.. bref !!)

On va dire que j'ai essuyé les plâtres de ce processeur qui, il faut l'avouer, me rend bien service quand même au quotidien.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 22:18, sam. 14 Sep 2019: Salut et bienvenue à Gretsh56 :-)
olinuxx, 13:44, sam. 14 Sep 2019: Bonjour et bienvenue à T-Yo cool
PenZyh, 16:09, mar. 10 Sep 2019: Merci ^^
olinuxx, 16:08, mar. 10 Sep 2019: Bienvenue e bonjour également à PenZyh cool
olinuxx, 14:47, mar. 10 Sep 2019: Bonjour et bienvenue à SKUNKLOAD cool
sub26nico, 10:29, lun. 09 Sep 2019: Salut et bienvenue à aldepr :-)
olinuxx, 09:01, dim. 08 Sep 2019: Bonjour et bienvenue à nuka cool
sub26nico, 20:21, jeu. 05 Sep 2019: Salut et bienvenue à smo :-)
olinuxx, 10:31, jeu. 05 Sep 2019: Il est tout beau, il est tout chaud, c'est l'édito de linuxmao ! [Lien]
olinuxx, 20:15, dim. 01 Sep 2019: Bonjour et bienvenue à Gordus cool
olinuxx, 01:46, ven. 30 Aug 2019: Bonjour et bienvenue à leouiche et à Bellus cool
allany, 12:15, mer. 28 Aug 2019: Coucou, r1 ! Content de te croiser ici !