Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Le home-studio, les instruments et le DIY

Dernier post
Page : 1/5   -   Aller directement à la page : 1  2  3  4  5 

Deux cartes son M-Audio Delta 1010

TerraSymbiosa utilisateur non connecté France
Bonjour à tous,
Je viens d'installer une deuxième carte M-Audio Delta 1010 et je voudrais les faire fonctionner toutes les deux en simultané en lecture et en enregistrement.
Je vois qu'il est possible de les faire fonctionner alternativement mais pas plus.
La deuxième carte est reconnue et visible dans les listes midi-jack et midi-alsa.
Je voudrais doubler les entrées-sorties visibles dans la liste audio de qjackctl et passer de 8 à 16 et pouvoir toutes les exploiter, mais je ne sais pas trop comment opérer.
Je précise que je tourne avec Librazik 2.
Si quelqu'un avait une idée, elle serait la bienvenue.
Avec mes remerciements anticipés.
Thierry

TerraSymbiosa utilisateur non connecté France
Je viens de lire cette page:
Fusionner deux cartes M-Audio Delta 1010

La dernière mise à jour date de 2015, j'hésite donc à me lancer.
Y aurait-il d'autres tutoriels plus récents pour faire ces modifications?

olinuxx utilisateur non connecté France
À ta place, je commencerai déjà par tenter d'utiliser la technique jack_alsa_io qui est beaucoup plus simple à mettre en œuvre.

TerraSymbiosa utilisateur non connecté France
Merci. J'y vais de ce pas.

yruama utilisateur non connecté
il y a assez peu de risque à essayer le tuto en question, il suffit juste que tu fasse une sauvegarde des fichier avant de les modifier, comme ça tu peut revenir en arrière si ça ne marche pas. Et si ça marche je te conseil aussi de sauvegarder le fichier que tu a modifié des fois qu'une mise à jour remette à zéro la conf.

olinuxx utilisateur non connecté France
Au contraire yruama. La méthode décrite modifie le fichier .asoundrc . Cadence (qui est présent et conseillé dans LZK-2) modifie à la volée ce fichier il me semble. Ça sent donc le conflit.

Je réitère donc le conseil d'utiliser jack_alsa_io.

TerraSymbiosa utilisateur non connecté France
J'ai fait plusieurs tentatives infructueuses.
Je recommence donc avec copies d'écrans
Image

Après avoir listé le hardware, je vois les deux cartes M Audio 2 et 3. La 2 était la première carte installée, ensuite j'ai installé la carte 3.
Je lance donc jackd sur la 2 mais je n’obtiens pas le résultat habituel, mais le résultat de la carte 3, et en sélectionnant la carte 3 j'obtiens en sortie le résultat de la carte 3.
Je sélectionne donc la carte 3 dans jackd comme carte par défaut.
C'est seulement quand je sélectionne la carte 3 pour alsa out que j'obtiens les 10 sorties supplémentaires.
Comme ça:
Image

Ça ne me parait pas logique. Je devrais avoir les sorties de la carte 2 normalement, non?
De plus le terminal reste bloqué et je ne peux pas continuer.

TerraSymbiosa utilisateur non connecté France
J'ai donc sur les sorties Système et sur les sorties Alsa les sons de la carte 3, ce qui me parait normal.
Il semblerait que la carte 2 ait disparu des contrôles radar.

TerraSymbiosa utilisateur non connecté France
Je suis donc obligé de fermer le terminal et une fois fermé alsa out disparaît.
En gros je tourne en rond.

TerraSymbiosa utilisateur non connecté France
J'ai inversé les cartes de leurs slots pci et maintenant les deux cartes fonctionnent alternativement, mais je suis toujours bloqué au niveau du terminal après avoir lancé la commande alsa_out, inscrivant un delay= -2 ou une autre valeur.
Je suis obligé de fermer le terminal et alsa out décroche avec. Je ne peux donc pas continuer à ce stade.

TerraSymbiosa utilisateur non connecté France
tsml@terra-symbiosa:~$ alsa_out -dhw:6
Cannot lock down 47664026 byte memory area (Cannot allocate memory)
WARNING: chennel count does not match (requested 2 got 10)
selected sample format: 32bit
delay = -4


TerraSymbiosa utilisateur non connecté France
Comme la proposition avec jack_alsa i_o ne fonctionne pas, j'ai tenté ce script dans .asoundrc, mais sans plus de succès.
Apparemment, quelque chose m'échappe.

pcm.multi_capture {
	type multi
	slaves.a.pcm hw:M1010
	slaves.a.channels 12
	slaves.b.pcm hw:M1010_1
	slaves.b.channels 12

# First 8 channels of first soundcard (capture)
 	bindings.1.slave a
 	bindings.1.channel 1
 	bindings.2.slave a
 	bindings.2.channel 2
 	bindings.3.slave a
 	bindings.3.channel 3
 	bindings.4.slave a
 	bindings.4.channel 4
 	bindings.5.slave a
 	bindings.5.channel 5
 	bindings.6.slave a
 	bindings.6.channel 6
 	bindings.7.slave a
 	bindings.7.channel 7
 	bindings.8.slave a
 	bindings.8.channel 8
    
# First 8 channels of second soundcard (capture)
 	bindings.9.slave b
 	bindings.9.channel 9
 	bindings.10.slave b
 	bindings.10.channel 10
 	bindings.11.slave b
 	bindings.11.channel 11
 	bindings.12.slave b
 	bindings.12.channel 12
 	bindings.13.slave b
 	bindings.13.channel 13
 	bindings.14.slave b
 	bindings.14.channel 14
 	bindings.15.slave b
 	bindings.15.channel 15
 	bindings.16.slave b
 	bindings.16.channel 16

}

ctl.multi_capture {
	type hw
	card 2
}

pcm.multi_playback {
	type multi
	slaves.a.pcm hw:M1010
	slaves.a.channels 10
	slaves.b.pcm hw:M1010_1
	slaves.b.channels 10

# First 8 channels of first soundcard (playback)
 	bindings.1.slave a
 	bindings.1.channel 1
 	bindings.2.slave a
 	bindings.2.channel 2
 	bindings.3.slave a
 	bindings.3.channel 3
 	bindings.4.slave a
 	bindings.4.channel 4
 	bindings.5.slave a
 	bindings.5.channel 5
 	bindings.6.slave a
 	bindings.6.channel 6
 	bindings.7.slave a
 	bindings.7.channel 7
 	bindings.8.slave a
 	bindings.8.channel 8

# First 8 channels of second soundcard (playback)
 	bindings.9.slave b
 	bindings.9.channel 9
 	bindings.10.slave b
 	bindings.10.channel 10
 	bindings.11.slave b
 	bindings.11.channel 11
 	bindings.12.slave b
 	bindings.12.channel 12
 	bindings.13.slave b
 	bindings.13.channel 13
 	bindings.14.slave b
 	bindings.14.channel 14
 	bindings.15.slave b
 	bindings.15.channel 15
 	bindings.16.slave b
 	bindings.16.channel 16

}

ctl.multi_playback {
	type hw
	card 3
}


olinuxx utilisateur non connecté France
Note modération : merci d'utiliser la balise CODE lorsque tu copies/colles du code sur le site. Celles-ci permettent un meilleur affichage. Voir également cette page.
Image

J'ai édité tes 2 précédents messages en tant que modéro-forum, essaie de le faire toi-même les prochaines fois, ça clarifie la lecture des posts. Merci.

Concernant ce fil de discussion, je note que :
Terrasymbiosa écrit :
Cannot lock down 47664026 byte memory area (Cannot allocate memory)

semble signifier que ton installation n'est pas complète. Comment as-tu installé LibraZiK-2 ? quelle méthode as-tu utilisé ? Ton système semble bancal à ce stade et il serait utile de rétablir cela.

Concernant le terminal, oui, il est normal que si tu quittes le terminal, alors il ferme les processus actifs lancés dans ce terminal. Il suffit de faire un script et un lanceur pour que les commandes deviennent pérennes, c'est pas très compliqué, mais il faudrait déjà que l'ensemble fonctionne, ce qui ne semble pas être encore le cas ici.

Je n'ai pas d'expérience avec la méthode asoundrc (ou plutôt, des expériences trop lointaines) et ne peux donc t'aider si tu choisis cette méthode. Je conseille toujours la méthode jack_alsa_io qui me paraît la plus pertinente pour toi.

Bon courage, tiens nous au jus !

TerraSymbiosa utilisateur non connecté France
Je retiens pour la balise code, merci.
J'ai installé Librazik 2 avec un dvd gravé suite à un téléchargement.
Je n'ai pas de problème particulier avec cette distribution. Tout a l'air de fonctionner normalement, mais peut-être y a-t-il des problèmes que je ne vois pas.
Pour rétablir la Librazik 2, que me conseillerais-tu?
Sinon, ça ne me pose pas de problème d'utiliser la méthode alsa_jack_io, si j'arrive à la finaliser.

TerraSymbiosa utilisateur non connecté France
J'ai maintenant mes deux cartes actives simultanément avec la méthode alsa_jack_io,

tsml@terra-symbiosa:~$ alsa_out -dhw:13 -j'deuxième sortie'
& 
tsml@terra-symbiosa:~$ alsa_in -dhw:13 -j'deuxième entrée'


Par contre impossible de fixer le bousin. Je dois reproduire la procédure à chaque démarrage de qjackctl avec en plus les terminaux ouverts. Si je ferme les terminaux, plus rien.

De plus la commande d'automatisation au démarrage disparaît également de qjackctl quand je relance qjackctl.

À part ça tout va bien.

Il y a cependant quelque chose qui m'échappe encore; -dwh:13 étant l'emplacement de la deuxième carte dans la liste, mais cette valeur change à chaque redémarrage. Cela devrait-il être également automatisé pour que l'emplacement de la carte soit localisé à chaque redémarrage ?

olinuxx utilisateur non connecté France
Chouette !

TerraSymbiosa écrit :
Je dois reproduire la procédure à chaque démarrage de qjackctl avec en plus les terminaux ouverts. Si je ferme les terminaux, plus rien.


Tu as essayé plusieurs choses dans ce fil de discussion et je ne suis pas certain de comprendre de quelle "procédure" tu parles. Détailles là.

On verra tes autres questions ensuite.

TerraSymbiosa utilisateur non connecté France
J'en suis à cette méthode qui fonctionne partiellement en l'adaptant à ma distribution:

jack_alsa_io

Cela donne:

Image

avec les commandes suivantes:

Image

Le premier problème étant à ce stade que je ne peux pas pérenniser ces commandes en quittant les consoles. Je ne connais pas la commande. Dès que je quitte les consoles la configuration disparaît.
Le deuxième problème étant que qjackctl ne mémorise pas le script à exécuter au démarrage, comme suit:

Image

Le script disparaît au redémarrage de qjackctl

Et interrogation à mon niveau de compétence: l'assignation des cartes visible avec la commande asound/cards change à chaque démarrage de l'ordi. L'opération de mise à jour des emplacements des cartes est-elle automatisée d’emblée ou faut-il le faire manuellement à l'aide d'un script?

olinuxx utilisateur non connecté France
Merci pour le résumé, j'y vois un peu plus clair.

Tu as toujours le message d'erreur suivant :
Cannot lock down 47664026 byte memory area (Cannot allocate memory)

Ce qui signifie qu'il manque toujours la finalisation de l'installation de ton système.

Que te donne un
uname -a
en terminal ?

Est-ce que le paquet "librazik-optimisations-all" est bien installé ?

On verra pour la suite après.

TerraSymbiosa utilisateur non connecté France
uname -a =

Image

Le paquet librazik-optimisations-all est bien installé.

olinuxx utilisateur non connecté France
Le noyau est un noyau Debian de base qui n'est pas optimisé pour la MAO. Il est probable que ce soit lui qui provoque les messages d'erreur. Lire http://librazik.tuxfamily.org/doc2/manuel/noyau Image , je te conseille l'installation d'un noyau 4.9.0-6-lzk-bl-amd64.

Ensuite, tu redémarres sur ce noyau et tu me dis ici si tu as encore ce vilain message ou pas.

Page : 1/5  [Suivant]
1  2  3  4  5 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


michelk

Mégaphone [Afficher / Cacher]

olinuxx, 16:23, jeu. 22 Oct 2020: Bonjour et bienvenue à Sherkaan cool
CyrilRos, 23:43, mer. 21 Oct 2020: Le noyau temps réel passe en version 5.9 sur Tux|N|Mix [Lien]
calixtus06, 08:56, mer. 21 Oct 2020: Bienvenue à Akashbro120 :-)
olinuxx, 14:03, mar. 20 Oct 2020: Bonjour et bienvenue à rico211 cool
calixtus06, 10:46, mar. 20 Oct 2020: Bienvenue à toi fran_studio :-)
minimoineau, 15:20, lun. 19 Oct 2020: Salut à tous, on aurait besoin d'aide pour faire tourner une Saffire pro 26 dans le forum [Lien] svp!
calixtus06, 20:40, sam. 17 Oct 2020: Bienvenu à Dan.p :-)
olinuxx, 19:34, sam. 17 Oct 2020: Bonjour et bienvenue à Dan.p cool
calixtus06, 23:00, ven. 16 Oct 2020: Bienvenue à MorganeH :-)
calixtus06, 09:56, jeu. 15 Oct 2020: Bienvenue à Michelk ! :-)
olinuxx, 14:44, mar. 13 Oct 2020: Merci @Sahaathyva, ça fait plaisir. @tous : n'hésitez pas à commenter l'édito, ça fait plaisir de voir que le travail est apprécié !
Sahaathyva, 10:49, mar. 13 Oct 2020: Encore 1 super edito, merci a vous !!!