Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

Dernier post

Claudia plus de son RÉSOLU

aletheia utilisateur non connecté France
J'ai voulu lancer Claudia et depuis je n'ai plus de son. Ni pour Ardour ni pour Pulse Audio.
Et je ne sais pas de me débarasser de ça pour relancer Cadence et Catia normalement sans studio.
Pouvez vous m'aider?

olinuxx utilisateur non connecté France
Comme d'habitude : quelle distribution, quelle version de claudia/cadence/catia... etc.

aletheia utilisateur non connecté France
Désolé
Librazic2 focusrite16/20 les logitiels en dernière version.
J'ai retrouvé le son par hasard à force de bidouillé, mais je ne sais pas ce qui se passe avec claudia et encore moins éviter que le son soi indisponible.

olinuxx utilisateur non connecté France
Il faudrait que tu trouves un moyen reproductible pour que l'on puisse t'aider, ou expliquer ce qui se passe.

En attendant, bonne musique à toi !

aletheia utilisateur non connecté France
En fait, lorsque j'ai ouvert Claudia, je n'avais plus de son alors que tout fonctionnait normalement avant. Je voulais juste retrouver facilement le routage de mes sorties sons pour PulseAudio. Je n'ai pas besoins de lancer automatiquement des applications.
Si je rouvrais Cadence après avoir arrêté Jack et fermé Cadence, Catia m'ouvrait un studio automatiquement. Ce que je ne voulais pas. Je voulais simplement reconfigurer le routage de pulseAudio.
J’ai vraiment eu l'impression que Claudia m'avait tout planté, surtout que j'ai dû reconfigurer mes cartes USB, les ports, éteindre les cartes sons et redémarré plusieurs fois le PC avant de retrouver mon son. Mais je ne saurai pas expliquer pourquoi ça fonctionne.

Ma question, maintenant, serait :comment arrêter le lancement automatique d'un studio de Claudia ?
Et pourquoi cette perte de son? Faut-il, par exemple, qu'Ardour soit obligatoirement enregistré dans un studio comme application pour le lancer et que ça fonctionne?
Merci pour vos réponses

olinuxx utilisateur non connecté France
aletheia écrit :
Ma question, maintenant, serait :comment arrêter le lancement automatique d'un studio de Claudia ?


Aurais-tu sélectionné la case "Démarrer automatiquement JACK ou LADISH à la connexion de la session" par hasard ? (voir ici  Image ).


aletheia écrit :
Et pourquoi cette perte de son?


Aucune idée, je n'ai pas compris ton paragraphe plus haut, et n'ai pas de manière reproductible à tester ici pour te faire une explication.

Bonne musique !

Et n'oublie pas le traditionnel [RÉSOLU] :
Note modération : le sujet étant résolu, merci d'ajouter un [RÉSOLU] (ou un [CONTOURNÉ], ou bien encore un [ABANDONNÉ]) dans le titre de ton premier message. Voir ce paragraphe du manuel du site pour davantage d'informations.



aletheia utilisateur non connecté France
EH NON! la case n'est pas cochée. C'est assez étrange.
Je ne le refais plus, promis.

aletheia utilisateur non connecté France
Je reviens vers vous pour Claudia.
Bon, d'abord, j'ai dû faire n'importe quoi, mais ça on le devinait.
Mais j'ai trouvé des solutions intéressantes avec Claudia.
D'abord, j'avais souligné le problème du lancement automatique d'une 2ème carte son avec Cadence. J'ai résolu le problème en faisant un script d'1 ligne qui contient ceci (Focusrite 16/20):
alsa_out -dhw:USB_1 -c 10 -jextra
que j'ai placé dans un dossier réservé aux scripts.
Dans Claudia j'ai créé un studio et j'ai ajouté un lanceur personnalisé qui pointe sur ce script. Et ma deuxième carte son est bien lancée au démarrage du studio.
Maintenant, je voulais aussi disposer d'un mixer pour étalonner plus précisément mes canaux (j'en utilise 18). J'ai ajouté à Claudia, Jack-mixer. J'ai configuré proprement celui-ci pour mes sorties.
(Pour Ardour, je dirige les sorties sur les entrées du mixer.)
J'ai également configuré PulseAudio Jack Sink, car j'en ai besoin pour certaines applications qui l'exigent comme certains programmes wine (Mammut par ex)
Image
J'ai sauvegardé le fichier de Jack-Mixer.
J'ai enregistré le studio.(Arrêt et déchargement)
Dans cadence j'ai demandé le lancement d'un studio au démarrage avec le nom de mon nouveau studio.
Image
Lorsque je relance Claudia, mon studio est bien chargé.
Je sélectionne "Démarrer le studio" dans le menu.
Ma 2e carte est lancée et jack-mixer aussi.
Je lance le pont pulseAudio dans cadence.
Je supprimer tous les liens de pulseAudio Sink.
Je charge le fichier de configuration du mixer et hop! tout est en place.
Merci pour votre aide, j'espère que ceci pourra aider certains d'entre nous.

olinuxx utilisateur non connecté France
@altheia : peux-tu éditer ton post précédent pour mettre un lien vers le message plus complet que tu as créé car il ne sert à rien (à part à se disperser) d'avoir une doublon comme celui-ci. Merci d'avance.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Mégaphone [Afficher / Cacher]

moncopainalain, 11:19, sam. 30 mai 2020: Confiné,j'ai écris Homescape, l'idée c'est d'enregistrer des sons pour faire de l’électro : [Lien] ça tourne sur pure data ou sur android en téléchargeant l'apk avec script fourni... Partagez. contactez moi.
olof, 09:15, jeu. 28 mai 2020: Ardour 6 est sorti.
olinuxx, 16:40, mar. 26 mai 2020: Bonjour et bienvenue à Jean Emberger et à JazzAddict cool
Sahaathyva, 23:49, lun. 25 mai 2020: ok pour la 1.3 , celle qui est censée supporter l'audio ;) @r1: lmms est mis de coté pour ma part à l'heure actuelle. là j'essaie d'aider Alex pour ZRythm mais dans la mesure de mes simples compétences
r1, 22:47, lun. 25 mai 2020: @Sahaathyva : Pour accélérer le mouvement, tu peux aussi participer au développement de lmms ! :-)
r1, 22:45, lun. 25 mai 2020: Excellente nouvelle pour lmms ! Et pour Ardour aussi d'ailleurs :-D
sub26nico, 21:21, lun. 25 mai 2020: ardour.org semble être redevenu fonctionnel, mais pas encore le forum
ycollet, 20:44, lun. 25 mai 2020: Aucune idée ... J'imagine plutôt une 1.3.0
Sahaathyva, 18:01, lun. 25 mai 2020: Desole pour les fautes de frappe je hais les claviers tactiles. Sinon ycollet c est annonce pour la 1.2.2 les lv2?
Sahaathyva, 15:40, lun. 25 mai 2020: C est possible sue le srv deconne leur forumme fait des blagues. Sinonycollet tres bonne nouvelle pout lmms il est quand meme temps pour un soft parti de linux de travailler avec des greffons linux natifs autres que ladspa
ycollet, 14:48, lun. 25 mai 2020: Le support LV2 vient d'être mergé dans la branche master de LMMS ...
Samuel, 13:57, lun. 25 mai 2020: @minimoineau. Ouais, c'est fatiguant, le serveur ne doit probablement pas bien tenir la charge en téléchargement