Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

Dernier post

Message d'erreur ZynAddSubFX [RÉSOLU]

maaou68 Articles : 52 utilisateur non connecté
Bonjour,
j'utilise la version de ubuntu studio: Ubuntu 18.04.2 LTS.
Après avoir ouvert Qjackctl, je démarre ZynAddSubFX et une fenêtre s'ouvre avec le message "Default IO did not initialize. Defaulting to NULL backend".
Dans Qjackctl, ZynAddSubFX n'apparaît pas dans les connexions de ports d'entrée et de sortie audio.
Par conséquent je n'ai pas de son lorsque je branche un clavier midi.

Que préconisez-vous?

bda Articles : 263 utilisateur non connecté France
Bonjour,
ouvrir QJackCtl ne suffit pas. Il faut configurer jackd. Ce n'est pas automatique.
Voir QJackCtl et Jack.

Par contre en nous donnant plus de détail sur le PC en question (surtout l'interface audio), nous pourrons probablement apporter plus d'aide.

maaou68 Articles : 52 utilisateur non connecté
Merci pour votre réponse.

Voici les infos que vous m'avez demandé:
ordinateur: acer m5610-m3610
Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
bits: 64 bits

En tapant:
lspci | grep -i audio

voici la réponse:
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)


J'ai paramétré QJackCtl en réglant pilote midi sur seq et j'ai activé la prise en charge du séquenceur Alsa dans Divers.

J'ai une carte graphique mais je n'ai pas de carte son. De plus j'ai le même problème sur un autre ordinateur avec la même installation de Ubuntu studio.

sub26nico Articles : 3222 utilisateur non connecté France
Note modération : merci d'utiliser la balise CODE lorsque tu copies/colles du code sur le site. Celles-ci permettent un meilleur affichage. Voir également cette page.
Image

@maaou68 : j'ai édité ton message précédent pour que les commandes et retour de terminal s'affiche correctement, penses y les prochaines fois stp.

bda Articles : 263 utilisateur non connecté France
jackd est bien démarré?
Quand il est arrêté:
Image

Quand il est démarré:
Image

Tu peux aussi nous copier (dans une balise CODE), le contenu de la fenêtre Messages?

maaou68 Articles : 52 utilisateur non connecté
Voici Jackd démarré et mes connexions:

Image

Image

Image

sub26nico Articles : 3222 utilisateur non connecté France
Note modération : @maaou68, tu peux poster ici les images en utilisant le bouton d'image (voir capture d'écran ci-bas) dans la barre d'outils plutôt que de mettre un lien vers un serveur externe, cela permet de garder les images dans le temps et de permettre une meilleure compréhension pour un lecteur qui viendrait ici ultérieurement. J'ai édité ton précédent message pour y placer les captures d'écran. Voir le paragraphe 'Image' du manuel du site.]


Image

sub26nico Articles : 3222 utilisateur non connecté France
À mon avis il manque l'activation du pont ALSA-MIDI-JACK.
Pour se faire essayes cette commande dans un terminal :
a2j -e

et dis nous si ça fonctionne. Si c'est le cas, tu pourras automatiser son lancement dans QjackCtl en rajoutant cette commande dans 'Réglages/Options/Exécuter un script après le démarrage'. Si ça ne fonctionne pas, mets nous ici le retour du terminal dans une balise code.

maaou68 Articles : 52 utilisateur non connecté
:~$ a2j -e

hardware ports export
--- enable export of hardware ports
--- start


Toujours pas de son. J'ai bien le niveau de dB qui bouge quand j'appuie sur mon clavier et j'ai bien sélectionné un son dans la banque de ZynAddSubFX...

sub26nico Articles : 3222 utilisateur non connecté France
Est ce que les sorties de ZynAdd sont routées vers les sorties de la carte son ? (onglet Audio de QjackCtl)

sub26nico Articles : 3222 utilisateur non connecté France
Aussi, il y a 2 versions de ZynAdd, une pour ALSA et une autre pour JACK, es tu sûr d'avoir lancé la version JACK ? Ça pourrait expliquer qu'il n'apparaît pas dans Qjack.

maaou68 Articles : 52 utilisateur non connecté
En utilisant la version JACK ça marche et je n'ai plus le message d'erreur.
J'ai d'ailleurs le message d'erreur sur la version Alsa et OSS.
A quoi servent ces versions?


Merci d'avoir résolu mon problème

sub26nico Articles : 3222 utilisateur non connecté France
Chouette que tu puisses utiliser ce super synthé virtuel.

maaou68 écrit :
J'ai d'ailleurs le message d'erreur sur la version Alsa et OSS.
A quoi servent ces versions?

Ces versions servent à utiliser ZynAddSubFx sans que JACK soit lancé, ALSA permet simplement de détecter les périphériques (comme ton clavier MIDI ou une carte son USB), c'est un ensemble de pilotes.
OSS est l'ancêtre d'ALSA. (Je te laisse cliquer sur les mots oranges qui te dirigeront sur les pages wiki du site).


Citation :
Merci d'avoir résolu mon problème

Avec plaisir, les forums sont là pour ça, merci à toi pour le [RÉSOLU] et bonne zic' wink.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Mégaphone [Afficher / Cacher]

olinuxx, 19:27, jeu. 22 Aug 2019: Bonjour et bienvenue à sutolip cool
sub26nico, 14:57, lun. 19 Aug 2019: Un thérémine numérique open-source : [Lien]
sub26nico, 20:14, sam. 17 Aug 2019: Salut et bienvenue à Samuel BARBIER :-)
sub26nico, 13:26, mer. 14 Aug 2019: Salut et bienvenue à Byond :-)
olinuxx, 14:48, mar. 13 Aug 2019: Bonjour et bienvenue à echevresm cool
olinuxx, 18:02, lun. 12 Aug 2019: Bonjour et bienvenue à barnabulle1700 cool
olinuxx, 15:15, dim. 11 Aug 2019: Bonjour et bienvenue à aldudes cool
sub26nico, 20:13, sam. 10 Aug 2019: Salut et bienvenue à pannanico1 :-)
dawamss, 13:09, ven. 09 Aug 2019: salut à toi olinuxx
olinuxx, 12:45, ven. 09 Aug 2019: Bonjour et bienvenue à dawamss cool
sub26nico, 15:11, mar. 06 Aug 2019: Salut et bienvenue à kiwi007 :-)
olinuxx, 14:07, mar. 06 Aug 2019: Bonjour et bienvenue à zigmhount cool