Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

5 - Les serveurs son : Jack, PulseAudio et autres...

> Forums de discussion > 5 - Les serveurs son : Jack, PulseAudio et autres... > [RÉSOLU] Charger une config jack_mixer au lancement d'un studio Claudia
Dernier post

[RÉSOLU] Charger une config jack_mixer au lancement d'un studio Claudia

sibfactory utilisateur non connecté
Bonjour,

J'aimerais charger une config perso de jack_mixer au chargement d'un studio Claudia.

Je ne vois pas quelle commande insérer dans le lanceur personnalisé question :/

Lorsque je lance la commande "man jack_mixer" j'ai :
-c CONFIG, --config=CONFIG
use a non default configuration file

J'ai essayé avec :
jack_mixer --config=CONFIG /home/user/Music/mon_fichier

ca ne fonctionne pas, ça ne doit pas être la bonne :P

aletheia utilisateur non connecté France
Bonjour

la commande c'est :

jack_mixer -c /home/user/Music/mon_fichier

Cordialement

sibfactory utilisateur non connecté
aletheia écrit :
la commande c'est :

jack_mixer -c /home/user/Music/mon_fichier


j'avais bien testé cette commande mais ça ne fonctionne pas :/ j'ai un message d'erreur

Image


idem cadence-pulse2jack ne lance pas automatiquement au démarrage il faut que je fasse clique droit-> demarrer une fois le studio lancé...

aletheia utilisateur non connecté France
Ça fonctionne pourtant très bien chez moi.
Cordialement

sibfactory utilisateur non connecté
ah mince grrr

Le fichier de config de jack_mixer a une extension ?

"normalement" la commande "cadence-pulse2jack" sur un lanceur personnalisé, devrait lancer le pont Pulse Audio tout seul ?

car dans mon cas, je dois le démarrer une fois le studio lancé en faisant clic droit-> démarrer

je ne sais pas si c'est lié :/

olinuxx utilisateur non connecté France
Quelle est la commande exacte que tu mets dans claudia ?

sibfactory utilisateur non connecté
Pour lancer Pulse => Lanceur personnalisé avec
cadence-pulse2jack


et pour jack_mixer =>
jack_mixer -c  /home/USER/Music/Studios/custom_jack_mixer


aletheia utilisateur non connecté France
est-ce que jack est actif au moment de l'appel à ton script jack_mixer? Dans le cas contraire, pas de jack_mixer.

olinuxx utilisateur non connecté France
"USER" -> à remplacer par un nom réel d'utilisateur

sibfactory utilisateur non connecté
olinuxx écrit :
"USER" - à remplacer par un nom réel d'utilisateur


bien évidemment wink

sibfactory utilisateur non connecté
Voici les logs lorsque j'essaie de lancer jack_mixer

Tue Oct 22 16:27:34 2019: New client 'jack_mixer' with PID 1942
Tue Oct 22 16:27:34 2019: ERROR: JackEngine::XRun: client = jack_mixer was not finished, state = Triggered
Tue Oct 22 16:27:34 2019: ERROR: JackAudioDriver::ProcessGraphAsyncMaster: Process error
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:midi in' to destroy
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:MAIN L' to destroy
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:MAIN R' to destroy
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:midi out' to destroy
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:Monitor L' to destroy
Tue Oct 22 16:27:34 2019: ERROR: Failed to find port 'jack_mixer:Monitor R' to destroy
Tue Oct 22 16:27:34 2019: Client 'jack_mixer' with PID 1942 is out
Tue Oct 22 16:27:34 2019: ERROR: cannot find client 13


sibfactory utilisateur non connecté
J'ai tout repris le studio de zéro, jack_mixer lance bien mon fichier de config au démarrage du studio, chouette ! :-)

Je ne vois pas ce qui plantait dans l'autre :/


Reste cadence-pulse2jack qui ne veut toujours pas se lancer au démarrage du studio, je dois le faire manuellement (clic droit -> Démarrer)...

Une idée pour ça ?

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 20:50, ven. 27 mars 2020: Salut et bienvenue à Topyweb, Serge Samson, ChtiJeff, Zeplead et Zonzon :-)
r1, 20:27, ven. 27 mars 2020: La joute 15 est sur les rails ! [Lien] Viendez jouer avec nous !!!
bluedid29, 17:13, ven. 27 mars 2020: Bon week-end, à fond encore sur Musescore et LibraZik-2... ...bientôt utilisation régulière sur LibraZik-3...
sub26nico, 14:11, ven. 27 mars 2020: @tolliac, ouvres un fil spécifique dans les forums.
tolliac, 11:41, ven. 27 mars 2020: Bonjour, je ne me suis intéressé jusqu'ici qu'à l'écriture de partitions via lilypond et Frescobaldi et pour résoudre des problèmes de lecture de fichiers MIDI je me retrouve dans l'univers de la MAO chaleureusement accueilli mais complètement perdu. quel
Sahaathyva, 09:08, ven. 27 mars 2020: 1 billet de mr Paul : [Lien]
Sahaathyva, 09:07, ven. 27 mars 2020: Salut a tous!
GuillaumeD, 10:58, jeu. 26 mars 2020: @sub26nico, merci pour le message et ravi de vous rejoindre. Le meilleur reste à venir... ;)
sub26nico, 10:27, jeu. 26 mars 2020: Salut et bienvenue à prederour, GuillaumeD et pennsoner :-)
Samuel, 11:55, mer. 25 mars 2020: @zigmhount, tu penses à quoi exactement ? Je pense qu'ouvrir un nouveau fil est plus adapté
zigmhount, 14:41, mar. 24 mars 2020: Bonjour à tous! Y a-t-il une section sur ce site pour des liens vers des cours en ligne (gratuits ou non) qui pourraient intéresser d'autres utilisateurs? Je viens d'en finir un pas mal!
olinuxx, 15:28, dim. 22 mars 2020: Bonjour et bienvenue à Mito77, à MikeRodd et à MenoiaJin cool