Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

2 - Les distributions et les noyaux

> Forums de discussion > 2 - Les distributions et les noyaux > [Résolu] Souci dwhelper et conversion audio/video
Dernier post

[Résolu] Souci dwhelper et conversion audio/video

Dens1 utilisateur non connecté France
Bonjour,
on en est où avec Buster ? J'ai un problème pour convertir des fichiers audio et video mmpeg à cause de ma version de libc6, 2.24 alors que downloadHelper (extension firefox) requière la 2.27. Quelqu'un a eu le cas et résout ça comment (j'ai pas envie de bidouiller avec la libc mrgreen ) ?

bda utilisateur non connecté France
Tu as quelle version de ffmpeg ou libav? En théorie, downloadhelper fait appel à l'un ou l'autre. J'en conclu que c'est ta version de ffmpeg ou libav qui est foireuse.
Il faut prendre la version des dépôts de ta distribution.
Avec un "which ffmpeg" et/ou "which avconv" pour savoir où se trouve le binaire et le supprimer si il ne vient pas des dépôts...
Les extensions FF sont en javascript et n'ont rien à voir avec la libc.

Dens1 utilisateur non connecté France
Bonjour,
les binaires viennent des dépôts, pas de prob de ce côté.
Je sais pas pourquoi j'ai mentionné la libc, mais il y avait un rapport, dans le message d'erreur. Toutefois on est d'accord c'est bien ffmpeg qui déclenche l'erreur et l'abandon.

$ apt-cache policy ffmpeg
ffmpeg:
  Installé : 7:3.2.14-1~deb9u1
  Candidat : 7:3.2.14-1~deb9u1
 Table de version :
 *** 7:3.2.14-1~deb9u1 500
        500 http://ftp.fr.debian.org/debian stretch/main amd64 Packages
        500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
        500 http://deb.debian.org/debian-security stretch/updates/main amd64 Packages
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
$ apt-cache policy avconv
N: Impossible de trouver le paquet avconv


La version demandée par l'extension est la 2.27, j'ai la 2.24, et je parlais bien de la libc6, lié à un problème de conversion donc sans doute de ffmpeg.
Pour ffmpeg, pas d'autre version dispo dans mes dépôts ...
Est-ce lié à la non-mise à jour de quelques paquets comme librazik-base-logicielsaudio librazik-logiciels-all (depuis un moment je ne peux les mettre à jour, car je dois leur préférer la version du dépôt LibraZik2 plutôt que Debian .. (?).

Je retente un download et je re avec le message exact, merci

bda utilisateur non connecté France
Est-ce que ffmpeg fonctionne en ligne de commande?
L'extension utilise la version de ffmpeg installée. Si un message d'erreur vient de ffmpeg, c'est soit qu'il ne fonctionne pas, soit que tu en as une seconde version installée quelque part et vue en priorité dans le PATH.
D'où l'intérêt de la commande which...

Dens1 utilisateur non connecté France

Impossible d'obtenir des informations du média 'JT Coldfire - She's Crazy - YouTube' dans le fichier '/tmp/vdh-15953K9Fnm8QkD29E.tmp'. Le fichier peut être corrompu.

{
    "file": "/tmp/vdh-15953K9Fnm8QkD29E.tmp",
    "stat": {
        "dev": 2055,
        "mode": 33188,
        "nlink": 1,
        "uid": 1000,
        "gid": 1000,
        "rdev": 0,
        "blksize": 4096,
        "ino": 32,
        "size": 23534079,
        "blocks": 45968,
        "atimeMs": 1574524853853.8262,
        "mtimeMs": 1574525004300.8699,
        "ctimeMs": 1574525004300.8699,
        "birthtimeMs": 1574525004300.8699,
        "atime": "2019-11-23T16:00:53.854Z",
        "mtime": "2019-11-23T16:03:24.301Z",
        "ctime": "2019-11-23T16:03:24.301Z",
        "birthtime": "2019-11-23T16:03:24.301Z"
    }
}
Exit code: 1
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffprobe: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavfilter.so.7)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffprobe: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavformat.so.58)
/opt/net.downloadhelper.coapp/converter/build/linux/64/ffprobe: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavcodec.so.58)

je vais faire un tour dans /opt/net.downloadhelper.coapp/ et le READFME dit :
vdhcoapp is an application providing the Video DownloadHelper add-on browser with:

- file access features that are not available from the browser
- a build of the ffmpeg video converter

vdhcoapp complies to the native messaging protocol (https://developer.mozilla.org/en-US/Add-ons/WebExtensions/Native_messaging)
and is not intended to be used directly from the command line.

vdhcoapp is free software under the Gnu Public License v2.0. Source code can be obtained from https://github/com/mi-g/vdhcoapp or as snapshot from https://github.com/mig/vdhcoapp/releases

Si je comprends bien il me fournit sa version de ffmpeg alors ?
il y a bien un binaire (ya pas que du javascript) :
ls -al /opt/net.downloadhelper.coapp/
drwxr-xr-x 4 root root  4096 nov.  22 07:55 .
drwxr-xr-x 4 root root  4096 nov.  22 07:55 ..
drwxr-xr-x 2 root root  4096 nov.  22 07:55 bin
-rw-rw-r-- 1 root root   456 juin  19 18:39 config.json
drwxr-xr-x 3 root root  4096 nov.  22 07:55 converter
-rw-rw-r-- 1 root root 18092 oct.  25  2017 LICENSE.txt
-rw-rw-r-- 1 root root   571 oct.  25  2017 README.txt


Je crois que c'est l'application qui va avec downloadhelper ça, l'appli amie qu'on m'a suggéré à l'install de DWHelper ... Il suffit peut-être de m'en séparer ... (?°°)

Dens1 utilisateur non connecté France
En effet :
$ ls -al /opt/net.downloadhelper.coapp/converter/build/linux/64/
ffmpeg                  libavformat.so.58       libopencore-amrnb.so.0  libswresample.so.3      libvorbisfile.so.3      libx264.so.152
ffplay                  libavresample.so.4      libopencore-amrwb.so.0  libswscale.so.5         libvorbis.so.0          libx265.so.130
ffprobe                 libavutil.so.56         libopenjp2.so.7         libtheoradec.so.1       libvpx.so.5             libxvidcore.so.4
libaom.so.0             libbz2.so.1.0           libopus.so.0            libtheoraenc.so.1       libwebpdecoder.so.3     libz.so.1
libavcodec.so.58        libmp3lame.so.0         liborc-0.4.so.0         libtheora.so.0          libwebpdemux.so.2       
libavdevice.so.58       libnuma.so.1            liborc-test-0.4.so.0    libvo-amrwbenc.so.0     libwebpmux.so.3         
libavfilter.so.7        libogg.so.0             libpostproc.so.55       libvorbisenc.so.2       libwebp.so.7            
denis@zikimao:~$ ls -al /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg
-rwxr-xr-x 1 root root 264320 juin  19 15:52 /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg

tandis que which ffmpeg : /usr/bin/ffmpeg

...

je vais virer VdhCoApp ... on va bien voir.

Dens1 utilisateur non connecté France
Nos messages se croisent, l'extension fait appel à une appli compagnon qui utilise sa propre version de ffmpeg si j'ai bien capté, c'est nimp. Attends je vire l'app.

Dens1 utilisateur non connecté France
Ok j'ai capté ...
L'appli compagnon est imposée pour dwhelper, pas le choix que de la réinstaller après sa suppression. Par contre c'est bien le ffmpeg de son rep /build qui merdoie. Donc implement,

# cd /opt/net.downloadhelper.coapp/converter/build/linux/64
# mv ffmpeg ffmpeg.bug && ln -s /usr/bin/ffmpeg

Et basta.

Dens1 utilisateur non connecté France
Pardon, j'ai cru que c'était lié à mes versions de paquet et notamment libc6 ... confusion.

bda utilisateur non connecté France
Je me disais bien qu'il y avait deux versions de ffmpeg installées. N'utilisant pas downloadhelper, je n'aurai pas imaginé qu'il installe quoi que ce soit pour Linux. C'est assez surprenant et complètement idiot AMA.

L'important est que tout soit rentré dans l'ordre :-)

Dens1 utilisateur non connecté France
Clairement Nimp oui ;-)
Merci à toi.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 21:36, mer. 01 Apr 2020: Bonjour et bienvenue à simon_martineau, martineau_simon, et à Roland57 cool
olinuxx, 20:13, mar. 31 mars 2020: Bonjour et bienvenue à sethi1cool
Nolwen, 22:46, lun. 30 mars 2020: Sortie d'Hydrogen 1.0.0-beta 2 ce 30 mars 2020. [Lien]
olinuxx, 17:39, lun. 30 mars 2020: Bonjour et bienvenue à JulienRadio cool
sub26nico, 23:48, dim. 29 mars 2020: Salut et bienvenue à Chihiro49130, Gigi, Ptilou, yudas, FF63, mimifloch, mvvl et tophque :-)
malt, 15:55, dim. 29 mars 2020: @Sahaathyva. Je n'avais pas vu ton post!
malt, 15:51, dim. 29 mars 2020: Ardour 6.0-pre1: [Lien]
sub26nico, 20:50, ven. 27 mars 2020: Salut et bienvenue à Topyweb, Serge Samson, ChtiJeff, Zeplead et Zonzon :-)
r1, 20:27, ven. 27 mars 2020: La joute 15 est sur les rails ! [Lien] Viendez jouer avec nous !!!
bluedid29, 17:13, ven. 27 mars 2020: Bon week-end, à fond encore sur Musescore et LibraZik-2... ...bientôt utilisation régulière sur LibraZik-3...
sub26nico, 14:11, ven. 27 mars 2020: @tolliac, ouvres un fil spécifique dans les forums.
tolliac, 11:41, ven. 27 mars 2020: Bonjour, je ne me suis intéressé jusqu'ici qu'à l'écriture de partitions via lilypond et Frescobaldi et pour résoudre des problèmes de lecture de fichiers MIDI je me retrouve dans l'univers de la MAO chaleureusement accueilli mais complètement perdu. quel