Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [RÉSOLU] AudioFire 12 (marque ECHO) en 192 kHz !
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

[RÉSOLU] AudioFire 12 (marque ECHO) en 192 kHz !

l_d_v_c utilisateur non connecté
Bonjour,

Le but étant de me servir de la carte sonore AudioFire 12 avec Ubuntu 10.10, je me suis appuyé sur ce sujet récent dans lequel l'auteur a réussi la connexion avec l'AudioFire 8 et Ubuntu 10.04.

En suivant pas-à-pas la procédure de compilation de FFado, ça plante avec :

[+]

Pourtant libdbus-1-3, libdbus-c++-1-0, libdbus-c++-dev, sont installées.

Avez-vous une piste s'il-vous-plait ?
Merci.

Samuel utilisateur non connecté Allemagne
Salut,

bon, a priori tu n'aurais même pas besoin de compiler, vu que la version de ffado dans ubuntu 10.10 est la dernière en date.
Quand tu lances le tout normalement, quel est le message d'erreur de jack ?
Et que renvoie la commande ffado-diag ?
Et que renvoie la commande lspci ? pour savoir quel est ton chipset firewire.

l_d_v_c utilisateur non connecté
Bonjour Samuel,

Merci.
lspci retourne
04:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev 46)


l_d_v_c utilisateur non connecté
J'ai vu passer une mise-à-jour de FFado, je vais refaire des essais.

l_d_v_c utilisateur non connecté
Bonjour,
Avec deux câbles différents, j'obtiens l'erreur :
ffado-dbus-server
-----------------------------------------------
FFADO Control DBUS service
Part of the FFADO project -- www.ffado.org
Version: 2.999.0-
(C) 2008, Pieter Palmers
This program comes with ABSOLUTELY NO WARRANTY.
-----------------------------------------------

01643827173:  (ffado-dbus-server.cpp)[ 270] main:  Discovering devices...
01643881305: Fatal (devicemanager.cpp)[ 191] initialize: No firewire adapters (ports) found.
01643881356: Error (ffado-dbus-server.cpp)[ 277] main: Could not initialize device manager
01643881489: Debug (ffado-dbus-server.cpp)[ 202] exitfunction: Debug output flushed...

$lspci|grep 1394
04:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev 46)

ffado-diag retourne une liste énorme qui ne passe pas en entière...

l_d_v_c utilisateur non connecté
D'accord, la fin de ffado-diag
=== REPORT ===
FireWire kernel drivers:

The new FireWire kernel stack is loaded. 
This stack is not supported by FFADO. Please use the old stack.


l_d_v_c utilisateur non connecté
$ jackd -d firewire
jackdmp 1.9.6
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
could not open driver .so '/usr/lib/jack/jack_oss.so': /usr/lib/jack/jack_oss.so: undefined symbol: _jack_get_microseconds
no message buffer overruns
could not open component .so '/usr/lib/jack/jack_oss.so': /usr/lib/jack/jack_oss.so: undefined symbol: _jack_get_microseconds
`default' server already active
Failed to start server


SyGEN utilisateur non connecté
Si ca t'intéresse toujours, je viens de passer la journée à essayer de connecter 4 audiofire 12 chainées à UbuntuStudio 10.10 (la seule qui marche pour moi).

Que du bonheur, tout marche enfin et les enregistrements se font parfaitement dans ardour sur les 48 pistes.

J'écrirai un petit tuto demain.

l_d_v_c utilisateur non connecté
Avé SyGEN !!!

OUI ça m'intéresse doublement car le but serait plus tard de chainer 2 AudioFire 12 pour un vrai 24 pistes... Éventuellement une troisième pour un 36 pistes...

Puis ça va permettre de comprendre ce que j'ai zappé...

Merci SyGEN !

Édit 201011112113 : SyGEN nous donne la solution juste après qui a fonctionné du premier coup sans même redémarrer l'ordinateur...

SyGEN utilisateur non connecté
Bon voilà comment je m'y suis pris.

À la base je suis parti d'une UbuntuStudio 10.04, sur laquelle j'avais fait un
apt-get remove --purge de ffado
et ffado-dbus-server (pour ne plus avoir de fichier de config résidents).
Ensuite suivi comme toi le tuto pour les audiofire 8 -> download depuis subversion de ffado et jack + compil.

Mais impossible à lancer sans problèmes de compatibilité, ceci dit, je les ai laissé installés eux.

Bref, de là j'ai télécharger la 10.10, gravé, tu mets le cd dedans il détecte l'upgrade de version, que tu fais bien évidemment (et donc ou il t'installe un nouveau ffado mixer? sans tes anciens fichiers de config dans l'interface implicitement).

J'imagine qu'une fresh install de la 10.10 serait équivalente (mais dans le doute j'ai quand même décrit ce que j'avais fait parce que, comme toi, j'en ai chié pas mal aussi pour enfin avoir mes AF 12 qui fonctionnent).

Reboot en 10.10 avec juste ffado mixer (que tu as à présent dans gnome)

Maintenant tu réinstalles ffado-dbus-server :
sudo apt-get install ffado-dbus-server

Je l'ai réinstallé du cd-rom d'install perso.

Tu checks ce que ca donne en le lançant en console : ffado-dbus-server (sans le &)
Normalement tu vas tomber sur un conflit firewire (en tout cas c'était mon cas).

Tu crées (en root) un fichier fw1394.sh (ou le nom qu'il te plaira) dans /etc/init.d/

Tu y colles ceci (qui vient du forum ubuntu) :

#!/bin/sh
#Unloads all FireWire drivers and loads older FireWire stack
#30.10.2010 by "ajaaskel" @ Ubuntu Forum
sudo modprobe -r video1394
sudo modprobe -r firewire-sbp2
sudo modprobe -r sbp2
sudo modprobe -r dv1394
sudo modprobe -r firewire-ohci
sudo modprobe -r raw1394
sudo modprobe -r ohci1394
sudo modprobe raw1394
sudo modprobe dv1394
sudo modprobe sbp2
sudo modprobe dv1394
sudo modprobe video1394
echo
echo '*** Load also ffado-dbus-server if you need ffado-mixer. ***'
echo
sleep 5


tu sauves et tu le "chmod 775"

tu fais ensuite (toujours en root) un
ln -s /etc/init.d/fw1394.sh /etc/rcS.d/S71FireWire

donc un nouveau lien dans /etc/rcS.d/ que tu nommes S71FireWire (ou le nom qu'il te plaira, faut juste qu'il soit en dernier dans tes fichiers de boot).

À ce niveau là, deux options.
Ou tu reboot tout de suite ou tu fais un test en manuel.

Pour le manuel :

  • sudo sh /etc/init.d/fw1394.sh
    (ca va donc exécuter le script)
  • ffado-dbus-server

Et là le serveur dbus devrait être lancé tu ne fermes ni ne touches rien à la console.
Tu lances ffado mixer? via gnome (avec ton ou tes audiofire connectés et ON).

Logiquement tu auras la console pour les piloter.

Pour le reboot:
Tu ouvres ffado mixer d'office toujours via le bureau et pas la console et ca devrait t'afficher la console des audiofire directement mais là t'auras pas de débug. (teste le manuel en premier).

Après tu ouvres jack control (toujours via gnome), qui va reconnaitre tes connexions firewire et te faire normalement déjà les liens qui vont bien. Si pas tu fais ta config et l'active et tu démarres le serveur de là.

Puis tu ouvres ardour, y va prendre d'office ffado en suivant jack, tu vires la piste général ou master stéréo, tu ajoutes tes 12 pistes mono, et c'est parti, tu mets chaque piste en record et les Vu-Meters et l'enregistrement fonctionnent.



Alors, notice :

AudioFire préconise un chipset Texas-Instruments pour le 1394.
Je vois que t'as du VIA ... c'est peut être une source de soucis mais j'en ai aucune idée réelle.

J'ai perso suivi leur recommandations et mon chip est :
02:0b.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)

Je travaille avec le firmware 4.8 sur les AF12. En passant au 5.5, même sur nuendo avec windows, impossible de débloquer le 192Khz sous XP. Sous Vista, impossible de changer quoi que ce soit tout court!

Ne pas oublier que si tu travailles en chaine, tu dois passer ta clock non plus en internal mais en wordclock et travailler en 96Khz sur toute la chaine.

Voilà, premier jet, j'éditerai si j'ai commis des erreurs, mais ca me semble cohérent.

l_d_v_c utilisateur non connecté
GÉNIAL !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

ÇA FONCTIONNE ET EN 192 kHz !!!!!!!!

Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN ! Merci SyGEN !

olinuxx utilisateur non connecté France
Cool, merci pour ce retour !

Du coup j'ai créé une page dédiée pour l'Echo audiofire 12 qui linke vers ici.
Si vous voulez la remplir pour les suivants, c'est cool cool

a+
Olivier, qui laisse trainer ce fil quelques jours avant de le fermer.

l_d_v_c utilisateur non connecté
Peut-on aussi avoir le MIDI IN/OUT en plus des 12 E/S ? ce serait complet...(j'ai peut-être loupé quelque chose après-tout...)

SyGEN utilisateur non connecté
Je sais qu'il est présent dans la version windows, mais hélas il ne me semble pas implémenté dans ffado mixer? (ou dbus) pour Le système GNU Linux.

Je ne l'ai pas là devant moi mais ca serait plutôt une question a leur poser directement sur leur forum (s'ils en ont un).

À creuser.

PS. De rien l_d_v_c :-) Content que ca t'aies aidé !

@Olivier, promis je remplirai le nouveau sujet dès demain ou cette nuit.

Samuel utilisateur non connecté Allemagne
Le midi il est pas dans l'onglet midi de qjackctl avec les nouvelles versions de ffado ?

SyGEN utilisateur non connecté
Je suis pas au studio pour te répondre, mais en tout cas sous windows tu as la config du midi dans l'interface des audiofire 12. Chose qui à pas dans l'interface Le système GNU Linux.

Comme j'en ai pas besoin j'ai pas trop creusé le sujet mais si tu trouves je suis quand même preneur lol

l_d_v_c utilisateur non connecté
Pas de MIDI apparent pour le moment avec qjackctl cependant j'ai les E/S qui vont de 0 à 11 (soient les 12 E/S) et une treizième ligne E/S sans numéro. eek

Samuel utilisateur non connecté Allemagne
Salut, si tu n'as pas de MIDI dans l'onglet MIDI ou alsa de qjackctl, c'est qu'il a été oublié à la compilation.

l_d_v_c utilisateur non connecté
Salut Samuel,
Pardon je précise pas de possibilité apparente d'utilisation du MIDI de la carte AudioFire 12 avec qjackctl en FireWire. D'ailleurs cela me pose un nouveau problème : comment se servir du Behringer BCF2000 en mode mackie avec Ardour en jack/alsa via l'Usb pour contrôler la carte AudioFire 12 en même temps que jack/firewire...
J'ai aperçu que je pouvais peut-être lancer 2 serveurs qjackctl distincts... J'aimerais lancer l'un en Alsa, l'autre en FireWire... (instance double ? à suivre...nouveau sujet...)

Au passage je signale que sur la carte audioFire 12 avec FFADO, les E/S pour le FireWire sont décalées de 2 :
firewire_audiofire0 : voie 2
firewire_audiofire1 : voie 3
firewire_audiofire2 : voie 4
firewire_audiofire3 : voie 5
firewire_audiofire4 : voie 6
firewire_audiofire5 : voie 7
firewire_audiofire6 : voie 8
firewire_audiofire7 : voie 9
firewire_audiofire8 : voie 10
firewire_audiofire9 : voie 11
firewire_audiofire10 : voie 12
firewire_audiofire11 : ????? je cherche ce que c'est...
firewire_audiofire : voie 1

Merci

olinuxx utilisateur non connecté France
Coucou

(mode : modo' = on)
Je ferme ou pas ?
(mode = off)

wink
a+
Olivier

l_d_v_c utilisateur non connecté
Bonjour Olivier !

On va dire résolu ! le 192kHz fonctionne, il est possible de chaîner au moins 4 AF12 en 96kHz... je continue de chercher l'histoire du MIDI de mon coté.

Merci à tous !
Merci à LinuxMAO !

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

bluedid29, 21:05, dim. 19 Nov 2017: Sortie de LibraZiK 2 :-) [Lien]
sub26nico, 13:48, dim. 19 Nov 2017: Salut et bienvenue à JohnWebster :-)
sub26nico, 00:18, dim. 19 Nov 2017: Salut et bienvenue à jjs95 :-)
bluedid29, 04:28, sam. 18 Nov 2017: Bon samedi musical ! :-) Je sens qu'aujourd'hui il va faire beau ;)
sub26nico, 20:38, ven. 17 Nov 2017: Salut et bienvenue à caline10mao :-)
sub26nico, 18:33, jeu. 16 Nov 2017: Salut et bienvenue à BlackVelvet :-)
sub26nico, 13:47, jeu. 16 Nov 2017: Salut et bienvenue à RnoxMadTan :-)
sub26nico, 23:32, mer. 15 Nov 2017: Salut et bienvenue à niconico :-)
sub26nico, 23:53, mar. 14 Nov 2017: Salut et bienvenue à jpcima :-)
olinuxx, 17:25, dim. 12 Nov 2017: Bonjour et bienvenue à loik56 :-)
sub26nico, 14:52, dim. 12 Nov 2017: Salut et bienvenue à NahMecl :-)
sub26nico, 01:23, dim. 12 Nov 2017: Salut et bienvenue à pitoufo3 :-)