Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > Configuration de ma carte son sous Reaper
Dernier post

Configuration de ma carte son sous Reaper

sylvko utilisateur non connecté
Bonjour à tous !

Alors voilà quelques temps que je n'étais pas venu faire un tour sur ce forum car manque de temps à accorder à la MAO, mais j'ai bien l'intention de m'y remettre !

Voilà, je suis sous Xubuntu. J'ai installé Wine afin de pouvoir utiliser Reaper.
Jusqu'ici tout se passe bien, sauf que Reaper ne reconnait pas ma carte son. Quand je vais sur options/préférences/périphérique/Système audio, si je sélectionne Asio, il me dit "Pilotes Asio Introuvables"
J'ai cherché un peu sur ce forum mais rien trouvé ...
Ma carte son est une M AUDIO Fast track Ultra
Mes connaissances, qu'il s'agisse d'informatique ou de MAO sont très empiriques et je bloque vite sur ce genre de problème ...

Des idées ?

Merci beaucoup !!

olinuxx utilisateur non connecté France
Note admin-forum : doublon de message effacé comme demandé.


olinuxx utilisateur non connecté France
Je n'ai pas d'expérience avec ça, mais il est probable qu'il te faille wineasio.

sub26nico utilisateur non connecté France
@ sylvko, je confirme la remarque d'olinuxx, il te faut installer wineasio pour que
les applications audio/midi windows puisse être effective sous wine.

Je me permets une petite remarque, Reaper propose une version beta native linux,
qui à peu de choses près, est aussi fonctionnelle que sur les autres OS.

Le manque principal est le support des LV2 qui n'est pas encore implanté, que l'on contourne
facilement avec Carla. Par contre si tu souhaites utiliser des VST windows, wineasio sera
demandé, sur la version native comme sur la version Windows.

sylvko utilisateur non connecté
Bonjour
Merci pour vos messages !
Alors pour wineasio ... a vrai dire je n'arrive pas à comprendre comment on l'installe.
J'ai essayé de suivre les liens :
https://sourceforge.net/projects/wineasio/
et
https://www.steinberg.net/en/company/developers.html

J'ai téléchargé les fichiers wineasio-0.9.2.tar.gz et asiosdk2.3.zip mais je n'arrive pas à les installer

Sinon, effectivement une version Linux de reaper serait le top, mais je ne trouve pas de lien de téléchargement

Merci beaucoup !

sub26nico utilisateur non connecté France
sylvko écrit :
Sinon, effectivement une version Linux de reaper serait le top, mais je ne trouve pas de lien de téléchargement

C'est normal, les dévs ne souhaitent pas que lien soit divulgué hors des forums de Reaper,
cette version étant encore en développement, il est préférable pour eux que les discussions
se passent dans les colonnes prévues à cet effet.
En gros, tu vas sur cette page ,
au premier chapitre, tu cliques sur 'LANDOLEET', puis tu choisis la version Linux
qui convient à ton système ('reaper577rc3_linux_armv7l.tar.xz' pour un Raspberry Py,
'reaper577rc3_linux_i686.tar.xz' pour un OS 32 bits ou 'reaper577rc3_linux_x86_64.tar.xz'
pour un système 64bits'). Tu décompresses l'archives dans le répertoire de ton choix et tu
lances l'installation avec le fichier 'reaper5' dans le dossier décompressé.
Pour le reste, c'est similaire aux versions proprios. Si tu souhaites utiliser les extensions SWS,
il y a une version linux dans le sous-dossier 'Dev' du LANDOLEET', mais de mémoire elle n'était pas
totalement fonctionnelle. Un utilisateur (également membre de LinuxMao) en a compilé une qui
marche très bien, que tu peux trouver dans ce forum , que je te conseille de rejoindre en plus d'ici. Si tu n'utilises pas les SWS, ignore cette phrase, et reviens y
quand tu en auras l'utilité.
N'hésites pas en cas de problème, ici ou là-bas.

sylvko utilisateur non connecté
Bonsoir !
Merci ! Génial !
Bon alors voilà chose faite, j'ai réussi à télécharger reaper et même à le mettre en français (d'ailleurs tout n'est pas en français c'est assez bizarre) ! Youpi !
Par contre une fois sur les préférences, sur "périphériques", je selectionne ma carte son en entrées et sorties, et quand je clique sur OK, voici le petit message que je reçois :

"There was an error opening the audio hardware:

ALSA: error opening output device"

Et là ... ben je trouve pas comment faire neutral... ma carte son est branchée, est-ce qu'il me faut installer un pilote ?

Merci wink

sub26nico utilisateur non connecté France
On dirait que Jack est lancé avant que tu lances Reaper.
Si c'est le cas, soit tu choisis Jack comme serveur son pour Reaper,
soit tu éteins Jack avant de lancer Reaper si tu souhaites utiliser Alsa.
Si ce n'est pas ça, c'est que ta carte n'est pas reconnue par Alsa, ce qui semblerait surprenant.
Peux tu donner stp le retour de terminal de
uname -a


sylvko utilisateur non connecté
Bonjour
Alors effectivement je lançais qjack, et j'ai fini par trouver, j'avais mal configuré qjack pour la sortie ... suis pas encore complètement au point
Mais par contre, il ne me propose pas Alsa ... et j'aimerais l'utiliser car avec qjack j'ai 32ms de latence ...

Voici le retour de terminal :

Linux sylvain-TECRA-M5 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:12 UTC 2014 i686 i686 i686 GNU/Linux

et merciwink !

sylvko utilisateur non connecté
oups je sais pas ce que j'ai fait mais ça y'est ça marche ... après avoir relancé, éteint qjack et puis reaper ...
Par contre grosse latence (en haut a droite sur reaper) :
11/23ms

du coup quand je selectionne l'écoute enregistrement, si par exemple je claque des doigts, j'entends un mini delay

sub26nico utilisateur non connecté France
Normal que tu aies autant de latence, tu utilises un noyau générique sur une distribution
non optimisée pour la mao. Donc en premier lieu, je te conseillerais d'installer un noyau
basse-latence (low-latency) ou temps réel (real-time) qui sont configurés pour diminuer la latence,
en autres choses. Il te faudra aussi optimiser ton système, en suivant cette page.
Il est possible aussi qu'il faille d'autres réglages du systèmes par la suite.

C'est l'intérêt des distributions 'spécialisées', tous ces réglages sont déjà faits,
c'est donc directement utilisable. Si tu ne souhaites pas faire toutes ces étapes de
configurations du système, il peut être intéressant pour toi de t'orienter vers une de ces
distributions audio. KX Studio et Ubuntu Studio sont basées sur Ubuntu,
AV linux, LibraZiK ou Io.gnu.linux sur Debian.

Si tu souhaites rester sur ta distib' actuelle, le mieux est de rajouter les dépôts de KX Studio,
qui fournit un noyau optimisé ainsi qu'une multitude d'applications musicales.
Mais il te faudra faire ces optimisations quand même.

olinuxx utilisateur non connecté France
De mémoire, KX studio ne fourni lui-même pas de noyau spécifique. Me trompé-je ?

sub26nico utilisateur non connecté France
Je vérifie....

sylvko utilisateur non connecté
Ok bon je répond à mon propre post, histoire qu'il puisse servir à un débutant comme moi (corrigez-moi si je me trompe !!)

Ce que j'ai cru comprendre, c'est que pour gérer la latence, il faut compenser avec l'espace-tampon (sous reaper apparemment c'est "blocksize" dans préférences/audio/pérépherique.
Plus on alloue de mémoire tampon, plus on permet de calculs aux logiciels (donc moins de craquements entre autres), mais plus on a de latence si on a comme moi un ordi un peu vieillot
Et par contre moins on alloue de mémoire-tampon et moins on a de latence, avec les risques de ralentissement et de craquements ...

128 de mon côté serait l'idéal avec une latence 2,9/5,8 ... ça vous parait comment ?

sylvko utilisateur non connecté
Ah je viens de voir vos réponses, je vais lire tout ça !

sub26nico utilisateur non connecté France
olinuxx écrit :
De mémoire, KX studio ne fourni lui-même pas de noyau spécifique. Me trompé-je ?

Eh bien non, c'est moi qui ait dit nawak redface.
En fait, sylvko, tu peux installer un noyau 'reel-time' à partir des
dépôts d'Ubuntu. Il te faudra ensuite modifier la PAM, voir
rtirq, olinuxx, corriges moi si dit encore une coquille.


sylvko écrit :
Ce que j'ai cru comprendre, c'est que pour gérer la latence, il faut compenser avec l'espace-tampon (sous reaper apparemment c'est "blocksize" dans préférences/audio/pérépherique.
Plus on alloue de mémoire tampon, plus on permet de calculs aux logiciels (donc moins de craquements entre autres), mais plus on a de latence si on a comme moi un ordi un peu vieillot
Et par contre moins on alloue de mémoire-tampon et moins on a de latence, avec les risques de ralentissement et de craquements ...

128 de mon côté serait l'idéal avec une latence 2,9/5,8 ... ça vous parait comment ?


Si tu utilises Alsa, oui c'est bien cela. Après le réglage dépend de l'optimisation de ton système, mais aussi de la puissance de ton processeur
ou de ta carte son. Car si un réglage avec un buffer bas, la latence diminue,
les décrochages audio (x-runs) vont vite apparaître quand tu vas multiplier
les pistes ou rajouter des effets ou des instruments virtuels.

olinuxx utilisateur non connecté France
Il est communément admin qu'une latence en dessous de 20ms est confortable pour la MAO dans la plupart des cas.

sylvko utilisateur non connecté
OK
Merci beaucoup pour ces conseils, j'y vois déjà beaucoup plus clair
Bon maintenant il me reste à continuer à me plonger dans tout ça, comprendre ce qu'est une distribution, un noyau ... va me falloir un peu de temps !
Bon en tout cas j'ai pour ma part la réponse à ma question : 128 (MB ?) c'est trop faible car la moindre recherche sur mon navigateur en même temps que reaper est ouvert me rajoute une magnifique disto ...
A bientôt !

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

olinuxx, 07:25, lun. 18 Jun 2018: @BrnVrn; réponse courte (mégaphone oblige) : oui et non. Ouvre un sujet dans le forum pour des réponses plus longues.
sub26nico, 22:42, dim. 17 Jun 2018: Salut et bienvenue à BrnVrn :-)
BrnVrn, 20:07, dim. 17 Jun 2018: LADSPA est-il obsolete ? On trouve du LADSPA parce qu'il y a beaucoup de legacy ou c'est utilisé sur de nouveau projets ?
sub26nico, 15:43, dim. 17 Jun 2018: Salut et bienvenue à ledufakademy :-)
olinuxx, 11:22, sam. 16 Jun 2018: Une nouvelle version du MOD Duo est apparue : [Lien]
sub26nico, 20:17, ven. 15 Jun 2018: Un éditeur audio original multiplateforme : [Lien]
sub26nico, 13:45, ven. 15 Jun 2018: Salut et bienvenue à Onerrach :-)
olinuxx, 19:23, mer. 13 Jun 2018: Bonjour et bienvenue à Zuardent :-)
sub26nico, 00:35, mer. 13 Jun 2018: Salut et bienvenue à milie :-)
sub26nico, 20:53, sam. 09 Jun 2018: @Nolwen, ça fonctionnait ici avec firefox
Nolwen, 18:46, sam. 09 Jun 2018: Bon, ce n'est pas que le son était de si mauvaise qualité, c'était surtout que FalkTX parlait tout bas (ou bien que son micro était trop loin de sa voix)...
Nolwen, 17:25, sam. 09 Jun 2018: Ah si, il faut un navigateur basé sur Chromium (Yandex en l'occurence). Firefox ESR ne fonctionne pas ! Youpi !