Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > ( Abandonné ) Souci avec FA66 Firewire et Jackd
Dernier post

( Abandonné ) Souci avec FA66 Firewire et Jackd

jmpc utilisateur non connecté
Salut à tous ,

Après deux jours de bataille et malgré la doc très complète sur Linuxmao , je ne suis pas arrivé à faire démarrer Jackd alors que la carte est parfaitement reconnue par FFADO : error creating virtual device . Je précise que je suis sur le new stack et sur Librazik 2 smile .

Première surprise : autant la carte est reconnue par FFADO , autant elle n' apparaît nulle part dans le système , ni avec aplay -l , ni avec cat /proc/asound/cards … peut-être est-ce normal … ou pas et c' est peut-être pour cela que Jackd ne la trouve pas …

J' ai donc tenté l' aventure avec Alsa : j' ai whitelisté Bebob et là , la carte apparaît bien dans le système et dans Alsa mais Jackd ne démarre toujours pas avec Freebob … même erreur ...

Je crains donc que ce soit le firmware de la carte Firewire ( 02 Micro inc ??? ) qui foute le bordel mais , avant d' investir dans une carte PCMCIA avec un firmware Texas Instrument qui n' est pas donnée , je voulais votre avis , surtout sur le fait que la carte n' apparaisse pas dans le systeme avec Bebob blacklisté .

Merci smile .
A plus .

JMPC

olinuxx utilisateur non connecté France
Citation :
J' ai donc tenté l' aventure avec Alsa : j' ai whitelisté Bebob et là , la carte apparaît bien dans le système et dans Alsa mais Jackd ne démarre toujours pas avec Freebob … même erreur ...


Si tu as mis bebob (un pilote ALSA) sur liste blanche, alors il te faut utiliser le pilote "ALSA" dans qjackctl/cadence, pas le pilote Freebob (ni FFADO).

jmpc utilisateur non connecté
Salut olinuxx .

Merci pour ta réponse aussi rapide smile . Ok , j' ai re withelisté Bebob et oui , Jackd démarre en choisissant Alsa mais ... une pluie de xruns s' abat dessus , juste en écoutant un morceau ... et à 2048 en taille de tampon ... De toute façon , ça plante Cadence et c' est totalement inutilisable ... smile .

L' ami Bebob va donc repartir dans le côté sombre du systeme .

De plus , avec Bebob blacklisté et en envoyant ffado-mixer par le terminal , j' ai un message ( que je n' ai pas en lançant avec le raccourci ) disant : sample rate not supported by input plug ... je crains que la piste du firmware de la carte firewire soit la bonne ... va falloir casser la tirelire ...

Dès que je me serai procuré la carte PCMCIA , je reposterai ... je l' espère , pas pour demander de l' aide mais pour annoncer que ça fonctionne smile .


Encore merci biggrin .

À très vite .

JMPC

dlb utilisateur non connecté
Bonsoir Jmpc,

Mon portable Dell possède aussi une sortie firewire gérée par une puce "Micro 02 inc" et fonctionne parfaitement sur mes deux cartes firewire, l'une avec un contrôleur BEBOB ( Presonus FP10), l'autre avec un contrôleur "DICE" (Presonus firestudio 2626). Et le contrôleur Micro 02 fonctionne aussi bien que l'expresscard dotée d'un chip Texas Instrument.
J'ai "blacklisté" les modules snd_bebob et snd_dice pour que jackd fonctionne correctement. Via qjackctl, j'ai pris le pilote "firewire" (il me semble que freebob n'existe plus depuis longtemps et ne fonctionne plus, c'est peut-être là la cause de ton problème avec jackd) Et surtout, j'ai installé un kernel rt, parce qu'avec ffado, sans rt, les perf de jackd sont vraiment très mauvaises ( xrun en pagaille et latence ingérable en "live" ).
Le seul gros bémol, mais ça n'a certainement rien à voir avec "Micro 02 inc", (parce que c'est pareil en utilisant une expresscard TI) c'est que ces deux cartes, du fait probable de leur chipset différent, ne se synchronisent pas et ne sont donc pas chaînables entre elles ...
A noter encore que bien que jackd et "Micro 02 inc" fonctionnent avec ces deux cartes, ffado-mixer ne se lance pas du tout avec la firestudio 2626 ... ( mais avec la FP10, oui ... ) Et enfin, quand ffado-mixer se lance, j'ai aussi ces messages "sample rate not supported" ... qui n'ont pas l'air d'avoir de conséquence ...

Tout ça sous Debian Stretch + backports

jmpc utilisateur non connecté
Bonjour dlb .

C" est une super information que tu me donnes là , merci smile , je vais continuer à batailler .

Je suis sur Librazik 2 , avec le kernel rt , et toutes les manips pour faire fonctionner le Firewire sont déjà par défaut dans la distrib smile . J ai repris pas à pas les docs et expérimenté la prise en charge par Alsa ( merci olinuxx smile ) car ça ne fonctionne pas sur ma machine mais tout est déjà parfaitement installé et configuré pour que ça tourne avec FFADO sur Librazik biggrin .

Un truc m" échappe et me chiffonne ... pourquoi la carte n' apparaît pas quand je fais un aplay -l ... elle apparaît , sur ta machine ? Je précise que sur qjackctl et sur cadence , j' ai testé hw:0 et hw:1 ... au hasard puisque je n' ai aucune info système ...

A tout hasard aussi , mon ffado-diag

FFADO diagnostic utility 2.3.0-Unversioned directory
============================
(C) 2008 Pieter Palmers
    2009-2010 Arnold Krille


=== CHECK ===
 Base system...
  kernel version............ 4.9.0-6-lzk-rt-amd64
    Preempt (low latency)... False
    RT patched.............. True
  old 1394 stack present.... False
  old 1394 stack loaded..... False
  old 1394 stack active..... False
  new 1394 stack present.... True
  new 1394 stack loaded..... True
  new 1394 stack active..... True
  /dev/raw1394 node present. False
  /dev/fw* permissions:
crw-------  1 root root  247, 0 août   7 19:24 /dev/fw0
crw-rw----+ 1 root audio 247, 1 août   7 19:24 /dev/fw1
  User IDs:
uid=1000(aitor) gid=1000(aitor) groupes=1000(aitor),0(root),4(adm),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),108(netdev),113(lpadmin),115(scanner)
 Prerequisites (dynamic at run-time)...
   gcc ............... sh: 1: gcc: not found
   g++ ............... sh: 1: g++: not found
   PyQt4 (by pyuic4) . sh: 1: pyuic4: not found
   jackd ............. jackdmp version 1.9.12 tmpdir /dev/shm protocol 8
     path ............ /usr/bin/jackd
     flags ........... sh: 1: pkg-config: not found
   libraw1394 ........ sh: 1: pkg-config: not found
     flags ........... sh: 1: pkg-config: not found
   libavc1394 ........ sh: 1: pkg-config: not found
     flags ........... sh: 1: pkg-config: not found
   libiec61883 ....... sh: 1: pkg-config: not found
     flags ........... sh: 1: pkg-config: not found
   libxml++-2.6 ...... sh: 1: pkg-config: not found
     flags ........... sh: 1: pkg-config: not found
   dbus-1 ............ sh: 1: pkg-config: not found
     flags ........... sh: 1: pkg-config: not found
 Prerequisites (static at compile-time)...
   gcc ............... gcc (Debian 6.3.0-18) 6.3.0 20170516
   g++ ............... g++ (Debian 6.3.0-18) 6.3.0 20170516
   PyQt4 (by pyuic4) . Python User Interface Compiler 4.11.4 for Qt version 4.8.7
   jackd ............. sh: 1: jackd: not found
     path ............ 
     flags ........... Package jack was not found in the pkg-config search path.
   libraw1394 ........ 2.1.2
     flags ........... -lraw1394
   libavc1394 ........ Package libavc1394 was not found in the pkg-config search path.
     flags ........... Package libavc1394 was not found in the pkg-config search path.
   libiec61883 ....... 1.2.0
     flags ........... -liec61883 -lraw1394
   libxml++-2.6 ...... 2.40.1
     flags ........... -I/usr/include/libxml++-2.6 -I/usr/lib/x86_64-linux-gnu/libxml++-2.6/include -I/usr/include/libxml2 -I/usr/include/glibmm-2.4 -I/usr/lib/x86_64-linux-gnu/glibmm-2.4/include -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/sigc++-2.0 -I/usr/lib/x86_64-linux-gnu/sigc++-2.0/include -lxml++-2.6 -lxml2 -lglibmm-2.4 -lgobject-2.0 -lglib-2.0 -lsigc-2.0
   dbus-1 ............ 1.10.18
     flags ........... -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -ldbus-1
 uname -a...
   Linux debian 4.9.0-6-lzk-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.88-1+deb9u1 (2018-05-07) x86_64 GNU/Linux
 Hardware...
   Host controllers:
48:03.4 FireWire (IEEE 1394) [0c00]: O2 Micro, Inc. Firewire (IEEE 1394) [1217:00f7] (rev 07) (prog-if 10 [OHCI])
	Subsystem: Fujitsu Limited. Firewire (IEEE 1394) [10cf:14d7]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
	Latency: 32, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at f2502000 (32-bit, non-prefetchable) [size=4K]
	Region 1: Memory at f2500800 (32-bit, non-prefetchable) [size=2K]
	Capabilities: <access denied>
	Kernel driver in use: firewire_ohci
	Kernel modules: firewire_ohci

   CPU info:
Architecture :        x86_64
Mode(s) opératoire(s) des processeurs : 32-bit, 64-bit
Boutisme :            Little Endian
Processeur(s) :       4
Liste de processeur(s) en ligne : 0-3
Thread(s) par cœur : 2
Cœur(s) par socket : 2
Socket(s) :           1
Nœud(s) NUMA :       1
Identifiant constructeur : GenuineIntel
Famille de processeur : 6
Modèle :             37
Nom de modèle :      Intel(R) Core(TM) i3 CPU       M 370  @ 2.40GHz
Révision :           5
Vitesse du processeur en MHz : 2399.000
Vitesse maximale du processeur en MHz : 2399,0000
Vitesse minimale du processeur en MHz : 933,0000
BogoMIPS :            4788.17
Virtualisation :      VT-x
Cache L1d :           32K
Cache L1i :           32K
Cache L2 :            256K
Cache L3 :            3072K
Nœud NUMA 0 de processeur(s) : 0-3
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt lahf_lm kaiser tpr_shadow vnmi flexpriority ept vpid dtherm arat
 Configuration...
  IRQ information
Hardware Interrupts:
--------------------
 IRQ    0: PID:  None, count:     [149, 0, 0, 0], Sched None (priority None), drivers: ['2-edge      timer']
 IRQ    1: PID:  None, count:  [3, 652, 264, 53], Sched None (priority None), drivers: ['1-edge      i8042']
 IRQ    7: PID:  None, count:       [0, 0, 0, 0], Sched None (priority None), drivers: ['7-edge      parport0']
 IRQ    8: PID:  None, count:       [0, 1, 0, 0], Sched None (priority None), drivers: ['8-edge      rtc0']
 IRQ    9: PID:  None, count:   [14, 42, 24, 20], Sched None (priority None), drivers: ['9-fasteoi   acpi']
 IRQ   12: PID:  None, count: [56, 110530, 111077, 108310], Sched None (priority None), drivers: ['12-edge      i8042']
 IRQ   16: PID:  None, count:   [21, 24, 24, 24], Sched None (priority None), drivers: ['16-fasteoi   firewire_ohci', 'mmc0', 'yenta', 'yenta']
 IRQ   17: PID:  None, count:   [0, 0, 0, 38441], Sched None (priority None), drivers: ['17-fasteoi   ath9k']
 IRQ   18: PID:  None, count:       [0, 0, 0, 0], Sched None (priority None), drivers: ['18-fasteoi   i801_smbus', 'ips']
 IRQ   19: PID:  None, count: [887, 898, 10409, 894], Sched None (priority None), drivers: ['19-fasteoi   ata_piix', 'ata_piix']
 IRQ   22: PID:  None, count:   [44, 43, 48, 41], Sched None (priority None), drivers: ['22-fasteoi   ehci_hcd:usb1', 'ehci_hcd:usb2']
 IRQ   24: PID:  None, count:   [0, 0, 1113, 36], Sched None (priority None), drivers: ['409600-edge      enp0s25']
 IRQ   25: PID:  None, count:       [6, 5, 5, 6], Sched None (priority None), drivers: ['360448-edge      mei_me']
 IRQ   26: PID:  None, count: [20, 12906, 18, 16], Sched None (priority None), drivers: ['32768-edge      i915']
 IRQ   27: PID:  None, count: [111, 109, 110, 112], Sched None (priority None), drivers: ['442368-edge      snd_hda_intel:card0']

Software Interrupts:
--------------------


=== REPORT ===
FireWire kernel drivers:

The new FireWire kernel stack is loaded. 
If running a kernel earlier than 2.6.37 and problems are experienced, either 
try with the old Firewire kernel stack or upgrade to a newer kernel 
(preferrably 2.6.37 or later).


Merci smile .

A plus .

JMPC

dlb utilisateur non connecté
Un aplay -l ne me donne que la carte intégrée de l'ordi (actuellement mon "gros" ordi de bureau avec une carte son HDA Intel), mais ne mentionne rien sur ma carte firewire, actuellement une Icon Firexon. Je pense que c'est assez normal, vu que j'ai "blacklisté" le module snd_bebob utilisé par alsa et la firexon ...

Je pense que cette commande devrait te permettre de voir si ta carte est vue par le système :
ffado-test ListDevices

Si elle est vue, alors je pense à une erreur de config dans qjackctl, ou une erreur de "blacklistage"

En root, dans /etc/modprobe.d/ tu crées un fichier : blacklist.conf qui contient cette ligne :
blacklist snd_bebob

et tu reboutes.
Vérifie ensuite le pilote dans qjackctl : ce doit être firewire (pas freebob)
l'interface est sur : default ( pas de hw:....)

A titre d'info, j'ai mis ça pour les autres paramètres :
fréquence : 44100
Echantillon/période : 128
Période/tampon : 2

Tout le reste est sur défault dans l'onglet "avancé", à part l'audio qui est sur duplex.

olinuxx utilisateur non connecté France
Citation :
Un aplay -l ne me donne que la carte intégrée de l'ordi (actuellement mon "gros" ordi de bureau avec une carte son HDA Intel), mais ne mentionne rien sur ma carte firewire, actuellement une Icon Firexon. Je pense que c'est assez normal, vu que j'ai "blacklisté" le module snd_bebob utilisé par alsa et la firexon ...


Exact. aplay est un utilitaire ALSA qui affiche les interfaces audio/midi reconnues par ALSA. Si un pilote ALSA (snd_bebob dans le cas présent) est blacklisté, alors ALSA ne reconnaît pas l'interface et la commande aplay ne l'affiche donc pas.

Citation :
Je pense que cette commande devrait te permettre de voir si ta carte est vue par le système :
ffado-test ListDevices


+1

jmpc utilisateur non connecté
Salut .

Merci à tous les deux , j' y vois beaucoup plus clair smile .

J' ai réussi à faire démarrer Jackd avec FFADO ... une seule fois et avec des millards de Xruns avant même d' avoir lancé une appli ... je n' ai même pas pu écouter un morceau smile .

Mais bon , il a démarré même si à nouveau , il ne veut plus rien savoir ...

En fait , dans ma config de Jackd , j' avais passé , comme à l' époque me semble-t-il ( je me trompe ? ) , la valeur de Periodes/Tampon à 3 ... le fait de l' avoir redescendue à 2 a permis son unique démarrage . Puis j' ai simplement augmenté la latence pour essayer d' arrêter ou au moins de ralentir les Xruns et depuis ... plus rien , même avec la config sur laquelle j' avais réussi à le démarrer ...

Bref , tout cela me paraît bien exotique ... smile d' autant plus que oui , oui , la carte est parfaitement reconnue par toutes les commandes FFADO .

Je continue donc à pencher pour un problème de firmware de la carte firewire ... ton firmware , dlb , est celui d' une carte PCI et il est peut-être plus récent et compatible que le mien qui est celui d' un vieux portable ... assez costaud , je le précise , pour faire dignement du son ... smile .

Pour en avoir le coeur net , je suis entrain de refaire une fresh install de Librazic ( il se pourrait que mes bidouilles aient corrompu le système ) et je vais refaire des tests sur les deux noyaux .

Merci biggrin .

A plus .

JMPC

jmpc utilisateur non connecté
Re salut .

Bon , ben , la messe est dite ... j' ai re installé Librazic 2 , installé le kernel bl et le kernel rt : je suis arrivé à démarrer jackd ( je pense que c' est le fait d' avoir monté le tampon à 3 qui l' empêchait de décoller ) mais c' est complètement inutilisable et franchement très instable ...

J' espère simplement que tout vient du firmware de la carte firewire , ça me ferait vraiment chier d' acheter la carte PCMCIA pour rien ...

En tous les cas , merci ! Je ne manquerai pas , bien-sûr , de faire remonter les infos smile .

A plus .

JMPC

jmpc utilisateur non connecté
Bonjour ,

Comme promis , je fais remonter mes avancées firewiresques après avoir reçu la carte Texas Instrument en PCMCIA … j' ai n' ai pas du tout le même type de problèmes mais ça ne fonctionne toujours pas …

Ce coup-ci , j' arrive à faire démarrer Qjackctl , avec quelques Xruns , que ce soit avec ALSA ou FFADO :
- avec ALSA , ça fonctionne beaucoup mieux mais ça reste inutilisable pour faire de la MAO .
- avec FFADO , quelques Xruns , certes , mais surtout les applis qui ne trouvent pas Jackd , un peu comme si PAM n' était pas configuré …

J' ai testé avec une freshinstall de Librazik , avec une LMDE optimisée et , au cas ou , avec un livecd de TangoStudio 2,2 … même résultat …

J' en conclus donc que mon vieux Fujitsu a quelque chose contre le Firewire sous Linux … et que c' est fort dommage ...

Merci pour votre aide smile .

A plus .

JMPC

jmpc utilisateur non connecté
Bonjour à tous .

Bon , j' ai fait mon dernier baroud d' honneur ... j' ai flashé le bios de la bécanne et j' ai récupéré ma FA101 pour faire des tests ... je n' arrive même pas à faire démarrer Jackd avec ... alors que, même si ce n' est pas utilisable , il démarre avec la FA66 ... je lâche l' affaire ... incompréhensible ... smile .

Le PC est un vieux Fujitsu Lifebook A780 qui tourne parfaitement sur Librazik 2 ... sauf en firewire ... mais j' ai des résultats plutôt encourageants avec la carte son interne ... j' espère que ça suffira au pote pour qui je l' ai préparé biggrin .

Merci pour tout .

A plus .

JMPC

olinuxx utilisateur non connecté France
Mmm, étrange tout ça. Désolé de ne pas pouvoir beaucoup t'aider, je n'ai pas énormément d'expérience avec le firewire sous linux.

jmpc utilisateur non connecté
Salut à tous , salut olinuxx .

Oui , étrange ... smile . Pas souci , les loi de l' informatique sont par moments ... impénétrables ...

Quoiqu' il en soit , à mon avis , la config de Librazic est nickel pour accueillir le firewire ... c' est simplement un manque de bol avec le hardware de cette machine , même en PCMCIA .

Il me reste une piste à explorer , découverte après mon post précédent: j' ai lu dans des fofos en anglais qu' il fallait virer yenta : conflit avec firewire . Je n' ai par contre pas trouvé la manière de le faire ... très peu d' infos ... Si quelqu' un a une idée , je suis preneur smile .

Je me ferai une joie de supprimer ( Abandonné ) si , d' une part , j' arrive à virer yenta et si , d' autre part , c' est réellement le problème smile .

Et quoiqu' il en soit à nouveau , merci smile .

A plus .

JMPC

olinuxx utilisateur non connecté France
OK, pas de soucis et merci pour ton suivi ici.

Bonne musique à toi dans tous les cas !

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Mégaphone [Afficher / Cacher]

olinuxx, 14:34, mer. 12 Dec 2018: Bonjour et bienvenue à kadiobale wink
r1, 20:25, mar. 11 Dec 2018: Les joutes sont sur le point de reprendre ! viendez jouer avec nous !!! :-)
olinuxx, 23:10, lun. 10 Dec 2018: Bonjour et bienvenue à titidu77 cool
olinuxx, 19:15, lun. 10 Dec 2018: Bonjour et bienvenue à GranDide :-)
sub26nico, 13:26, lun. 10 Dec 2018: Salut et bienvenue à Floyd84 :-)
sub26nico, 09:09, ven. 07 Dec 2018: Salut et bienvenue à alansnow73 :-)
allany, 18:40, jeu. 06 Dec 2018: Avec un ch'tit retard, voici l'édito de décembre ! [Lien]
jipeL, 17:46, mer. 05 Dec 2018: Sweet Vibes "Approuvé" pour distribution via RouteNote, et ce, du premier coup !! et sans modif à faire !!! super !!! ( voir mon post dans le forum "le Nimp"
Nolwen, 21:42, mar. 04 Dec 2018: Bonsoir, quelqu'un a-t-il mis les doigts et les oreilles sur OrDrumBox (www.ordrumbox.com/), et peut-il nous dire si cela vaut le coup de s'y pencher ?
olinuxx, 21:05, mar. 04 Dec 2018: Bonjour et bienvenue à karum cool
sub26nico, 21:00, dim. 02 Dec 2018: Salut et bienvenue à michelcher :-)
sub26nico, 13:09, dim. 02 Dec 2018: Salut et bienvenue à pureOL et petete :-)