Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [Résolu] MOTU 624 AVB, connexion USB, ethernet et GUI
Dernier post

[Résolu] MOTU 624 AVB, connexion USB, ethernet et GUI

dede utilisateur non connecté
Bonjour à tous,

suite à de nombreux feedbacks positifs à propos de la nouvelle ligne d'interfaces MOTU et de son usage sous notre OS favori, j'ai décidé de passer le pas et de m'offrir une 624 en remplacement de ma vieille et fidèle Echo Layla 24 (qui va sur ses 20 ans si je ne m'abuse...).

Et là, c'est le drame. La carte étant censé être Class Compliant, je pensais qu'elle fonctionnerait out of the box, ou presque. Que nenni... Si mon PC la voit bien à travers KInfoCenter comme un périphérique USB, mon serveur Jack refuse absolument de démarrer, avec ces lignes en log :
Thu Nov  8 10:09:07 2018: Starting jack server...
Thu Nov  8 10:09:07 2018: JACK server starting in realtime mode with priority 85
Thu Nov  8 10:09:07 2018: self-connect-mode is "Don't restrict self connect requests"
Thu Nov  8 10:09:07 2018: Acquired audio card Audio2
Thu Nov  8 10:09:07 2018: creating alsa driver ... hw:D624,0|hw:D624,0|512|2|48000|6|8|hwmon|swmeter|-|32bit
Thu Nov  8 10:09:07 2018: Using ALSA driver USB-Audio running on card 2 - MOTU 624 at usb-0000:00:1a.0-1.2, high speed
Thu Nov  8 10:09:07 2018: configuring for 48000Hz, period = 512 frames (10.7 ms), buffer = 2 periods
Thu Nov  8 10:09:07 2018: ALSA: final selected sample format for capture: 24bit little-endian in 3bytes format
Thu Nov  8 10:09:07 2018: ERROR: ALSA: cannot set channel count to 6 for capture
Thu Nov  8 10:09:07 2018: ERROR: ALSA: cannot configure capture channel
Thu Nov  8 10:09:07 2018: Released audio card Audio2
Thu Nov  8 10:09:07 2018: ERROR: Cannot initialize driver
Thu Nov  8 10:09:07 2018: ERROR: JackServer::Open failed with -1
Thu Nov  8 10:09:07 2018: ERROR: Failed to open server


De plus, les tentatives de connexion ont tendance à faire bugger Cadence, qui freeze. KMix plante systématiquement quand j'allume la carte et s'éteint.

De plus, je ne parviens pas à me connecter à l'interface via mon navigateur et le port ethernet du PC ! Quand j'ai pingé l'adresse IP de la 624, j'ai eu droit à "host unreachable".

En bref, j'ai besoin d'aide. Dans le pire des cas, je la renverrai et resterai avec l'Echo Layla, mais bon, c'est pénible... Merci d'avance pour vos réponses.

Edit : quelques précisions. Le PC est sous KXStudio. J'ai aussi testé tout ça avec une clé USB contenant KXStudio Live (pour voir si ça venait des divers tripatouillages que j'ai pu faire sur mon PC), ainsi qu'avec une Librazik2 Live sur le même support. Ca ne change absolument rien au problème.

Édition modéro-forum olinuxx le 08 novembre 2018 à 12h58 : ajout de liens internes.


dede utilisateur non connecté
Ca alors... je viens de parvenir à résoudre le problème de son. J'ai passé 6h dessus hier sans succès, et juste après avoir posté le message, j'ai trouvé :il fallait passer dans Cadence le nombre d'Inputs et Outputs Channels à 0.

Par contre, toujours impossible de se connecter au GUI...

Edit : par contre, il faut impérativement la brancher à un port USB2. Ca plante sur un USB3. Un peu dégoûté quand même, mais comme je n'enregistre que rarement plus de deux pistes simultanément, ça ne devrait pas être trop gênant.

dede utilisateur non connecté
Résolu !!

Impossible de se connecter directement à la MOTU 624 en utilisant la deuxième interface réseau de ma tour. Alors que ça fonctionne sous Windows...

Heureusement, il me restait un vieux switch ethernet que j'ai exhumé d'un placard pour l'occasion, et miracle, ça tourne !

On dirait que le système ne savait pas quelle interface réseau utiliser pour se connecter... Mais plus étrange, même quand la carte était branchée seule au PC (cad sans aucune connexion ethernet supplémentaire), elle était impossible à atteindre. Même un ping en spécifiant l'interface réseau à utiliser ne donnait rien.

En bref, si votre tour dispose de plusieurs interfaces réseau et que vous voulez avoir votre connexion internet + le GUI MOTU, il faut passer par un switch. Ca marche peut-être aussi en connectant la carte son directment à la box, faut voir, mais ma box est trop loin de ma salle de musique pour que je teste ça...

olinuxx utilisateur non connecté France
Merci pour ce retour d'expérience @dede. Nous n'avions pas encore d'information concernant cette interface et son utilisation sur le site. J'ai donc créé une page MOTU 624 AVB et y ai mis un lien vers ici. Grâce à ton retour et à tes explications, la connaissance commune et partagée sur ce site vient encore d'augmenter ! Merci !

Et bonne musique à toi maintenant cool

dede utilisateur non connecté
De rien, j'ai tellement profité de ce site que je suis content d'apporter ma petite pierre.

En bref, pour faire fonctionner la MOTU624 sous Linux :

- à l'allumage du PC, la carte doit être éteinte et branchée sur un port USB2 (plantage sur USB3) et sur un port ethernet ;

- sous KXStudio, désactiver KMix qui va de toute façon planter ;

- allumer l'interface et attendre qu'elle soit initialisée pour ouvrir Cadence ;

- lancer le serveur Jack après l'avoir paramétré (choix de l'interface, nombre de canaux In et Out à zéro ;

- lancer le bridge PulseAudio si nécessaire (j'en ai besoin pour avoir du son depuis mon navigateur) ;

- ouvrir un navigateur et entrer l'adresse IP de la MOTU624 (elle apparaît sur l'écran de l'interface après être entré dans le sous-menu Network). Assurez-vous que votre navigateur accepte les cookies.

- A priori, enjoy ! Je reviendrai vers vous quand j'aurais tenter deux trois enregistrements avec Ardour.

Sylv_01 utilisateur non connecté
Salut,
ça n'a rien à voir avec la musique, mais concernant ton pb avec Ethernet, j'avais eu la même mésaventure avec une caméra IP : pas moyen de me connecter dessus directement depuis le PC, ça ne fonctionnait qu'en intercalant un switch !
Je n'ai jamais compris pourquoi...
Mais ça, ça ne va pas beaucoup t'aider ! mrgreen

dede utilisateur non connecté
Oui, et c'est d'autant plus bizarre que le switch est inutile sous Windows...

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Mégaphone [Afficher / Cacher]

sub26nico, 22:36, sam. 17 Nov 2018: Salut et bienvenue à hubert_fr_69 et stefets :-)
sub26nico, 11:00, sam. 17 Nov 2018: Salut et bienvenue à danger89 et Tylun :-)
sub26nico, 01:15, sam. 17 Nov 2018: Salut et bienvenue à ramblingpedro :-)
sub26nico, 17:56, ven. 16 Nov 2018: Salut et bienvenue à Dinosor :-)
sub26nico, 14:37, ven. 16 Nov 2018: @pierrotlo, bien-revenue :-)
olinuxx, 14:30, ven. 16 Nov 2018: Content de te revoir dans le coin @pierrotlo !
sub26nico, 13:55, ven. 16 Nov 2018: Le 'moteur' de Tracktion est désormais 'ouvert' : [Lien]
pierrotlo, 11:45, ven. 16 Nov 2018: Re salut tous, après une absence de presqu'un an, me voici de retour
l_d_v_c, 20:41, jeu. 15 Nov 2018: Sinon je change de système d'exploitation pour IcareOS Desktop (afin de faire fonctionner les programmes Amiga sur PC). JE VEUX LE TRACKER MIDI / WAV ! :-)
l_d_v_c, 19:59, jeu. 15 Nov 2018: Le programmeur Teijo Kinnunen ayant écrit OctaMED Sound Studio a fait une version pour PC sous Windows, j'espère que cela fonctionne sous Wine...
l_d_v_c, 19:29, jeu. 15 Nov 2018: Voici un article de présentation d'OctaMED soundstudio : [Lien]
l_d_v_c, 19:24, jeu. 15 Nov 2018: Je vais essayer d'écrire au programmeur de octamed soundstudio afin qu'il nous le porte pour GNU/Linux ... Car c'est ce logiciel que je veux et les autres ne me servent à rien à part Audacity.