Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

1 - Le matériel et les pilotes ALSA, FFADO, ...

> Forums de discussion > 1 - Le matériel et les pilotes ALSA, FFADO, ... > [RÉSOLU]Probleme d'affichage aprés ecran de loggin [LZK]
Dernier post
Page : 1/4   -   Aller directement à la page : 1  2  3  4 

[RÉSOLU]Probleme d'affichage aprés ecran de loggin [LZK]

Blinux utilisateur non connecté
Bonjour,

Donc ce nouveau fil avec le même problème résolu ici.
Mais je suis un peu moins à l'aise visiblement en mode console et je crois avoir besoin d'un peu plus de précision sur la marche à suivre neutral

Après une installation toute neuve de Librazic et après l'écran de connexion qui lui n'a pas de soucis d'affichage, mon écran ressemble donc à ceci :
Image

Je veux bien essayer de configurer le fichier xorg.conf mais il n'est visiblement pas ici : /etc/X11/xorg.conf

Je vais essayer d'utiliser cette #!££ de commande "find" qui fonctionne une fois sur 100 pour le chercher, j'y suis arrivé une fois mais je ne me souviens plus de l'endroit ou il se cachait !!

Blinux utilisateur non connecté
Ok bien noté !

jujudusud utilisateur non connecté France
Bonjour Blinux,

Je te suggère de vérifier quelle carte vidéo se trouve sur ta machine.
Cela te permettra d'aller voir dans le manuel de Debian comment faire pour mettre en place le bon driver.

la commande à taper est :
lspci -nn | egrep -i "3d|display|vga"


Et ensuite, il faut suivre le manuel pour la version Stretch de Debian :
Wiki de Debian

Blinux utilisateur non connecté
La carte est une MSI 8826 nvidia GEFORCE 2 MX400
Je vais essayer d'avancer avec ça ..

jujudusud utilisateur non connecté France
Salut,

Pour commencer, je pense qu'il faut que tu actives le dépot "non free" de Debian pour permettre l'installation du bon driver pour ta carte. Debian ne donne pas accès à de logiciels propriétaires par défaut. il faut donc intervenir pour ouvrir cet accès.


Regardes ici :
https://debian-facile.org/doc:systeme:apt:sources.list:sources.list-non-free

Cela te permettra de mettre en place le driver avec la méthode décrite dans le wiki Debian.

Ta carte étant assez ancienne, je pense qu'on peut avoir du mal à trouver le bon driver.
De plus, je n'ai pas de carte nvidia chez moi et du coup je tatonne un peu.


Si on n'arrive pas à un résultat rapidement avec mes idées, il faudra aller demander de l'aide chez Debian-facile... je te filerai un coup de main.

Blinux utilisateur non connecté
Il semblerait donc que le driver Version 96.43.23 est approprié pour ma carte ..
Par contre dois-je essayer de l'installer à votre avis ?

jujudusud utilisateur non connecté France
Tu utilises une version 32 bits de LibraZiK2 ?

Oui il faut installer le pilote que recommande NVIDIA, c'est une bonne idée.
Pour cela il faut que tu installes le dernier noyau de LibraZiK2 ainsi que les headers qui permettent de mettre en place le pilote vidéo.

Blinux utilisateur non connecté
Oui j'ai préféré la version 32b pour cet ancien matériel.
Citation :
installes le dernier noyau de LibraZiK2 ainsi que les headers

heuu je vais voir ça ..

Par contre petit problème peut être pas très grave mais ..
Image

Mon fichier sources.list :
Image

Désolé pour les photos, il faudrait que je configure le serveur SSH pour faire des copier/coller de la console, mais cela sera une autre histoire :-)

jujudusud utilisateur non connecté France
Pas de soucis pour les photos.

Pour le 32b c'est juste si ton processeur fonctionne en 64b, il faut que tu installes une version 64b. Si ton processeur fonctionne seulement en 32b alors là tu n'a pas le choix et tu passes en 32b.

Le petit problème dont tu parles est connu. tu pourras facilement le résoudre quand tu auras installé ton pilote NVIDIA et que tu auras accès à synaptic. Je te donnerai le lien vers la documentation pour faire ça.

Est ce que c'est bon pour installer le dernier noyau et ses headers et du coup pouvoir installer le pilote vidéo ?

Blinux utilisateur non connecté
Je n'étais pas sûr pour le processeur, un Intel celeron 2.4 d'il y a déjà quelques années !
Pour l'install du dernier noyau et ses headers ... heuu je vais y travailler et potasser smile

jujudusud utilisateur non connecté France
Pour savoir si ta machine est en 64 bits ou en seulement en 32 bits, il faut que tu regardes ici :
https://librazik.tuxfamily.org/doc2/faq#ai-je_besoin_d_un_systeme_64_ou_32_bits

Pour installer le dernier noyau de librazik, il te faut en root taper cette commande :
# apt-get install linux-image-$(uname -r|sed 's/[^-]*-[^-]*-//')

Puis les headers :
# apt-get install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//')


Blinux utilisateur non connecté
Bon heureusement que tu m'as livré la ligne de commande toute prête, je n'ai jamais tapé de trucs aussi ésotérique pour moi dans une console !!

Alors après vérif, le processeur fonctionne effectivement en 32b.
La mise à jour du noyau semble s'être bien passée
Par contre ça a l'air d'avoir coincé quelque part pour les headers ..

Image

jujudusud utilisateur non connecté France
Ouille, il manque la version du noyau dans la commande que je t'ai dis de taper ... :-(

il faudrait changer ça par :
# apt-get install linux-image-4.9.0-9-lzk-bl-686-pae
# apt-get install linux-headers-4.9.0-9-lzk-bl-686-pae


désolé pour la rattage ... :-)

Blinux utilisateur non connecté
Oh ben pas quoi être désolé .. mais c'est pas bien mieux
Par contre je vois parmi les premières lignes que la version du noyau est a jour non ?

Image

Blinux utilisateur non connecté

ça a bien avancé :-)
J'ai tenté d'installer le driver NVDIA pour ma carte.
L'assistant NVDIA me demande d'arrêter le serveur X (ce que j'ai fait avec la commande init 3 de mémoire ..)
Puis l'assistant me dit que le pilote "Nouveau" doit être désactivé avant l'install.
Ce que l'assistant fait en créant visiblement un fichier "nvidia-installer-disable-nouveau.conf

Image


Puis reboot.
Et ça fonctionne, affichage ok !!

Par contre je n'ai pas osé pour l'instant de relancer l'install du driver NVIDIA et la résolution est un peu bizarre, mais je vais voir ça !

Image

jujudusud utilisateur non connecté France
Super !

Ta capture d'écran montre que l'installation ne s'est pas terminée correctement.
A moins que ce soit volontaire, tu devrais avoir l'interface en français et avec le thème librazik (la c'est le theme mate).
https://librazik.tuxfamily.org/doc2/manuel/installer_librazik/install-live-4
Il faut que tu finisses l'installation en suivant le manuel.

Ensuite faut que tu installes le dernier noyau, tu as oublié quelque chose dans la ligne de commande et du coup ça n'a pas fonctionné (4.0.9-9). Maintenant que tu as accés au mode graphique, il faut utiliser Synaptic qui se trouve dans les menus. Pour cela tu dois suivre :
https://librazik.tuxfamily.org/doc2/logiciels/synaptic/mise-a-jour_de_vos_logiciels

Deuxièmement il faut que tu connaisses la résolution native de ton écran. C'est sûrement noté quelque part sur une étiquette ou alors accessible dans le menu de l'écran qui s'active en appuyant sur un bouton de l'écran. Mais déjà, fais tout le reste ... et suis bien mot à mot les pages que je te donnes.

Blinux utilisateur non connecté
En tout cas c'est un vrais plaisir de pouvoir naviguer sur le forum, faire de vrais captures d'écran sans être en mode console uniquement sur le même PC et Librazik biggrin

Alors :

Citation :
Il faut que tu finisses l'installation en suivant le manuel.

Nickel ! :
Image

Citation :
Ensuite faut que tu installes le dernier noyau


Y compris le petit passage suppression des doublons dans le source.list, c'est en cours pendant que je fais ce post (au cas ou tout explose après la mise a jour il y aura au moins une trace de la première partie de la réussite wink )

Image

jujudusud utilisateur non connecté France
Bonjour Blinux,

C'est sympathique de ta part :-)
Je compte sur toi pour bien utiliser cet ordinateur pour faire de la musique :-)

Il ne te reste plus qu'un petit truc à faire :

Note modération : le sujet étant résolu, merci d'ajouter un [RÉSOLU] (ou un [CONTOURNÉ], ou bien encore un [ABANDONNÉ]) dans le titre de ton premier message. Voir ce paragraphe du manuel du site pour davantage d'informations.



Blinux utilisateur non connecté
Hello

Ben c'est 90% resolu razz, il me resterais à installer le driver NVIDIA car je ne peux pas sélectionner la bonne résolution
de mon écran, je n'ai que les 3 résolutions de base 1024X768, 800X600 et 540X480 de dispo.
Je ne trouve pas grand chose dans les paquets dispo avec synaptic.

Je suis en train de tenter ça "à la main". J'ai du installer GCC suite à une erreur de l'installateur NVDIA :
Unable to find the development tool cc in your path; please make sure that you have the package ‘gcc’ installed. If gcc is installed on your system, then please check that cc is in your PATH.


Et j'ai maintenant une erreur :
Received signal SIGTERM: Aborting


Note modération : merci d'utiliser la balise CODE lorsque tu copies/colles du code sur le site. Celles-ci permettent un meilleur affichage. Voir également cette page.
Image


jujudusud utilisateur non connecté France
Salut Blinux,

Il faut que tu colles entre les balises code ce que tu veux qu'on lise comme etant la sortie du terminal de ta machine.
Comme ça c'est plus facile à comprendre et à lire.

Est ce que tu peux recommencer ce que tu fais pour installer ce pilote et nous coller la sortie s'il te plait ?

Page : 1/4  [Suivant]
1  2  3  4 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]

bda

tongo

Mégaphone [Afficher / Cacher]

sub26nico, 13:26, mer. 14 Aug 2019: Salut et bienvenue à Byond :-)
olinuxx, 14:48, mar. 13 Aug 2019: Bonjour et bienvenue à echevresm cool
olinuxx, 18:02, lun. 12 Aug 2019: Bonjour et bienvenue à barnabulle1700 cool
olinuxx, 15:15, dim. 11 Aug 2019: Bonjour et bienvenue à aldudes cool
sub26nico, 20:13, sam. 10 Aug 2019: Salut et bienvenue à pannanico1 :-)
dawamss, 13:09, ven. 09 Aug 2019: salut à toi olinuxx
olinuxx, 12:45, ven. 09 Aug 2019: Bonjour et bienvenue à dawamss cool
sub26nico, 15:11, mar. 06 Aug 2019: Salut et bienvenue à kiwi007 :-)
olinuxx, 14:07, mar. 06 Aug 2019: Bonjour et bienvenue à zigmhount cool
allany, 19:30, lun. 05 Aug 2019: Du tonnerre, l'édito d'août !!! [Lien]
ycollet, 11:07, lun. 05 Aug 2019: freqtweak est sur github maintenant ... [Lien]
sub26nico, 14:55, sam. 03 Aug 2019: Salut et bienvenue à Blinux :-)