Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié Ardour

> Forums de discussion > 3 - Forum dédié Ardour > [RESOLU] Ardour 5.10 Clavier midi en USB et QjackCTL
Dernier post

[RESOLU] Ardour 5.10 Clavier midi en USB et QjackCTL

mOOnSlide utilisateur non connecté
Bonsoir.

Je rencontre un soucis avec Ardour et mon synthé midi relier via un cordon USB-Midi. J'utilise QjackCTL et il semble réglé correctement vu qu'avec Hydrogen tout fonctionne.
Je m'explique, sous Ardour mon clavier ne semble pas détecté? Lorsque je crée une piste midi et que j'y adjoint un instrument, il n'y a aucun son lorsque j'utilise les touches de mon synthé.... je suis obligé d'éditer à la souris via le clavier virtuel de la piste (pas super pratique).
De plus dans Jack, sous l'onglet Alsa, j'ai bien mon interface midi visible ainsi
q'hydrogen, mais ardour n'apparaît pas.... est ce normal (je ne crois pas).

Si vous savez comment m'éclairer je suis preneur. Merci d'avance :-)

PS : je précise que je suis novice en MAO et sous linux... je sais ça ne va pas être facile ;-)

sub26nico utilisateur connecté France
Chez moi, c'est dans l'onglet 'Midi' qu'Ardour est présent
dans la fenêtre de connexion de Qjaclctl.
De plus, dans Ardour, tu peux aussi connecter ton clavier directement en
activant l'entrée midi (symbole 'prise midi' vert dans la capture d'écran)
et en renseignant ton clavier dans le champs à gauche du symbole (- dans la capture)

Image

mOOnSlide utilisateur non connecté
Bonjour et merci pour ton rapide retour.
en effet sous Qjack dans l'onglet Midi Ardour est présent, mais je ne sais pas si je dois relier des options entres elles :
Image

Dans Qjack, onglet Alsa j'ai ça :
Image

Dans Ardour la prise midi est verte comme sur ta capture. le bouton à gauche m'indique "MIDI entrée vers MIDI déconnecté"

Donc je clique sur le bouton haut desssus intitulé "MIDI" et je sélectionne "Entrées" :
Image

Je ne sais pas si ce qui est coché est bon..... Je pense que ça doit être sous Ardour que je n'ai pas bien fait les choses.... ou pas... ;-)

J'avoue que je nage totalement :-/

Merci d'avance.

sub26nico utilisateur connecté France
Si je comprend bien, ton clavier midi est 'CH345' dans l'onglet ALSA,
mais il n'apparait pas dans l'onglet 'MIDI'.
Donc tu peux essayer de taper dans un terminal
a2j -e

et voir si ton clavier apparait dans l'onglet 'MIDI'.
Si ça fonctionne, on pourra automatiser cela au lancement de Qjack.
Tu me dis si ça marche.

mOOnSlide utilisateur non connecté
sub26nico écrit :
Si je comprend bien, ton clavier midi est 'CH345' dans l'onglet ALSA,
mais il n'apparait pas dans l'onglet 'MIDI'.


Oui c'est bien cela. Alors qu'il fonctionne sous Hydrogen.

J'ai effectué ta manip dans un terminal :
a2j -e


GENIAL sub26nico !!!!! mon synthé apparait sous ardour et il fonctionne !!! smile

Un grand Merci à toi, vraiment ! Et Merci pour ta rapidité de réponse. Tu es au top wink

PS : la ligne de commande que tu m'as fait faire, elle permet de détecter les "ports" hardware ?
Faudra t'il que j'effectue cette manip à chaque lancement d'ardour ?

sub26nico utilisateur connecté France
Super si ça marche, et de rien pour le coup de main,
les forums sont là pour ça wink.
pour automatiser la commande et ainsi t'éviter de la faire à chaque fois,
tu tapes les commandes comme dans la capture d'écran ci dessous
dans l'onglet 'Options' des 'Réglages' de QjackCtl.
(Si pulseaudio ne te poses pas de problèmes, tu peux ignorer les 2
commandes le concernant , la 1ère et la dernière).

Image

sub26nico utilisateur connecté France
MOOnSlide, merci de mettre les ligne de commande dans une balise code,
ça permet une meilleure lisibilité du message, je l'ai fait cette fois ci,
penses y à l'avenir stp.
Pour répondre à ta question, la commande permet de faire un pont entre Alsa et
Jack pour les connexions Midi si je ne dis pas de bêtises.

mOOnSlide utilisateur non connecté
Ok super ! merci je vais mettre ça dans Q jackctl.

et ok pour les balises j'y penserais pour la prochaine fois redface

Merci encore et bonne zik smile

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]

sub26nico

Mégaphone [Afficher / Cacher]

sub26nico, 21:08, jeu. 19 Oct 2017: salut et bienvenue à rosjjim :-)
olinuxx, 15:28, mer. 18 Oct 2017: bonjour et bienvenue à Gopherlechien :-)
olinuxx, 08:46, mer. 18 Oct 2017: @Respire : contacte moi à l'adresse info HATTE linuxmao POINGT org
sub26nico, 23:46, mar. 17 Oct 2017: Salut et bienvenue à Fonky62 :-)
Pascal, 21:03, mar. 17 Oct 2017: Je crois qu'on peut y aller àdonf maintenant ;)
Pascal, 21:02, mar. 17 Oct 2017: avec un coreI5 on peut faire ca sans soucis :-) crash test ben pas de crash ! renoise + ardour + reaper + bitwig + fusion + lightworks + resolve. j'ai pas réussi a planter le PC !!!!
Pascal, 21:02, mar. 17 Oct 2017: Merci sans doute à Apple qui tourne en rond...
Pascal, 21:01, mar. 17 Oct 2017: Pendant des années Linux en MAO vidéo c'était un peu la galère... et puis...
olinuxx, 18:36, mar. 17 Oct 2017: bonjour et bienvenue à Respire :-)
bluedid29, 14:28, mar. 17 Oct 2017: Perso je suis passé (au moins en MAO) sur l'excellente distribution Debian Librazik réalisé par le talentueux olinuxx ! :-)
bluedid29, 23:06, lun. 16 Oct 2017: Voilà, je ne fais que relayer l'info... ;) Inscription ici : /
bluedid29, 23:05, lun. 16 Oct 2017: Hello ! Ubuntu-fr organise une ubuntu party et recherche à Paris à la cité des sciences et de l'industrie (25 et 26 nov.) des personnes qui pourraient y proposer une conférence, un atelier