Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié Ardour

> Forums de discussion > 3 - Forum dédié Ardour > Ardour5 Librazic Pistes canaux et BUS [RESOLU]
Dernier post
Page : 1/2   -   Aller directement à la page : 1  2 

Ardour5 Librazic Pistes canaux et BUS [RESOLU]

aletheia utilisateur non connecté France
Bonjour
'ai constaté un phénomène étrange.
J'utilise une carte son Focusrite 18i20 et deux sorties de la carte son du PC.
La carte son PC est lancé dans un terminal avec l'utilitaire jack_alsa_io.
Je lance Ardour et je crée mes pistes.
Lorsque j'assigne les canaux aux pistes directement dans les sorties de celles-ci, tout fonctionne correctement.
Deux pistes monos sur les canaux 1 et 2 du PC.
4 canaux sur la Focusrite.
Si je crée un Bus, que je redirige les pistes sur le bus afin de mettre des plugins, que je redéfinis les sorties du bus vers les canaux souhaités : mes canaux sont mélangés tout en portant le même nom et je ne comprends pas ce qui se passe.
J'ai fait et refais plusieurs fois cette manipulation, et cela me donne toujours ce curieux résultat.
On s'en rend parfaitement compte en affectant les sorties une part une pour contrôler le son.

J’ai du passer à côté de quelque chose concernant le routage avec les BUS !!!

Cordialement

sub26nico utilisateur non connecté France
Pour une utilisation normale, seul le master_out est connecté aux sorties systèmes.
Si tu connectes tout, les pistes et les bus, selon ce que tu as inséré comme traitement
dans ton bus, il se peut que cela engendre une latence supplémentaire, les bus d'Ardour
n'ayant pas, à ma connaissance, de compensation de latence. Elle est géré en interne,
mais pas pour des configurations comme la tienne.
Connectes tes pistes et tes bus uniquement au master d'Ardour, et celui ci aux sorties système.
Et dis nous si ça règle le problème.

aletheia utilisateur non connecté France
Merci pour ta réponse.
Je regarde cela ce soir.
Le master est-il limité en canaux ?
Est-ce que je peux connecter seulement les pistes aux bus puis les bus au master sans avoirs ces problèmes?
Cordialement

sub26nico utilisateur non connecté France
Toutes les pistes et les bus sont connectés au master,
sans limitation du nombre. Normalement, tu ne devrais pas avoir
de problème. S'il t'en a, c'est qu'il y a un souci avec
le réglage d'un greffon ou du routing des pistes.
Oui tu peux connecter seulement les pistes au bus et les bus
au master. Le problème venait à coup sûr que tu connectais les
pistes et/ou bus aux sorties système alors que le master y est
déjà connecté. si seul le master est connecté aux sorties système,
tu devrais régler ton problème.

olof utilisateur non connecté
moi je me demande pourquoi tenter d'utiliser 2 sorties de la carte son du pc quand on en a 20 sous le coude sur la carte, et de bien meilleure qualité ?
et quelle utilisation fais tu de ces 6 sorties ?

aletheia utilisateur non connecté France
Bonjour
Première chose, le phénomène est totalement indépendant de l'usage ou non d'une deuxième carte son.
Afin de m'en assurer, j'ai créé une session avec uniquement la Focusrite.

Par ailleurs mon système se présentent ainsi avec un décalage entre le sol et le plafond car le studio se trouve sous les toits.

Image

Je joue dans une petite cour :
Jean-Marc Duchenne

Vous pouvez tester ce que je décris pour vérifier.

Une nouvelle session avec un master donc stéréo tout à fait basique.
J'ai supprimé toutes les connexions existantes avec Catia.(même le master)
Je crée trois pistes monos et je dispose un échantillon sur chacune.
Chaque sortie est adressée à une entrée système ( playback1, playback2, playback3) et pas de routage sur le master qui de ce fait est muet.
J'ai besoin pour la spatialisation du son que chaque sortie corresponde bien à l'enceinte souhaitée( ou à un même groupe d'enceintes dans le cas d'une installation).
Si je lance la lecture dans cette configuration, le son sort bien là où je veux. C'est parfait.
Une remarque, les pistes audios monos présentent deux sorties G et D. C'est étrange, puisqu'elles sont monos. C'est un héritage de l'approche stéréo? C'est inutile et cela porte à confusion au niveau de l'interface.

Maintenant j'ajoute deux canaux au master.
J'affecte les 4 sorties à 4 entrées systèmes (1,2,3,4)
Je crée une nouvelle piste mono.
Cette piste comporte 4 sorties ??? 2 sont effectives et peuvent être dirigée sur une entrée du master qui dans ce cas donne un son plus gros/plus gras ???
Si je regarde dans le gestionnaire de connexion, les quatre pistes monos disposent maintenant au niveau de l'interface de 4 sorties. Ce qui est totalement inutile, et rend peu lisible le tableau de routage dans l'interface. Imaginons un master de 18 canaux et 40 pistes???

Je supprime les sorties systèmes des pistes.
Je route chaque sortie des pistes sur une entrée du master dans l'ordre (1,2,3,4).
Lorsque je lance la lecture, les entrées du master s'animent bien en fonction du routage des pistes et dans l'ordre défini, mais c'est le grand bazar dans l'affectation des enceintes, le routage réel est imprévisible.

Ça me laisse perplexe. J'ai fait un test en utilisant un nouveau bus. Même résultat.
Ce n'est pas une critique d'Ardour.
C'est simplement que les bus fonctionnent de manière improbable et que cela les rend peu performant pour des réalisations où la spatialisation du son est vitale. Une question peut-être à soumettre aux développeurs.



Cordialement

sub26nico utilisateur non connecté France
Essayes avec une piste audio 4 canaux en lieu et place du bus, pour voir si cette histoire
de latence est lié au manque de compensation.

aletheia utilisateur non connecté France
J'utilise des pistes de huit canaux, voir plus, et je n'ai pas de problème de routage si j'adresse directement les canaux aux sorties voulues sans passer par un bus.

En fait la question s'est posée en voulant utiliser le plugin Argolunar pour la granulation sur plusieurs pistes. Il m'a semblé plus intéressant de regrouper les pistes sur un bus et de définir le plugin sur le bus. En théorie, cela fonctionne, mais j'ai constaté au bout d'un moment que je ne retrouvais plus mes petits!!!
Ce n'est pas le plugin qui est en cause. En mono ou multicanal, je peux utiliser ce plugin en affectant directement les sorties aux entrées systèmes. Ce sont les bus, mais j'ai mis un moment à le comprendre.

Évidemment, la solution pour ce cas particulier était de regrouper les pistes monos sur une même piste multicanal et d'appliquer le plugin sur cette nouvelle piste.
Cependant, cela n'est pas toujours possible/souhaitable et cela ne change rien à la question du fonctionnement des bus.

sub26nico utilisateur non connecté France
Ça semble confirmé le problème de compensation de latence des bus.

aletheia utilisateur non connecté France
Pourquoi l'absence de compensation de latence des bus provoque le bazar dans les enceintes ? C'est un peu comme s'il ne tenait pas compte du routage et qu'il réaffectait lui-même les sorties systèmes.

aletheia utilisateur non connecté France
Vous trouverez ici une thèse (206p) sur cette question de compensation dans les DAW, et tout particulièrement dans Ardour ici:

Latence DAW

Je ne sais pas si je vais tout comprendre mais je vais au moins régarder ça.

"Même si elle s’attache ostensiblement à Ardour, cette thèse décrit les concept génériques des station audio tels que les Ports, les pistes (Tracks), les bus (Busses) et les processeurs de traitement numériques du signal (Processors) ainsi que les interactions opérationnelles entre eux.
Les concepts de base communs à toutes les entrées/sorties numériques sont expliqués ainsi que les sources de latence. Les graphes de traitement et de latence sont illustrés pour présenter une vue d’ensemble.
Les problèmes généraux rencontrés lors de l’alignement temporel, tant local que global, seront étudiés, de même que des cas plus spécifiques aux stations audionumériques comme l’automatisation des paramètres et le parallélisme d’exécution"

sub26nico utilisateur non connecté France
merci pour ce lien aletheia.

olof utilisateur non connecté
j'ai une config approchante, meme si le but est différent :
une interface audio avec 8 sorties, 2 utilisée en façade, et 6 pour des retours scène.
je branche donc le master sur la façade, mais rien n'empecherait de ne pas utiliser le master , et de gerer la façade comme les retours, dont voici la mise en oeuvre :

je crée 6 bus mono, un par sortie donc.

j'utilise uniquement la sortie out1 de mes bus mono (il y a la meme chose sur la 2)

les piste sont envoyées aux retours en etant à même de regler la quantité pour chaque retour différemment.
pour cela je mets pour chaque piste un depart auxiliaire vers chaque bus, et je règle le volume d'envoi aux inserts pour chaque piste.

Image

et je peux assurer qu'il n'y a absolument aucun bazard dans les pistes... et chaque depart auxiliaire peut faire l'objet d'une automation, ou être piloté par un controle extérieur.

aletheia utilisateur non connecté France
Ce sont des bus monos. Le problème survient avec des bus multicanaux.
Heureusement que cela fonctionne dans la configuration d'Olof.

olof utilisateur non connecté
bien sur que ce sont des bus monos, chaque bus correspond a une sortie, la question que je me pose est pourquoi utiliser des bus multicanaux ?
on peut tres bien utiliser des bus monos, un par sortie physique, et des pistes monos ou des pistes multis d'ailleurs, chaque canal etant dirigé vers un bus mono different.

aletheia utilisateur non connecté France
Oui, mais cela n'apporte pas de réponse au problème signalé...j'ai expliqué plus haut les raisons d'un bus multicanal et j'ai proposé une solution. Cependant elle n'est pas généralisable à tous les plugins pour de nombreuses raisons et cela ne change rien à la question du comportement des bus multicanaux.

sub26nico utilisateur non connecté France
Juste au cas où, tu peux nous mettre une capture d'écran du pin-connection de Argolunar
dans le Bus midi multi-canaux qui pose problème stp ainsi que le routage du Master ?

Citation :
mais cela n'apporte pas de réponse au problème signalé

Tu devrais ouvrir un fil dans les forums d'ardour.org et coller
le lien ici pour que l'on puisse suivre les discussions. Ou contacter les développeurs sur le canal IRC
d'ardour.

olof utilisateur non connecté
j'utilise aussi des plugin multicanaux et avec ma methode je peux dispatcher les canaux sur mes bus ou pistes sans souci. les pistes multicanl ont une fonction de creation de bus ou de pistes reliés aux differnts canaux qu'il suffit alors de conecter aux sortie physiques. peut etre cela peut il etre la solution à ce que tu cherches à faire.
je comprends bein que resoudre un bug est important mais trouver un contournement pour pouvoir faire ce que tu veux, c'est la seule chose a laquelle je puisse apporter quelque chose, donc j'essaie de te mettre sur d'autres pistes aussi ...

j'ai aussi essayé de reproduire le probleme avec le plugin multicanaux que j'utilise regulierement : red zeppelin?, et n'ai pas vu le genre de souci dont tu parles se produire, ce qui m'amène à a poser la question du plugin en lui même : pourrait il etre responsable du bazard ?

aletheia utilisateur non connecté France
Pas de soucis et je vous remercie de me répondre.
Je vais m'occuper du forum d'ardour.org dès que possible.

Il me semble avoir résolu un élément d'interface qui me dérangeait :

"If Ardour is configured to automatically connect new tracks and busses, the number of outputs will be determined by the number of inputs of the master bus, to which the track outputs will be connected.

For example, with a two-channel master bus, a Mono track has one input and two outputs; a Stereo track has two inputs and two outputs.

If Edit > Preferences > Audio > Connection of Tracks and Busses is set to manual, then tracks will be left disconnected by default and there will be as many outputs as there are inputs. It is up to the user to connect them as desired. This is not a particularly useful way to work unless something fairly unusual is done with signal routing and processing. It is almost always preferable to leave Ardour make connections automatically, even if some changes are manually done later. "

Mais dans la version 5.5 d'Ardour (j'utilise la version de librazic2 sur une autre machine) cela se trouve dans Edit > Preferences > Signal Flow où il faut mettre les connections en manuel.
Mais il faut également choisir l'option E/S Flexibles dans Ports de sortie du menu de création de pistes.
Ainsi une piste mono a bien q'une seule sortie, une piste 3 canaux à bien 3 canaux même si le master est en huit canaux.
C'est une curieuse idée d'assujettir le nombre de canaux de sortie d'une piste au nombre de canaux du master car il n'y a pas de raison que cela soit lié sauf si on travaille toujours en stéréo.

Ça, c'est résolu et me semble plus lisible pour les routages un peu complexes.
Voici un exemple master 4 canaux, une piste mono et une piste 3 canaux.

Image

C'est quand même plus lisible que
Image
surtout qu'on n'a ici que 4 canaux sur le master bus.

aletheia utilisateur non connecté France
Argotlunar n’est responsable de rien, c'était juste pour décrire le contexte qui a éveillé mes soupçons. C'est comme la deuxième carte son qui n'avait aucune incidence.

Dans ma description du test donné sur ce forum ci-dessus je n'ai défini aucun plugin et pourtant le problème se pose bien.

Pour Argotlunar, je donnerai plus tard les écrans. Je ne suis pas sur ma machine de studio.

En fait mon obstination sur cette histoire de bus vient du fait que je trouverai particulièrement intéressant de disposer d'un bus intermédiaire multicanal sur lequel on peut placer un ou des plugins pour un ensemble de pistes tout en pouvant définir sur chacune d'entre elles des plugins différents par exemple un délai ou une reverb avec des réglages spécifiques ainsi que des automations indépendantes, le tout en multicanal.
Cela peut sembler obscur, mais cela correspond bien à certains besoins en création audio.

Je pourrai toujours utiliser des pistes indépendantes dont les sorties sont routées sur les canaux adéquates et dupliquer les plugin sur chaque piste. Mais je ne trouve pas cela rationnelle et regrettable lorsqu'on dispose de bus.

Il reste au final la question du routage vers les enceintes souhaitées et si on ne peux pas être certains du routage cela peut mettre en question le projet surtout dans une spatialisation 3d d'objets sonores.

olof utilisateur non connecté
je n'ai encore jamais utilisé de master multicanaux et n'ai donc pas fait ce type de test. lorsque je veux avoir plus de deux sorties a mon systeme son, j'utilise des bus specifiques en auxiliares comme montré plus haut, et le routage est toujours celui auquel je m'attends. je dois reconnaitre qu'un master multicanaux ferait economiser des ressources et merite qu'on se penche sur la question, mais je trouve bien plus puissant le principe d'un bus par sortie physique car je peux ainsi envoyer le signal à plusieurs sorties, pas seulement le localiser à un seul endroit, comme me semble obliger à le faire le principe du master multicanaux :
pour faire se deplacer un son avec un master multicanaux, il faudrait changer les branchements des pistes vers les canaux du master, tandis qu'avec des inserts vers des bus, on peut automatiser le deplacement du son juste en jouant sur les faders d'envoi aux inserts.
j'ai testé la question, et suis ainsi à même tres simplement par exemple de faire rebondir un son dans la piece, puis de le faire venir de partout, et disparaitre au centre, etc ...

un simple jeu de 6 sorties dans la piece (une encastree dans le sol, une dans le plafond au centre de la piece, une au centre de chaque mur) me permet de creer une localisation complete du son dans la piece, en affectant les coordonnees spatiales des objets sonores au envois aux auxiliares en partant d'un systeme de reperes orthonormaux en 3 dimensions dont l'origine est au centre du volume de la piece (à condition d'etre soi meme au centre de la piece)
mais avec 8 autres sorties, une dans chaque coin, il me semble que la spacialisation pourrait etre complete quelque soit l'endroit ou on se situe dans la piece...

Page : 1/2  [Suivant]
1  2 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 09:43, jeu. 16 Aug 2018: Salut et bienvenue à georges74 :-)
sub26nico, 22:36, mar. 14 Aug 2018: Salut et bienvenue à maharo :-)
sub26nico, 22:25, mar. 14 Aug 2018: En attendant la V5 de Mixbus 32C, qui devrait arriver demain...
sub26nico, 22:25, mar. 14 Aug 2018: Un nouveau greffon de chez Harrison : [Lien]
syberia303, 22:03, lun. 13 Aug 2018: Pour ceux que ça pourrait intéresser, Traktion en version 7 est gratuit: [Lien]
sub26nico, 17:53, lun. 13 Aug 2018: Salut et bienvenue à Nydoxic :-)
olinuxx, 18:27, dim. 12 Aug 2018: Bonjour et bienvenue à GhostOfBushes ! cool
sub26nico, 00:55, dim. 12 Aug 2018: Salut et bienvenue à TotoLeTroll :-)
olinuxx, 17:05, jeu. 09 Aug 2018: @jipeL : merci pour le partage d'expérience. La prochaine fois, mets un lien vers le fil de discussion stp. [Lien]
jipeL, 18:32, mer. 08 Aug 2018: Mise en garde concernant le code "ISRC" d'une oeuvre dans le forum.
jujudusud, 15:20, mer. 08 Aug 2018: un petit coup de pouce pour mon annonce : [Lien]
olinuxx, 16:56, dim. 05 Aug 2018: Bonjour et bienvenue à eleatus ! cool