Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié Ardour

> Forums de discussion > 3 - Forum dédié Ardour > [Résolu] Xruns importants sous Librazik Ardour 5
Dernier post

[Résolu] Xruns importants sous Librazik Ardour 5

alandave36 utilisateur non connecté
Bonjour tout le monde !

Avec une configuration de Jack courante de sorte à avoir une latence acceptable, j'ai de très nombreux Xrun quand j' enregistre dès la première piste sous Ardour (5.12). Pour ne plus en avoir, je dois changer mes valeurs jusqu' à un point où la latence n'est plus supportable entre l'entrée et la sortie en mode Duplex. Je n'avais pas ce problème sous Ubuntustudio. Il s'agit d'un autre disque, mais il ne semble pas moins performant.
J'ai 3 Go de Ram. J'ai cherché du côté de l'outil hdparm. Voici ce que me renvoient les commandes :



root@LibraZiK2-studio-audio:/home/alain# hdparm -tT /dev/sdb

/dev/sdb:
 Timing cached reads:   6044 MB in  2.00 seconds = 3027.50 MB/sec
 Timing buffered disk reads: 186 MB in  3.01 seconds =  61.79 MB/sec
root@LibraZiK2-studio-audio:/home/alain# hdparm -i /dev/sdb

/dev/sdb:

 Model=WDC WD2500JS-55NCB1, FwRev=10.02E01, SerialNo=WD-WCANK2425813
 Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=50
 BuffType=unknown, BuffSize=8192kB, MaxMultSect=16, MultSect=off
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=488397168
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: Unspecified:  ATA/ATAPI-1,2,3,4,5,6,7

 * signifies the current active mode



Devrais-je suivre les méthodes préconisées sur la page dédiée : Optimiser ses disques durs

ou essayer d' utiliser comme proposé en haut de page la RAM comme disque de travail ?

Merci d'avance pour vos conseils.

Bonne soirée !

Alain

sub26nico utilisateur connecté France
À mon avis, c'est plutôt un problème dût au noyau.
Peux tu retourner le retour de cette commande en console stp:
uname -a


alandave36 utilisateur non connecté
Merci sub26nico.

Voici :
root@LibraZiK2-studio-audio:/home/alain# uname -a
Linux LibraZiK2-studio-audio 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+deb9u3 (2018-03-02) x86_64 GNU/Linux
root@LibraZiK2-studio-audio:/home/alain#


olinuxx utilisateur non connecté France
Bonjour Alain.

Pourquoi as-tu pensé au disque dur comme cause de l'apparition de désynchronisations ? Est-il très actif lorsque tu enregistres ?

Les xruns peuvent provenir de plusieurs goulets d'étranglement, la vitesse d'un disque dur pouvant en être un mais n'étant pas le plus courant. De plusse, j'ai ce disque :

/dev/sdb:
 Timing cached reads:   2752 MB in  2.00 seconds = 1376.60 MB/sec
 Timing buffered disk reads: 224 MB in  3.01 seconds =  74.52 MB/sec

et je n'ai pas de soucis spécial de désynchronisation.

En outre, puisque tu écris que tu obtiens des désynchro dès la première piste, je ne miserai pas tout de suite vers un problème avec le disque dur. Les problèmes de Xruns provoqués par des disques durs pas assez rapides apparaissant généralement avec des pistes nombreuses.

Vérifions déjà que les préréglages de LibraZiK-2 sont bien en place. Questions :
  • comment as-tu installé LibraZiK ? En suivant quel tuto ? Avec quelle méthode ?
  • quel est le noyau utilisé ? (commande : "uname -a" dans un terminal)
  • est-ce que le paquet "librazik-optimisations-all" est installé ? (à vérifier dans synaptic)

olinuxx utilisateur non connecté France
Messages croisés !

Le noyau utilisé n'est pas un noyau LibraZiK optimisé pour la MAO.

Installes-en un si ça n'est pas déjà fait, et démarre dessus, et ça devrait aller mieux. Voir cette documentation  Image

sub26nico utilisateur connecté France
C'est bien ce que je pensais, tu as installé le dernier noyau Debian qui n'est pas optimisé pour le temps réel. Cela c'est sûrement produit ces derniers jours lors d'une mise à jour,
qui t'as proposé une mise à jour du noyau, comme cette version Debian est plus récente
que le noyau actuel de LibraZiK, ton système démarre dessus. Si tu as déjà installé
le noyau 4.9.0-5-bl ou rt-lzk, tu peux le sélectionner au démarrage. Sinon il te faudra installer
l'un des noyaux pré-cités via Synaptic.
Le mieux est de redémarrer et au boot de choisir un autre noyau.

sub26nico utilisateur connecté France
Encore croisés olinuxx biggrin

alandave36 utilisateur non connecté
biggrin Merci pour vos messages croisés !!!

J'avais suivi la piste du disque dur à cause d'une suggestion par un moteur de recherches, je crois. Il est stupide de ma part de ne pas avoir pensé au noyau préconisé au démarrage.

Je redémarre tout de suite et vous tiens au courant !!

alandave36 utilisateur non connecté
biggrin

Ben forcément, ça marchait beaucoup moins bien !!

C'était tellement bête que je n'y avais pas pensé. Effectivement, ce devait être une mise à jour qui a dû changer l'ordre dans le Grub.

Merci à vous et désolé pour le dérangement !

Je mets résolu, bien sûr.

biggrin

Bonne soirée à tous.

sub26nico utilisateur connecté France
De rien et merci pour le [Résolu].
Bonne Zic.

alandave36 utilisateur non connecté
wink

olinuxx utilisateur non connecté France
Garde un œil sur le blog de LibraZiK Image car un nouveau noyau est en test ces jours-ci et devrait être disponible incessamment sous peu.

Bonne musique !

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


sub26nico

Mégaphone [Afficher / Cacher]

Gmanclub, 19:04, mer. 19 Sep 2018: merci pour le meg de bienvenue de olinuxx
olinuxx, 14:55, mer. 19 Sep 2018: Bonjour et bienvenue à Gmanclub cool
sub26nico, 10:13, mer. 19 Sep 2018: Salut et bienvenue à thibaux :-)
jipeL, 08:34, mer. 19 Sep 2018: Bonjour à tous les musicien(nes)
olinuxx, 14:33, mar. 18 Sep 2018: Bonjour et bienvenue à Captain Holy Roger cool
sri_raoul, 15:53, lun. 17 Sep 2018: Soirée de lancement Lab Art le 9 octobre [Lien]
olinuxx, 14:15, lun. 17 Sep 2018: Bonjour et bienvenue à lbaldi ! (cool)
jipeL, 18:12, dim. 16 Sep 2018: Un nouveau morceau à écouter : [Lien]
sub26nico, 12:21, dim. 16 Sep 2018: Salut et bienvenue à diaz :-)
sub26nico, 09:50, dim. 16 Sep 2018: Salut et bienvenue à evgolk :-)
eazymaogeek, 04:03, dim. 16 Sep 2018: Bonjour à tous, un panel de fichiers .mid de batterie [Lien]
Penzignosis, 00:07, ven. 14 Sep 2018: Merci ^^ J'ai écrit un pavé en guise de présentation je crois (pavé César)