Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

3 - Forum dédié Ardour

> Forums de discussion > 3 - Forum dédié Ardour > [RESOLU] Ardour5 greffons calf problemes
Dernier post

[RESOLU] Ardour5 greffons calf problemes

piteke utilisateur non connecté
Bonjour,

Je viens d'installer et de configurer Ardour 5 sur ubuntu studio. Je venais d'essayer ubuntu 18.04 et là, les greffons ne posaient aucun problèmes.
Ici je peux ouvrir un calf LADSPA, mais pas de lv2.Par contre, un autre lv2 non Calf s'ouvre ?
Voici ce que j'ai dans la fenêtre journal : (cela ressemble à un probleme
d'icônes graphiques ? mais je suis novice ...) merci pour votre aide et votre temps !

[WARNING]: ardour-request-device binary was not found..'
[WARNING]: AlsaAudioBackend: adjusted output channel count to match device.
[WARNING]: AlsaAudioBackend: adjusted input channel count to match device.
[WARNING]: L'icône "zoom_in_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "zoom_out_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "scissors" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "grabber" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "grabber_note" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "grabber_edit_point" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "trim_left_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "anchored_trim_left_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "trim_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "anchored_trim_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "trim_left_cursor_right_only" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "trim_right_cursor_left_only" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "fade_in_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "fade_out_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_left_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_top_left_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_top_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_top_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_bottom_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_bottom_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_bottom_left_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "move_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "expand_left_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "expand_up_down_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "i_beam_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "zoom_in_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "zoom_out_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "scissors" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "grabber" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "grabber_note" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "grabber_edit_point" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "trim_left_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "anchored_trim_left_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "trim_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "anchored_trim_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "trim_left_cursor_right_only" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "trim_right_cursor_left_only" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "fade_in_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "fade_out_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_left_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_top_left_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_top_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_top_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_bottom_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_bottom_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "resize_bottom_left_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "move_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "expand_left_right_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "expand_up_down_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[WARNING]: L'icône "i_beam_cursor" est introuvable dans le jeu d'icônes "default", icône par défaut utilisée
[INFO]: Loading bindings from /etc/ardour5/ardour.keys
Chargement des menus depuis /etc/ardour5/ardour.menus
[INFO]: Loading 88 MIDI patches from /usr/share/ardour5/patchfiles
[INFO]: Loading history from /home/pierre/test degrande trio/test degrande trio.history
[ERROR]: LV2: Failed to instantiate plugin http://calf.sourceforge.net/plugins/MultibandCompressor
[ERROR]: LV2: Failed to instantiate plugin http://calf.sourceforge.net/plugins/MultibandCompressor


sub26nico utilisateur non connecté France
Note modération : merci d'utiliser la balise CODE lorsque tu copies/colles du code sur le site. Celles-ci permettent un meilleur affichage. Voir également cette page.
Image


piteke utilisateur non connecté
Merci de l'avoir fait pour moi, j'y veillerai à l'avenir !

jujudusud utilisateur non connecté France
Salut Piteke :

Il faut que tu regardes dans le menu :
Menu
--Aide
-----A propos
--------configuration


et regarder si 'LV2 UI embedding: True' est bien là.
Si c'est la cas, la cause la plus probable est une compilation avec deux version de gcc différentes.
(ardour est compilé avec une version, et ton greffon avec une autre version.

olinuxx utilisateur non connecté France
95% de probabilité que tu puisses utiliser les calf en LV2 après avoir supprimé le paquet "calf-ladspa".

piteke utilisateur non connecté



Salut,


Merci jujudusud J'ai vérifié et LV2 UI embedding: True' est bien là.
Grâce à toi j'ai découvert cette fenêtre et remarqué tous les trucs à encore installer ...

Merci olinuxx, tout est ok !
...mais pourquoi ce probleme, et ladspa et lv2 sont-ils les mêmes excepté l'interface graphique ?

Je dois encore lire pas mal sur la page linux mao ! :-)

olinuxx utilisateur non connecté France
piteke écrit :
Merci olinuxx, tout est ok !
...mais pourquoi ce probleme, et ladspa et lv2 sont-ils les mêmes excepté l'interface graphique ?


Un peu compliqué à expliquer précisément. Disons (pour schématiser et vulgariser) que le projet CALF ne fournit plus de version LADSPA depuis longtemps, mais que le projet LMMS (c'est lui qui fourni le paquet calf-ladspa) utilise en interne, une ancienne version de CALF LADSPA et qu'il y a conflit entre ces 2 versions.

Bonne musique à toi !

bast utilisateur non connecté
Bonjour Olinuxx,
j'ai eu exactement le même problème hier et effectivement en désinstallant les Calf LADSPA, tout roule. Le problème c'est que j'aurais bien aimé me mettre à LMMS une fois que j'aurais fini de faire ce que j'ai à faire dans Ardour...

Question :
Je pensais installer / désinstaller les plug-in Calf LV2 selon que j'utilise Ardour ou LMMS. Mais que se passerait-il si je désinstalle les LV2 que j'ai utilisé dans Ardour à un moment pour utiliser LMMS et que je les réinstalle, si jamais je veux me remettre dans Ardour ??

sub26nico utilisateur non connecté France
bast, plusieurs solutions :

1) La plus commune (notamment conseillée par les devs d'Ardour): ne pas utilisé les calf (lv2) et les remplacer par des greffons qui ne plantent pas Ardour.
2) Ne pas installer Lmms et pour l'utiliser, télécharges lmms sur son site , l'archive téléchargée est une appimage, qui contient tous les paquets nécessaires pour utiliser le logiciel sans les installer sur le système, ce qui fait que tu pourras utiliser les lv2 sans conflits avec les Ladspa.

bast utilisateur non connecté
Merci pour ton retour !
Je ne savais pas que les devs d'Ardour déconseillaient l'utilisation des Calf LV2. C'est dommage, parce que d’après ce que j'ai lu par-ci par-là, ils sont très appréciés... Est ce que les Calf LADSPA, donnent exactement le même rendu (ils ne sont plus maintenus, si?)

Pour LMMS version, appimage, je suis tombé sur un post qui parlait de ça (ici, je crois) mais je débute en Linux et j'ai pas tout compris : en gros, tu ne l'installe pas comme certains exe sous windows ? C'est ça ou il y a une manip supplémentaire ?

sub26nico utilisateur non connecté France
En gros, tu double-cliques sur le fichier AppImage et le logiciel se lance, c'est l'équivalent des logiciel 'portable' sous Windows.

olinuxx utilisateur non connecté France
Pour préciser les choses :


bast écrit :
Question : Je pensais installer / désinstaller les plug-in Calf LV2 selon que j'utilise Ardour ou LMMS.


Tu n'as pas besoin de désintaller/réinstaller les calf-lv2. Ce dont tu as besoin, c'est de désinstaller le paquet calf-ladspa lorsque tu veux utiliser les calf-lv2. Puis, lorsque tu veux utiliser LMMS, alors tu peux réinstaller le paquet calf-ladspa (car LMMS utilise les calf-ladspa en interne de mémoire).


Le conseil de sub26nico d'installer une appimage pour LMMS fonctionne. Il faut cependant savoir que l'utilisation de LMMS en appimage consommera plusse de ressources (RAM) que l'utilisation de LMMS de ta distribution.

Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]


Houston4444

Mégaphone [Afficher / Cacher]

sub26nico, 22:59, lun. 17 Dec 2018: Salut et bienvenue à BlueSubaru et ImagineReckless :-)
olinuxx, 16:42, sam. 15 Dec 2018: Bonjour et bienvenue à shanjian wink
sub26nico, 16:56, jeu. 13 Dec 2018: Salut et bienvenue à Bambou :-)
olinuxx, 14:48, jeu. 13 Dec 2018: Bonjour et bienvenue à Svens cool
programLyrique, 10:59, jeu. 13 Dec 2018: La joute 14 commence : [Lien]
olinuxx, 14:34, mer. 12 Dec 2018: Bonjour et bienvenue à kadiobale wink
r1, 20:25, mar. 11 Dec 2018: Les joutes sont sur le point de reprendre ! viendez jouer avec nous !!! :-)
olinuxx, 23:10, lun. 10 Dec 2018: Bonjour et bienvenue à titidu77 cool
olinuxx, 19:15, lun. 10 Dec 2018: Bonjour et bienvenue à GranDide :-)
sub26nico, 13:26, lun. 10 Dec 2018: Salut et bienvenue à Floyd84 :-)
sub26nico, 09:09, ven. 07 Dec 2018: Salut et bienvenue à alansnow73 :-)
allany, 18:40, jeu. 06 Dec 2018: Avec un ch'tit retard, voici l'édito de décembre ! [Lien]