Chargement...
 
[Voir/Cacher menus de gauche]
[Voir/Cacher menus de droite]

4 - Toutes les autres applications, les émulateurs...

Dernier post
Page : 2/3   -   Aller directement à la page : 1  2  3 

(RESOLU) Pas de son avec guitarix

calixtus06 Articles : 544 utilisateur non connecté
Image

Re bonsoir, bon je commence à essayer les logiciels libres de linux.

J'ai une carte son UX2 de line6 et pas de son avec guitarix et même ce message.

Que dois je en penser ?

Je voudrais ensuite l'enregistrer dans sooper looper. Comment faire ?

Et si possible comment synchroniser hydrogen avec sooper looper ??

Un énorme merci !!

olinuxx Articles : 15277 utilisateur non connecté France
QjackCtl -> Réglages... -> onglet "Divers" -> décocher "[]Activer l'interface D-Bus"

calixtus06 Articles : 544 utilisateur non connecté
j'ai décoché D-bus mais toujours pas de son et impossible de joindre le serveur jack ..J'ai fait le tour : alsa mixer ( sélectionné ma carte son qui est en 0 maintenant, réglé pcm sur instrument et micro ) je suis allé voir sur les paramètre du son pour vérifier que j'étai aussi avec ma carte son. Tout est ok mais pas de liaison au serveur jack. Que faire ?

Une semaine déjà est passée et ça me pose question ..

Merci pour votre patience qui m'aide à garder la mienne

olinuxx Articles : 15277 utilisateur non connecté France
Il faut que tu nous redonnes les messages de qjackctl après chaque modification, sinon, nous ne pouvons pas t'aider.

Articles : 7151
Pulseaudio est un emmerdeur et prend toujours la main sur la carte son et si ce n'est pas le cas quand jack prend la main le flashplayer ne sait plus causer.

Pour PAM c'est juste une question de priorité et que tu fasse bien partie du groupe audio (voir ta toute première capture)
Donc ça c'est réglé.


Ensuite tu as ce problème de pulseaudio

Tu vas dans ton menu tu devrai y trouver une entrées qui s'applle "mes applications au démarrage" si tu trouve pas on va faire autrement (terminal):
sudo nano /etc/xdg/autostart/pulseaudio.desktop

Tu va tout en bas et tu remplace :
XXXXX-Autostart-Phase=true

XXXXX-Autostart-Phase=false

Ensuite tu sauve Ctrl+O suivit de Entrée puis Ctrl+X pour sortir.
Maintenant ça va lui éviter de faire ce qu'il veut et on va lui demander gentime,nt de prend la porte :
killall -KILL pulseaudio


Si t'as un doute avant de modifier le fichier tu nous envois le retour de ceci:
cat /etc/xdg/autostart/pulseaudio.desktop


Mais logiquement jack doit avoir la main mais attention :
Jack doit toujours être démarré en premier suivit de mozilla (pour youtube par exemple) sinon c'est comme vouloir sauter dans un train alors qu'il est déja parti ...

calixtus06 Articles : 544 utilisateur non connecté
Pour répondre à Olinuxx

Image

Ensuite je fais les manip que jam me recommande:

Image

et pour la commande de vérification: cat /etc/xdg/autostart/pulseaudio.desktop

ça donne:

Image

et à la fin:

Image

calixtus06 Articles : 544 utilisateur non connecté
Après avoir éteint et rallumé l'ordi :

Image

J'avoue que je suis partagé. Je débute sous linux et au bout d'une semaine ma patience s'use et ça me fait déprimer. Devons nous lorsqu'on veut quitter windows se taper des semaines, des mois de galère ? La MAO sous linux c'est nouveau pour moi. J'ai déjà passé des mois à tenter d'installer des tas de distribution, de logiciels...et à chaque fois c'est pareil.
merci pour votre aide

NB: à priori tout fonctionnait jusqu'à je touche à la latence par le biais de l'échantillonage. J'avais tenté ensuite de remettre d'aplomb mais plus rien.

Est ce que tout est ok ?

Image

Image

A chaque fois que je retourne sur alsamixer je tombe par défaut sur la carte son interne à l'ordi et je re re re sélectionne ma carte son ux2. le son sort en montant le curseur monitor mais pas non plus très fort..

Articles : 7151
Ecoute Je vais reprendre la lecture à zéro de ce fil dès que j'ai un moment ce n'est pas toujours facile de répondre correctement.
Mais ce serait tout de même étonnant qu'on arrive pas à la faire marcher cette carte .

Citation :
A chaque fois que je retourne sur alsamixer je tombe par défaut sur la carte son interne à l'ordi et je re re re sélectionne ma carte son ux2. le son sort en montant le curseur monitor mais pas non plus très fort..


Pour la première partie c'est normal.
Pour la seconde nous on te conseille alsa mixer mais tu peux aussi utiliser le mixeur audio intégré au bureau ça marche aussi hein (enfin sauf preuve du contraire et cas de figre bien spécifique genre hdsp RME est un bon exemple)

Citation :
La MAO sous linux c'est nouveau pour moi. J'ai déjà passé des mois à tenter d'installer des tas de distribution, de logiciels...et à chaque fois c'est pareil.


Non relaçons les éléments dans leur contextes voulez vous :-)

En temps qu'utilisateur les première fois j'ai galérer comme toi et puis petit à petit on se fait à la logique de linux et tout fini par prendre son sens.
Le problème pour le débutant c'est d'attaquer sur tout les fronds alors qu'il devrais procéder étape par étape et ne pas dévier.

Par exemple dans ton cas faire tourner jack est la priorité.
Tu peux entrer et faire sortir du son dans ya carte est le point sur lequel tu dois te concentrer.

Windows bosse à sa manière linux aussi.

Les habitudes sont faits pour être changée et toute les ordures du gouvernement devraient en comprendre la quintessence (ici c'est un petit hors piste)
Ce que je veux dire c'est qu'on a du passé à coté de quelques choses mais une choses à la fois:

Jack d'abord le reste après ;)

olinuxx Articles : 15277 utilisateur non connecté France
En regardant la première capture d'écran de ton dernier message, je vois dans les messages de qjackctl ceci :
configuring for 48000Hz, period = 128 frames (2.7 ms) buffer = 3 periods

Tu devrais refaire un essai par :
  • 44100Hz (au lieu de 48000Hz) car en lisant les pages des matériels de line6, il semble que certains ne fonctionnent pas en 48Khz
  • frames : 1024, tu lui en demandes un peu beaucoup à ton interface là, relâche le avec 1024 et quand tu arriveras à ce que qjackctl puisse lancer jackd, alors, au coup par coup, tu essaieras d'améliorer la latence. Pour l'instant, tu essaies de faire démarrer jackd.
  • buffer : tu peux faire des essais avec : 2

Résumé : tu lances qjackctl, tu cliques sur son bouton "réglages..." puis tu modifies ces valeurs.

D'autre part, il y a des questions qu'y t'ont été posées et auxquelles tu n'as pas répondues :

Et quand tu disais :

calixtus06 écrit :
Quand j'allume jack le son de youtube s'arrête....? et quand je l'arrête youtube reprend du son ..


C'est un comportement relativement habituel, ça peux se corriger, mais pour l'instant, on en est pas là.

Bon courage à toi
Olivier

calixtus06 Articles : 544 utilisateur non connecté
sorry olinuxx, je n'avais pas vu ton message. j'essaie ce soir en rentrant .
merci beaucoup

calixtus06 Articles : 544 utilisateur non connecté
hello, de retour sur ma carte son

Image

Image

Image

Ma distribution est linux mint rapaela 17.2 en 64 bits. Dois je installer autre chose comme ubuntu studio ?

Alsamixer ne se met plus par défaut sur ux2 et quand je monte le curseur du monitor j'ai du son une fois avoir sélectionné ux2. Je n'en ai plus avec guitarix qui m'indique qu'on ne peut avoir jack en client.

retour sur PAM, est il bien édité ??

# /etc/security/limits.conf
#
#Each line describes a limit for a user in the form:
#
#            
#
#Where:
# can be:
#        - a user name
#        - a group name, with @group syntax
#        - the wildcard *, for default entry
#        - the wildcard %, can be also used with %group syntax,
#                 for maxlogin limit
#        - NOTE: group and wildcard limits are not applied to root.
#          To apply a limit to the root user,  must be
#          the literal username root.
#
# can have the two values:
#        - "soft" for enforcing the soft limits
#        - "hard" for enforcing hard limits
#
# can be one of the following:
#        - core - limits the core file size (KB)
#        - data - max data size (KB)
#        - fsize - maximum filesize (KB)
#        - memlock - max locked-in-memory address space (KB)
#        - nofile - max number of open files
#        - rss - max resident set size (KB)
#        - stack - max stack size (KB)
#        - cpu - max CPU time (MIN)
#        - nproc - max number of processes
#        - as - address space limit (KB)
#        - maxlogins - max number of logins for this user
#        - maxsyslogins - max number of logins on the system
#        - priority - the priority to run user process with
#        - locks - max number of file locks the user can hold
#        - sigpending - max number of pending signals
#        - msgqueue - max memory used by POSIX message queues (bytes)
#        - nice - max nice priority allowed to raise to values: [-20, 19]
#        - rtprio - max realtime priority
#        - chroot - change root to directory (Debian-specific)
#
#                 
#

#*               soft    core            0
#root            hard    core            100000
#*               hard    rss             10000
#@student        hard    nproc           20
#@faculty        soft    nproc           20
#@faculty        hard    nproc           50
#ftp             hard    nproc           0
#ftp             -       chroot          /ftp
#@student        -       maxlogins       4
# Support Temps réel pour le groupe audio
@audio  -  rtprio   90
@audio  -  memlock  unlimited
# @audio  -  nice -15
# End of file


J'ai ce message aussi concernant D-bus:
Image

Merci de votre aide

calixtus06 Articles : 544 utilisateur non connecté
avec cette commande :

Image

J'ai alors un son pourri de robot

Je vais donc du côté d'alsamixer, baisse le monitor et n'ai plus de son..

Articles : 7151
Concernant toin avant dernier message:
Remplace gedit par pluma ça aura plus de change de fonctionner ;)

Par contre un truc me chiffonne c'est quoi ce délire avec:

@audio - rtprio 90
@audio - memlock unlimited

    @audio - nice -15
    End of file


?

Normalement ça doit te donner ça:

cat /etc/security/limits.d/audio.conf 
# Provided by the jackd package.
#
# Changes to this file will be preserved.
#

@audio   -  rtprio     95
@audio   -  memlock    unlimited
#@audio   -  nice      -19


Donc sudo
pluma /etc/security/limits.d/audio.conf


TU retire ce qu'est en trop et du remplace ce qui va pas ...

C'est pas tout
la commande groups elle te retourne bien ton utilisateur dans la liste ?

Et s'il te plait prend le temps de faire les choses par étape sinon ça devient très vite compliqué et tu va t'embourber ...

olinuxx Articles : 15277 utilisateur non connecté France
nan utilisateur_anonyme, c'est juste qu'il n'avait pas utilisé la balise de CODE. Je viens de l'appliquer et son audio.conf semble bon.

@calixtus06 : ceci dit :
1) merci d'utiliser toi même les balises CODE lorsque tu es en édition.
2) prend le temps de relire les messages de tout le monde, surtout ceux auxquels tu réponds car par exemple :
- tu n'as toujours pas donné la réponse à la commande : uname -a
- dans mon précédent message, je te disais d'utiliser frame=1024 et si j'en juge par tes captures d'écran, tu as frame=256

calixtus06 Articles : 544 utilisateur non connecté
@calixtus06 : dans la capture d'écran suivante : Image
on voit que les entrées de ta carte-son (system capture_1 et system_capture_2) envoie le son sur le PulseAudio JACK Source et que le PulseAudio JACK Sink envoie le son sur tes enceintes (system capture_1 et system capture_2). Mais ton guitarix n’apparaît pas dans ce chemin, aucune chance donc que le signal de ta guitare n'arrive sur guitarix et aucune chance que guitarix n'envoie du son sur les enceintes puisqu'il n'y est pas connecté.

Conseil est de (re-)lire la page Débuter - la MAO et GNU-linux.

olinuxx Articles : 15277 utilisateur non connecté France
Tu sembles te tromper dans tes branchements. Si j'en crois ta 2ème capture d'écran, il te manque des éléments de compréhension pour relier des applications entre elles. Je te conseille donc cette lecture : QJackCtl Connecter des applications

J'ai deux petits conseils amicaux pour toi :
1) Jongler entre les forums n'est pas la meilleure idée du monde parce que tu vas te mélanger les pinceaux (ça semble déjà le cas puisque tu donnes le résultat du "uname -a" sur la ubuntu studio alors que c'était demandé pour la linux mint, là ça ne sert plus à grand chose maintenant).
2) Ne pas donner les réponses aux questions que les gens (qui prennent de leur temps pour t'aider) te demandent, peut être également contre-productif. Les gens ne vont plus avoir envie de te répondre.

C'est vrai qu'avec les logiciels libres, dès qu'on soulève un coin du terminal, on voit qu'on peut faire beaucoup de choses et que l'on peut se sentir parfois perdu, mais courir dans tous les sens n'apporte rien. Il vaut mieux prendre ton temps, tester les choses et les modifications une par une, et surtout, comprendre ce que l'on fait. Et de cette façon, tu progresseras wink

calixtus06 Articles : 544 utilisateur non connecté
Désolé, j'ai pu loupé des questions. Je m'efforce vraiment d'apporter les éléments qui pourront vous aider à m'aider.

Je suis allé sur la page en question: qjack mais je ne vois pas où je me trompe dans les branchements. peux tu m'éclairer.

Et encore un grand merci à vous tous !

allany Articles : 5576 utilisateur non connecté
Une question sans doute idiote mais qui me rappelle un vague souvenir :
As-tu essayé d'inverser les connexions, dans Jack, entre head et fx de Guitarix ?
là, tu mets head en premier.
A voir mais, comme dit plus haut, il faut d'abord que Jack tourne correctement et de façon stable.
A+

Articles : 7151
Citation :
A force d'aller de forum en forum et de ne rien comprendre


C'est une très mauvaise idée si tu vas sur un forum il vaut mieux que tu suive ton fil sinon c'est clair que chacun a ses méthodes.

Nous même ici nous ne verrons pas les chose de la même façon donc si une ou deux personnes font l'effort de te suivre pas que mine de rien ça prend du temps (et oui on dirait pas hein) charge à toi de suivre.

Citation :
Une question sans doute idiote mais qui me rappelle un vague souvenir :
As-tu essayé d'inverser les connexions, dans Jack, entre head et fx de Guitarix ?
là, tu mets head en premier.


Y'a rien de noté à ce sujet non ? Guitarix2

allany Articles : 5576 utilisateur non connecté
@utilisateur_anonyme : ben non...

Du coup, c'est ma faute, j'aurais du le noter dans l'article la fois où je l'avais utilisé, le Guitarix...
D'autant qu'il me semble que j'avais bien m***é avec cette interconnexion dans Jack.

Par contre, dans cet article, je vois que Guitarix peut lancer Jack lui-même, automatiquement.
Je sais pas si ça peut aider mais n'y aurait-il pas un paramètre zarbi concernant cette automation de Jack ?

Articles : 7151
Non c'est une option qui n'est pas activée par défaut du moins il faut la sélectionné soit même mais si jack est actif t'as un message derreur donc ...

Je suis passé mettre les infos sur Guitarix2 mais les tests effectués ici me disent que la connexion du head et du fx se font automatiquement d'autant que tu ne peux pas te tromper ça entre en mono et ça ressort en stéréo. J'ai mis des captures de qjackctl et aussi une de claudia....

Page : 2/3  [Suivant]
1  2  3 
Afficher les articles :
Aller au forum :

Documentation [Afficher / Cacher]

Connexion
[Afficher / Cacher]



Mégaphone [Afficher / Cacher]

sub26nico, 23:47, mer. 13 Nov 2019: Salut et bienvenue à Laety_angel et jasongouzien :-)
sub26nico, 10:08, mar. 12 Nov 2019: Salut et bienvenue à Jacques Prat :-)
sub26nico, 22:51, ven. 08 Nov 2019: Salut et bienvenue à Lionel Bonnarde :-)
lila, 17:04, ven. 08 Nov 2019: Bonjour, j'ai bien eu vos messages, je dois partir en WE, je vous recontacte à mon retour et je vous dis tout ;D
olinuxx, 12:15, ven. 08 Nov 2019: Bonjour et bienvenue à lila et Airelle cool Lila, j'appuie le conseil d'allany wink
allany, 07:32, ven. 08 Nov 2019: @lila : tu obtiendras davantage de réponses à ta question si tu postes dans le forum adéquat...
lila, 18:02, jeu. 07 Nov 2019: Bonjour, je suis donneur de voix et je veux faire évoluer mes enregistrements vers plus de qualité. Je voudrais savoir si la carte son audient id14 fonctionne sous linux. Je suis sur ubuntu
sub26nico, 00:51, jeu. 07 Nov 2019: Salutet bienvenue à chrisbernay et VCTRMRTNS :-)
allany, 18:17, mar. 05 Nov 2019: Avant Noël, cadeau l'édito !!! [Lien]
olinuxx, 11:32, mar. 05 Nov 2019: Bonjour et bienvenue à kingkhan cool
louiesauvage, 10:48, mar. 05 Nov 2019: pédalier nux cerberus non reconnu en usb besoin de changer IR
r1, 09:49, mar. 05 Nov 2019: @samuel : c'est gentil mais pourquoi ne pas utiliser le formulaire adéquate ?